Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
15.05.2021, 23:51:01

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 735578
  • Themen insgesamt: 59247
  • Heute online: 700
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema: [gelöst]  Nvidia Grafiktreiber wird nicht geladen  (Gelesen 1903 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] Nvidia Grafiktreiber wird nicht geladen
« am: 09.05.2017, 21:12:06 »
Hi, ich brauche mal wieder nen guten Rat.

Ich habe mein System eben frisch installiert beim Wechsel von 17.3 zu 18.1
Nach der Installation noch Updates gemacht und den 4.10er Kernel installiert.

Nach dem Neustart das ppa von hier hinzugefügt: https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa
Anschließend den Nvidia-Treiber 3.75.66 Installiert. Nach dem Neustart Rückfallmodus.
Dann wieder auf den quelloffenen Treiber gewechselt. Danach den 378 und den 38X probiert. Jetzt gibts zwar keinen Rückfallmodus mehr, aber in den nv-settings nix zum Einstellen... Also fix mit inxi geschaut:
FAILED: nouveau
Gut, ich also zum Quelloffenen zurück. Den neuesten Ubuntu-Kernel 4.11 von hier probiert: http://kernel.ubuntu.com/~kernel-ppa/mainline/

Leider auch in zusammenarbeit mit dem ppa kein Erfolg.

Gut, dann wieder zum Quelloffenen zurück. Neustart. ppa rausgeworfen. Anschließend den 375.39 probiert, der ja von haus aus angeboten wird...
Selbes Ergebnis: FAILED: nouveau und in den nv-settings nix zu sehen von der Karte.

Ja, die Kernel-Header sind alle installiert und dkms auch.

Abschließend noch das inxi fürs System:
System:    Host: Moon Kernel: 4.11.0-041100-generic x86_64 (64 bit) Desktop: Cinnamon 3.2.7
           Distro: Linux Mint 18.1 Serena
Machine:   Mobo: ASUSTeK model: P8Z77-V LX2 v: Rev X.0x Bios: American Megatrends v: 2501 date: 09/02/2014
CPU:       Quad core Intel Core i5-3570K (-MCP-) cache: 6144 KB
           clock speeds: max: 4100 MHz 1: 2159 MHz 2: 2199 MHz 3: 2196 MHz 4: 2120 MHz
Graphics:  Card: NVIDIA GM204 [GeForce GTX 980]
           Display Server: X.Org 1.18.4 drivers: (unloaded: fbdev,vesa) FAILED: nouveau
           Resolution: 2560x1440@59.95hz
           GLX Renderer: Gallium 0.4 on NV124 GLX Version: 3.0 Mesa 12.0.6
Audio:     Card-1 Intel 7 Series/C210 Series Family High Definition Audio Controller driver: snd_hda_intel
           Card-2 NVIDIA GM204 High Definition Audio Controller driver: snd_hda_intel
           Card-3 Creative Labs EMU20k2 [X-Fi Titanium Series] driver: snd_ctxfi
           Card-4 ASUSTek Xonar U3 sound card driver: USB Audio
           Sound: Advanced Linux Sound Architecture v: k4.11.0-041100-generic
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169
           IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 2128.4GB (1.3% used) ID-1: /dev/sda model: Samsung_SSD_840 size: 128.0GB
           ID-2: /dev/sdb model: WDC_WD20EZRX size: 2000.4GB
Partition: ID-1: / size: 87G used: 6.7G (9%) fs: ext4 dev: /dev/sda2
           ID-2: /home size: 1.8T used: 451M (1%) fs: ext4 dev: /dev/sdb1
           ID-3: swap-1 size: 20.00GB used: 0.00GB (0%) fs: swap dev: /dev/sdb2
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C
           Fan Speeds (in rpm): cpu: 0
Info:      Processes: 189 Uptime: 6 min Memory: 914.2/15987.8MB Client: Shell (bash) inxi: 2.2.35

Was nun tun?  :o

« Letzte Änderung: 11.05.2017, 19:06:55 von launacorp »

Re: Nvidia Grafiktreiber wird nicht geladen
« Antwort #1 am: 10.05.2017, 05:53:22 »
Als ppa für Nvidia ist mir bekannt:
graphics-drivers/ppa
https://itsfoss.com/ubuntu-official-ppa-graphics/

Bei meinem Sohn läuft das auf Mint Mate 18.1 super.
« Letzte Änderung: 10.05.2017, 05:57:57 von Michelle_Br »

Re: Nvidia Grafiktreiber wird nicht geladen
« Antwort #2 am: 10.05.2017, 06:05:17 »
Moin lunacorp,

bin gerade zufällig über deinen Post gestolpert.
Das einzige was ich dir Anbieten kann ist mein Abschlussbericht aus meinem Thread vor geraumer Zeit. Dort hatte ich ein ähnlich Haare raufendes Grafiktreiber Problem  ;)

Schlussbericht:

hiermit gebe ich bekannt das der Nvidia Treiber nun endlich läuft.

Wieder erfolgte ein Doppeltest:

inxi -Fz
System:    Host: me Kernel: 4.8.0-39-generic x86_64 (64 bit)
           Desktop: Cinnamon 3.2.7  Distro: Linux Mint 18.1 Serena
Machine:   System: ASUSTeK (portable) product: G752VY v: 1.0
           Mobo: ASUSTeK model: G752VY v: 1.0
           Bios: American Megatrends v: G752VY.213 date: 03/30/2016
CPU:       Quad core Intel Core i7-6700HQ (-HT-MCP-) cache: 6144 KB
           clock speeds: max: 3500 MHz 1: 812 MHz 2: 816 MHz 3: 804 MHz
           4: 801 MHz 5: 800 MHz 6: 799 MHz 7: 3210 MHz 8: 800 MHz
Graphics:  Card: NVIDIA GM204M [GeForce GTX 980M]
           Display Server: X.Org 1.18.4 drivers: nvidia (unloaded: fbdev,vesa,nouveau)
           Resolution: 1920x1080@75.00hz
           GLX Renderer: GeForce GTX 980M/PCIe/SSE2
           GLX Version: 4.5.0 NVIDIA 378.13
Audio:     Card-1 NVIDIA GM204 High Definition Audio Controller
           driver: snd_hda_intel
           Card-2 Intel Sunrise Point-H HD Audio driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.8.0-39-generic
Network:   Card-1: Intel Wireless 8260 driver: iwlwifi
           IF: wlp2s0 state: up mac: <filter>
           Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169
           IF: enp3s0 state: down mac: <filter>
Drives:    HDD Total Size: 1000.2GB (3.2% used)
           ID-1: /dev/nvme0n1 model: N/A size: 256.1GB
           ID-2: /dev/sda model: HGST_HTS541010A9 size: 1000.2GB
Partition: ID-1: / size: 31G used: 6.7G (24%) fs: ext4 dev: /dev/nvme0n1p5
           ID-2: swap-1 size: 26.00GB used: 0.00GB (0%) fs: swap dev: /dev/dm-0
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 43.0C mobo: N/A gpu: 54C
           Fan Speeds (in rpm): cpu: 0
Info:      Processes: 260 Uptime: 2 min Memory: 1150.2/24049.4MB
           Client: Shell (bash) inxi: 2.2.35

und

lspci -nnk | egrep -i "VGA|3D|Display" -A2
VGA compatible controller [0300]: NVIDIA Corporation GM204M [GeForce GTX 980M] [10de:1617] (rev a1)
Subsystem: ASUSTeK Computer Inc. GM204M [GeForce GTX 980M] [1043:1ced]
Kernel driver in use: nvidia

in beiden Tests stimmen die Treiber nun überein.

Der Werdegang


  • Bios update auf aktuellste Version
  • Mint Installieren (vll geht's auch ohne-bei mir war es nicht der fall)
  • Vollupdate via Terminal
sudo apt-get update && sudo apt-get dist-upgrade
  • reboot
  • (noch im Software Rendering Modus) - installiert einen aktuellen Kernel aus der Aktualisierungsverwaltung & reboot
  • der Nouveau ist vollständig geladen, hochauflösende Desktopumgebung
  • PPA installiert https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa & reboot
  • Aus der Treiberverwaltung heraus entsprechenden Nvidia Treiber Installtiert & reboot
  • Auflösung 800x600 im Bootvorgang/Anmeldebildschirm sowie Desktopumgebung+ wlan adapter ausfall
  • direkt erneuter reboot
  • weiterhin Auflösung 800x600 im Bootvorgang, HD Nvidia Screen, HD Anmeldebildschirm sowie HD Desktopumgebung

!Großes Lob gebührt an dieser Stelle den Nervenstarken Unterstützern!


Bis zum nächsten Thread ;) Hoffe Ihr kommt wieder  ;D
P.S Ab da an läuft mein Mint ohne zu mucken. Zwischenzeitlich bin ich auf den 381.09 nvidia umgesattelt...als dieser aber mit dem 4.08.0-39 Kernel nicht wollte, habe direkt den 4.10.0-19 Kernel hinterher geschoben und alles works fine.

Also ich hoffe ich konnt an der Stelle vll weiterhelfen, good luck.


Beste Grüße
« Letzte Änderung: 10.05.2017, 06:13:20 von lagonboe »

Re: Nvidia Grafiktreiber wird nicht geladen
« Antwort #3 am: 10.05.2017, 06:27:03 »
@lagonboe
Quasi hab ich das so gemacht wie ich bei dir beschrieben. Mit 17.3 und dem ppa lief es ja. Ist mir ehrlich gesagt schleierhaft, was da nicht stimmt.

@michelle_br
Das ppa kannte ich nicht. Kenne nur das von mir und lagonboe genannte. Das hat bisher auch zuverlässig seinen Dienst getan.

Vllt sollte ich dazu erwähnen, dass ich den Software-rendering Modus nur direkt nach der Installation hatte. Nach dem Kernelupdate auf 4.10 hatte ich wohl Video Beschleunigung.

Re: Nvidia Grafiktreiber wird nicht geladen
« Antwort #4 am: 10.05.2017, 10:09:01 »

@michelle_br
Das ppa kannte ich nicht. Kenne nur das von mir und lagonboe genannte. Das hat bisher auch zuverlässig seinen Dienst getan.


https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa

https://itsfoss.com/ubuntu-official-ppa-graphics/

sind doch beide das gleiche

Re: Nvidia Grafiktreiber wird nicht geladen
« Antwort #5 am: 11.05.2017, 18:51:08 »
Also...
Hab nochmal fix neu installiert heute. Alle Updates gemacht (dist-upgrade) und den neuesten 4.4er Kernel installiert.
Anschließend den empfohlenen NVidia 375.39 installiert. Nach dem Neustart Softwarerendering inkl. grober Auflösung.

inxi -G
Graphics:  Card: NVIDIA GM204 [GeForce GTX 980]
           Display Server: X.Org 1.18.4 drivers: fbdev (unloaded: vesa) FAILED: nouveau
           Resolution: 1024x768@76.00hz
           GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 3.8, 256 bits)
           GLX Version: 3.0 Mesa 12.0.6
lspci -nnk | grep -i vga -A2
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GM204 [GeForce GTX 980] [10de:13c0] (rev a1)
Subsystem: ZOTAC International (MCO) Ltd. GM204 [GeForce GTX 980] [19da:2368]
Kernel driver in use: nvidia

Also ohne PPA und mit dem Standardkernel gehts nicht... Was soll ich nun tun? 17.3 installieren ???

Re: Nvidia Grafiktreiber wird nicht geladen
« Antwort #6 am: 11.05.2017, 18:56:42 »
Hi :)
manchmal ging der 375er mit dem 4.4er nicht... versuche mal den neusten 4.8er oder 4.10er kernel.

Re: Nvidia Grafiktreiber wird nicht geladen
« Antwort #7 am: 11.05.2017, 18:58:29 »
ich probiere gerne nochmal den 4.10er. Allerdings hatte ich das ja schon gemacht gehabt.... Ob wirklich Sinn macht es NOCHMAL zu probieren? :-\

BTW: unter 17.3 gings mitm 4.4er und 375

Re: Nvidia Grafiktreiber wird nicht geladen
« Antwort #8 am: 11.05.2017, 19:06:37 »
Jetzt hat´s geklappt. Warum auch immer es nicht geklappt hat vorher.
Einziger unterschied:

Vorher hab ich ERST nen neuen Kernel installiert und jetzt erst den Treiber und mit AKTIVIERTEM Treiber den Kernel aktualisiert.

Ganz schön komisch das ganze :P

Ich mach erstmal zu hier