Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
20.04.2021, 05:36:25

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 729906
  • Themen insgesamt: 58881
  • Heute online: 309
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online
Mitglieder: 4
Gäste: 301
Gesamt: 305

Autor Thema:  Neuinstallation Mint19 nach W7 --> Nur Windowsbootmanager kein Mint  (Gelesen 2377 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Moin Zusammen,
vermutlich können die Eingeweihten das Thema schon nicht mehr hören  ???... aber ich hänge fest.

Bin gerade dabei einen gebrauchten Thinkpad P50 (XEON CPU, 24GB RAM, 500GB SSD, sowie eine noch nicht formatierte 1TB SSD) einzurichten. W7 war schon drauf (und soll wegen Kompatibilität zu CAD-Programmen auch bleiben) Linux Mint wurde ("daneben") installiert - "daneben" soll heißen, nicht mit eigener Partitionionierung, sondern ich habe die Mint-Installationsroutine alles machen lassen (Ich war optimistisch und dachte so wird alles gut :-[). Installiert wurde auf der 500GB nvme-SSD.

Leider bindet sich der Bootmanager nicht richtig ein.

fdisk -l zeigt:
Festplatte dev/nvme0n1...

/dev/nvme0n1p1 100MB EFI
/dev/nvme0n1p2 128MB MS reserviert
/dev/nvme0n1p3 212GB MS7
/dev/nvme0n1p4  16GB  MS Basisdaten (das ist die Lenovo Recovery, wobei die in der Partitionsansicht ganz hinten steht)
/dev/nvme0n1p5    1MB  BIOS Boot
/dev/nvme0n1p6 247GB Linux Dateisystem

Seltsam mutet die Fehlermeldung an:

"GPT-PMBR Größenunterschied (40125 !=31205375) wird durch w(korrigiert)"

die bezieht sich aber vermutlich auf die nicht formatierte Festplatte /dev/sda


In der Bootreihenfolge des BIOS zeigte sich der WindowsBootManager auf Platz 1, Platz 2 "NVM00" und NVM02 auf Platz 3 (ich nehme an, das sind Partitionen auf der SSD) dahinter, dann USB-CD etc.. Ich kann die Reihenfolge ändern wie ich will. Beim normalen Starten bootet nur Windows. 

Mit der SuperGrub2 Disk komme ich zwar in das Mint rein, aber trotz stundenlangem Rumsuchen habe ich bislang keine Lösung gefunden.

Meine Hoffnung mit

sudo grub-install --recheck /dev/nvme0n1 update-grub

hat sich auch nicht erfüllt:

"grub-install: Fehler: Mehr als nur ein Insatallationsgerät?."


Hat jemand eine Lösung? BTW:Sollte der Eindruck entstanden sein, ich habe nur begrenzte Kenntnisse, dann täuscht der nicht, übt bitte Nachsicht.

Dank im Voraus
Olaf
 

Willkommen BriandeHalma!

/dev/nvme0n1p1 100MB EFIstammt sicher von Windows.
/dev/nvme0n1p5    1MB  BIOS Bootwohl von Linux.

Das sieht so aus, dass das Linux System im BIOS-Modus gebootet und installiert wurde.
Die
/dev/nvme0n1p5    1MB  BIOS Boot
/dev/nvme0n1p6 247GB Linux Dateisystem
würde ich löschen und Linux noch mal installieren, aber vorher prüfen, ob es auch im UEFI-Modus gebootet wurde.

Zeigt, ob das System mit UEFI oder BIOS läuft:
[ -d /sys/firmware/efi ] && echo UEFI || echo BIOS
« Letzte Änderung: 28.11.2018, 16:27:04 von helli »

vielen Dank helli. Nachdem ich festgestellt habe, dass Leerzeichen durchaus bedeutsam sein können, auch innerhalb eckiger Klammern ;D, sagt er mir: UEFI. Wie gesagt, in das System bin ich jetzt über SuperGrub2 Disk gekommen (falls das von Bedeutung sein könnte).

Da ich da seit heute Morgen dran bin, habe ich sehr viel herumprobiert, auch eine Neuinstallation. Kann ich natürlich auch noch einmal machen, nur wieso sollte das zu einem anderen Ergebnis führen? Oder gibt es da andere Einstellungen die ich bei der Installation vornehmen sollte?

Als Installationsmedium habe ich übrigens einen USB Stick, auf den ich eine Mint19-64Bit ISO mit Etcher geflasht habe. 

Zitat
in das System bin ich jetzt über SuperGrub2 Disk gekommen
Dann versuche noch mal
sudo grub-installund
sudo update-grub
Allerdings frage ich mich, woher
/dev/nvme0n1p5    1MB  BIOS Bootkommt.

also... grub-install liefert ein:

i386-pc wird für Ihre Plattform installiert.
grub-instal: Fehler: Kein Installationsgerät eingegeben

aber dann hatte ich ja für einen Moment etwas Hoffnung, denn mit
update-grub

kam:

Linux Abbild gefunden:/boot/vmlinux-4.15.0.-3-20-generic
initrd-Abbild gefunden:/boot/vmlinux-4.15.0.-3-20-generic

Windows Bootmanager auf /dev/nvme01p1@/efi/Microsoft/Boot/bootmgfw.efi gefunden
Mac OX X auf /dev/sdb3 gefunden ( :o Hää??)
Hinzufügen des Booteintrages für die EFI Firmware Konfiguration erledigt


Aber leider .. Neustart...Windows

achso..

/dev/nvme0n1p5    1MB  BIOS Boot


kommt eindeutig von der Mint Installation. Warum der das macht: ???

Was sagt
[ -d /sys/firmware/efi ] && echo UEFI || echo BIOSaus dem installierten Linux?

Zitat
i386-pc wird für Ihre Plattform installiert.
Hört sich nach BIOS an.

Vielleicht hilft es, wenn auch die Grub-Pakete neu installiert werden:
sudo apt-get --reinstall install grub-common grub-efi-amd64 os-prober

Mist... Also das "UEFI" in der vorherigen Antwort kam aus dem Mint in das ich in die installierte Version (SuperGrub2..) eingestiegen bin. Die Installation erfolgte aber natürlich über die Live-Installation (USB-Stick). Nur habe ich die gerade aufgerufen und scheitere an diesem Driss-senkrechten Strich >:(.

In der Live Installation ist ein englischer Tastaturtreiber (kann ich das irgendwo ändern? Fragen tut der mich nicht) Auf einer schweizer Tastatur mit englischem Keyboardtreiber bin ich aufgeschmissen.   

Da - Bios/Uefi der Live-Installation - könnte aber des Pudels Kern begraben liegen... oder ?

UEFI als Ausgabe, aber
i386-pc wird für Ihre Plattform installiert.sieht jedenfalls nach einem Mischmasch von UEFI und BIOS aus.
Aber wie gesagt, vielleicht hilft
sudo apt-get --reinstall install grub-common grub-efi-amd64 os-proberdenn damit kann man auch ein im BIOS-Modus installiertes System auf UEFI umstellen.

Mit
setxkbmap chkann die Schweizer Tastatur eingestellt werden.

nein, Neuinstallation hat auch nicht geholfen  :-[

Matrix

  • Gast
achso..

/dev/nvme0n1p5    1MB  BIOS Boot


kommt eindeutig von der Mint Installation. Warum der das macht: ???
weil dein Installationsmedium im BIOS-Modus war - der Installer hatte gar keine andere Wahl, als diese "bios_boot" anzulegen.

Und da das P50 meines Wissens zu den Geräten gehört, die durch eine BIOS-Installation zerstört werden können, solltest du schnellsten abbrechen.

Starte ein Livesystem und prüfe den Modus - zeig das bitte in einem Codeblock.

Nebenbei, du musst fürs Terminal nichts abtippen, copy+paste tut es auch.

Bei der Auswahl der Betriebsysteme sagt mir SuperGrub2:

Linux /boot/vmlinux-4.15.0-20-generic (hd2,gpt6)

während der erste Windowseintrag lautet:

BIOS-BOOT-REQUIRED: Windows Vista/7/8/2008 (R2) ... (hd2,gpt3)

Kann man daraus etwas erkennen?

Matrix

  • Gast
ja, man erkennt dass dein Mint im BIOS-Modus ist - ein UEFI-System kann Grub nur in die Efi-Partition installieren.

Nochmal - starte bitte das Livesystem und zeig die gesamte Ausgabe von
[ -d /sys/firmware/efi ] && echo UEFI || echo BIOS

@ helli, was meinst du, ist es machbar, dass man in der fstab die Bios-Boot auskommentiert und dann einfach ein "grub-install" durchlaufen lässt? Theoretisch sollte das machbar sein - probiert hab ich das aber noch nie.