Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
16.10.2021, 19:17:58

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 25987
  • Letzte: Friedel2
Statistiken
  • Beiträge insgesamt: 758198
  • Themen insgesamt: 60932
  • Heute online: 598
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  Dualboot LM20.2 + Win10 : Universales Sicherungsprogramm gesucht  (Gelesen 1253 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

error: disk 'sd0,4' not found.
versuch mal mit hd0

Davon hatte ich zuvor noch geschrieben das anstatt einer sda4 eine hd0,4 eingetragen werden muß, und trotzdem falsch eingetragen.

Habs aber schon korrigiert#!/bin/sh
exec tail -n +3 $0
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
menuentry "Rescuezilla-Life" {
  set isofile="/mnt/Mint-Safe/Boot-Rescue-Sticks/Rescuezilla/rescuezilla-2.2-64bit.hirsute.iso"
  loopback loop (hd0,4)$isofile
  linux (loop)/casper/vmlinuz boot=casper iso-scan/filename=$isofile quiet noeject fastboot toram fsck.mode=skip noprompt splash
  initrd (loop)/casper/initrd.lz
}
und erhalte jetzt die Fehlermeldung
error: disk 'hd0,4' not found.
error: no server ist specified.
error: you ned to load the kernel first.

Press any key to continue..._
ich hab den Verdacht das es am fehlenden mount des Laufwerks liegt oder erledigt das der Befehl:  loopback loop (hd0,4)$isofile
« Letzte Änderung: 20.09.2021, 22:27:29 von kuehhe1 »

nun was soll ich sagen, irgendwie hatte ich auch die Probleme,
weswegen ich die ISO dann kurzer Hand nach /boot geschoben habe
eventuell kann dir da @ billyfox05 weiterhelfen, bei ihm gehts ja wohl

Jo Versuch macht kluch.

Hatte nun das Iso-File nach /boot verschoben, und die /etc/grub.d/40_custom geändert:
#!/bin/sh
exec tail -n +3 $0
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
menuentry "Rescuezilla-Life" {
  set isofile="/boot/rescuezilla-2.2-64bit.hirsute.iso"
  loopback loop (hd0,6)$isofile
  linux (loop)/casper/vmlinuz boot=casper iso-scan/filename=$isofile quiet noeject fastboot toram fsck.mode=skip noprompt splash
  initrd (loop)/casper/initrd.lz
}
bei der Laufwerksangabe komme ich aber auf keinen grünen Zweig.
in dem Fall liegt mein /boot Verzeichnis auf der /dev/nvme0n1p6 und ich habe deshalb in die Zeile: loopback loop (hd0,6)$isofile eingetragen.
Wobei ich mir nicht vorstellen kann das die Bezeichnung korrekt ist, vielleicht geht das in meiner Konstellation mit einer nvme  +  ssd  gar nicht?

Feierabend...

schau mal Antwort #23
ging ohne Laufwerkangabe wenn es in /boot liegt

@kuehhe1
du könntest dich natürlich auch mal mit Clonezilla anfreunden,
das habe ich hinbekommen, das es auch gleich in Deutsch bootet und die ISO iss wesentlich kleiner,
macht ja auch alles was Rescuezilla kann

Moin,
schau mal Antwort #23
ging ohne Laufwerkangabe wenn es in /boot liegt
Neuer Versuch ohne Verweis auf das Laufwerk:#!/bin/sh
exec tail -n +3 $0
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
menuentry "Rescuezilla-Life" {
  set isofile="/boot/rescuezilla-2.2-64bit.hirsute.iso"
  loopback loop $isofile
  linux (loop)/casper/vmlinuz boot=casper iso-scan/filename=$isofile quiet noeject fastboot toram fsck.mode=skip noprompt splash
  initrd (loop)/casper/initrd.lz
}
anschließend ein: sudo update-grub

Nach Neustart steht Rescuezilla-Life wieder im Grub-Menü zur Auswahl
Nach Klick darauf erschienen einige Fehlermeldungen im Display und das System hing, während meines harten Ausschalten mit dem Ein/Aus Schalter erschien dann kurz das Rescuezilla-Vollbild auf dem Display und das Notebook schaltete ab.

Neustart, dieses mal wählte ich wieder Rescuezilla-Life aus erhielt wieder die Fehlermeldungen (Screenshot reiche ich nachsiehe Anhang) und wartete länger, dann erschien das Rescuezilla Vollbild aber leider ohne Auswahlmenü der Sprachen und ist somit nur in englischer Sprache verfügbar.

Resümee:
entweder ich teste es nochmal wie von dir vorgeschlagen mit Clonezilla oder ich belasse es beim Starten über den Ventoy-Stick. Dann muss ich auch keine *. iso in /boot ablegen und habe Rescuezilla in Deutscher Sprache.

Nochmals Überlegungen zur Laufwerkangabe in /etc/Grub.d/40_custom,
Ich habe hier ebenfalls zwei Laufwerke verbaut:
Standardmäßig eine nvme mit darauf befindlichen neun (9) Partitionen nvme01np1 - nvme01np9
Und ein ein (1) TB ssd Laufwerk mit sechs (6) Partitionen für Daten, Medien, Sicherungen, siehe Antwort #27

Wenn meine nvme doch das erste Laufwerk ist, wie kann es dann sein das im System und im Tool Laufwerke meine zusätzlich verbaute ssd als /dev/sda und die darauf befindlichen Partitionen als sda1 - sda6 angezeigt werden.

Vermutlich ist die Bezeichnungs- und Zählweise in meiner Konstellation anders und ich kann deshalb die erforderliche Laufwerksbezeichnung als (hd0,4) oder (hd1,4) so nicht in die /etc/grub.d/40_custom eintragen. Oder es müsste die bisher noch ungetestete korrekte Systembezeichnung nvme0n1p4 verwendet werden.

Darum verstehe ich nicht warum es bei @billyfox05 in Antwort #26 mit nur einer nvme und der Angabe (hd0,6) funktioniert?

EDIT: Screenshot des Bootfehlers angehängt
« Letzte Änderung: 21.09.2021, 10:46:53 von kuehhe1 »

Wenn meine nvme doch das erste Laufwerk ist, wie kann es dann sein das im System und im Tool Laufwerke meine zusätzlich verbaute ssd als /dev/sda und die darauf befindlichen Partitionen als sda1 - sda6 angezeigt werden.
weil die "nvme" nicht als "sdx" erfasst / gelistet wird - sondern als "nvme0n1" (die Angabe gilt für die erste nvme)
Guck dir das mal in "Laufwerke" an bei Gerät - siehe Bild - oder ein "sudo parted -l" zeigt es auch.

Moin,
weil die "nvme" nicht als "sdx" erfasst / gelistet wird - sondern als "nvme0n1" (die Angabe gilt für die erste nvme)
das ist mir schon klar, wird doch hier genauso angezeigt, siehe Anhänge 1 + 2

Aber aus genau dem Grund, wenn (m)eine nvme als erste (hd0,x) eingetragen werden soll kann es doch mit einem *.iso-File das auf einer sda4 liegt und eine sda als (hd0,x) eingetragen werden soll nicht funktionieren. Jedenfalls hat es hier auch nicht funktioniert als ich versuchte aufgrund der im Script erforderlichen Zählweise die hier als sda4 angezeigte Partition als (hd1,4) einzutragen.

Break:
an dieser Stelle breche ich meine Versuche ab:
da Rescuezilla auf diese Weise nur in Englisch zur Verfügung steht, meine Versuch mit Clonezilla zu Fehlermeldungen führten und ein Booten der Clonezilla.iso verhinderten:
error: file ’/casper/vmlinuz’ not found
error: you need to load the kernel first.

Press any key to continue..._

Ich werde in Zukunft weiter mit dem Ventoy-Stick und den darauf zur Verfügung stehenden Rettungstools arbeiten.
Entlastet auch das /boot Verzeichnis

Dennoch vielen Dank an @red1900 und @billyfox05 für die Unterstützung. :-*

Edit, Gramatik
« Letzte Änderung: 21.09.2021, 19:34:31 von kuehhe1 »

Hi, ich bin's, der TE !
Meinen herzlichsten Dank schon mal vorab red1900, kuehhe1 und billyfox05 !
Ihr Jungs habt meine Ursprungsfrage nun so krass gekapert, daß es inzwischen wieder lehrreich und höchst informativ für mich wird.
Eine spitzenmäßige "Bauanleitung" ist nun auch noch dabei herausgekommen, so daß ich ab heute abend Clone-,bzw. Rescuezilla
testweise ins System basteln kann - mal sehen, welches besser läuft !

Danke dafür und bitte macht weiter - im Ernst !

Ed

und meine Versuch mit Clonezilla zu Fehlermeldungen führten und ein Booten der Clonezilla.iso verhinderten
der Eintrag in 40_custom  für Clonezilla sieht so aus

menuentry "Clonezilla" {
set isofile="/boot/iso/clonezilla-live-2.7.3-19-amd64.iso"
loopback loop $isofile
linux (loop)/live/vmlinuz boot=live config locales=de_DE.UTF-8 keyboard-layouts=de boot=live config noswap edd=on nomodeset noprompt nosplash toram=filesystem.squashfs findiso=$isofile
initrd (loop)/live/initrd.img
}

bitte beachte, das ich in /boot einen Ordner namens "iso" erstellt habe, indem sich halt die isos befinden

PS. Clonezilla live gibt es hier https://clonezilla.org/downloads/download.php?branch=stable
2. Select file type: hier iso wählen, zip ist voreingestellt
« Letzte Änderung: 21.09.2021, 16:34:33 von red1900 »

Hallo @red1900,
hab Deine Hinweise beachtet und die Vorgaben in: /boot/iso/clonezilla-live-2.7.3-19-amd64.iso und die Befehle in: /etc/grub.d/40_custom umgesetzt.

Was soll ich sagen, damit funktioniert Clonezilla-Life auch Hier.
Interessant wie du die Befehle zum Tastatur Layout, Sprache und Schrift utf-8 umgesetzt hast. ;)

Es wäre schön wenn ich das so mit der: rescuezilla-2.2-64bit.hirsute.iso hinbekäme....

Denn ganz ehrlich gesagt ist und war Clonezilla noch nie so mein Ding. Denn es verwirrt mich bei der Erstellung eines Backups weil dabei Hinweise gegeben werden als würde Clonezilla jetzt ein Image zurückschreiben wollen. Anscheinend hab ich zu lang mit Rescuezilla gearbeitet
« Letzte Änderung: 21.09.2021, 20:19:01 von kuehhe1 »

Es wäre schön wenn ich das so mit der: rescuezilla-2.2-64bit.hirsute.iso hinbekäme....
hatte ich auch versucht, nur leider ging es nicht so wie ich dachte, darum schrieb ich ja, leider nur in Englisch,
nun ich benutze Clonezilla schon so lange, habe also keine Probleme damit,
vestehe aber das du dich in Rescuezilla eingearbeitet hast

Alles gut Rescuezilla-Life funktioniert ja vom Ventoy-Stick aus gestartet wie gewünscht.
Der Versuch war es aber allemal wert.
Ich danke dir.
« Letzte Änderung: 21.09.2021, 21:06:10 von kuehhe1 »