Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
14.05.2021, 19:46:45

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 25596
  • Letzte: lumineux
Statistiken
  • Beiträge insgesamt: 735303
  • Themen insgesamt: 59234
  • Heute online: 662
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema: [gelöst]  Upgrade Linux Mint 19.3 auf 20.1  (Gelesen 297 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] Upgrade Linux Mint 19.3 auf 20.1
« am: 03.05.2021, 19:44:56 »
LM 19.3 mit Cinamon.

Moin,

Ich wollte ein Upgrade machen, also nach der Webseite.

Leider bleibt das bei den Zeilen hängen:

docralle@docralle-F5Z:~$ mintupgrade download


    Executing 'download'. This will perform the following:
   
    1 - Your repositories will be switched to point to Linux Mint 20 'Ulyana' and
        any 3rd party repositories will be removed. A backup of your APT sources
        will be written to /home/docralle/Upgrade-Backup-tricia/APT.
   
    2 - The packages and updates to perform the upgrade will be downloaded.
   
    Your sources will be restored to Linux Mint 19.3 'Tricia' at the end of this command.

    Do you want to continue? [y/n]: y

  + Checking your Linux Mint codename...

  + Checking your Linux Mint edition...

  + Checking your Timeshift configuration...

  + Updating cache...

OK:1 http://ftp.uni-mainz.de/ubuntu bionic InRelease
Ign:2 http://ddebs.ubuntu.com bionic InRelease                                                             
Ign:3 http://ddebs.ubuntu.com bionic-updates InRelease                                                     
Ign:4 http://ftp.fau.de/mint/packages tricia InRelease                                                     
OK:5 http://ftp.uni-mainz.de/ubuntu bionic-updates InRelease                                               
OK:6 http://ftp.uni-mainz.de/ubuntu bionic-backports InRelease                                             
OK:7 http://security.ubuntu.com/ubuntu bionic-security InRelease                                           
OK:8 http://archive.canonical.com/ubuntu bionic InRelease                                                 
OK:9 http://ppa.launchpad.net/openshot.developers/ppa/ubuntu bionic InRelease                             
OK:10 http://ppa.launchpad.net/ubuntuhandbook1/audacity/ubuntu bionic InRelease                           
OK:11 http://ftp.fau.de/mint/packages tricia Release                                               
OK:12 http://ddebs.ubuntu.com bionic Release                               
OK:13 http://ddebs.ubuntu.com bionic-updates Release
Paketlisten werden gelesen... Fertig

  + Checking your APT repositories...

------------------------------------------------
!!  ERROR: The following 3rd party repositories were detected. Disable them and refresh your APT cache.

    - Audacity Audio Editor and Recorder (LP-PPA-ubuntuhandbook1-audacity) - ppa.launchpad.net
    - OpenShot: Stable PPA - Official Releases (LP-PPA-openshot.developers) - ppa.launchpad.net

!!  Exiting.
------------------------------------------------

  + Restoring your backed up APT sources...


Diese 2 Programme habe ich dann deinstalliert, nur das Problem ist immer noch. Anleitung ist hier zu finden:
https://linuxmint-user-guide.readthedocs.io/en/latest/upgrade-to-mint-20.html

Ich habe, nach dem ich meinen Ordner auf die Externe kopiert habe, eine Neuinstallation gemacht. Somit ist das erledigt. Bei den 18er geht es nicht anders, nur da überlege ich mir doch etwas neue Hardware zu zulegen, weil bei Open Shot die Videos doch zu sehr ruckeln. 
« Letzte Änderung: 06.05.2021, 20:29:08 von docralle »

Re: Upgrade Linux Mint 19.3 auf 20.1
« Antwort #1 am: 03.05.2021, 19:50:02 »
Diese 2 Programme habe ich dann deinstalliert
Hast du danach auch die Paketquelle entfernt?

Re: Upgrade Linux Mint 19.3 auf 20.1
« Antwort #2 am: 03.05.2021, 20:01:02 »
The following 3rd party repositories were detected. Disable them and refresh your APT cache.

Es steht doch da, was du tun sollst. Die beiden Repositories rausnehmen, nicht die Programme deinstallieren. Gemacht wird das mit Anwendungspaketquellen - zusätzliche Paketquellen. Bei den beiden Repos die Haken rausnehmen. Das Programm führt dann ein apt-get update aus. Das brauchst du dann nicht mehr extra zu machen. Danach kannst du dein Upgrade fortsetzen.

Edit: @moehre war schneller.

Re: Upgrade Linux Mint 19.3 auf 20.1
« Antwort #3 am: 03.05.2021, 22:04:35 »
In den Systemeinstellungen den Button „Paketquellen“ anklicken, Passwort eingeben, dann in der Seitenleiste „PPAs“ anklicken, dort alle Einträge deaktivieren.

Re: Upgrade Linux Mint 19.3 auf 20.1
« Antwort #4 am: 04.05.2021, 04:19:40 »
Ich frage mich nur: " Warum kommt bei dir die Meldung bei "mintupgrade download"?  :o :o
Denn "mintupgrade check" hätte schon abbrechen müssen!  ;) ;)

Oder hast du deine eigene Upgradeanleitung?

Re: Upgrade Linux Mint 19.3 auf 20.1
« Antwort #5 am: 04.05.2021, 16:41:25 »
Ich habe das was mir @Franz Stahl empfohlen hat, gemacht. Auch die Einträge gefunden. Dann habe ich es noch mal versucht, allerdings immer die selbe Stelle:

docralle@docralle-F5Z:~$ mintupgrade check


    Executing 'check'. This will perform the following:
   
    1 - Your repositories will be switched to point to Linux Mint 20 'Ulyana' and
        any 3rd party repositories will be removed. A backup of your APT sources
        will be written to /home/docralle/Upgrade-Backup-tricia/APT.
   
    2 - The upgrade will be simulated so impacted packages can be evaluated.
   
    Your sources will be restored to Linux Mint 19.3 'Tricia' at the end of this command.

    Do you want to continue? [y/n]: y

  + Checking your Linux Mint codename...

  + Checking your Linux Mint edition...

  + Checking your Timeshift configuration...

  + Updating cache...

[sudo] Passwort für docralle:           
OK:1 http://ftp.uni-mainz.de/ubuntu bionic InRelease
Ign:2 http://ddebs.ubuntu.com bionic InRelease                                                                               
Ign:3 http://ddebs.ubuntu.com bionic-updates InRelease                                                                       
Ign:4 http://ftp.fau.de/mint/packages tricia InRelease                                                                       
OK:5 http://ftp.uni-mainz.de/ubuntu bionic-updates InRelease                                                                 
OK:6 http://ftp.uni-mainz.de/ubuntu bionic-backports InRelease                                                               
OK:7 http://archive.canonical.com/ubuntu bionic InRelease                                                                     
OK:8 http://ftp.fau.de/mint/packages tricia Release                                                                           
OK:9 http://ddebs.ubuntu.com bionic Release                                 
OK:10 http://ddebs.ubuntu.com bionic-updates Release                       
Holen:11 http://security.ubuntu.com/ubuntu bionic-security InRelease [88,7 kB]
Holen:15 http://security.ubuntu.com/ubuntu bionic-security/main amd64 DEP-11 Metadata [48,5 kB]
Holen:16 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 DEP-11 Metadata [60,3 kB]
Holen:17 http://security.ubuntu.com/ubuntu bionic-security/multiverse amd64 DEP-11 Metadata [2.464 B]
Es wurden 200 kB in 5 s geholt (39,2 kB/s).   
Paketlisten werden gelesen... Fertig

  + Checking your APT repositories...

  + Checking your APT packages...

    - init: 1.56+nmu1~ubuntu18.04.1, should be 1.51 (from bionic)
    - init-system-helpers: 1.56+nmu1~ubuntu18.04.1, should be 1.51 (from bionic)
    - libopenshot-audio6: 0.1.8+dfsg2+67+201903210434~ubuntu18.04.1, should be 0.1.5+dfsg1-1 (from bionic)
    - python3-openshot: 0.2.5+dfsg2+876+202003032112+daily~ubuntu18.04.1, should be 0.1.9+dfsg1-3build1 (from bionic)

------------------------------------------------
!!  ERROR: The packages above have incorrect versions. They can be downgraded using 'Software Sources -> Maintenance -> Downgrade Foreign Packages'.
!!  Exiting.
------------------------------------------------

  + Restoring your backed up APT sources...

docralle@docralle-F5Z:~$


Das Problem bei mir ist, ich habe in der Schule niemals Englisch gehabt, sonder Russisch als Pflichtfach. Und maximal wäre Französisch möglich gewesen. Und der Google-Übersetzer macht es auch nicht immer richtig. 

Re: Upgrade Linux Mint 19.3 auf 20.1
« Antwort #6 am: 04.05.2021, 17:34:42 »
Hi :)

übersetzt.. anwendungpaketquellen > wartung > fremde pakete herabstufen..  und die oberen 3 sind auch nicht verkehrt ;)

allerdings.. wer auf seinem system schon so viele fremde systemnotwendige pakete hat... da ist das mit dem upgrade so eine sache..

Re: Upgrade Linux Mint 19.3 auf 20.1
« Antwort #7 am: 04.05.2021, 18:04:23 »
Den Hinweis findest du in deiner Ausgabe:
!!  ERROR: The packages above have incorrect versions. They can be downgraded using 'Software Sources -> Maintenance -> Downgrade Foreign Packages'