Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
18.05.2021, 01:29:03

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 736103
  • Themen insgesamt: 59269
  • Heute online: 476
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online
Mitglieder: 2
Gäste: 418
Gesamt: 420

Autor Thema: [gelöst]  VirtualBox Fehler "No suitable module for running kernel found"  (Gelesen 6055 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] VirtualBox Fehler "No suitable module for running kernel found"
« am: 14.05.2016, 19:32:31 »
Ich habe kürzlich nach der Installation von Mint 17.3 Cinnemon Edition vom Kernel 3.19.0-32-generic x86_64 (64 bit) auf Kernel 4.4.0-22-generic x86_64 (64 bit) upgegraded. Davor hatte ich VirtualBox bereits installiert, aber noch keine VMs eingerichtet. Nun wollte ich VirtualBox einrichten und erhalte unmittelbar nach dem Starten der VM (testhalber auch eine ganz neue VM ohne HD) die folgende Fehlermeldung:
Zitat
Für die virtuelle Maschine test konnte keine neue Sitzung eröffnet werden.

The virtual machine 'test' has terminated unexpectedly during startup with exit code 1 (0x1).

Fehlercode:NS_ERROR_FAILURE (0x80004005)
Komponente:MachineWrap
Interface:IMachine {f30138d4-e5ea-4b3a-8858-a059de4c93fd}


Also habe ich, wie in diversen Foren und Artikeln empfohlen alle VirtualBox Pakete entfernt, den PC neu gestartet und dann VirtualBox erneut installiert. Zuletzt nicht mehr über die Anwendungsveraltung, sondern über das Terminal:
$ sudo apt-get install virtualbox virtualbox-qt virtualbox-dkms virtualbox-guest-dkms

Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Die folgenden zusätzlichen Pakete werden installiert:
  libgsoap4 libvncserver0 virtualbox-guest-utils virtualbox-guest-x11
Vorgeschlagene Pakete:
  libvncserver0-dbg vde2 virtualbox-guest-additions-iso
Die folgenden NEUEN Pakete werden installiert:
  libgsoap4 libvncserver0 virtualbox virtualbox-dkms virtualbox-guest-dkms
  virtualbox-guest-utils virtualbox-guest-x11 virtualbox-qt
0 aktualisiert, 8 neu installiert, 0 zu entfernen und 1 nicht aktualisiert.
Es müssen noch 2.658 kB von 23,8 MB an Archiven heruntergeladen werden.
Nach dieser Operation werden 105 MB Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren? [J/n] j
Holen: 1 http://ftp-stud.hs-esslingen.de/pub/Mirrors/packages.linuxmint.com/ rosa/upstream virtualbox-guest-utils amd64 5.0.4-dfsg-2 [394 kB]
Holen: 2 http://ftp.uni-mainz.de/ubuntu/ trusty/universe libgsoap4 amd64 2.8.16-2 [525 kB]
Holen: 3 http://ftp-stud.hs-esslingen.de/pub/Mirrors/packages.linuxmint.com/ rosa/upstream virtualbox-guest-dkms all 5.0.4-dfsg-2 [520 kB]
Holen: 4 http://ftp.uni-mainz.de/ubuntu/ trusty-updates/main libvncserver0 amd64 0.9.9+dfsg-1ubuntu1.1 [168 kB]
Holen: 5 http://ftp-stud.hs-esslingen.de/pub/Mirrors/packages.linuxmint.com/ rosa/upstream virtualbox-guest-x11 amd64 5.0.4-dfsg-2 [1.051 kB]
Es wurden 2.658 kB in 0 s geholt (3.846 kB/s).                                 
Vormals nicht ausgewähltes Paket libgsoap4:amd64 wird gewählt.
(Lese Datenbank ... 202874 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../libgsoap4_2.8.16-2_amd64.deb ...
Entpacken von libgsoap4:amd64 (2.8.16-2) ...
Vormals nicht ausgewähltes Paket libvncserver0:amd64 wird gewählt.
Vorbereitung zum Entpacken von .../libvncserver0_0.9.9+dfsg-1ubuntu1.1_amd64.deb ...
Entpacken von libvncserver0:amd64 (0.9.9+dfsg-1ubuntu1.1) ...
Vormals nicht ausgewähltes Paket virtualbox wird gewählt.
Vorbereitung zum Entpacken von .../virtualbox_5.0.4-dfsg-2_amd64.deb ...
Entpacken von virtualbox (5.0.4-dfsg-2) ...
Vormals nicht ausgewähltes Paket virtualbox-dkms wird gewählt.
Vorbereitung zum Entpacken von .../virtualbox-dkms_5.0.4-dfsg-2_all.deb ...
Entpacken von virtualbox-dkms (5.0.4-dfsg-2) ...
Vormals nicht ausgewähltes Paket virtualbox-guest-utils wird gewählt.
Vorbereitung zum Entpacken von .../virtualbox-guest-utils_5.0.4-dfsg-2_amd64.deb ...
Entpacken von virtualbox-guest-utils (5.0.4-dfsg-2) ...
Vormals nicht ausgewähltes Paket virtualbox-guest-dkms wird gewählt.
Vorbereitung zum Entpacken von .../virtualbox-guest-dkms_5.0.4-dfsg-2_all.deb ...
Entpacken von virtualbox-guest-dkms (5.0.4-dfsg-2) ...
Vormals nicht ausgewähltes Paket virtualbox-guest-x11 wird gewählt.
Vorbereitung zum Entpacken von .../virtualbox-guest-x11_5.0.4-dfsg-2_amd64.deb ...
Entpacken von virtualbox-guest-x11 (5.0.4-dfsg-2) ...
Vormals nicht ausgewähltes Paket virtualbox-qt wird gewählt.
Vorbereitung zum Entpacken von .../virtualbox-qt_5.0.4-dfsg-2_amd64.deb ...
Entpacken von virtualbox-qt (5.0.4-dfsg-2) ...
Trigger für ureadahead (0.100.0-16) werden verarbeitet ...
ureadahead will be reprofiled on next reboot
Trigger für man-db (2.6.7.1-1ubuntu1) werden verarbeitet ...
Trigger für gnome-menus (3.10.1-0ubuntu2) werden verarbeitet ...
Trigger für desktop-file-utils (0.22-1ubuntu1) werden verarbeitet ...
Trigger für mime-support (3.54ubuntu1.1) werden verarbeitet ...
Trigger für menu (2.1.46ubuntu1) werden verarbeitet ...
Trigger für hicolor-icon-theme (0.13-1) werden verarbeitet ...
Trigger für shared-mime-info (1.2-0ubuntu3) werden verarbeitet ...
libgsoap4:amd64 (2.8.16-2) wird eingerichtet ...
libvncserver0:amd64 (0.9.9+dfsg-1ubuntu1.1) wird eingerichtet ...
virtualbox (5.0.4-dfsg-2) wird eingerichtet ...
 * Stopping VirtualBox kernel modules                                    [ OK ]
 * Starting VirtualBox kernel modules                                            * No suitable module for running kernel found
                                                                         [fail]
invoke-rc.d: initscript virtualbox, action "restart" failed.
virtualbox-guest-utils (5.0.4-dfsg-2) wird eingerichtet ...
virtualbox-guest-dkms (5.0.4-dfsg-2) wird eingerichtet ...
Loading new virtualbox-guest-5.0.4 DKMS files...
First Installation: checking all kernels...
Building only for 4.4.0-22-generic
Building initial module for 4.4.0-22-generic
Done.

vboxguest:
Running module version sanity check.
Error! Module version 5.0.4_LinuxMint for vboxguest.ko
is not newer than what is already found in kernel 4.4.0-22-generic (5.0.18_Ubuntu).
You may override by specifying --force.

vboxsf.ko:
Running module version sanity check.
Error! Module version 5.0.4_LinuxMint for vboxsf.ko
is not newer than what is already found in kernel 4.4.0-22-generic (5.0.18_Ubuntu).
You may override by specifying --force.

vboxvideo.ko:
Running module version sanity check.
Error! Module version 5.0.4_LinuxMint for vboxvideo.ko
is not newer than what is already found in kernel 4.4.0-22-generic (5.0.18_Ubuntu).
You may override by specifying --force.

depmod....

DKMS: install completed.
virtualbox-guest-x11 (5.0.4-dfsg-2) wird eingerichtet ...
Trigger für ureadahead (0.100.0-16) werden verarbeitet ...
virtualbox-qt (5.0.4-dfsg-2) wird eingerichtet ...
virtualbox-dkms (5.0.4-dfsg-2) wird eingerichtet ...
Loading new virtualbox-5.0.4 DKMS files...
First Installation: checking all kernels...
Building only for 4.4.0-22-generic
Building initial module for 4.4.0-22-generic
Error! Bad return status for module build on kernel: 4.4.0-22-generic (x86_64)
Consult /var/lib/dkms/virtualbox/5.0.4/build/make.log for more information.
 * Stopping VirtualBox kernel modules                                    [ OK ]
 * Starting VirtualBox kernel modules                                            * No suitable module for running kernel found
                                                                         [fail]
invoke-rc.d: initscript virtualbox, action "restart" failed.
Trigger für libc-bin (2.19-0ubuntu6.7) werden verarbeitet ...
Trigger für menu (2.1.46ubuntu1) werden verarbeitet ...

Ich vermute, dass dieser Fehler bei der Installation die Ursache des Problems ist.
* Starting VirtualBox kernel modules                                           
* No suitable module for running kernel found"


Hat jemand eine Idee wie sich das lösen lässt? Vielen Dank vorab!


Anhang (möglicherweise relevant?):
$ dpkg -l virt*
Gewünscht=Unbekannt/Installieren/R=Entfernen/P=Vollständig Löschen/Halten
| Status=Nicht/Installiert/Config/U=Entpackt/halb konFiguriert/
         Halb installiert/Trigger erWartet/Trigger anhängig
|/ Fehler?=(kein)/R=Neuinstallation notwendig (Status, Fehler: GROSS=schlecht)
||/ Name                    Version          Architektur      Beschreibung
+++-=======================-================-================-===================================================
ii  virtualbox              5.0.4-dfsg-2     amd64            x86 virtualization solution - base binaries
un  virtualbox-2.0          <keine>          <keine>          (keine Beschreibung vorhanden)
un  virtualbox-2.1          <keine>          <keine>          (keine Beschreibung vorhanden)
un  virtualbox-2.2          <keine>          <keine>          (keine Beschreibung vorhanden)
un  virtualbox-3.0          <keine>          <keine>          (keine Beschreibung vorhanden)
un  virtualbox-3.1          <keine>          <keine>          (keine Beschreibung vorhanden)
un  virtualbox-3.2          <keine>          <keine>          (keine Beschreibung vorhanden)
un  virtualbox-4.0          <keine>          <keine>          (keine Beschreibung vorhanden)
un  virtualbox-4.1          <keine>          <keine>          (keine Beschreibung vorhanden)
un  virtualbox-4.2          <keine>          <keine>          (keine Beschreibung vorhanden)
un  virtualbox-4.3          <keine>          <keine>          (keine Beschreibung vorhanden)
un  virtualbox-5.0          <keine>          <keine>          (keine Beschreibung vorhanden)
ii  virtualbox-dkms         5.0.4-dfsg-2     all              x86 virtualization solution - kernel module sources
un  virtualbox-guest-additi <keine>          <keine>          (keine Beschreibung vorhanden)
ii  virtualbox-guest-dkms   5.0.4-dfsg-2     all              x86 virtualization solution - guest addition module
un  virtualbox-guest-module <keine>          <keine>          (keine Beschreibung vorhanden)
un  virtualbox-guest-source <keine>          <keine>          (keine Beschreibung vorhanden)
ii  virtualbox-guest-utils  5.0.4-dfsg-2     amd64            x86 virtualization solution - non-X11 guest utiliti
ii  virtualbox-guest-x11    5.0.4-dfsg-2     amd64            x86 virtualization solution - X11 guest utilities
ii  virtualbox-qt           5.0.4-dfsg-2     amd64            x86 virtualization solution - Qt based user interfa
un  virtualbox-source       <keine>          <keine>          (keine Beschreibung vorhanden)
« Letzte Änderung: 16.05.2016, 19:28:17 von Samo »

Hi,
schau mal hier ob dich das weiter bringt.:

Kein Start mehr nach Kernelupdate
https://wiki.ubuntuusers.de/VirtualBox/Problembehebung/

Der Abschnitt "Kein Start mehr nach Kernelupdate" scheint zu passen. Gleich der erste Schritt schlägt allerdings fehl und dieser Fehlerfall ist nicht abgedeckt.
$ sudo /etc/init.d/vboxdrv setup
sudo: /etc/init.d/vboxdrv: command not found

Schau mal hier:
https://forum.ubuntuusers.de/post/4962062/

...da geht es allerdings um eine ältere Version und müsste angepasst werden.
« Letzte Änderung: 15.05.2016, 10:08:38 von helli »

virtualbox.org

Doppelklick auf die aktuelle Version für ubuntu trusty nutzt dpkg für die Installation. Beim ersten Start der VB wirst Du gefrakgt ob Du die aktuelle Extension installieren willst: natürlich willst Du.

Es kann sein daß Du beim Start eine Fehlermeldung daß etwas fehlt bekommst. Das angezeigte Kommando in einem Terminal als root eingeben.

Zuletzt noch die Erweiterung in den Clients einlegen und die Installation ausführen. Danach steht der Betrieb von USB-Geräten nichts mehr entgegen, wenn man die einsteckt und dann im BIOS des Clients den Treiber unter USB einfügt. Fer sollte dann dort angezeigt werden.

Ich habe versucht die von helli verlinkte Lösung für meinen 4.4er Kernel anzuwenden. Das ging aber kräftig schief:
$ sudo /etc/init.d/vboxdrv setup
sudo: /etc/init.d/vboxdrv: command not found

$ sudo apt-add-repository 'deb http://download.virtualbox.org/virtualbox/debian xenial contrib'
$ sudo add-apt-repository --remove 'deb-src http://download.virtualbox.org/virtualbox/debian xenial contrib'
Usage: add-apt-repository [options] repository
add-apt-repository: error: no such option: --remove

$ wget -q http://download.virtualbox.org/virtualbox/debian/oracle_vbox.asc -O- | sudo apt-key add -
OK

$ killall -9 virtualbox
virtualbox: Kein Prozess gefunden

sudo apt-get remove virtualbox*
...
Package 'virtualbox-2.0' is not installed, so not removed
Package 'virtualbox-2.1' is not installed, so not removed
Package 'virtualbox-2.2' is not installed, so not removed
Package 'virtualbox-3.0' is not installed, so not removed
Package 'virtualbox-3.1' is not installed, so not removed
Package 'virtualbox-3.2' is not installed, so not removed
Package 'virtualbox-4.0' is not installed, so not removed
Package 'virtualbox-4.1' is not installed, so not removed
Package 'virtualbox-4.2' is not installed, so not removed
Package 'virtualbox-4.3' is not installed, so not removed
Package 'virtualbox-ose' is not installed, so not removed
Package 'virtualbox-guest-additions' is not installed, so not removed
Package 'virtualbox-modules' is not installed, so not removed
Package 'virtualbox-nonfree' is not installed, so not removed
Package 'virtualbox-dbg' is not installed, so not removed
Package 'virtualbox-guest-source' is not installed, so not removed
Package 'virtualbox-source' is not installed, so not removed
Package 'virtualbox-5.0' is not installed, so not removed
Package 'unity-scope-virtualbox' is not installed, so not removed
Package 'virtualbox-guest-additions-iso' is not installed, so not removed
Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
  libgsoap4 libvncserver0
Verwenden Sie »apt-get autoremove«, um sie zu entfernen.
Die folgenden Pakete werden ENTFERNT:
  virtualbox virtualbox-dkms virtualbox-guest-dkms virtualbox-guest-utils
  virtualbox-guest-x11 virtualbox-qt
0 aktualisiert, 0 neu installiert, 6 zu entfernen und 1 nicht aktualisiert.
Nach dieser Operation werden 103 MB Plattenplatz freigegeben.
Möchten Sie fortfahren? [J/n] j
(Lese Datenbank ... 203735 Dateien und Verzeichnisse sind derzeit installiert.)
Entfernen von virtualbox-qt (5.0.4-dfsg-2) ...
Entfernen von virtualbox-dkms (5.0.4-dfsg-2) ...

------------------------------
Deleting module version: 5.0.4
completely from the DKMS tree.
------------------------------
Done.
Entfernen von virtualbox (5.0.4-dfsg-2) ...
 * Stopping VirtualBox kernel modules                                    [ OK ]
Entfernen von virtualbox-guest-dkms (5.0.4-dfsg-2) ...

-------- Uninstall Beginning --------
Module:  virtualbox-guest
Version: 5.0.4
Kernel:  4.4.0-22-generic (x86_64)
-------------------------------------

Status: Before uninstall, this module version was ACTIVE on this kernel.

vboxguest.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.4.0-22-generic/
rmdir: konnte »“ nicht entfernen: Datei oder Verzeichnis nicht gefunden
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


vboxsf.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.4.0-22-generic/
rmdir: konnte »“ nicht entfernen: Datei oder Verzeichnis nicht gefunden
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


vboxvideo.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.4.0-22-generic/
rmdir: konnte »“ nicht entfernen: Datei oder Verzeichnis nicht gefunden
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.

depmod....

DKMS: uninstall completed.

------------------------------
Deleting module version: 5.0.4
completely from the DKMS tree.
------------------------------
Done.
Entfernen von virtualbox-guest-x11 (5.0.4-dfsg-2) ...
Entfernen von virtualbox-guest-utils (5.0.4-dfsg-2) ...
Trigger für man-db (2.6.7.1-1ubuntu1) werden verarbeitet ...
Trigger für shared-mime-info (1.2-0ubuntu3) werden verarbeitet ...
Trigger für hicolor-icon-theme (0.13-1) werden verarbeitet ...
Trigger für menu (2.1.46ubuntu1) werden verarbeitet ...
Trigger für gnome-menus (3.10.1-0ubuntu2) werden verarbeitet ...
Trigger für desktop-file-utils (0.22-1ubuntu1) werden verarbeitet ...
Trigger für mime-support (3.54ubuntu1.1) werden verarbeitet ...
Trigger für libc-bin (2.19-0ubuntu6.7) werden verarbeitet ...

$ sudo apt-get clean
$ sudo apt-get update
...
Es wurden 9.868 B in 3 s geholt (3.067 B/s).
Paketlisten werden gelesen... Fertig
W: GPG-Fehler: http://download.virtualbox.org xenial InRelease: Die folgenden Signaturen konnten nicht überprüft werden, weil ihr öffentlicher Schlüssel nicht verfügbar ist: NO_PUBKEY A2F683C52980AECF

$ sudo apt-get install virtualbox-5.0
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 virtualbox-5.0 : Hängt ab von: libdevmapper1.02.1 (>= 2:1.02.97) aber 2:1.02.77-6ubuntu2 soll installiert werden
                  Hängt ab von: libstdc++6 (>= 5.2) aber 4.8.4-2ubuntu1~14.04.1 soll installiert werden
                  Hängt ab von: libvpx3 (>= 1.5.0) ist aber nicht installierbar
                  Empfiehlt: libsdl-ttf2.0-0 soll aber nicht installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.


Zum Post von centaur: Müsste ich nicht von https://www.virtualbox.org/wiki/Linux_Downloads aufgrund meines Kernels die Version für Xenial anstelle der vorgeschlagenen Trusty verwenden?
Sollten zuvor alle bereits installierten Pakete zu VirtualBox und/oder die zusätzliche Paketquelle 'deb http://download.virtualbox.org/virtualbox/debian xenial contrib' entfernt werden?
Dieser Ansatz basiert darauf die aktuelle VirtualBox Version 5.0.20 anstelle der, in der Anwendungsverwaltung verfügbaren Version 5.0.4 zu verwenden, oder?
« Letzte Änderung: 16.05.2016, 10:54:59 von Samo »

Sollten zuvor alle bereits installierten Pakete zu VirtualBox und/oder die zusätzliche Paketquelle 'deb http://download.virtualbox.org/virtualbox/debian xenial contrib' entfernt werden?


Würde ich an Deiner Stelle machen. Also alles, was in Sachen Virtualbox da ist, vollständig entfernen (apt-get purge). Alle zusätzlichen Quellen, die wegen Virtualbox eingetragen hast, entfernen. Dann
sudo apt-get update && sudo apt-get install virtualbox virtualbox-dkms virtualbox-guest-dkms virtualbox-guest-utils virtualbox-guest-x11 virtualbox-qt

Macht der vorgeschlagene Befehl denn nicht im Wesentlichen das gleiche wie der in meinem ersten Post verwendete? Vgl:
$sudo apt-get install virtualbox virtualbox-dkms virtualbox-guest-dkms virtualbox-guest-utils virtualbox-guest-x11 virtualb$sudo apt-get install virtualbox virtualbox-qt virtualbox-dkms virtualbox-guest-dkms
Der Fehler ist auf jeden Fall bei beiden Befehlen der gleiche wie in meinem ersten Post benannt:
...
virtualbox (5.0.4-dfsg-2) wird eingerichtet ...
 * Stopping VirtualBox kernel modules                                     [ OK ]
 * Starting VirtualBox kernel modules                                             * No suitable module for running kernel found
                                                                          [fail]
invoke-rc.d: initscript virtualbox, action "restart" failed.
virtualbox-dkms (5.0.4-dfsg-2) wird eingerichtet ...
Loading new virtualbox-5.0.4 DKMS files...
First Installation: checking all kernels...
Building only for 4.4.0-22-generic
Building initial module for 4.4.0-22-generic
Error! Bad return status for module build on kernel: 4.4.0-22-generic (x86_64)
Consult /var/lib/dkms/virtualbox/5.0.4/build/make.log for more information.
 * Stopping VirtualBox kernel modules                                     [ OK ]
 * Starting VirtualBox kernel modules                                             * No suitable module for running kernel found
                                                                          [fail]
invoke-rc.d: initscript virtualbox, action "restart" failed.
virtualbox-guest-utils (5.0.4-dfsg-2) wird eingerichtet ...
virtualbox-guest-dkms (5.0.4-dfsg-2) wird eingerichtet ...
Loading new virtualbox-guest-5.0.4 DKMS files...
First Installation: checking all kernels...
Building only for 4.4.0-22-generic
Building initial module for 4.4.0-22-generic
Done.

vboxguest:
Running module version sanity check.
Error! Module version 5.0.4_LinuxMint for vboxguest.ko
is not newer than what is already found in kernel 4.4.0-22-generic (5.0.18_Ubuntu).
You may override by specifying --force.

vboxsf.ko:
Running module version sanity check.
Error! Module version 5.0.4_LinuxMint for vboxsf.ko
is not newer than what is already found in kernel 4.4.0-22-generic (5.0.18_Ubuntu).
You may override by specifying --force.

vboxvideo.ko:
Running module version sanity check.
Error! Module version 5.0.4_LinuxMint for vboxvideo.ko
is not newer than what is already found in kernel 4.4.0-22-generic (5.0.18_Ubuntu).
You may override by specifying --force.

depmod....

DKMS: install completed.
virtualbox-guest-x11 (5.0.4-dfsg-2) wird eingerichtet ...
virtualbox-qt (5.0.4-dfsg-2) wird eingerichtet ...
Trigger für libc-bin (2.19-0ubuntu6.7) werden verarbeitet ...
Trigger für menu (2.1.46ubuntu1) werden verarbeitet ...

Diese Meldungen sollten m.E. nichts ausmachen.
Ich kann das nicht ganz nachprüfen bei mir, weil ich Mint gar nicht installiert habe (sondern Ubuntu). Mint hat ja dieses eigene Virtualbox in der Mint-Quelle (das wird mit dem Befehl auch installiert). Dennoch glaube ich hier im Forum schon mitbekommen zu haben, dass Virtualbox mit Kernel 4.4 trotz dieser Meldungen bei der Installation lief.

Entscheidend ist m.E., dass Du alle anderen Quellen besetitigt hast vorher. Das scheint ja der Fall zu sein.

Ja, ich habe alle VirtualBox Pakete entfernt, die zusätzliche Paketquelle 'deb http://download.virtualbox.org/virtualbox/debian xenial contrib' deaktiviert und dann mit deinem Befehl neu installiert.

Ich lande wieder bei dem gleichen Problem wie ganz am Anfang meines ersten Posts beschrieben.
Zitat
Für die virtuelle Maschine esr konnte keine neue Sitzung eröffnet werden.

The virtual machine 'name' has terminated unexpectedly during startup with exit code 1 (0x1).

Fehlercode:NS_ERROR_FAILURE (0x80004005)
Komponente:MachineWrap
Interface:IMachine {f30138d4-e5ea-4b3a-8858-a059de4c93fd}


Re: VirtualBox Fehler "No suitable module for running kernel found"
« Antwort #10 am: 16.05.2016, 13:53:34 »
sudo adduser $USER vboxusersund
newgrp - vboxusershast Du gemacht?

UND: Welches Extension-Pack hast Du jetzt installiert? Du hast ja jetzt offenbar VB 5.0.4, brauchst also
http://download.virtualbox.org/virtualbox/5.0.4/Oracle_VM_VirtualBox_Extension_Pack-5.0.4-102546.vbox-extpack

Re: VirtualBox Fehler "No suitable module for running kernel found"
« Antwort #11 am: 16.05.2016, 14:56:20 »
Bislang nicht. Jetzt habe ich die beiden Kommandos ausgeführt und den verlinkten Extension-Pack (ja, habe VirtualBox Version 5.0.4) installiert.
Der Fehler ist weiterhin unverändert der gleiche.

Re: VirtualBox Fehler "No suitable module for running kernel found"
« Antwort #12 am: 16.05.2016, 15:05:11 »
Was sagt jetzt
sudo /etc/init.d/vboxdrv setup?

Re: VirtualBox Fehler "No suitable module for running kernel found"
« Antwort #13 am: 16.05.2016, 15:21:43 »
Das gleiche wie bisher auch:
sudo /etc/init.d/vboxdrv setup
sudo: /etc/init.d/vboxdrv: command not found

Re: VirtualBox Fehler "No suitable module for running kernel found"
« Antwort #14 am: 16.05.2016, 15:42:10 »
Hm, blöd...

Zeig mal bitte folgende Sachen nochmal
dpkg -l | grep dkmsdpkg -l | grep linux | grep genericdpkg -l | grep virtual
grep -P '^[ \t]*[^#[ \t]+' /etc/apt/sources.list /etc/apt/sources.list.d/*.list