LMU - Das Hilfe Forum für Linux Mint

Hardware => Hardware gesucht? => Thema gestartet von: Manny_K am 22.02.2021, 22:04:59

Titel: PCIe Lan-Karte gesucht
Beitrag von: Manny_K am 22.02.2021, 22:04:59
Hallo Leute,

ich habe bei mir Leider die Realtek RTL8125 onboard. Anscheinend gibt es da keine Treiber im Kernel. Könnt Ihr mir eine PCIe Lan-Karte empfehlen, die von Mint (Linux Mint 20.1 Ulyssa) unterstützt wird?
Titel: Re: PCIe Lan-Karte gesucht
Beitrag von: Michelle_Br am 23.02.2021, 10:46:57
Die Frage ist, was Du damit machen willst - reines Streaming, Internet etc. oder auch Gaming (Bedeutung der niedrigen Latenzen beachten)?

Gib doch bitte mal im Terminal ein inxi -Fz und poste die Ausgabe hier im Codeblock (#).
Titel: Re: PCIe Lan-Karte gesucht
Beitrag von: tommix am 23.02.2021, 10:53:00
In die Desktops meiner Enkelkinder habe ich diese eingebaut.
Sie laufen auf jeden Fall ab LM 19 und auch LMDE4 ohne zusätzliche Treiber (auch mit LM 20.1).

https://www.amazon.de/gp/product/B006BSPTAQ/ref=ppx_yo_dt_b_asin_title_o01_s01?ie=UTF8&psc=1 (https://www.amazon.de/gp/product/B006BSPTAQ/ref=ppx_yo_dt_b_asin_title_o01_s01?ie=UTF8&psc=1)
Titel: Re: PCIe Lan-Karte gesucht
Beitrag von: Michelle_Br am 23.02.2021, 10:58:51
Vielleicht ist ein Neukauf nicht erforderlich. Ab Kernel 5.9 ist das gefixt:
https://askubuntu.com/questions/1259947/cant-get-rtl8125b-working-on-20-04 (https://askubuntu.com/questions/1259947/cant-get-rtl8125b-working-on-20-04)

Nun müssen wir aber noch das System kennen lernen um zu sehen, ob dieser work-around ginge. Außerdem wurde doch eine Lan-Karte gesucht?!
Titel: Re: PCIe Lan-Karte gesucht
Beitrag von: tommix am 23.02.2021, 11:18:45
Das ist doch wieder so ein 2500 MB/s Karte.
Das wird wohl nichts mit 5.9er Kernel.
Schaut mal in die Suche, da hatte Flash63 schon mal Support zu.
Titel: Re: PCIe Lan-Karte gesucht
Beitrag von: Manny_K am 23.02.2021, 13:42:51
Die Frage ist, was Du damit machen willst - reines Streaming, Internet etc. oder auch Gaming (Bedeutung der niedrigen Latenzen beachten)?
Also Internet und Streaming. Spiele tu ich kaum noch.

Gib doch bitte mal im Terminal ein
inxi -Fz

und poste die Ausgabe hier im Codeblock (#)inxi -Fz
inxi -Fz
System:
  Kernel: 5.8.0-43-generic x86_64 bits: 64 Desktop: Cinnamon 4.8.6
  Distro: Linux Mint 20.1 Ulyssa
Machine:
  Type: Desktop System: Micro-Star product: MS-7C35 v: 2.0 serial: <filter>
  Mobo: Micro-Star model: MEG X570 UNIFY (MS-7C35) v: 2.0 serial: <filter>
  UEFI: American Megatrends LLC. v: A.80 date: 01/22/2021
CPU:
  Topology: 8-Core model: AMD Ryzen 7 3700X bits: 64 type: MT MCP
  L2 cache: 4096 KiB
  Speed: 2198 MHz min/max: 2200/3600 MHz Core speeds (MHz): 1: 2200 2: 2198
  3: 2196 4: 2199 5: 2793 6: 2800 7: 1866 8: 1866 9: 2200 10: 2200 11: 2815
  12: 2801 13: 1866 14: 1866 15: 2197 16: 2196
Graphics:
  Device-1: NVIDIA TU116 [GeForce GTX 1660 SUPER] driver: nvidia
  v: 460.32.03
  Display: x11 server: X.Org 1.20.9 driver: fbdev,modesetting,nouveau
  unloaded: vesa resolution: 2560x1440~93Hz
  OpenGL: renderer: llvmpipe (LLVM 11.0.0 256 bits) v: 4.5 Mesa 20.2.6
Audio:
  Device-1: Philips s SAA7160 driver: SAA716x Budget
  Device-2: NVIDIA TU116 High Definition Audio driver: snd_hda_intel
  Device-3: AMD Starship/Matisse HD Audio driver: snd_hda_intel
  Device-4: Microsoft LifeChat LX-3000 Headset type: USB
  driver: hid-generic,snd-usb-audio,usbhid
  Sound Server: ALSA v: k5.8.0-43-generic
Network:
  Device-1: Realtek RTL8125 2.5GbE driver: r8169
  IF: enp39s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi
  IF: wlo1 state: up mac: <filter>
Drives:
  Local Storage: total: 3.18 TiB used: 156.29 GiB (4.8%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO Plus 500GB
  size: 465.76 GiB
  ID-2: /dev/nvme1n1 vendor: Samsung model: SSD 980 PRO 1TB size: 931.51 GiB
  ID-3: /dev/sda vendor: SanDisk model: SDSSDA-2T00 size: 1.82 TiB
  ID-4: /dev/sdb vendor: Samsung model: SSD 840 EVO 500GB size: 465.76 GiB
Partition:
  ID-1: / size: 915.43 GiB used: 156.25 GiB (17.1%) fs: ext4
  dev: /dev/nvme1n1p2
Sensors:
  System Temperatures: cpu: 34.6 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 376 Uptime: 1m Memory: 31.34 GiB used: 1.74 GiB (5.6%)
  Shell: bash inxi: 3.0.38

[MOD: Zitat korrigiert.]
Titel: Re: PCIe Lan-Karte gesucht
Beitrag von: Manny_K am 23.02.2021, 15:56:32
Nun müssen wir aber noch das System kennen lernen um zu sehen, ob dieser work-around ginge. Außerdem wurde doch eine Lan-Karte gesucht?!

Mein System:
CPU: AMD Ryzen 7 3700X
Board: MSI MEG X570 Unify
BIOS: E7C35AMS.A70
RAM: 2 x 16 GB Corsair CMK32GX4M2B3000C15
Netzteil:Straight Power 10 600 Watt
SSD 1: Samsung SSD 980 PRO 1 TB
SSD 2: Samsung SSD 970 EVO Plus 500 GB
SSD 3: Samsung SSD 840 EVO 500 GB
SSD 4: SanDisk SDSSDA 2 TB
Grafikkarte: NVIDIA GeForce GTX 1660 SUPER
TV Karte: TechniSat SkyStar 2 eXpress HD
Titel: Re: PCIe Lan-Karte gesucht
Beitrag von: Manny_K am 23.02.2021, 16:00:54
In die Desktops meiner Enkelkinder habe ich diese eingebaut.
Sie laufen auf jeden Fall ab LM 19 und auch LMDE4 ohne zusätzliche Treiber (auch mit LM 20.1).

https://www.amazon.de/gp/product/B006BSPTAQ/ref=ppx_yo_dt_b_asin_title_o01_s01?ie=UTF8&psc=1

Ich Suche eine Lan-Karte! WLan ist bereits auf meinem Motherboard integriert.
Titel: Re: PCIe Lan-Karte gesucht
Beitrag von: toffifee am 23.02.2021, 16:17:28
Device-1: Realtek RTL8125 2.5GbE driver: r8169
  IF: enp39s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Die Karte ist erkannt, Treiber geladen und Interface "up". Sicher, dass das Problem noch besteht?
Titel: Re: PCIe Lan-Karte gesucht
Beitrag von: Manny_K am 23.02.2021, 18:16:29
Die Karte ist erkannt, Treiber geladen und Interface "up". Sicher, dass das Problem noch besteht?
Das scheint aber nicht der richtige Treiber zu sein. Nach kurzer Zeit kommt die Meldung, dass die Verbindung getrennt ist. Die Karte schaltet sich aus. Am Anfang ist mir das nicht gleich aufgefallen. ich dachte erst das Lan Kabel wäre defekt. Wahrscheinlich funktionierte die Karte mit älteren Kernelversionen zumindest besser. Ich probiere das mal aus. Wenn ich aber mit jedem Kernelupdate rechnen muss, dass die Karte nicht funktioniert, baue ich mir lieber eine zusätzliche Karte ein die Problemlos funktioniert.
Titel: Re: PCIe Lan-Karte gesucht
Beitrag von: Michelle_Br am 23.02.2021, 18:45:08
nein - ich habe jetzt nicht weiter recherchiert - aber in dem link stand, dass sie mit dem 5.9´er Kernel wohl läuft. Es ist ja ganz neue Hardware und i.d.R. braucht es dafür neue Kernel. Aber ich bin betreffs neuer Hardware auch nicht up2date - ich habe nur olle Bretter.....

In dem link oben steht unter #17, wie bei älteren Kerneln vorgegangen werden muss.....
Zitat
............
17

I had the same exact issue. Looks like you're missing drivers for the Ethernet.

Go to this link (which is from the actual Ethernet provider): https://www.realtek.com/en/component/zoo/category/network-interface-controllers-10-100-1000m-gigabit-ethernet-pci-express-software

Download the "2.5G Ethernet LINUX driver r8125 for kernel up to 5.6" and follow the installation instructions.

You should be able to use wired connection once you're done.
...........
Titel: Re: PCIe Lan-Karte gesucht
Beitrag von: Manny_K am 23.02.2021, 19:04:37
Ist bekannt wann der 5.9er Kernel für Mint zur Verfügung steht?
Titel: Re: PCIe Lan-Karte gesucht
Beitrag von: tommix am 23.02.2021, 19:29:30
Ist bekannt wann der 5.9er Kernel für Mint zur Verfügung steht?
Nie!
Das nächste Ubuntu 21.04 wird wohl mit Kernel 5.11 erscheinen.
Und der 5.9er Mainline ist schon EOL.
Bleibt als nur Mainline - Kernel Linux 5.10er, dieser ist ein LTS - Kernel oder der neue Mainline Kernel Linux 5.11er.
Titel: Re: PCIe Lan-Karte gesucht
Beitrag von: ehtron am 24.02.2021, 13:21:51
Hi :)
du hast aber nicht das lan kabel gesteckt, während du die wlan verbindung aktivierst?
Titel: Re: PCIe Lan-Karte gesucht
Beitrag von: Michelle_Br am 24.02.2021, 18:41:02
...noch einmal - es braucht nicht zwingend einen neuen Kernel! Lese doch bitte mal.....es gibt für ANDERE Kernel einen workaround.....
Titel: Re: PCIe Lan-Karte gesucht
Beitrag von: Manny_K am 25.02.2021, 21:48:45
So ich habe das ganze noch mal getestet. Der Lan-Anschluss läuft manchmal über eine halbe Stunde es kann aber genauso sein, dass er nur Sekunden oder ein paar Minuten läuft. Ich hoffe das Problem wird mit dem 5.10er Kernel behoben ist. Weis einer, wenn er für Mint zu erwarten ist?
Hallo ethron; WLan war nicht gleichzeitig mit Lan aktiviert.
Der von Michelle_Br vorgeschlagene Workaround hat leider nicht funktioniert.
Da ich eine funktionierente W-Lan Verbindung habe, verzichte ich auf den Kauf einer Lan-Karte.
Titel: Re: PCIe Lan-Karte gesucht
Beitrag von: Michelle_Br am 25.02.2021, 21:59:03
Dieser workaround stammt ja nicht von mir. Hast Du es auch exakt (!) abgearbeitet?

D.h. hast Du diese Datei herunter geladen?
https://www.realtek.com/en/directly-download?downloadid=95f1076134d28cfcebcb49fc65a6811e (https://www.realtek.com/en/directly-download?downloadid=95f1076134d28cfcebcb49fc65a6811e)

Ich habe das gerade mal gemacht - es muss kompiliert werden! Da weiß ich aber auch nicht weiter.....aber es gibt eine Readme
Läuft bis Kernel 5.6

Hast Du das alles versucht? Du sagst, es habe nicht funktioniert?

Hier die Readme:
Zitat
<Linux device driver for Realtek Ethernet controllers>

   This is the Linux device driver released for RealTek RTL8125 2.5Gigabit Ethernet controllers with PCI-Express interface.

<Requirements>

   - Kernel source tree (supported Linux kernel 2.6.x and 2.4.x)
   - For linux kernel 2.4.x, this driver supports 2.4.20 and latter.
   - Compiler/binutils for kernel compilation

<Quick install with proper kernel settings>
   Unpack the tarball :
      # tar vjxf r8125-8.aaa.bb.tar.bz2

   Change to the directory:
      # cd r8125-8.aaa.bb

   If you are running the target kernel, then you should be able to do :

      # ./autorun.sh   (as root or with sudo)

   You can check whether the driver is loaded by using following commands.

      # lsmod | grep r8125
      # ifconfig -a

   If there is a device name, ethX, shown on the monitor, the linux
   driver is loaded. Then, you can use the following command to activate
   the ethX.

      # ifconfig ethX up

      ,where X=0,1,2,...

<Set the network related information>
   1. Set manually
      a. Set the IP address of your machine.

         # ifconfig ethX "the IP address of your machine"

      b. Set the IP address of DNS.

         Insert the following configuration in /etc/resolv.conf.

         nameserver "the IP address of DNS"

      c. Set the IP address of gateway.

         # route add default gw "the IP address of gateway"

   2. Set by doing configurations in /etc/sysconfig/network-scripts
      /ifcfg-ethX for Redhat and Fedora, or /etc/sysconfig/network
      /ifcfg-ethX for SuSE. There are two examples to set network
      configurations.

      a. Fixed IP address:
         DEVICE=eth0
         BOOTPROTO=static
         ONBOOT=yes
         TYPE=ethernet
         NETMASK=255.255.255.0
         IPADDR=192.168.1.1
         GATEWAY=192.168.1.254
         BROADCAST=192.168.1.255

      b. DHCP:
         DEVICE=eth0
         BOOTPROTO=dhcp
         ONBOOT=yes

<Modify the MAC address>
   There are two ways to modify the MAC address of the NIC.
   1. Use ifconfig:

      # ifconfig ethX hw ether YY:YY:YY:YY:YY:YY

      ,where X is the device number assigned by Linux kernel, and
        YY:YY:YY:YY:YY:YY is the MAC address assigned by the user.

   2. Use ip:

      # ip link set ethX address YY:YY:YY:YY:YY:YY

      ,where X is the device number assigned by Linux kernel, and
        YY:YY:YY:YY:YY:YY is the MAC address assigned by the user.

<Force Link Status>

   1. Force the link status when insert the driver.

      If the user is in the path ~/r8125, the link status can be forced
      to one of the 5 modes as following command.

      # insmod ./src/r8125.ko speed=SPEED_MODE duplex=DUPLEX_MODE autoneg=NWAY_OPTION

      ,where
         SPEED_MODE   = 1000   for 1000Mbps
               = 100   for 100Mbps
               = 10   for 10Mbps
         DUPLEX_MODE   = 0   for half-duplex
               = 1   for full-duplex
         NWAY_OPTION   = 0   for auto-negotiation off (true force)
               = 1   for auto-negotiation on (nway force)
      For example:

         # insmod ./src/r8125.ko speed=100 duplex=0 autoneg=1

      will force PHY to operate in 100Mpbs Half-duplex(nway force).

   2. Force the link status by using ethtool.
      a. Insert the driver first.
      b. Make sure that ethtool exists in /sbin.
      c. Force the link status as the following command.

         # ethtool -s ethX speed SPEED_MODE duplex DUPLEX_MODE autoneg NWAY_OPTION

         ,where
            SPEED_MODE   = 1000   for 1000Mbps
                  = 100   for 100Mbps
                  = 10   for 10Mbps
            DUPLEX_MODE   = half   for half-duplex
                  = full   for full-duplex
            NWAY_OPTION   = off   for auto-negotiation off (true force)
                  = on   for auto-negotiation on (nway force)

      For example:

         # ethtool -s eth0 speed 100 duplex full autoneg on

      will force PHY to operate in 100Mpbs Full-duplex(nway force).

<Jumbo Frame>
   Transmitting Jumbo Frames, whose packet size is bigger than 1500 bytes, please change mtu by the following command.

   # ifconfig ethX mtu MTU

   , where X=0,1,2,..., and MTU is configured by user.

   RTL8125 supports Jumbo Frame size up to 9 kBytes.
Titel: Re: PCIe Lan-Karte gesucht
Beitrag von: Flash63 am 25.02.2021, 22:29:14
Hallo,
nicht vergessen, dass fälschlicherweise zugeordnete/fehlerhaft arbeitende Modul r8169 zu sperren! Sonst funktionier das nicht.
Titel: Re: PCIe Lan-Karte gesucht
Beitrag von: Manny_K am 25.02.2021, 22:45:56
Läuft bis Kernel 5.6

Ich benutze aktuell den 5.8er Kernel. Dann kann das wohl nicht gehen.
Titel: Re: PCIe Lan-Karte gesucht
Beitrag von: Manny_K am 25.02.2021, 22:46:26
nicht vergessen, dass fälschlicherweise zugeordnete/fehlerhaft arbeitende Modul r8169 zu sperren! Sonst funktionier das nicht.

Wie muß ich das machen?
Titel: Re: PCIe Lan-Karte gesucht
Beitrag von: Michelle_Br am 27.02.2021, 11:19:47
Läuft bis Kernel 5.6

Ich benutze aktuell den 5.8er Kernel. Dann kann das wohl nicht gehen.

Läuft denn der 5.4´er ggfs. nicht? Probiere das doch mal, wenn es ggfs. die Lösung bringt? Oder versuche, einen höheren von außerhalb einzubinden. Da müssen aber andere hier helfen. Das kann ich nicht.
Titel: Re: PCIe Lan-Karte gesucht
Beitrag von: Flash63 am 27.02.2021, 13:08:40
Hallo,
das Treibermodul kann auch unter Kernel 5.8 gebaut werden. Installierter und verwendeter Kernel?
uname -aInstallationsanleitung mittels Internetverbindung über WLAN:
echo "blacklist r8169" | sudo tee /etc/modprobe.d/blacklist_r8169.conf
mkdir r8125 && cd r8125
sudo apt install dkms build-essential
wget https://media-cdn.ubuntu-de.org/forum/attachments/27/49/9210307-r8125-dkms_9.004.01.tar.gz
sudo tar xvf 9210307-r8125-dkms_9.004.01.tar.gz -C /usr/src
sudo dkms install r8125/9.004.01
sudo depmod -a
sudo update-initramfs -u
Neustart und Test (WLAN deaktivieren):
dkms status
lsmod | grep r81
ip a
Titel: Re: PCIe Lan-Karte gesucht
Beitrag von: Manny_K am 27.02.2021, 18:31:53
Hallo Flash63

uname -a
Linux manfred-Linux 5.8.0-43-generic #49~20.04.1-Ubuntu SMP Fri Feb 5 09:57:56 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

Ich habe deinen Code eingegeben und er lief auch anscheinend ohne Fehler durch.
Nach dem Neustart und deaktivieren von WLan

erhalte ich bei

dkms status
lsmod | grep r81
ip a


dkms status
nvidia, 460.39, 5.8.0-43-generic, x86_64: installed
r8125, 9.001.00: added
r8125, 9.004.01, 5.8.0-43-generic, x86_64: installed (WARNING! Diff between built and installed module!)
manfred@manfred-Linux:~$ lsmod | grep r81
r8125                 155648  0
manfred@manfred-Linux:~$ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: enp39s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 2c:f0:5d:25:b4:29 brd ff:ff:ff:ff:ff:ff
3: wlo1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether ac:67:5d:47:eb:a9 brd ff:ff:ff:ff:ff:ff
    altname wlp40s0
    inet 10.220.0.6/16 brd 10.220.255.255 scope global dynamic noprefixroute wlo1
       valid_lft 1378sec preferred_lft 1378sec
    inet6 fe80::ed1d:45d0:ba32:28ba/64 scope link noprefixroute
       valid_lft forever preferred_lft forever

inxi -G zeigt
inxi -N
Network:
  Device-1: Realtek RTL8125 2.5GbE driver: r8125
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi

Leider läßt sich die Verbindung trotzdem nicht aktivieren!

Nachdem ich ein zweites mal die Verbindung versucht habe zu aktivieren, ging es plötzlich! Ich hoffe das es jetzt funktioniert und es nicht nach einiger Zeit wieder zum Abbruch kommt.
Titel: Re: PCIe Lan-Karte gesucht
Beitrag von: Flash63 am 27.02.2021, 20:51:03
Zitat
r8125, 9.004.01, 5.8.0-43-generic, x86_64: installed (WARNING! Diff between built and installed module!)
Nicht ganz sauber. Kommt vielleicht von dem vorhergehenden Installationsversuch. Aber nicht weiter schlimm, einfach mal laufen lassen und weiter testen.
Zitat
r8125, 9.001.00: added
Den entferne doch mal:
sudo dkms remove r8125/9.001.00 --all
dkms status
Noch Reste vorhanden?
ls -l /usr/src/* | grep r81
Titel: Re: PCIe Lan-Karte gesucht
Beitrag von: Manny_K am 28.02.2021, 08:22:39
sudo dkms remove r8125/9.001.00 --all
[sudo] Passwort für manfred:           
Das hat nicht funktioniert, bitte nochmal probieren.
[sudo] Passwort für manfred:       

------------------------------
Deleting module version: 9.001.00
completely from the DKMS tree.
------------------------------
Done.

ls -l /usr/src/* | grep r81
/usr/src/r8125-9.001.00:
/usr/src/r8125-9.004.01:
/usr/src/r8125-9.005.01:

Hallo Flash63, ich hatte gehofft, das jetzt alles korrekt ist.
Leider wurde eben die Verbindung nach einem Neustart wieder getrennt. vorm Neustart funktionierte die Verbindung von gestern abend bis heute morgen.

In welchen Verzeichnis liegt jetzt eigentlich der Treiber "/usr/src/r8125-9.001.00: oder /usr/src/r8125-9.004.01: oder /usr/src/r8125-9.005.01:" ? Könnte bzw müsste man die anderen Löschen?
Titel: Re: PCIe Lan-Karte gesucht
Beitrag von: Flash63 am 28.02.2021, 10:09:40
Den Quellcode der alten und nicht funktionierenden Version auch noch entfernen, dann ist alles wieder "clean":
sudo rm -r /usr/src/r8125-9.001.00
sudo rm -r /usr/src/r8125-9.005.01
Titel: Re: PCIe Lan-Karte gesucht
Beitrag von: Manny_K am 28.02.2021, 10:35:46
sudo rm -r /usr/src/r8125-9.001.00
sudo rm -r /usr/src/r8125-9.005.01

Ich habe die beiden Befehle eingegeben!

Bei dem Befehl
ls -l /usr/src/* | grep r81

erhalte ich jetzt folgende Ausgabe

/usr/src/r8125-9.004.01:

Aber die Veerbindung wird trotzdem nicht aufgebaut!

In der folgenden Ausgabe gibt es die Warnung
WARNING! Diff between built and installed module!
Könnte da noch ein Problem liegen?

dkms status
nvidia, 460.39, 5.8.0-43-generic, x86_64: installed
r8125, 9.004.01, 5.8.0-43-generic, x86_64: installed (WARNING! Diff between built and installed module!)
manfred@manfred-Linux:~$ lsmod | grep r81
r8125                 155648  0
manfred@manfred-Linux:~$ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: enp39s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 2c:f0:5d:25:b4:29 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::230b:4532:d511:6129/64 scope link noprefixroute
       valid_lft forever preferred_lft forever
3: wlo1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether ac:67:5d:47:eb:a9 brd ff:ff:ff:ff:ff:ff
    altname wlp40s0
    inet 10.220.0.6/16 brd 10.220.255.255 scope global dynamic noprefixroute wlo1
       valid_lft 1542sec preferred_lft 1542sec
    inet6 fe80::ed1d:45d0:ba32:28ba/64 scope link noprefixroute
       valid_lft forever preferred_lft forever
Titel: Re: PCIe Lan-Karte gesucht
Beitrag von: Flash63 am 28.02.2021, 11:15:29
Ist das verwendete Kabel und der Anschluss ganz sicher in Ordnung?

Treiberinstallation noch mal ganz von vorn.
sudo dkms remove r8125/9.001.00 --all
sudo rm -r /usr/src/r8125-9.004.01
cd r8125
sudo tar xvf 9210307-r8125-dkms_9.004.01.tar.gz -C /usr/src
sudo dkms install r8125/9.004.01
sudo depmod -a
sudo update-initramfs -u
dkms status
Neustart und testen.

Immer noch kein Erfolg? Installiere ansonsten über WLAN mal ethtool.
Abfragen:
sudo ethtool enp39s0
Titel: Re: PCIe Lan-Karte gesucht
Beitrag von: Manny_K am 28.02.2021, 12:06:24
Ist das verwendete Kabel und der Anschluss ganz sicher in Ordnung?
Ich hatte das Kabel schon getauscht. Ich habe hier eine Dualbootinstallation mit Win10 und da macht der Lan-Anschluß keinerlei Probleme.

Ich probiere jetzt nochmal die von Dir empfohlene Treiberinstallation
Titel: Re: PCIe Lan-Karte gesucht
Beitrag von: Manny_K am 28.02.2021, 12:16:39
Nach dem Start funktioniert der Anschluß wieder.

sudo ethtool enp39s0
[sudo] Passwort für manfred:       
Settings for enp39s0:
Supported ports: [ TP ]
Supported link modes:   10baseT/Half 10baseT/Full
                        100baseT/Half 100baseT/Full
                        1000baseT/Full
                        2500baseX/Full
Supported pause frame use: Symmetric Receive-only
Supports auto-negotiation: Yes
Supported FEC modes: Not reported
Advertised link modes:  10baseT/Half 10baseT/Full
                        100baseT/Half 100baseT/Full
                        1000baseT/Full
                        2500baseX/Full
Advertised pause frame use: Symmetric Receive-only
Advertised auto-negotiation: Yes
Advertised FEC modes: Not reported
Speed: 1000Mb/s
Duplex: Full
Port: Twisted Pair
PHYAD: 0
Transceiver: internal
Auto-negotiation: on
MDI-X: Unknown
Supports Wake-on: pumbg
Wake-on: g
Current message level: 0x00000033 (51)
       drv probe ifdown ifup
Link detected: yes
Titel: Re: PCIe Lan-Karte gesucht
Beitrag von: Flash63 am 28.02.2021, 12:45:53
Sieht doch alles soweit gut aus und funktioniert.
Titel: Re: PCIe Lan-Karte gesucht
Beitrag von: Manny_K am 28.02.2021, 20:17:54
Ja es scheint jetzt zu funktionieren, und Ich hoffe es bleibt so.

Danke an alle die hier mitgeholfen haben.

Gibt es irgendwo Informationen bezüglich der Installation und auch Deinstallation zusätzlicher Treiber.
Am besten natürlich in Deutsch. Notfalls versuche ich mich auch an Englischen Texten.
Titel: Re: PCIe Lan-Karte gesucht
Beitrag von: Flash63 am 01.03.2021, 06:27:04
Siehe z.B.

https://wiki.ubuntuusers.de/DKMS/
https://wiki.ubuntuusers.de/Programme_kompilieren/
https://wiki.ubuntuusers.de/Makefile/
Titel: Re: PCIe Lan-Karte gesucht
Beitrag von: Manny_K am 01.03.2021, 18:25:05
Hallo Flash63,

ich war heute in der Aktivierungsverwaltung habe leider auch den Kernel aktualisiert von 5.8.0-43 auf 44.

Jetzt wird kein Lan-Treiber mehr angezeigt.

inxi -N
Network:
  Device-1: Realtek RTL8125 2.5GbE driver: N/A
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi

Ich habe dann dein Script ausgeführt aber leider nichts erreicht. Gibt es da noch was Kernelspezifisches einzustellen?
Titel: Re: PCIe Lan-Karte gesucht
Beitrag von: tommix am 01.03.2021, 18:35:07
Dann versuche bitte den Start mit Kernel 5.8.0-43.
Wenn der dann funktioniert den 5.8.0-44 löschen und auf die ignorieren Liste setzten.
Titel: Re: PCIe Lan-Karte gesucht
Beitrag von: Manny_K am 01.03.2021, 21:09:19
Dann versuche bitte den Start mit Kernel 5.8.0-43.
Wenn der dann funktioniert den 5.8.0-44 löschen und auf die ignorieren Liste setzten.
Hat funktioniert Danke!