Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
16.10.2021, 19:24:16

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 25987
  • Letzte: Friedel2
Statistiken
  • Beiträge insgesamt: 758200
  • Themen insgesamt: 60932
  • Heute online: 598
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:   Habe Probleme mit wine  (Gelesen 775 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Habe Probleme mit wine
« am: 20.09.2021, 18:17:55 »
Hallo Leute

Ich hab Mint 20 xfce am laufen. Und bekomme ständig Probleme mit wine wenn ich ein Spiel starten möchte. 
X Error of failed request:  GLXBadFBConfig

<pre>X Error of failed request:  GLXBadFBConfig
 
major opcode of failed request:  152 (GLX)
  Minor opcode of failed request:  0 ()
  Serial number of failed request:  944

für Hilfe bin ich dankbar

Re: Habe Probleme mit wine
« Antwort #1 am: 20.09.2021, 18:20:37 »
Deine Angaben sind leider kaum hilfreich. Es gibt keine allgemein zu lösenden Probleme mit wine, sondern diese hängen immer mit dem konkreten Spiel und der genauen wine Version zusammen. Du musst also schon deutlich konkreter werden. Beschränke dich für den Anfang am besten auf ein bestimmtes Spiel.
« Letzte Änderung: 20.09.2021, 18:35:52 von toffifee »

Re: Habe Probleme mit wine
« Antwort #2 am: 21.09.2021, 20:15:13 »
Mir war langweilig:

Suchmaschine mit "GLXBadFBConfig error" gefüttert:
https://metager.de/meta/meta.ger3?eingabe=GLXBadFBConfig+error&submit-query=&focus=web

Siehe da, einer der Treffer stammt vom WineHQ:
https://forum.winehq.org/viewtopic.php?t=34889

Naja, ist leider auf englisch. Daher bitte Achtung, auf eigene Gefahr:
Aus dem post von  jasperro » Mon Mar 29, 2021 5:37 am     interpretiere ich:

Er/Sie/Es hat für sich unter Arch Linux gelöst (vielleicht funktioniert das dann auch mit LM?)
Du kannst es mit
export MESA_GL_VERSION_OVERRIDE=4.5im Terminal versuchen und dann direkt testen, ob der Fehler behoben ist.

Funktioniert es damit, steht im dem gleichen Post (aber als erstes), das man in der Datei  ~/.pam_environment  eine Zeile mit 
MESA_GL_VERSION_OVERRIDE=4.5
eintragen kann, was dann wohl die dauerhafte Lösung sein könnte. Falls die Datei fehlt, soll man sie einfach anlegen.

Ende meiner Abschreibkünste, wie gesagt ohne eigenes Wissen zum Thema und daher ohne Garantie.

Re: Habe Probleme mit wine
« Antwort #3 am: 21.09.2021, 23:36:20 »
Danke Leute für die Hilfe.

Bei mir Wine 5.0 Version installiert

Dann muss ich  im Terminal ständig ins Hauptverzeichnis jedes  Spieles und dann export MESA_GL_VERSION_OVERRIDE=4.5  ausführen ? Das ist der einzige Möglichkeit die bei mir funktioniert.

Das ist auch ziemlich nervig und eine Tastentipperei im Terminal, vorallem wenn man  mehrere Spiele hat.  Und nach jedem einem Neustart  muss Befehl wieder eintippen .
Den Shortcuts auf dem Desktop funktionieren übrigens auch nicht.

so ich bin schon viel zu müde . werde ihr morgen nochmals reinschreiben.



« Letzte Änderung: 21.09.2021, 23:49:44 von hokuspokus »

Re: Habe Probleme mit wine
« Antwort #4 am: 24.09.2021, 11:28:03 »
Zunächst einmal: Du solltest natürlich Deinem System aktualisieren, die verfügbaren Updates installieren. Das könnte Dein Problem evtl. bereits lösen. (Und Du hast hier bisher keine Info geliefert, welche Version von Mint, welche Hardware...)

Ich rate mal, es ist nicht verständlich, was ich bzw. der Quellpost meint, ich versuche es mit anderen Worten:
Du kannst es mit
export MESA_GL_VERSION_OVERRIDE=4.5im Terminal versuchen und dann direkt testen, ob der Fehler behoben ist.
Das meint ausprobieren, ob diese Maßnahme das Problem behebt.
Das setzt ein sogenannte Umgebungsvariable. Und die muss nur einmal pro Anmeldung gesetzt (eingeben) werden. Sollte das nicht funktionieren, einfach neu starten und die manuelle Änderung der Umgebungsvariable ist vergessen.

Anscheinend hast Du es probiert und es behebt das Problem tatsächlich? - Na dann wäre das automatische Setzen beim Login/Starten wohl interessant:
Funktioniert es damit, steht im dem gleichen Post, das man in der Datei ~/.pam_environment eine Zeile mit
MESA_GL_VERSION_OVERRIDE=4.5
eintragen kann, was dann wohl die dauerhafte Lösung sein könnte. Falls die Datei fehlt, soll man sie einfach anlegen.
".pam_environment" ist eine Datei - lass Dich nicht von dem Punkt am Anfang verwirren. Anders als bei Win sind unter Linux Dateiendungen nicht ausschlaggebend.
Ein grober, stark humpelnder Vergleich wäre "Punkt als Beginn des Dateinamens" unter Linux ist so ähnlich wie Windowsdateien mit der Endung .sys. Die werden standardmäßig ausgeblendet, damit sie z.B. nicht versehentlich gelöscht werden.

Und diese Datei muss um eine Zeile mit
MESA_GL_VERSION_OVERRIDE=4.5
ergänzt werden. Sollte die Datei .pam_environment bei Dir noch nicht existieren, musst Du sie eben neu anlegen und dann da diese eine Zeile eintragen.
Der Pfad ist mit "~/" angegeben, dabei handelt es sich um das Unterverzeichnis des users unter /home/.
Wenn also Dein Username bei der Anmeldung am PC "hokuspokus" sein sollte, dann lautet der "echte" Pfad/Dateiname /home/hokuspokus/.pam_environment
(Im Terminal kann man  "cd ~/" benutzen und wechselt dann in dieses Verzeichnis.)

Ist Dein Problem gelöst, dieses Thema bitte auch so kennzeichnen. => https://www.linuxmintusers.de/index.php?action=wiki;page=Editor_Maske_f%C3%BCr_eigenen_Beitrag
« Letzte Änderung: 25.09.2021, 19:08:25 von Cybertron »

Re: Habe Probleme mit wine
« Antwort #5 am: 24.09.2021, 14:48:51 »
Off-Topic:
dann lautet der "echte" Pfad \home\hokuspokus\.pam_environment
So lautet der bestimmt nicht...
~$ cd \home\hokuspokus
bash: cd: homehokuspokus: Datei oder Verzeichnis nicht gefunden
Fällt dir was auf?
Dazu ein wenig Lektüre:
https://wiki.ubuntuusers.de/Homeverzeichnis/#Das-Zeichen
https://www.gnu.org/software/bash/manual/html_node/Escape-Character.html

Re: Habe Probleme mit wine
« Antwort #6 am: 25.09.2021, 18:41:31 »
[Edit: Post zurückgenommen, da ich in dem Post mal \ und mal / verwendet habe und dann...]

@ZeckeSZ:
Oh man, Dein Name ist Programm, mehr Freunde willst Du nicht, oder was?
Ein einfacher Hinweis das ich teilweise das falsche Zeichen benutzt habe hätte mehr geholfen.
Sorry, ja ich wurde ca. 30+ Jahre lang durch Windows beeinflusst, und da ist nun mal \ der Trenner in Pfadnamen.
Aber ja, ohne Korrektur war es falsch und würde mehr verwirren als helfen.

@hokuspokus:
Ich werde den Post oben korrigieren, die falschen \ durch korrekt / ersetzen.
[Erledigt, mein Post vom 24.09. ist nun korrigiert.]
« Letzte Änderung: 25.09.2021, 19:13:10 von Cybertron »

Re: Habe Probleme mit wine
« Antwort #7 am: 08.10.2021, 17:52:45 »
Danke Leute für eure  für eure Hilfe.

Bei mir hat Erstellen  .pam_environment  Texteditor erstellt habe  nichts verändert am Problem.

Ausserdem habe das System akualisiert auf Mint 20.2.
was auch nichts verändert hat.

Das war mein kleiner Zwischenbericht

Re: Habe Probleme mit wine
« Antwort #8 am: 08.10.2021, 19:30:25 »
Die Experten vermissen weiterhin das Ergebnis von inxi -Fz und eine Aussage, welches Spiel/Programm (ein konkretes Beispiel) zu der Fehlermeldung führt.
Blöder Vergleich: Keine Autowerkstatt kann bei einem Motorenproblemen beraten, wenn man ihr nur sagt, das Auto ist blau.

Noch mal zum Verständnis: Wenn Du vor dem Start des Spiels export MESA_GL_VERSION_OVERRIDE=4.5 im Terminal ein gibst/ausführst, dann funktioniert es, kommt keine Fehlermeldung?

Re: Habe Probleme mit wine
« Antwort #9 am: 09.10.2021, 09:39:09 »
System:
  Kernel: 5.4.0-88-generic x86_64 bits: 64 Desktop: Xfce 4.16.0
  Distro: Linux Mint 20.2 Uma
Machine:
  Type: Laptop System: Acer product: Aspire V3-571G v: V2.21
  serial: <filter>
  Mobo: Acer model: VA50_HC_CR v: Type2 - Board Version serial: <filter>
  UEFI [Legacy]: Insyde v: 2.21 date: 12/16/2013
Battery:
  ID-1: BAT1 charge: 53.2 Wh condition: 53.2/48.8 Wh (109%)
CPU:
  Topology: Quad Core model: Intel Core i7-3632QM bits: 64 type: MT MCP
  L2 cache: 6144 KiB
  Speed: 1197 MHz min/max: 1200/3200 MHz Core speeds (MHz): 1: 1197 2: 1197
  3: 1197 4: 1197 5: 1197 6: 1197 7: 1197 8: 1197
Graphics:
  Device-1: Intel 3rd Gen Core processor Graphics driver: i915 v: kernel
  Device-2: NVIDIA GF117M [GeForce 610M/710M/810M/820M / GT
  620M/625M/630M/720M]
  driver: N/A
  Display: x11 server: X.Org 1.20.11 driver: modesetting
  unloaded: fbdev,vesa resolution: 1920x1080~60Hz
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2)
  v: 4.2 Mesa 21.0.3
Audio:
  Device-1: Intel 7 Series/C216 Family High Definition Audio
  driver: snd_hda_intel
  Sound Server: ALSA v: k5.4.0-88-generic
Network:
  Device-1: Broadcom and subsidiaries NetLink BCM57785 Gigabit Ethernet PCIe
  driver: tg3
  IF: enp2s0f0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: Qualcomm Atheros AR9462 Wireless Network Adapter driver: ath9k
  IF: wlp3s0 state: down mac: <filter>
Drives:
  Local Storage: total: 111.79 GiB used: 83.91 GiB (75.1%)
  ID-1: /dev/sda vendor: Kingston model: SA400S37120G size: 111.79 GiB
Partition:
  ID-1: / size: 109.53 GiB used: 83.91 GiB (76.6%) fs: ext4 dev: /dev/sda1
Sensors:
  System Temperatures: cpu: 52.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 223 Uptime: 45m Memory: 15.53 GiB used: 1.50 GiB (9.6%)
  Shell: bash inxi: 3.0.38


Das  Problem betrifft  alle Spiele welche wine benötigen.

Zitat
Noch mal zum Verständnis: Wenn Du vor dem Start des Spiels
Code: [Auswählen]

export MESA_GL_VERSION_OVERRIDE=4.5

im Terminal ein gibst/ausführst, dann funktioniert es, kommt keine Fehlermeldung?

Genau   ich muss vor jedem starten einen export MESA_GL_VERSION_OVERRIDE=4.5  eingeben .Und zwar im Verzeizchnis  des Spieles  wo sich die exe Datei befindet sonst geht es nicht.
Und wenn ich ein anderes Spiel Spiele muss ich das Verzechniss wieder.



« Letzte Änderung: 09.10.2021, 09:53:06 von hokuspokus »

Re: Habe Probleme mit wine
« Antwort #10 am: 09.10.2021, 10:04:14 »

Re: Habe Probleme mit wine
« Antwort #11 am: 09.10.2021, 12:58:00 »
vor jedem starten einen export MESA_GL_VERSION_OVERRIDE=4.5  eingeben
Es bestünde natürlich auch die Möglichkeit, die Starter zu bearbeiten und diesen Aufruf vor den eigentlichen Befehl zum Starten des Programms zu setzen oder, falls das wider Erwarten nicht funktionieren sollte, einfach alles in ein kleines Script zu packen und dieses dann aufzurufen.

Re: Habe Probleme mit wine
« Antwort #12 am: 09.10.2021, 23:56:27 »
Zitat
Es bestünde natürlich auch die Möglichkeit, die Starter zu bearbeiten und diesen Aufruf vor den eigentlichen Befehl zum Starten des Programms zu setzen oder, falls das wider Erwarten nicht funktionieren sollte, einfach alles in ein kleines Script zu packen und dieses dann aufzurufen.
Moderator informieren   Gespeichert


 So etwas hab ich mir auch schon überlegt.  Würde mit Wine starter auch funktionieren ???

Exec=wine+export MESA_GL_VERSION_OVERRIDE=4.5 .wine/BLA /BLA BLA/ spiel.exe.
was meing ihr dazu ?
« Letzte Änderung: 10.10.2021, 00:08:15 von hokuspokus »

Re: Habe Probleme mit wine
« Antwort #13 am: 10.10.2021, 09:53:54 »
Als Beispiel:   Moorhuhn.sh
(Unter Eigenschaften -> Zugriffsrechte: Der Datei erlauben sie als Programm auszuführen)
#!/bin/bash
export MESA_GL_VERSION_OVERRIDE=4.5
cd /home/user/.wine/drive_c
wine Moorhuhn.exe