Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
07.12.2021, 12:30:14

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 26126
  • Letzte: jonnybee
Statistiken
  • Beiträge insgesamt: 766510
  • Themen insgesamt: 61486
  • Heute online: 592
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  MX-Linux - Partitionen einhängen nicht mehr mögiich  (Gelesen 185 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Evtl. hat ja hier irgendwer zufällig eine Idee, wie man das lösen könnte....?

Auf meinem Laptop mit MX Linux 19.4 xfce - 64bit habe ich mit xrdp experimentiert bzw. versucht es einzurichten.
Leider kann ich nun keine Partitionen einhängen und auch keine Apps starten, die sudo erfordern.
Um solche Apps zu starten, muss ich su im Terminal eingeben und anschließend die gewünschte App über den Namen, den ich im Starter nachschaue, starten.

Will ich eine Partition einhängen, werde ich normalerweise nach dem sudo-Password gefragt und dann kann ich die Partition öffnen.
Seit Bestehen des Problems jedoch passiert beim Doppelklick auf die Partition (unter Orte) gar nichts und wenn ich die Partition per Kontext Option "Einhängen" einhängen will, bekomme ich folgende Meldung (hier am Beispiel einer Windows-Partition, da es sich um ein Triple-Boot-System handelt, mit MX19.4, Win10 und Bodhi5.1):

Der Datenträger >>Windows<< konnte nicht eingehängt werden

Not authorized to perform this operation (polkit authority not available and caller is not uid 0)

Folgende Versuche zur Einrichtung von xrdp habe ich nach Web-Anleitungen probiert:

In "Sitzung und Startverhalten" sichergestellt, dass der Policykit Legitimations Agent aktiviert ist (ist er!).

Vor der vorletzten Zeile bzw, nach dem letzten fi-Befehl (="Ausleitung" von if) ergänzt:

unset DBUS_SESSION_BUS_ADDRESS
unset XDG_RUNTIME_DIR
. /etc/profile

sudo ufw allow 3389
sudo add user xrdp ssl-cert
Anschließend habe ich, da diese Versuche nichts nutzten und eben auch zum genannten Problem führten, xrdp wieder gepurgt.

Das Problem ist aber noch da.

Auch eine erneute Installation von xrdp und der Versuch die beiden unset-Befehle mit set rückgängig zu machen, halfen nicht.

Gibt es irgend eine Chance, das zu fixen (falls ja, wie bitte?) oder ist ein Neuaufsetzen unumgänglich?