Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
07.12.2021, 23:01:59

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 26127
  • Letzte: Klartext
Statistiken
  • Beiträge insgesamt: 766594
  • Themen insgesamt: 61489
  • Heute online: 628
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  Keine updates möglich bei LM20.1 LTS XFCE, (Docker)  (Gelesen 739 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Moin liebe Community, ich habe seit tagen probleme mit dem updaten von meinem LM 20.1 xfce, denn jedes mal bei "sudo apt update" oder auch im update manager, kommt immer der fehler das die seite von docker Link: https://download.docker.com/linux/linuxmint nicht exitiert mehr und da brauche ich grad hilfe, denn wie soll ich jetzt denn noch "sudo apt update" machen wenn der fehler es immer unterbricht

Mein system:
OS: Linux Mint 20.1 x86_64
Host: D3162-B1
Kernel: 5.4.0-89-generic
Uptime: 14 hours, 59 mins
 Packages: 3013 (dpkg), 5 (flatpak), 15 (snap)
Shell: bash 5.0.17
Resolution: 1920x1080
DE: Xfce
WM: Xfwm4
 WM Theme: Mint-Y-Dark-Red
 Theme: Mint-Y-Dark-Red [GTK2], Mint-Y [GTK3]
Icons: Mint-Y-Dark-Red [GTK2], Mint-Y [GTK3]
Terminal: xfce4-terminal
Terminal Font: Monospace 12
CPU: Intel i5-3470 (4) @ 3.600GHz
GPU: AMD ATI Radeon HD 7970/8970 / R9 280X
Memory: 8321MiB / 15929MiB


Re: Keine updates möglich bei LM20.1 LTS XFCE, (Docker)
« Antwort #1 am: 20.11.2021, 12:42:10 »
Herzlich willkommen bei uns im Grünen! ;D
Du bekommst da ja einen 404 File not found.
Also die Docker Quelle einfach erstmal entfernen, dann sollten die Updates wieder laufen.

PS: das Brett, in dem du gepostet hattest ist für Forumsinterna. ;)

Re: Keine updates möglich bei LM20.1 LTS XFCE, (Docker)
« Antwort #2 am: 20.11.2021, 13:04:34 »
@lmumischabln, oh hatte ich nd gesehen, aber es gab mal einen linuxmint eintrag bei docker, der aber gelöscht wurde, und ein freund hat mir dann gesagt ändere es auf ubuntu und das ging dann nd, und ich hatte alles zur sicherheit geändert wie es war und hatte mich da verschrieben, und der code denn du geschickt hast, einfach im terminal eingeben und sollte dann gehen?

Re: Keine updates möglich bei LM20.1 LTS XFCE, (Docker)
« Antwort #3 am: 20.11.2021, 13:25:19 »
Nein. Das ist der Eintrag für die grafische Paketquellenverwaltung. Über das Menü der Akt.verwaltung zu erreichen.

Benutzt du überhaupt Docker? Für mich hört sich das nicht so an, als ob du weißt, was das ist. In dem Falle die Quelle einfach komplett entfernen.

Re: Keine updates möglich bei LM20.1 LTS XFCE, (Docker)
« Antwort #4 am: 21.11.2021, 01:33:13 »
@toffifee

ich denke das docker vielleicht ein paket ftp ist der mir meine pakete zur verfügung gibt, docker hab ich schon seit ich das linux hab, wofür wäre denn docker?

Re: Keine updates möglich bei LM20.1 LTS XFCE, (Docker)
« Antwort #5 am: 21.11.2021, 02:42:37 »
Zitat
Wikipedia definiert Docker als   
Zitat
…  ein Open-Source-Projekt, das die Bereitstellung von Softwareanwendungen in Containern automatisiert, indem es eine zusätzliche Abstraktionsebene und Automatisierung der Virtualisierung auf Betriebssystemebene unter Linux bietet.
Wow! Das ist ein ganz schöner Brocken. Einfacher ausgedrückt: Docker ist ein Tool, mit dem Entwickler, Systemadministratoren usw. ihre Anwendungen einfach in einer Sandbox (Container genannt) bereitstellen können, um sie auf dem Host-Betriebssystem, d. h. Linux, auszuführen. Der Hauptvorteil von Docker besteht darin, dass es Benutzern ermöglicht, eine Anwendung mit all ihren Abhängigkeiten in eine standardisierte Einheit für die Softwareentwicklung zu verpacken. Im Gegensatz zu virtuellen Maschinen haben Container keinen hohen Overhead und ermöglichen daher eine effizientere Nutzung des zugrunde liegenden Systems und der Ressourcen.
https://docker-curriculum.com/
Übersetzt mit www.DeepL.com/Translator (kostenlose Version)

Re: Keine updates möglich bei LM20.1 LTS XFCE, (Docker)
« Antwort #6 am: 21.11.2021, 10:19:51 »
@aexe Also es doch wichtig?

Re: Keine updates möglich bei LM20.1 LTS XFCE, (Docker)
« Antwort #7 am: 21.11.2021, 10:46:43 »
Nein! Das benötigst du überhaupt nicht, das ist was für Profis! Komplett entfernen und die Quelle auch. KA, wer dir erzählt hat, dass du das brauchst!

Re: Keine updates möglich bei LM20.1 LTS XFCE, (Docker)
« Antwort #8 am: 21.11.2021, 16:04:50 »
Ich weiß nicht, ob das wichtig ist, kommt vermutlich darauf an, was man mit dem Rechner machen will. 

Es gibt übrigens auch in den Quellen ein Paket "docker", ein Übergangspaket (kann gefahrlos entfernt werden) für "wmdocker".
Zitat
Description: Systemablage für angedockte Anwendungen für KDE3/GNOME2
 Docker ist eine Andockanwendung (»WindowMaker dock app«), die als
 Systemablage für beliebige Arbeitsumgebungen fungiert. Dies erlaubt es
 Ihnen, eine Systemablage zu haben, ohne dass das Panel von KDE/GNOME
 läuft. Docker wurde entworfen, um mit Openbox 2 zu arbeiten, aber es
 sollte problemlos in beliebigen Fenstermanagern laufen.
Sagt Apt.
Hat aber wohl nichts mit dem zusätzlichen Repository zu tun.
« Letzte Änderung: 21.11.2021, 16:09:41 von aexe »

Re: Keine updates möglich bei LM20.1 LTS XFCE, (Docker)
« Antwort #9 am: 21.11.2021, 17:08:39 »
ich denke das docker vielleicht ein paket ftp ist der mir meine pakete zur verfügung gibt,
Wenn etwas wichtig wäre für Mint wäre es ja vorinstalliert. Docker ist aber nicht Teil einer Mint Installation. Wikipedia verrät dir, wozu die erwähnten Netzwerk- und Entwicklerprofis sowas nutzen. Ein Normalanwender braucht das nicht.

Re: Keine updates möglich bei LM20.1 LTS XFCE, (Docker)
« Antwort #10 am: 25.11.2021, 21:57:38 »
Wie entferne ich es denn?

Re: Keine updates möglich bei LM20.1 LTS XFCE, (Docker)
« Antwort #11 am: 25.11.2021, 23:44:03 »
docker hab ich schon seit ich das linux hab,
Hattest du das selber installiert?

Re: Keine updates möglich bei LM20.1 LTS XFCE, (Docker)
« Antwort #12 am: 27.11.2021, 09:19:04 »
no hatte ich nicht selber installiert

Re: Keine updates möglich bei LM20.1 LTS XFCE, (Docker)
« Antwort #13 am: 27.11.2021, 10:40:45 »
Zeig doch mal
dpkg -l docker*im Codeblock bitte (siehe Hilfe oben).

Re: Keine updates möglich bei LM20.1 LTS XFCE, (Docker)
« Antwort #14 am: 27.11.2021, 17:50:26 »
@toffifee: 
Sieh dir nochmal das Foto von sudo apt update an: "hit" und "get" ?