Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
11.05.2021, 16:40:58

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 734619
  • Themen insgesamt: 59183
  • Heute online: 652
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  Prime Applet / Funktion nicht mehr vorhanden  (Gelesen 454 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Prime Applet / Funktion nicht mehr vorhanden
« am: 24.03.2021, 12:11:27 »
Ich habe hier auf einem Lenovo P50s Latop  Linux Mint 20.1 Ulyssa installiert. Nun hatte ich  bis vor einigen Tagen immer das Intel oder das Nvidia Symbol in der Taskleiste zum Umschalten zwischen den beiden Grafikkarten. Das fehlt jetzt. Ich habe schon danach gesucht, bin aber mit den einschlägigen Lösungsvorschlägen nicht weiter gekommen. So wie es aussieht, erkennt das Betriebssystem die Karte gar nicht (mehr). Interessanterweise ist die Quadro unter Win10 auf dem selben Laptop vorhanden.

Wo könnte man hier noch ansetzen?


Daten:
System:
  Kernel: 5.4.0-70-generic x86_64 bits: 64 Desktop: Cinnamon 4.8.6
  Distro: Linux Mint 20.1 Ulyssa
Machine:
  Type: Laptop System: LENOVO product: 20FL000DGE v: ThinkPad P50s
  serial: <filter>
  Mobo: LENOVO model: 20FL000DGE v: SDK0J40705 WIN serial: <filter>
  UEFI: LENOVO v: N1KET39W (1.26 ) date: 05/28/2018
Battery:
  ID-1: BAT0 charge: 38.8 Wh condition: 39.6/44.5 Wh (89%)
  ID-2: BAT1 charge: 57.4 Wh condition: 66.9/71.3 Wh (94%)
CPU:
  Topology: Dual Core model: Intel Core i7-6500U bits: 64 type: MT MCP
  L2 cache: 4096 KiB
  Speed: 723 MHz min/max: 400/3100 MHz Core speeds (MHz): 1: 749 2: 763
  3: 714 4: 700
Graphics:
  Device-1: Intel Skylake GT2 [HD Graphics 520] driver: i915 v: kernel
  Device-2: NVIDIA GM108GLM [Quadro K620M / Quadro M500M] driver: N/A
  Display: x11 server: X.Org 1.20.9 driver: modesetting unloaded: fbdev,vesa
  resolution: 1920x1080~60Hz
  OpenGL: renderer: Mesa Intel HD Graphics 520 (SKL GT2) v: 4.6 Mesa 20.2.6
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel
  Sound Server: ALSA v: k5.4.0-70-generic
Network:
  Device-1: Intel Ethernet I219-V driver: e1000e
  IF: enp0s31f6 state: down mac: <filter>
  Device-2: Intel Wireless 8260 driver: iwlwifi
  IF: wlp4s0 state: up mac: <filter>
Drives:
  Local Storage: total: 232.89 GiB used: 39.75 GiB (17.1%)
  ID-1: /dev/sda vendor: Samsung model: SSD 850 EVO 250GB size: 232.89 GiB
Partition:
  ID-1: / size: 102.00 GiB used: 39.72 GiB (38.9%) fs: ext4 dev: /dev/sda5
Sensors:
  System Temperatures: cpu: 31.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 0
Info:
  Processes: 225 Uptime: 54m Memory: 7.63 GiB used: 1.93 GiB (25.3%)
  Shell: bash inxi: 3.0.38


Re: Prime Applet / Funktion nicht mehr vorhanden
« Antwort #1 am: 24.03.2021, 12:19:06 »
Moin und Willkommen im Grünen Bereich..

Ich habe hier auf einem Lenovo P50s Latop  Linux Mint 20.1 Ulyssa installiert. Nun hatte ich  bis vor einigen Tagen immer das Intel oder das Nvidia Symbol in der Taskleiste zum Umschalten zwischen den beiden Grafikkarten. Das fehlt jetzt.
wurde LM20.1 neu installiert oder Upgegradet?

Schau mal dort, aus meinen Lesezeichen: https://www.linuxmintusers.de/index.php?topic=62979
« Letzte Änderung: 24.03.2021, 12:34:41 von kuehhe1 »

Re: Prime Applet / Funktion nicht mehr vorhanden
« Antwort #2 am: 24.03.2021, 12:25:14 »
Device-2: NVIDIA GM108GLM [Quadro K620M / Quadro M500M] driver: N/A
Erkennt sie schon, es wird aber kein Treiber geladen.

Re: Prime Applet / Funktion nicht mehr vorhanden
« Antwort #3 am: 24.03.2021, 12:32:42 »
Danke, das  hilft schonmal weiter.

Leider ist bei mir das Konfigurationsfenster für die Nvidia Xserver Settings total leer.
Vielleicht stimmt was mit der Treiberinstallation nicht?
 

Re: Prime Applet / Funktion nicht mehr vorhanden
« Antwort #4 am: 24.03.2021, 12:48:40 »
Device-2: NVIDIA GM108GLM [Quadro K620M / Quadro M500M] driver: N/A
Erkennt sie schon, es wird aber kein Treiber geladen.

Ich habe den Treiber nun mal komplett deinstalliert und frisch installiert. Leider nach wie vor keine Besserung.

Ich bin zwar kein Linux Anfänger, aber mit Grafischen Desktops hatte ich bisher nicht viel am Hut. ;)

Danke nochmal.

Re: Prime Applet / Funktion nicht mehr vorhanden
« Antwort #5 am: 24.03.2021, 12:56:05 »
das nvidia Problem
Leider ist bei mir das Konfigurationsfenster für die Nvidia Xserver Settings total leer.
gabs schon mehrfach.

Dass Beste wird sein den jetzt installierten nvidia Treiben zu deinstallieren --purgen
der Reihe nach:
apt purge nvidia*rebootsudo ubuntu-drivers autoinstallreboot
schau mal dort: https://www.linuxmintusers.de/index.php?topic=61322.msg812605#msg812605
« Letzte Änderung: 20.04.2021, 08:33:49 von kuehhe1 »

Re: Prime Applet / Funktion nicht mehr vorhanden
« Antwort #6 am: 24.03.2021, 13:35:12 »
Danke, habe ich gefunden und ausgeführt. Ich fürchte, irgendwas ist bei mir durcheinander gewürfelt:


ie folgenden Pakete haben unerfüllte Abhängigkeiten:
 linux-modules-nvidia-460-generic : Hängt ab von: nvidia-kernel-common-460 (<= 460.39-1) aber 460.67-0ubuntu0~0.20.04.1 soll installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.

Graphics:
  Device-1: Intel Skylake GT2 [HD Graphics 520] driver: i915 v: kernel
  Device-2: NVIDIA GM108GLM [Quadro K620M / Quadro M500M] driver: nouveau
  v: kernel
  Display: x11 server: X.Org 1.20.9 driver: modesetting unloaded: fbdev,vesa
  resolution: 1920x1080~60Hz
  OpenGL: renderer: Mesa Intel HD Graphics 520 (SKL GT2) v: 4.6 Mesa 20.2.6



Re: Prime Applet / Funktion nicht mehr vorhanden
« Antwort #7 am: 25.03.2021, 13:09:57 »
Ok,
Bitte bei Terminal Rückmeldungen immer auch den Eingabe Befehl zeigen...
...sprich Eingabe incl. Rückmeldung, immer Alles komplett hier zeigen, siehe Hilfe Oben im Site-Menü

E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.
Die Korrektur der zurückgehaltenen oder defekten Pakete über die Synaptic Paketverwaltung ausführen:
Menü > Systemverwaltung > Synaptic- Paketverwaltung > Bearbeiten > Defekte Pakete reparieren

Graphics:
  Device-1: Intel Skylake GT2 [HD Graphics 520] driver: i915 v: kernel
  Device-2: NVIDIA GM108GLM [Quadro K620M / Quadro M500M] driver: nouveau
Die Teilrückmeldung zeigt das die nVidia-Karte keinen nvidia Treiber sondern den: nouveau verwendet.

Kontrolle ob und welche nvidia Pakete installiert sind:dpkg -l *nvidia* | egrep '^ii '
Die gezeigten Befehle nicht abtippen, sondern mit Klick auf: [Auswählen] Markieren, Kopieren und ins Terminal Einfügen, Ausführen und wie gesagt die Ein- Ausgabe komplett hier zeigen.

Re: Prime Applet / Funktion nicht mehr vorhanden
« Antwort #8 am: 19.04.2021, 12:11:01 »
Sorry für meine sehr späte Antwort. Ich habe nun versucht, weite nach dem Problem zu forschen.

Menü > Systemverwaltung > Synaptic- Paketverwaltung > Bearbeiten > Defekte Pakete reparieren -> Es passiert... Nichts.

~/Downloads$ dpkg -l *nvidia* | egrep '^ii '
ii  nvidia-kernel-common-460         460.67-0ubuntu0~0.20.04.1 amd64        Shared files used with the kernel module

Offensichtlich habe ich es geschafft, den Nouveau Treiber zu entfernen:

~/Downloads$ inxi -G
Graphics:  Device-1: Intel Skylake GT2 [HD Graphics 520] driver: i915 v: kernel
           Device-2: NVIDIA GM108GLM [Quadro K620M / Quadro M500M] driver: N/A
           Display: x11 server: X.Org 1.20.9 driver: modesetting unloaded: fbdev,vesa
           resolution: 1920x1080~60Hz, 1920x1200~60Hz, 1600x900~60Hz
           OpenGL: renderer: Mesa Intel HD Graphics 520 (SKL GT2) v: 4.6 Mesa 20.2.6

Ein weiterer Autoinstallversuch bringt leider immer noch den Fehler:

~/Downloads$ sudo ubuntu-drivers autoinstall
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 linux-modules-nvidia-460-generic : Hängt ab von: linux-modules-nvidia-460-5.4.0-72-generic (= 5.4.0-72.80) soll aber nicht installiert werden
                                    Hängt ab von: nvidia-kernel-common-460 (<= 460.56-1) aber 460.67-0ubuntu0~0.20.04.1 soll installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.

Danke nochmal für eure Hilfe.

Gruß






Re: Prime Applet / Funktion nicht mehr vorhanden
« Antwort #9 am: 19.04.2021, 17:56:34 »
@SerpensAlatus,
Was hast du gemacht?
Momentan ist deine Intel Grafikkarte aktiv.
Graphics:  Device-1: Intel Skylake GT2 [HD Graphics 520] driver: i915 v: kernel
           Device-2: NVIDIA GM108GLM [Quadro K620M / Quadro M500M] driver: N/A

Offensichtlich habe ich es geschafft, den Nouveau Treiber zu entfernen:
Wie kommst du darauf?Welche nouveau Pakete installiert sind zeigt:
dpkg -l *nouveau* | egrep '^ii '
Vergleichsweise siehts Hier mit LM20.1Cin. so aus:
kuehhe1@LM20-1-Test:~$ dpkg -l | grep nouveau
ii  libdrm-nouveau2:amd64                      2.4.102-1ubuntu1~20.04.1              amd64        Userspace interface to nouveau-specific kernel DRM services -- runtime
ii  xserver-xorg-video-nouveau                 1:1.0.16-1                            amd64        X.Org X server -- Nouveau display driver

Ein weiterer Autoinstallversuch bringt leider immer noch den Fehler:
Wurden denn vor den erneuten Versuchen der/die installierten nVidia Treiber Pakete deinstalliert (purge) und anschließend, wie in Antwort #5 empfohlen, neu gestartet (reboot) ?

Zeig doch bitte einmal inxi -Fz
Bitte bei Terminal Rückmeldungen immer auch den Eingabe Befehl zeigen...
...sprich Eingabe incl. Rückmeldung, immer Alles komplett hier zeigen, siehe Hilfe Oben im Site-Menü

Aber mal generell die Frage da Niemand deinen Systemstatus kennt was bereits eingerichtet/Installiert ist, was hälst du von einer Neuinstallation um nicht unnötig Zeit in eine Fehlerbereinigung zu investieren?

Edit: Grammatik
« Letzte Änderung: 20.04.2021, 08:42:14 von kuehhe1 »