Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
04.08.2021, 21:24:28

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 25804
  • Letzte: DanI
Statistiken
  • Beiträge insgesamt: 748207
  • Themen insgesamt: 60194
  • Heute online: 599
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema: [gelöst]  Problem mit Synaptic  (Gelesen 392 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] Problem mit Synaptic
« am: 26.05.2021, 15:45:42 »
Wie sind die Einträge (siehe Anhang) entstanden?
Kann ich diese löschen?
(sudo apt-get autoremove - autoclean - clean  <- habe ich ausgeführt)
System:
  Kernel: 5.4.0-73-generic x86_64 bits: 64
  Desktop: Cinnamon 4.8.6 Distro: Linux Mint 20.1 Ulyssa
« Letzte Änderung: 26.05.2021, 19:32:21 von OptiPlex »

Re: Problem mit Synaptic
« Antwort #1 am: 26.05.2021, 16:40:15 »
@ lmumischabln - danke für die informative Antwort.
Zur Info:
$ dpkg -l libc{6,-}* locales | egrep '^ii '
ii  libc-ares2:amd64 1.15.0-1build1  amd64        asynchronous name resolver
ii  libc-bin         2.31-0ubuntu9.3 amd64        GNU C Library: Binaries
ii  libc-dev-bin     2.31-0ubuntu9.3 amd64        GNU C Library: Development binaries
ii  libc6:amd64      2.31-0ubuntu9.3 amd64        GNU C Library: Shared libraries
ii  libc6:i386       2.31-0ubuntu9.3 i386         GNU C Library: Shared libraries
ii  libc6-dbg:amd64  2.31-0ubuntu9.3 amd64        GNU C Library: detached debugging symbols
ii  libc6-dev:amd64  2.31-0ubuntu9.3 amd64        GNU C Library: Development Libraries and Header Files
ii  libc6-i386       2.31-0ubuntu9.3 amd64        GNU C Library: 32-bit shared libraries for AMD64
ii  locales          2.31-0ubuntu9.3 all          GNU C Library: National Language (locale) data [support]
$ apt install libc6:amd64=2.31-0ubuntu9.2 libc6:i386=2.31-0ubuntu9.2 libc6-dbg:amd64=2.31-0ubuntu9.2 locales=2.31-0ubuntu9.2 -s
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
  dh-strip-nondeterminism dwz icu-devtools libarchive-cpio-perl libc-dev-bin libclang-cpp10 libcrypt-dev libdebhelper-perl
  libffi-dev libfile-stripnondeterminism-perl libltdl-dev libmail-sendmail-perl libobjc-9-dev libobjc4 libomp-10-dev libomp5-10
  libpfm4 libpng-tools libsub-override-perl libsys-hostname-long-perl libz3-4 libz3-dev llvm-10 llvm-10-runtime llvm-10-tools
  po-debconf python3-pygments
Verwenden Sie »sudo apt autoremove«, um sie zu entfernen.
Vorgeschlagene Pakete:
  glibc-doc glibc-doc:i386 locales:i386
Die folgenden Pakete werden ENTFERNT:
  build-essential clang clang-10 clang-tidy clang-tidy-10 clang-tools-10 debhelper dh-autoreconf g++ g++-9 hardinfo lib32gcc-s1
  lib32stdc++6 libbluray-dev libc6-dev libc6-i386 libclang-common-10-dev libdvd-pkg libexpat1-dev libfontconfig1-dev
  libfreetype-dev libfreetype6-dev libicu-dev libncurses-dev libpng-dev libpython3-dev libpython3.8-dev libstdc++-9-dev
  libtinfo-dev libtool libxml2-dev llvm-10-dev python3-dev python3.8-dev uuid-dev zlib1g-dev
Die folgenden Pakete werden durch eine ÄLTERE VERSION ERSETZT (Downgrade):
  libc6 libc6:i386 libc6-dbg locales
0 aktualisiert, 0 neu installiert, 4 durch eine ältere Version ersetzt, 36 zu entfernen und 0 nicht aktualisiert.
Remv libdvd-pkg [1.4.2-1-1]
Remv build-essential [12.8ubuntu1.1]
Remv clang [1:10.0-50~exp1]
Remv clang-tidy [1:10.0-50~exp1]
Remv clang-tidy-10 [1:10.0.0-4ubuntu1]
Remv clang-tools-10 [1:10.0.0-4ubuntu1]
Remv dh-autoreconf [19] [debhelper:amd64 ]
Remv debhelper [12.10ubuntu1]
Remv libtool [2.4.6-14]
Remv clang-10 [1:10.0.0-4ubuntu1]
Remv g++ [4:9.3.0-1ubuntu2]
Remv g++-9 [9.3.0-17ubuntu1~20.04]
Remv hardinfo [0.5.1+git20180227-2]
Remv libclang-common-10-dev [1:10.0.0-4ubuntu1]
Remv lib32stdc++6 [10.2.0-5ubuntu1~20.04]
Remv lib32gcc-s1 [10.2.0-5ubuntu1~20.04]
Remv libbluray-dev [1:1.2.0-1]
Remv python3-dev [3.8.2-0ubuntu2]
Remv python3.8-dev [3.8.5-1~20.04.2]
Remv libfontconfig1-dev [2.13.1-2ubuntu3]
Remv libfreetype6-dev [2.10.1-2ubuntu0.1]
Remv libfreetype-dev [2.10.1-2ubuntu0.1]
Remv libpng-dev [1.6.37-2]
Remv zlib1g-dev [1:1.2.11.dfsg-2ubuntu1.2]
Remv uuid-dev [2.34-0.1ubuntu9.1]
Remv libstdc++-9-dev [9.3.0-17ubuntu1~20.04]
Remv llvm-10-dev [1:10.0.0-4ubuntu1]
Remv libtinfo-dev [6.2-0ubuntu2]
Remv libncurses-dev [6.2-0ubuntu2]
Remv libc6-dev [2.31-0ubuntu9.3] [libexpat1-dev:amd64 libicu-dev:amd64 ]
Remv libc6-i386 [2.31-0ubuntu9.3] [libexpat1-dev:amd64 libicu-dev:amd64 ]
Remv libpython3-dev [3.8.2-0ubuntu2] [libexpat1-dev:amd64 libicu-dev:amd64 ]
Remv libpython3.8-dev [3.8.5-1~20.04.2] [libexpat1-dev:amd64 libicu-dev:amd64 ]
Remv libexpat1-dev [2.2.9-1build1] [libicu-dev:amd64 ]
Remv libxml2-dev [2.9.10+dfsg-5] [libicu-dev:amd64 ]
Remv libicu-dev [66.1-2ubuntu2]
Inst libc6-dbg [2.31-0ubuntu9.3] (2.31-0ubuntu9.2 Ubuntu:20.04/focal-updates [amd64]) []
Inst libc6 [2.31-0ubuntu9.3] (2.31-0ubuntu9.2 Ubuntu:20.04/focal-updates [amd64]) [libc6:amd64 on libc6:i386] [libc6:i386 on libc6:amd64] [libc6:i386 ]
Inst libc6:i386 [2.31-0ubuntu9.3] (2.31-0ubuntu9.2 Ubuntu:20.04/focal-updates [i386])
Inst locales [2.31-0ubuntu9.3] (2.31-0ubuntu9.2 Ubuntu:20.04/focal-updates [all])
Conf libc6-dbg (2.31-0ubuntu9.2 Ubuntu:20.04/focal-updates [amd64])
Conf libc6 (2.31-0ubuntu9.2 Ubuntu:20.04/focal-updates [amd64])
Conf libc6:i386 (2.31-0ubuntu9.2 Ubuntu:20.04/focal-updates [i386])
Conf locales (2.31-0ubuntu9.2 Ubuntu:20.04/focal-updates [all])

Re: Problem mit Synaptic
« Antwort #2 am: 26.05.2021, 17:34:48 »
@ lmumischabln
Habe schon nach der Anleitung gehandelt und:
$ apt install build-essential
$ apt install hardinfo
Ergebnis siehe Anhang.

Re: Problem mit Synaptic
« Antwort #3 am: 26.05.2021, 17:50:03 »
Das sieht alles nicht richtig aus. Du hättest alle zug. Pakete gemeinsam herabstufen sollen. So bei dir (hier als Simulation):
apt install libc-bin=2.31-0ubuntu9.2 libc-dev-bin=2.31-0ubuntu9.2 libc6:amd64=2.31-0ubuntu9.2 libc6:i386=2.31-0ubuntu9.2 libc6-dbg:amd64=2.31-0ubuntu9.2 libc6-dev:amd64=2.31-0ubuntu9.2 libc6-i386=2.31-0ubuntu9.2 locales=2.31-0ubuntu9.2 -sUnd dabei nachsehen, dass kein Paket entfernt wird. Du kannst natürlich die entfernten Paket jetzt nochmal installieren.

Re: Problem mit Synaptic
« Antwort #4 am: 26.05.2021, 18:13:43 »
Habe MediathekView über Synaptic neu installiert (damit die Version 13.2.1 statt der vorher 13.7.1).
Jetzt gibt es nur noch den Eintrag 'libc-bin' bei Synaptic.