Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
13.04.2021, 08:46:06

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 728261
  • Themen insgesamt: 58784
  • Heute online: 386
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema: [gelöst]  Installation mit Dualboot unter UEFI (+WIN10)  (Gelesen 9904 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] Installation mit Dualboot unter UEFI (+WIN10)
« am: 20.02.2016, 12:47:35 »
Hallo liebe community,

ich habe meinen Weg in das Forum gefunden, nachdem ich auf meinem Laptop ohne Probleme auf Mint umgestiegen bin. Auf meinem PC (der nur per UEFI bootbar ist) muss ich allerdings Windows behalten (Adobe Suite). Deshalb habe ich versucht mir ein Dualboot System einzurichten. Ich bin im Prinzip nach dieser Anleitung vorgegangen:
http://linuxbsdos.com/2015/08/18/how-to-dual-boot-linux-mint-17-2-windows-10-windows-8-1-on-a-pc-uefi-firmware/
Ich moechte Linux Mint 17.3 (Cinnamon) nutzen und habe das entsprechende img auf einem Stick.
Allerdings habe ich vorher Win10 komplett frisch installiert, und bei der Partitionierung Platz fuer Linux gelassen:
Number  Start   End     Size    File system     Name                          Flags
 1      1049kB  473MB   472MB   ntfs            Basic data partition          hidden, diag
 2      473MB   578MB   105MB   fat32           EFI system partition          boot
 3      578MB   595MB   16.8MB                  Microsoft reserved partition  msftres
 4      595MB   44.5GB  43.9GB  ntfs            Basic data partition          msftdata
 5      44.5GB  59.5GB  15.0GB  ext4
 6      59.5GB  84.5GB  25.0GB  ext4
 7      84.5GB  101GB   16.0GB  linux-swap(v1)
 8      101GB   250GB   150GB
Nachdem ich Mint erfolgreich installiert habe befinde ich mich jetzt wieder im Live-System, weil im bootloader keine Auswahlmoeglichkeit fuer Linux besteht:
https://www.dropbox.com/s/3o48qod0w0w7yec/IMG_20160220_120506.jpg?dl=0

Ich habe versucht GRUB auf /dev/sda2 zu installieren, indem ich bei der Installation "Geraet fuer die Bootloader-Installation:" /dev/sda2 ausgewaehlt habe.
Allerdings frage ich mich hier, warum da unter filesystem fat32 und nicht efi gelistet ist?

Gibt es eine Moeglichkeit GRUB jetzt nachtraeglich zu installieren?

Viele Gruesse und besten Dank
zabbn

P.S.: sorry fuer die Umlaute^^ ich weiss nicht wie ich das Layout der Tastatur auf deutsch stelle...
« Letzte Änderung: 26.02.2016, 14:15:33 von zabbn »

Re: Installation mit Dualboot unter UEFI (+WIN10)
« Antwort #1 am: 20.02.2016, 13:00:35 »
Willkommen!
setxkbmap de  ;)
Bei einem EFI System muss der Grub in die Efi Bootpartition, das war schon richtig.
Die Angabe Fat32 war doch richtig, denn das ist ja das Filesystem!

Re: Installation mit Dualboot unter UEFI (+WIN10)
« Antwort #2 am: 20.02.2016, 13:03:02 »
Hallo!

Danke für das Willkommen und das deutsche Layout :)

Ok, seltsam, warum taucht dann keine bootoption LinuxMint auf??

Re: Installation mit Dualboot unter UEFI (+WIN10)
« Antwort #3 am: 20.02.2016, 13:07:05 »
Da muss ich leider an die Uefi Kenner übergeben, ich hatte diese "Freude" noch nicht oft! ;)

Re: Installation mit Dualboot unter UEFI (+WIN10)
« Antwort #4 am: 20.02.2016, 13:14:47 »
Poste bitte mal die Ausgabe von
sudo efibootmgr -v
Falls efibootmgr auf dem Live-System nicht vorhanden ist kann es dort installiert werden mit
sudo apt-get install efibootmgr
Mit
setxkbmap dekann man im Live-System die Tastatur auf deutsch stellen.

Re: Installation mit Dualboot unter UEFI (+WIN10)
« Antwort #5 am: 20.02.2016, 13:16:57 »
Der Hammer seid ihr schnell!

Fatal: Couldn't open either sysfs or procfs directories for accessing EFI variables.
Try 'modprobe efivars' as root.

Das fängt ja schonmal gut an?

Re: Installation mit Dualboot unter UEFI (+WIN10)
« Antwort #6 am: 20.02.2016, 13:19:13 »
Wurde Secure Boot deaktiviert?

Re: Installation mit Dualboot unter UEFI (+WIN10)
« Antwort #7 am: 20.02.2016, 13:20:07 »
oh ja, hatte ich vergessen zu erwähnen, secure boot und fastboot sind deaktiviert


EDIT: Also im BIOS gibt es keine Option fur secureboot...
« Letzte Änderung: 20.02.2016, 13:43:26 von zabbn »

Re: Installation mit Dualboot unter UEFI (+WIN10)
« Antwort #8 am: 20.02.2016, 13:42:59 »
Ich wollte mit
sudo efibootmgr -vherausfinden, ob ubuntu gelistet ist und versuchen es danach mit nextboot zu starten und eventuell danach einen neuen Eintrag in der Boot Order vornehmen.
Mit dieser Fehlermeldung
Fatal: Couldn't open either sysfs or procfs directories for accessing EFI variables.
Try 'modprobe efivars' as root.
habe ich nicht gerechnet und bin selbst erst mal ratlos.

Re: Installation mit Dualboot unter UEFI (+WIN10)
« Antwort #9 am: 20.02.2016, 13:50:57 »
hm ok... :(
Könnte denn die Fehlermedlung durch secureboot hervorgerufen sein?
Ich bin mir nämlich nicht 100% sicher ob es deaktiviert ist, gehe jetzt nur davon aus, da es nicht im BIOS vorhanden ist.

Re: Installation mit Dualboot unter UEFI (+WIN10)
« Antwort #10 am: 20.02.2016, 13:58:05 »
Ich glaube nicht mehr, dass die Fehlermeldung mit Secure Boot zu tun hat.
Bin beim Googlen, hab aber noch keine für mich verständliche Antwort gefunden.

Ich glaube auch nicht, dass Grub nicht richtig installiert wurde, sondern eher dass im UEFI-Setup eine Einstellung nicht stimmt.
Ich vermute etwas in dieser Richtung:
https://www.linuxmintusers.de/index.php?topic=32470.msg450429#msg450429
« Letzte Änderung: 20.02.2016, 14:10:46 von helli »

Re: Installation mit Dualboot unter UEFI (+WIN10)
« Antwort #11 am: 20.02.2016, 14:26:16 »
Hm OK, ich habe selten ein so abgespecktes BIOS-Menü gesehen... Musste das MoBo austauschen, da mein ursprüngliches defekt war. Ich finde aber mal gar keine Einstellungen in die Richtung... Alles was es gibt:

https://www.dropbox.com/s/pqhk34vbx3ibb7q/IMG_20160220_141633.jpg?dl=0

https://www.dropbox.com/s/zer9jbq0d9jdnpj/IMG_20160220_141708.jpg?dl=0

Wüsste nicht was da zielführend wäre... BIOS-Version ist aktuell.

Re: Installation mit Dualboot unter UEFI (+WIN10)
« Antwort #12 am: 20.02.2016, 14:52:39 »
In diesem Bild ganz unten
https://www.dropbox.com/s/zer9jbq0d9jdnpj/IMG_20160220_141708.jpg?dl=0
scheint noch ein Untermenü möglich zu sein bei:
> UEFI Hard Disk Drive BBS Priorities
Falls dort der Eintrag "ubuntu" erscheint und dieser sich an die erste Stelle setzen ließe, hättest du glaub ich gewonnen.

Diese Option
Zitat
Im Uefi gibt es noch eine Option "Select an Uefi file..."; damit kann ich ein grub-irgendwas64.efi zu den "trusted files" hinzufügen;
könnte bei diesem Bild
https://www.dropbox.com/s/pqhk34vbx3ibb7q/IMG_20160220_141633.jpg?dl=0
unter > Security zu finden sein, wenn vorhanden.
« Letzte Änderung: 20.02.2016, 14:59:33 von helli »

Re: Installation mit Dualboot unter UEFI (+WIN10)
« Antwort #13 am: 20.02.2016, 15:16:29 »
Hey, nochmal danke für deine Bemühungen!

Leider soweit keinen Erfolg... Bei > UEFI Hard Disk Drive BBS Priorities
gibt es zwar zwei Einträge, beide sind aber als Windows Bootloader bezeichnet... seltsam.
https://www.dropbox.com/s/q4moub0u3p47vyz/IMG_20160220_150007.jpg?dl=0

Unter Security gibt es keine brauchbaren Einstellungen:
https://www.dropbox.com/s/ufzdghi4mwvy4iz/IMG_20160220_141720.jpg?dl=0

Re: Installation mit Dualboot unter UEFI (+WIN10)
« Antwort #14 am: 20.02.2016, 15:26:12 »
Bei manchen Rechnern muss ein Administratorkennwort im UEFI-Setup vergeben sein, um an weitere Einstellungen zu kommen. Eventuell könnte es für weitere Einstellungen außerdem nötig sein, Secure Boot vorübergehend zu aktivieren.
« Letzte Änderung: 20.02.2016, 15:31:10 von helli »