Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
09.05.2021, 19:58:49

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 25578
  • Letzte: pastirma
Statistiken
  • Beiträge insgesamt: 734311
  • Themen insgesamt: 59161
  • Heute online: 555
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema: [gelöst]  Installation mit Dualboot unter UEFI (+WIN10)  (Gelesen 9996 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] Re: Installation mit Dualboot unter UEFI (+WIN10)
« Antwort #45 am: 21.02.2016, 10:38:10 »
@ helli. immer gut wenn Leute genauer hinschauen. Meine ich ehrlich.
Meine "reparierte Bootpartition" sieht derzeit so aus (schaue mal aufs Dateisystem - funzt trotzdem)
Nummer  Anfang  Ende    Größe   Dateisystem     Name                          Flags
 1      1049kB  683MB   682MB   ntfs            Basic data partition          versteckt, diag
 2      683MB   955MB   273MB   fat16           EFI system partition          boot


@ TE,  meine persönliche Meinung ist, man kommt auf kurz oder lang nicht mehr an UEFI vorbei.
Und wenn man schon einen UEFI Rechner hat, sollte man auch die BS im UEFI-Modus installieren. Nur so lernt man den Umgang damit.

Wenn du bisl Zeit hast, kannst du ja mal versuchen nur durch löschen der Bootpartition, mit anschließender Neuformatierung in Fat32 sowie einspielen eines Backups jenes zu "richten". Aber das Backup muss natürlich ausschließlich von der Bootpartition, sprich bei dir sda2 sein. Kommt also auf die Art und Weise deines Backups drauf an, wie erstellt und kann man das nutzen.
Ein nur von Windows gemachtes Backup, stellt sich die Frage ob die Bootpartition mit dabei war/ist.
Ich hatte damals zum Glück mit Paragon die Bootpartition kurz nach Inbetriebnahme mir gesichert. War dann ganz nützlich, da ich so auch die Testtools der Firmware des Laptops weiter nutzen kann.
Bei mir war aber auch das löschen und formatieren der Bootpartition wichtig, einfach nur Backup einspielen funzte nicht.

Ansonsten, wenn das nicht geht.
- mit rufus unter derzeitigen Windoiws dir ein Installationsstick für Linux im UEFI Modus machen
- dein Win-Installationsstick ist in UEFI Modus?
Ansonsten musst du es neu machen, dort. https://www.microsoft.com/de-de/software-download/windows10ISO
- danach alles neu machen mit gparted
- dabei die Bootpartition etwas größer gemacht 500 bis 1000 MB vielleicht. Und jener das Bootflag in uefi geben.

Re: Installation mit Dualboot unter UEFI (+WIN10)
« Antwort #46 am: 21.02.2016, 10:45:34 »
Kleine Tipp-Liste für: win10_und_lm_im_uefi_inst.

PC:
Octa-AMD FX8350 auf UEFI Board ASUS M5A97 LE R2.0 mit 8 GB ram, 4GB Graka, 500 GB hdd, DVD-Brenner und DVD-Rom.
BIOS.V.2.10.1208 America Meg....

Die Installations-Stricks für win und LM hatte ich normal erstellt!! Soll angeblich nur im speziell vorbereitetem UEFI-Modus gehen ?!?
sonst : https://wiki.ubuntuusers.de/UNetbootin/#Verwendung-fuer-U-EFI

1. Bootreihenfolge ändern: 1. USB ; 2. CD/DVD ; 3. HDD/SSD
    Ging bei mir (Sohn) nicht, hat aber USB-Stick automatisch als Installation-Medium erkannt.
    Näheres:  http://linuxwelt.blogspot.co.ke/2014/03/boot-reihenfolge-im-bios-andern.html
    und  http://linuxwelt.blogspot.co.ke/2015/02/bootreihenfolge-andern-anleitung-linux.html

2. Secure-Boot abschalten / anderes Betriebssystem wählen.

3. Fast-Boot Abschalten

3.a) CSM am besten im UEFI-Setup deaktivieren, damit das Installationsmedium nicht im
       BIOS-Modus gestartet werden kann.
       Sollte das nicht gehen : Alles auf UEFI Einstellen! Netzwerk kann auf disable

4. erst Win 10 installieren
    Näheres:
    1 HDD/SSD: http://linuxwelt.blogspot.co.ke/2015/12/linux-neben-windows-10-installieren.html

    Mehrere: http://linuxwelt.blogspot.co.ke/2015/12/linux-ubuntu-neben-windows-10.html


4.a) Fast-Boot Abschalten im Schnellstart im Windows-System
http://techmixx.de/schnellstart-unter-windows-10-deaktivieren/

4.b)  Die Neugier von Win 10 etwas aus bremsen:
http://www.heise.de/newsticker/meldung/Windows-10-Datensammelwut-beherrschen-2774941.html

5. Partitionen verändern unter Win !

6. LinuxMint installieren etwas anderes → ja
  Für die Grub-Installation die von Win angelegte EFI-Partition wählen!
   Und die Links unter Punkt 4 beachten!

7. Nach der Installation eventuell noch "ubuntu" im UEFI-Setup unter dem Reiter Boot in
    der Bootreihenfolge an die oberste Stelle setzen.
   
    Wurde bei mir automatisch erledigt!!

8. Beten das es klappt!


Noch ein weiteres ergänzendes Info zu UEFI ist der Ubuntu-Wiki und
http://wiki.ubuntu-forum.de/index.php?title=Benutzer:Klaus_P#

Das BOOT-MENUE sah dann so aus:

1. LinuxMint 17.3 ….
2. Erweiterte Optionen LinuxMint 17.3 …
3. Windows Bootmanager (auf /dev/sda2)
4. System … (hier kommt man noch mal in das UEFI-BIOS!)

Alles richtig? Dann sieht es je nach HDD/SDD so aus:

~ $ inxi -Fz
System:    Host: lms-pc Kernel: 3.19.0-32-generic x86_64 (64 bit) Desktop: Cinnamon 2.8.6
           Distro: Linux Mint 17.3 Rosa
Machine:   Mobo: ASUSTeK model: M5A97 LE R2.0 v: Rev 1.xx Bios: American Megatrends v: 2601 date: 03/24/2015
CPU:       Octa core AMD FX-8350 Eight-Core (-MCP-) cache: 16384 KB
           clock speeds: max: 4000 MHz 1: 1400 MHz 2: 1400 MHz 3: 1400 MHz 4: 1400 MHz 5: 2100 MHz 6: 1400 MHz
           7: 1400 MHz 8: 1400 MHz
Graphics:  Card: NVIDIA GF108 [GeForce GT 630]
           Display Server: X.Org 1.17.1 drivers: nvidia (unloaded: fbdev,vesa,nouveau)
           Resolution: 1280x1024@75.0hz
           GLX Renderer: GeForce GT 630/PCIe/SSE2 GLX Version: 4.5.0 NVIDIA 352.63
Audio:     Card-1 NVIDIA GF108 High Definition Audio Controller driver: snd_hda_intel
           Card-2 Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA) driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k3.19.0-32-generic
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 500.1GB (2.7% used) ID-1: /dev/sda model: ST3500418AS size: 500.1GB
Partition: ID-1: / size: 94G used: 5.4G (6%) fs: ext4 dev: /dev/sda6
           ID-2: swap-1 size: 8.19GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 9.4C mobo: N/A gpu: 26C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 215 Uptime: 21 min Memory: 730.5/7886.4MB Client: Shell (bash) inxi: 2.2.28


 ~ $ sudo parted -l
[sudo] password for ***:
Modell: ATA ST3500418AS (scsi)
Festplatte  /dev/sda:  500GB
Sektorgröße (logisch/physisch): 512B/512B
Partitionstabelle: gpt

Nummer  Anfang  Ende   Größe   Dateisystem     Name                          Flags
 1      1049kB  473MB  472MB   ntfs            Basic data partition          versteckt, diag
 2      473MB   578MB  105MB   fat32           EFI system partition          boot
 3      578MB   595MB  16,8MB                  Microsoft reserved partition  msftres
 4      595MB   251GB  250GB   ntfs            Basic data partition          msftdata
 5      251GB   259GB  8193MB  linux-swap(v1)
 6      259GB   362GB  102GB   ext4
 7      362GB   392GB  30,7GB  ext4
 8      392GB   500GB  108GB   ext4
Nr 7 ist eine Reserve-Part zum ausprobieren andere OS. Wie das unter UEFI geht weiss ich noch nicht genau!
Nr 10 ist eine Datenpartition und mit /daten bei der Partitionierung des LM Systems während der Installation, also da wo / ; swap und die  Grub-Installation angelegt werden! Hier landen per Systemlink, die später noch angelegt werden müssen ,Dokumente, Fotos ect ... .

Sollten irgendwann die Links nicht mehr funktionieren da es sie nicht mehr gibt, bitte PM an mich da ich sie als PDF-Datei habe!

Wenn Optionen im UEFI-BIOS nicht zu Verfügung stehen, hilft vielleicht ein UEFI-BIOS Update.
Aber bitte nur wenn man Ahnung hat, keine Gewähr!  ;)

Viel Spass inne Backen! :-)

Gruß Nuffi

Da ich dies mal schnell geschrieben haben, werdet Ihr u.a. Rechtschreibfehler finden. Behaltet sie oder schreibt mir eine PM!  ;)
« Letzte Änderung: 21.02.2016, 22:53:21 von Nuffi »

Re: Installation mit Dualboot unter UEFI (+WIN10)
« Antwort #47 am: 21.02.2016, 12:07:24 »
Ich habe die Festplatte für die Betriebssysteme während der Win 10 Installation komplett neu partitioniert, und entsprechend unpartitionierten Platz gelassen, um später Linux zu installieren.


Da ich ja sowieso alles als backup habe, kann ich ja nochmal komplett neu anfangen. Was würdet ihr jetzt empfehlen?
0. MB in den UEFI-Modus
1. UEFI-Bootstick mit WIN10 erstellen
2. WIN10 installieren, Partition freilassen für Linux
3. Mint installieren, bootloader in die EFI-Partition schreiben lassen.

Habe ich irgendwas vergessen? So bin ich das erste mal vorgegangen, nur dass das MB noch auf Legacy+UEFI stand. (hat allerdings WIN10 nicht gehindert, als UEFI installiert zu werden.)
Macht es überhaupt Sinn, alles nochmal zu machen?

Viele Grüße
zabbn

Hi da mal rum eddiert ... schau Dir mal meine Tipps an! Partitionieren : lass das Win machen... für LM später erst!

Ja es macht Sinn ...  ;)

Re: Installation mit Dualboot unter UEFI (+WIN10)
« Antwort #48 am: 21.02.2016, 12:16:53 »
Also ich habe jetzt alles nochma lneu gemacht nach Anleitung von Nuffi.
UEFI-Modus only eingestellt.
Win10-UEFI-stick erstellt
Festplatte neu partitioniert, Win10 installiert
Fastboot deaktiviert, mit Rufus UEFI-LM 17.3-Stick erstellt
Mint gestartet, war im UEFI Modus mit: [ -d /sys/firmware/efi ] && echo UEFI || echo BIOS -> UEFI
Mint installiert, dann wieder dieselbe Fehlermeldung:
Zitat
Das Paket "grub-efi-amd64-signed" konnte nicht in /target/ installiert werden. Ohne den GRUB-Bootloader wird das installierte System nicht booten.

Ist das Problem doch, dass secureboot vllt. noch aktiviert ist und mein ver*** MB das nicht deaktivieren kann?
Ach und sehr komisch finde ich auch, dass ich jetzt keinen Internetzugang mehr im Live-System habe... Muss deshalb immer vom Laptop posten.

Re: Installation mit Dualboot unter UEFI (+WIN10)
« Antwort #49 am: 21.02.2016, 12:20:14 »
...
Ist das Problem doch, dass secureboot vllt. noch aktiviert ist und mein ver*** MB das nicht deaktivieren kann?

Sicher das es sich nicht deaktivieren lässt?

Mh denke ich dann mal, bin aber im UEFI-Breich auch noch ein Frischling ...

Re: Installation mit Dualboot unter UEFI (+WIN10)
« Antwort #50 am: 21.02.2016, 12:22:45 »
Geht das denn?

3.a) CSM am besten im UEFI-Setup deaktivieren, damit das Installationsmedium nicht im
       BIOS-Modus gestartet werden kann.
       Sollte das micht gehen : Alles auf UEFI Einstellen! Netzwerk kann auf disable

Und Schau Dir das UEFI-Bios genau in Ruhe an...  Habe mit meinem Sohn von 14 bis fast 20 Uhr für alles gebraucht, immer mit der Ruhe damit er und ich auch kapiert was mir da machten ...

Re: Installation mit Dualboot unter UEFI (+WIN10)
« Antwort #51 am: 21.02.2016, 12:28:12 »
Hast Du mal die genaue Bezeichnung vom Board und die Art und Version vom UEFI-BiOS?

Re: Installation mit Dualboot unter UEFI (+WIN10)
« Antwort #52 am: 21.02.2016, 12:30:07 »
Nein, leider habe ich dazu tatsächlich keinerlei Einstellmöglichkeiten im MB-Setup... Habe jeden einzelnen Punkt genau durchgesehen...

Das MB ist: MSI H81M-E35 V2 (MS-7817)
Bios-Version ist 4.0 also aktuell, wobei es vom Datum eine neuere 4.0 - Version gibt. Vllt flashe ich doch mal...
« Letzte Änderung: 21.02.2016, 12:34:55 von zabbn »

Re: Installation mit Dualboot unter UEFI (+WIN10)
« Antwort #53 am: 21.02.2016, 12:40:56 »
Also lässt sich im Secure-Boot nicht die Art des Betierbssystems ändern?

Von Win auf anderes system?

Re: Installation mit Dualboot unter UEFI (+WIN10)
« Antwort #54 am: 21.02.2016, 12:45:35 »
Nein. leider nicht. Es gibt nicht einmal die Option secureboot. Alles was unter Security möglich ist, ist ein Admin-PW zu vergeben. Tue ich dies, ergeben sich aber auch keine weiteren Möglichkeiten, die evtl. vorher versteckt waren. Alles was unter boot möglich ist, ist bootreihenfolge und bbs-priorities. Da taucht aber eben kein Linux auf. Ich flashe jetzt mal auf die vllt. neuere Version.

Re: Installation mit Dualboot unter UEFI (+WIN10)
« Antwort #55 am: 21.02.2016, 13:07:50 »
Ist bei Deinen Bord nicht von Win 10 die Rede ...(ready for Win10 ...) Bios-Update hilft vielleicht ...

Zitat
Eigenschaften
- Automatische Erkennung von BIOS/Treiber/VGA/Utility Updates
- Unterstützung von Microsoft Windows XP/Vista/7 32/64bit
featurePic

MSI's Click BIOS 4 ist das neueste UEFI-BIOS mit Optimierungen für Windows 8. Außerdem wurden Reaktionsschnelligkeit, Darstellungsqualität und Mausunterstützung verbessert. Dazu gibt es einige neue und coole Eigenschaften

Grins ... wo wird das denn eingesetzt ....?  ;D

Zitat
Military Class Essentials


Military Class 4 basiert auf wesentlichen Bauteilen, die die Stabilität des Motherboards unter erschwerten Umweltbedingungen garantieren. Der Schutz vor Feuchtigkeit und der Temperaturschutz machen das Motherboard auch unter Extrembedingungen einsatzfähig. Die verbesserte PCB-Struktur limitiert die EMV Strahlung deutlich und alle Anschlüsse sind ESD-Protected und so vor einem Kurzschluss geschützt.


Military Class 4


Military Class 4 ist der nächste Schritt im Bereich der Qualitätskomponenten. Hocheffiziente Spulen und Solid Caps (Feststoffkondensatoren) garantieren den stabilen Betrieb deines PCs im Langzeiteinsat

Auch EMP-Sicher?  8)
« Letzte Änderung: 21.02.2016, 13:21:20 von Nuffi »

Re: Installation mit Dualboot unter UEFI (+WIN10)
« Antwort #56 am: 23.02.2016, 00:45:12 »
Das flashen war wohl nix, das Board ist gebricked...
Und ja Mann, ein richtiges hardcore Board - habe ich mir von einem PC-Reparateur verkaufen lassen... Wenn man nicht alles selber macht. Ist jetzt draussen, habe eben das heute im Alternate-Outlet erworbene Gigabyte GA-H97-HD3 verbaut.

Ich kann jetzt auf UEFI-only stellen und secure sowie fastboot definitiv deaktivieren. Die Fehlermeldung bei der Mint-Installation kommt aber erwartungsgemäß immer noch.

Ich werde jetzt so Win10 nochmal installieren, allerdings ist oft die Rede davon, dass man die Partitionstabelle vorher mit einem Live-System erstellt. Dann könnte ich die EFI-Partition auch etwas üppiger ausfallen lassen, als die jetztigen 100MB (vllt ist das ein Problem?).
Falls das möglich ist, wie würde ich das anstellen? Was ich sonst so gelesen habe, taucht die Fehlermeldung auf, wenn der bootloader auf die falsche Partition geschrieben wird... Habe aber ja definitiv die efi-Partition angegeben :/

Re: Installation mit Dualboot unter UEFI (+WIN10)
« Antwort #57 am: 23.02.2016, 00:56:19 »
Zitat
Dann könnte ich die EFI-Partition auch etwas üppiger ausfallen lassen, als die jetztigen 100MB (vllt ist das ein Problem?)
Ich habe hier 4 Systeme im UEFI-Modus installiert und keine Probleme mit den 100 MB der EFI-Partition.
Die EFI-Partition wurde von dem vorinstallierten Win 8.1 erstellt.

Da ist noch reichlich Platz:
Dateisystem    Größe Benutzt Verf. Verw% Eingehängt auf
/dev/sda1        96M     29M   68M   31% /boot/efi


Zitat
Habe aber ja definitiv die efi-Partition angegeben :/
Mit / wird eigentlich immer die Systempartition des Linux bezeichnet und nicht etwa die EFI-Partition.

Welche die EFI-Partition ist, sagt eigentlich parted -l
Bei dir
sudo parted -lroot@KanotixBoxSpit:/home/spit# parted -l
Model: ATA ST500LT012-1DG14 (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags:

Number  Start   End     Size    File system     Name                          Flags
 1      1049kB  106MB   105MB   fat32           EFI system partition          boot, esp
 2      106MB   1050MB  944MB   ntfs            Basic data partition          hidden, diag
 3      1050MB  1184MB  134MB                   Microsoft reserved partition  msftres
 4      1184MB  201GB   200GB   ntfs            Basic data partition          msftdata
 5      201GB   350GB   149GB   ntfs            Basic data partition          msftdata
10      350GB   382GB   31,8GB  ext4
 9      382GB   414GB   32,4GB  ext4
 6      414GB   472GB   57,7GB  ext4            Basic data partition
 7      472GB   479GB   6738MB  linux-swap(v1)  Basic data partition
 8      479GB   500GB   21,5GB  ntfs            Basic data partition          hidden, diag
« Letzte Änderung: 23.02.2016, 01:17:14 von helli »

Re: Installation mit Dualboot unter UEFI (+WIN10)
« Antwort #58 am: 23.02.2016, 04:47:44 »
Was ich so gelesen habe sollte man erst Win installieren und auch die "Ersteinteilung" machen lassen. Verkleinern in Win (bei mir Nr.4) und weiteren Änderungen sind während der Linux installatin zu erledigen ...

Meine gpt:
~ $ sudo parted -l
[sudo] password for ***:
Modell: ATA ST3500418AS (scsi)
Festplatte  /dev/sda:  500GB
Sektorgröße (logisch/physisch): 512B/512B
Partitionstabelle: gpt

Nummer  Anfang  Ende   Größe   Dateisystem     Name                          Flags
 1      1049kB  473MB  472MB   ntfs            Basic data partition          versteckt, diag
 2      473MB   578MB  105MB   fat32           EFI system partition          boot
 3      578MB   595MB  16,8MB                  Microsoft reserved partition  msftres
 4      595MB   251GB  250GB   ntfs            Basic data partition          msftdata
 5      251GB   259GB  8193MB  linux-swap(v1)
 6      259GB   362GB  102GB   ext4
 7      362GB   392GB  30,7GB  ext4
 8      392GB   500GB  108GB   ext4

Orakelix

  • Gast
Re: Installation mit Dualboot unter UEFI (+WIN10)
« Antwort #59 am: 23.02.2016, 06:44:23 »
bei UEFI ist es total egal, welches System wann installiert wurde - Windows überschrteibt kein Linux.

In /boot/efi/EFI/* liegen alles Systeme brav nebeneinander - was ein Mint allerdings überschreiben würde, wäre ein Ubuntu-Installation.

Was die Größe der EFI-Partition anbelangt , ein Linux belegt ca. 4-5 MB, mehr nicht, Windows will ein wenig mehr - aber mit 100MB für EFI kommt man weit.

..... Verkleinern in Win (bei mir Nr.4) ....
würde ich immer mit Windows machen - den frei gewordenen neuen Platz frisch einteilen hingegen  bei der Installation mit dem zu installierenden Linux.
« Letzte Änderung: 23.02.2016, 06:53:11 von Orakelix »