Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
21.11.2017, 07:10:39

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 19116
  • Letzte: Lix
Statistiken
  • Beiträge insgesamt: 492955
  • Themen insgesamt: 39615
  • Heute online: 195
  • Am meisten online: 679
  • (03.04.2017, 15:20:01)
Benutzer Online

Autor Thema: [erledigt] conky funktioniert nicht mehr, LM18.2 Cinnamon  (Gelesen 408 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[erledigt] conky funktioniert nicht mehr, LM18.2 Cinnamon
« am: 14.11.2017, 19:55:46 »
Hallo,
bis vor einigen Tagen funktionierte meine conky Anzeige noch einwandfrei, nun startet es nicht mehr. Bis auf die hier fehlende Transparenz sah es so aus, (das Bild ist älter darum passt die Kernel Version nicht, aktuell ist 4.4.0-98, auch sda5 war nicht mehr doppelt angezeigt) 
conky sensors lm ico
conky sensors lm ico
conky hatte ich mir vor längerer Zeit mit dem conky-builder-1.24_all.deb Paket installiert und eingerichtet.

Wenn ich conky per Starter aus dem Menü aufrufe öffnet sich das conky nicht aber die Systemüberwachung zeigt conky als laufenden Prozess an. Starte ich conky via Terminal erhalte ich diese Rückmeldung:
conky
conky: Syntax error (/home/helmut/.conkyrc:2: '=' expected near 'yes') while reading config file.
conky: Assuming it's in old syntax and attempting conversion.
conky: desktop window (3c00041) is subwindow of root window (290)
conky: window type - override
conky: drawing to created window (0x4000001)
conky: drawing to double buffer
conky: Unknown setting 'max_specials'

Die .conkyrc befindet sich nach wie vor in meinem ~/ deren Inhalt ich bei Bedarf hochladen kann. Ich hab keinen Plan mehr wie ich damals conky installiert habe und ob es einen Zusammenhang mit kürzlichen Updates gibt Systemabstürze scheiden jedenfalls aus und die Umstellung von mdm auf lightdm erfolgte im August. Das System startet aus Grub heraus einwandfrei, dennoch habe ich mal mit dem älteren Kernel 4.4.0-97 gestartet mit gleichem negativen conky Ergebnis.

Diese conky Pakete sind installiert:
dpkg -l | grep conky
ii  conky                                        1.10.1-3                                     all          highly configurable system monitor (transitional package)
ii  conky-all                                    1.10.1-3                                     amd64        highly configurable system monitor (all features enabled)
ii  conky-builder                                1.24                                         all          Ultimate Edition Conky Builder
ii  conky-fonts                                  0.0.2                                        all          Conky Fonts

Zuletzt noch mein System:
inxi -Fz
System:    Host: K52jc-lm18 Kernel: 4.4.0-98-generic x86_64 (64 bit) Desktop: Cinnamon 3.4.6
           Distro: Linux Mint 18.2 Sonya
Machine:   System: ASUSTeK (portable) product: K52Jc v: 1.0
           Mobo: ASUSTeK model: K52Jc v: 1.0 Bios: American Megatrends v: K52Jc.216 date: 01/25/2011
CPU:       Dual core Intel Core i5 M 460 (-HT-MCP-) cache: 3072 KB
           clock speeds: max: 2534 MHz 1: 1733 MHz 2: 2399 MHz 3: 2399 MHz 4: 2266 MHz
Graphics:  Card-1: Intel Core Processor Integrated Graphics Controller
           Card-2: NVIDIA GT218M [GeForce 310M]
           Display Server: X.Org 1.18.4 driver: nvidia Resolution: 1366x768@60.00hz
           GLX Renderer: GeForce 310M/PCIe/SSE2 GLX Version: 3.3.0 NVIDIA 340.102
Audio:     Card Intel 5 Series/3400 Series High Definition Audio driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.4.0-98-generic
Network:   Card-1: Intel Wireless 7260 driver: iwlwifi
           IF: wls1 state: up mac: <filter>
           Card-2: JMicron JMC250 PCI Express Gigabit Ethernet Controller driver: jme
           IF: ens5f5 state: down mac: <filter>
Drives:    HDD Total Size: 750.2GB (36.7% used) ID-1: /dev/sda model: Samsung_SSD_850 size: 250.1GB
           ID-2: /dev/sdb model: Samsung_SSD_850 size: 500.1GB
Partition: ID-1: / size: 20G used: 9.8G (53%) fs: ext4 dev: /dev/sda5
           ID-2: /home size: 50G used: 35G (74%) fs: ext4 dev: /dev/sda7
           ID-3: swap-1 size: 12.88GB used: 0.00GB (0%) fs: swap dev: /dev/sda6
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 63.0C mobo: N/A gpu: 63C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 286 Uptime: 2:55 Memory: 3531.4/7771.8MB Client: Shell (bash) inxi: 2.2.35

« Letzte Änderung: 17.11.2017, 11:35:11 von kuehhe1 »

Re: conky funktioniert nicht mehr, LM18.2 Cinnamon
« Antwort #1 am: 14.11.2017, 20:14:28 »
conky: Syntax error (/home/helmut/.conkyrc:2: '=' expected near 'yes') while reading config file.
conky: Assuming it's in old syntax and attempting conversion
conky: Unknown setting 'max_specials' Da schon nachgeschaut?
Seit conky Version 1.10 gilt eine andere Syntax für den conf-file .conkyrc (Lua).
Fängt normalerweise so an: -- vim: ts=4 sw=4 noet ai cindent syntax=lua
--[[
Conky, a system monitor, based on torsmo
[ … ]
« Letzte Änderung: 14.11.2017, 20:28:40 von aexe »

Re: conky funktioniert nicht mehr, LM18.2 Cinnamon
« Antwort #2 am: 14.11.2017, 20:47:37 »
Hab da jetzt im Moment leider kein Mint und noch conky-builder-1.23, der macht "hier" aber keine Probleme!

Re: conky funktioniert nicht mehr, LM18.2 Cinnamon
« Antwort #3 am: 14.11.2017, 20:47:53 »
hi " aexe",
die Fehlermeldung hab ich auch gesehen konnte aber nichts damit anfangen.
conky: Unknown setting 'max_specials'steht bei mir auf 1024
# Minimum size of text area (min max size,width 420) -adjust if you would like to user smaller fonts etc.
minimum_size 400 0
maximum_width 400
max_specials 1024
max_user_text 16384
default_bar_size 250 5
Wegen der neuen conky Version schau ich gleich mal nach ob und wann es da Updates gab.
Ist denn die Anzahl der vier installierten conky Pakete überhaupt richtig?.

Fängt normalerweise so an:
Code: [Auswählen]
-- vim: ts=4 sw=4 noet ai cindent syntax=lua
--[[
Conky, a system monitor, based on torsmo
[ … ]
kommt in meiner .conkyrc gar nicht vor...soll ich die mal einstellen? Falls conky Upgedatet sein sollte past die wahrscheinlich gar nicht mehr.
« Letzte Änderung: 14.11.2017, 21:00:35 von kuehhe1 »

Re: conky funktioniert nicht mehr, LM18.2 Cinnamon
« Antwort #4 am: 14.11.2017, 20:52:51 »
und noch conky-builder-1.23
Hallo, den Link zu conky-builder-1.24-all.deb hatte ich, meine ich, mal von dir, die Datei hab ich gesichert aber die Quelle meldet Fehler. Gibts da etwas aktuelles?

Re: conky funktioniert nicht mehr, LM18.2 Cinnamon
« Antwort #5 am: 14.11.2017, 21:12:25 »
Du könntest auch eine ältere Conky-Version (1.9.x) installieren (die vorhandenen Pakete vorher rauswerfen) und die dann pinnen.
Mit conky-builder kenne ich mich nicht aus.
So sieht es in meinem LMDE-2 aus: dpkg -l | grep conky ii  conky        1.9.0-6                                   
ii  conky-std    1.9.0-6
   Damit funktioniert die alte Syntax.     
Bin mir nicht ganz sicher, irgendein liblua-Paket ist evtl als Abhängigkeit noch dabei.
« Letzte Änderung: 14.11.2017, 21:43:09 von aexe »

Re: conky funktioniert nicht mehr, LM18.2 Cinnamon
« Antwort #6 am: 14.11.2017, 21:32:05 »
Zitat
aber die Quelle meldet Fehler.

Versuch mal die:
http://www.os-builder.com/UETOYS/conky-builder-1.23_all.deb

Re: conky funktioniert nicht mehr, LM18.2 Cinnamon
« Antwort #7 am: 14.11.2017, 22:33:46 »
Zitat
aber die Quelle meldet Fehler.

Und die Fonts, falls vermisst.
http://www.os-builder.com/UETOYS/conky-fonts-0.0.2_all.deb

Re: conky funktioniert nicht mehr, LM18.2 Cinnamon
« Antwort #8 am: 14.11.2017, 22:34:23 »
So sieht es in meinem LMDE-2 aus:
Ausser meinem installierten conky1.24.deb paket habe ich zuerst noch conky-fonts-deb installieren müssen, die zwei Pakete hatte ich mir gesichert und notiert das conky-fonts-0.0.2-all.deb zuerst installiert werden mußte.
ii  conky-builder                                1.24                                         all          Ultimate Edition Conky Builder
ii  conky-fonts                                  0.0.2                                        all          Conky Fonts

Die folgenden Zwei sind seit März 2017 im System und lassen sich auch nicht in einer anderen Version erzwingen.
ii  conky                                        1.10.1-3                                     all          highly configurable system monitor (transitional package)
ii  conky-all                                    1.10.1-3                                     amd64        highly configurable system monitor (all features enabled)
liblua5.1-0 ist vorhanden und kommt über conky-all bzw. conky-std ins System.

das sagt Synaptic über conky:
This is a dummy package to ease transition to the new packaging scheme.
It may be safely removed after upgrade/installation.

Danke erst mal, Morgen gehts weiter. gN8
« Letzte Änderung: 15.11.2017, 06:56:06 von kuehhe1 »

Re: conky funktioniert nicht mehr, LM18.2 Cinnamon
« Antwort #9 am: 14.11.2017, 22:52:04 »
Ich starte conky immer beim Hochfahren.
Keine Probleme!  ::)
Ist jetzt aber auch XFCE, kein Cinnamon!
« Letzte Änderung: 14.11.2017, 23:04:58 von sidewinder »

Re: conky funktioniert nicht mehr, LM18.2 Cinnamon
« Antwort #10 am: 15.11.2017, 08:34:59 »
@sidewinder,
würdest du bitte mal in Synaptik nachschauen wieviel conky-xxxx Pakete bei dir installiert sind. "aexe" hat ja auch nur zwei Conky-xxxx im System und bei mir sinds vier an der Zahl.
Conky hab ich auch in Startprogramme aber meist deaktiviert, zusätzlich ist einen Starter angelegt wenn ich conky adhok benötige.

@aexe",
Bin jetzt unterwegs und schaue mir das nachher ganz genau an, vermutlich sind bei mir die Pakete conky 1.10 und conky-all 1.10 zuviel bzw. störend da ich ja das conky-builder 1.24.deb installiert hatte.
Und dann schaue ich auch noch mal nach ob in SystemBack die .conkyrc Konfigurationsdatei vorhanden ist.
« Letzte Änderung: 15.11.2017, 08:40:36 von kuehhe1 »

Re: conky funktioniert nicht mehr, LM18.2 Cinnamon
« Antwort #11 am: 15.11.2017, 09:46:57 »
Zitat
würdest du bitte mal in Synaptik nachschauen wieviel conky-xxxx Pakete bei dir installiert sind.
Aber gerne. Es sind drei Pakete.

Re: conky funktioniert nicht mehr, LM18.2 Cinnamon
« Antwort #12 am: 15.11.2017, 10:01:41 »
Danke dir,
deine installierten conky Pakete hatte ich im Bild deiner Antwort #2 völlig übersehen.

Re: conky funktioniert nicht mehr, LM18.2 Cinnamon
« Antwort #13 am: 15.11.2017, 10:07:02 »
Hast Du schon mal versucht die Zeile max_specials 1024 auszukommentieren, also ein '#' davor zu setzen?

Re: conky funktioniert nicht mehr, LM18.2 Cinnamon
« Antwort #14 am: 15.11.2017, 11:18:24 »
conky ist nur ein Metapaket, ohne weitere Funktion und zieht nur andere Pakete als Abhängigkeit nach. Muss man nicht haben, wenn man ein anderes Installiert, wie conky-std, conky-all oder conky-builder / -manager.