Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
24.11.2017, 21:29:14

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 19136
  • Letzte: Bazzer
Statistiken
  • Beiträge insgesamt: 493755
  • Themen insgesamt: 39660
  • Heute online: 344
  • Am meisten online: 679
  • (03.04.2017, 15:20:01)
Benutzer Online

Autor Thema:  Wei Funktion eines USB->LPT-Adapters erkennen  (Gelesen 373 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Re: Wei Funktion eines USB->LPT-Adapters erkennen
« Antwort #15 am: 12.11.2017, 18:42:54 »
lmumischabln, was meinst Du denn damit?
Hast den Fehler gefunden?
Das einzigste, was mir auffällt ist folgendes
[213670.943610] usblp 2-1.3.4:1.0: usblp2: USB Bidirectional printer dev 10 if 0 alt 0 proto 2 vid 0x1A86 pid 0x7584
[283268.611039] usbserial: `1a86' invalid for parameter `vendor'

In der ersten Zeile ist 0x1A86 mit großem A geschrieben,
in der 2ten mit kleinem a.
Aber kann das der Fehler sein?

Es scheint sich ja wohl eher um diesen "invalid parameter " vendor zu handeln.
Also die sog. Herstelelrkennung...
« Letzte Änderung: 12.11.2017, 19:24:39 von Ralf-DC7FB »

Re: Wei Funktion eines USB->LPT-Adapters erkennen
« Antwort #16 am: 14.11.2017, 13:14:14 »
HAllo Leutz;
entschuldigt, das ich jettz erst wieder dran bin, war gesundheitlich abgestürzt....
( Und jetzt muß ich mit Frauchen zum Weißkittel )
Ich muß noch mal auf die bisherigen Beiträge. resp den letzten von lmumischabln eingehen..
ICh verstehe nicht, was mir dies kopierte sagen soll?
Was ich fand, war einmal die Groß/Kleinschreibung der Vendor-ID,
dann das mit dem Invalid Parameter,
was mir dann huete so durch den Kopf ging ist folgendes:
Das ist doch ein USB-LPT Adapter, wieso wird er dann als USB-Ser-Adapter angeführt?

Re: Wei Funktion eines USB->LPT-Adapters erkennen
« Antwort #17 am: 14.11.2017, 14:12:12 »
Hi :)
wird in den drucker einstellungen z.b. unter cups
http://localhost:631/

kein anschluss usblp2 aneboten?

Re: Wei Funktion eines USB->LPT-Adapters erkennen
« Antwort #18 am: 15.11.2017, 08:34:48 »
http://localhost:631/

Nein, es werden nur der angeschlossene HP1010 und PDF als Drucker angeboten.
Aber kann das nicht auch daran liegen, das DIESER Druckeranschluß noch nicht richtig konfiguriert ist?

Re: Wei Funktion eines USB->LPT-Adapters erkennen
« Antwort #19 am: 15.11.2017, 08:47:36 »
lmumischabln, was meinst Du denn damit?
Hast den Fehler gefunden?
Das einzigste, was mir auffällt ist folgendes
[213670.943610] usblp 2-1.3.4:1.0: usblp2: USB Bidirectional printer dev 10 if 0 alt 0 proto 2 vid 0x1A86 pid 0x7584
[283268.611039] usbserial: `1a86' invalid for parameter `vendor'

In der ersten Zeile ist 0x1A86 mit großem A geschrieben,
in der 2ten mit kleinem a.
Aber kann das der Fehler sein?

Es scheint sich ja wohl eher um diesen "invalid parameter " vendor zu handeln.
Also die sog. Herstelelrkennung...
Ja, der Adapter wird nicht korrekt unterstützt, funktioniert also grundsätzlich nicht unter Linux. Der verbaute Chipsatz ist grundsätzlich zunächst ein USB-to-Serial Chip. Was lmumischabln meint weiß ich auch nicht, er äußert sich ja nicht.

Da die benötigte Software nur für Windows konzipiert ist, bleibt es bei der Empfehlung ein Dualsystem einzurichten. Zweite SSD 120GB für ~60€ wäre im Rahmen, denke ich. Wobei auch da nicht garantiert ist, dass die Ansteuerung des SDR-Transceiver aus dem Programm heraus mit diesem Adapter korrekt funktionieren wird.

Re: Wei Funktion eines USB->LPT-Adapters erkennen
« Antwort #20 am: 15.11.2017, 10:57:22 »
Was lmumischabln meint weiß ich auch nicht, ...
Nichts was du in AW#13 nicht schon in Worte gefaßt hast.  ;)
Das Modul mag die Optionen nicht, also wieder entfernen:
...
Dennoch wird der Adapter anscheinend richtig erkannt:

Tja, ich hatte etwas länger gebraucht die relevanten Stellen als Antwort auf
Bin noch nicht so weit, das mir das alles was sagt, aber es sieht nicht wirklich funktional aus, oder ?
zu markieren,
War zwar nun bereits alles gesagt, aber da es nun schon mit dem "bunten Bildchen" fertig war habe ich es auch gesendet.  ;)

Der erste Befehl ging ins Leere. Die bash führt einen Befehl ganz der garnicht aus. Ein bischen gibt es da nicht.
Ohne die Optionen in der Konfigurationsdatei wurde das Modul auf meiner Testmaschine ohne Fehler eingerichtet.
Wie die Auswirkungen auf den folgenden zweiten Befehl ausgefallen wären kann ich nicht sagen da das Gerät nicht an meinem Rechner hängt.

Ich will mich da aber auch nicht weiter reinhängen. Ist Ralf-DC7FB's Kiste und da muß er dann ggf. auch ein wenig experimentieren.

Mein Ansatz wäre es mit einer VM unter VirtualBox mit WinXP (da es nur nur einer lokalen Lösung bedarf) zu versuchen (ausreichende Hardwareressourcen vorausgesetzt). Das erspart vorerst die Bastelei an Partitionen usw. Da das ein USB-Gerät ist und auch erkannt wird könnte das funktionieren. Datenverwaltung/-zugriff ist über einen Gemeinsamen Ordner ebenfalls keine Hürde.
Entweder findet sich anschließend im Laufe der Zeit noch eine direkte Lösung für Linux oder man beläßt es dabei.
Ich bin aber auch Pragmatiker und sehe das nicht ganz so verbissen.  8)

Dann noch viel Erfolg.