Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
17.05.2021, 00:41:04

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 25602
  • Letzte: zanu1947
Statistiken
  • Beiträge insgesamt: 735809
  • Themen insgesamt: 59256
  • Heute online: 524
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online
Mitglieder: 4
Gäste: 496
Gesamt: 500

Autor Thema: [gelöst]  FritzNas doppelt eingehängt  (Gelesen 336 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] FritzNas doppelt eingehängt
« am: 21.04.2021, 20:15:50 »
Hallo,
ich habe  Linux Mint 20.1 Cinnamon installiert und das FritzNas über etc/fstab eingetragen, damit es beim Systemstart eingehängt wird.
Das funktioniert, ich habe Zugriff, allerdings ist das FritzNas doppelt eingehängt. Ich sehe es unter GERÄTE und unter NETZWERK. Wenn ich oben rechts in der Leiste auf Wechseldatenträger gehe sind dort zwei FritzNas eingetragen. Die Desktopsymbole, die bei eingehängten Datenträgern erscheinen zeigen ein FritzNas mit Ordnersymbol und ein FritzNas mit dem Aushängen-Symbol.

der Eintrag in etc/fstab lautet:
//192.168.10.1/FRITZ.NAS/ordner/ordner /home/user/fritznas cifs credentials=/home/user/.smbcredentials,vers=1.0,noserverino,uid=1000,gid=1000,x-systemd.automount,x-systemd.requires=network-online.target 0 0
ich habe den Eintrag aus einer Anleitung aus einem anderen Forum kopiert und entsprechend auf mein FritzNas angepasst, weiß aber nicht was z. B. noserverino oder x-systemd bedeutet.

ich hoffe jemand kann mir weiterhelfen, habe natürlich vorher schon in verschiedenen Foren nach diesem Problem gesucht, aber nichts gefunden.

Grüße
Ezyjones
« Letzte Änderung: 28.04.2021, 19:59:47 von Ezyjones »

Re: FritzNas doppelt eingehängt
« Antwort #1 am: 22.04.2021, 14:29:48 »
Hi :)
eingehängt ist nur was unter geräte zu sehen ist :)

unter netzwerk wird angezeigt was gefunden wird und kann ebenfalls darauf zugreifen.
also kein doppeltes einhängen ;)

parameter
https://linux.die.net/man/8/mount.cifs

Re: FritzNas doppelt eingehängt
« Antwort #2 am: 23.04.2021, 19:32:26 »
Hallo,
Danke für den Hinweis, darauf wäre ich nicht gekommen, finde ich auch verwirrend. Vor allem oben rechts unter Wechseldatenträger gibt's bei Mouseover keinen Hinweis was Geräte und was Netzwerk ist, sieht immer so aus als wenn was verkehrt läuft. Aber wenn's so gewollt ist, na gut, dann bin ich jetzt schlauer.

Danke auch für den Link. Leider werden dort nicht alle Einträge erklärt.
Dann werde ich wegen x-systemd und automount noch mal auf die Suche gehen.

Schöne Grüße
Ezyjones
 

Re: FritzNas doppelt eingehängt
« Antwort #3 am: 24.04.2021, 10:56:16 »
Moin

so wie ich das verstehe: fstab mounted normalerweise lokale Laufwerke.  systemd ist bei Mint der Teil, wo Dienste und Services nach und nach beim Booten hochgefahren werden. systemd.automount übergibt das Mounten an systemd mit dem Vorteil, dass erst gewartet wird, dass dein Rechner auf Netzwerkressourcen und in dem Fall deine Fritzbox zugreifen kann (x-systemd.requires=network-online.target). Siehe:

https://wiki.archlinux.org/index.php/fstab#Automount_with_systemd

Re: FritzNas doppelt eingehängt
« Antwort #4 am: 24.04.2021, 14:49:28 »
Hi :)
was ist verwirrend?
unter netzwerk ist alles zu sehen was im netzwerk an shares gefunden wird..
unter geräte, die die eingehängt und nutzbar sind.

es gibt 2 mount arten.. einmal mount (was in der fstab genutzt wird)
und
gio, was z.b. direkt im dateibrowser oder für die automatik bentutzt wird.

Re: FritzNas doppelt eingehängt
« Antwort #5 am: 24.04.2021, 21:02:28 »
Hi,
@Slangbein: Danke für die Erklärung. Ich hatte mich schon gefragt, warum ich keine Fehlermeldung beim Hochfahren erhalte. Ich hatte nämlich bereits irgendwo gelesen, dass es da zu Fehlern kommen kann, wenn die Netzwerkverbindung noch nicht besteht, auf die Fritzbox aber bereits zugegriffen wird. Aber umso besser. Es läuft jetzt alles einwandfrei.
Vielen Dank
schöne Grüße
Ezyjones

Re: FritzNas doppelt eingehängt
« Antwort #6 am: 24.04.2021, 23:45:01 »
Wenn du dann noch bitte auf "gelöst" setzen würdest. Dazu musst du in deinem Eröffnungspost auf "Ändern" gehen.
Schau Dir dazu oben die "Hilfe" an. - Danke.