Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
13.05.2021, 03:09:26

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 25585
  • Letzte: x-dd
Statistiken
  • Beiträge insgesamt: 734888
  • Themen insgesamt: 59203
  • Heute online: 446
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online
Mitglieder: 5
Gäste: 311
Gesamt: 316

Autor Thema:  Abbruch beim Kopieren auf externe Festplatten  (Gelesen 550 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Abbruch beim Kopieren auf externe Festplatten
« am: 20.04.2021, 11:04:13 »
Servus.

Ich will Dateien von meinem Linux Rechner auf eine externe Festplatte kopieren. Das klappt manchmal, meistens aber bricht der Kopiervorgang ab.
Das passiert dann auf zweierlei Art:

1. entweder friert der Kopiervorgang ein, während das Fenster mit dem Kopiervorgang noch angezeigt wird (Die Festplatten stehen still)
oder
2. das ganze System friert ein und erwacht auch nach längerem Warten (ca. 10min) nicht mehr.

Im 1. Fall kann ich Linux noch bedienen, allerdings werden Dateimanager nicht geladen und Dateioperation nicht mehr durchgeführt, so daß nur ein Neustart hilft

Mein System:

Zitat
System:    Kernel: 5.8.0-50-generic x86_64 bits: 64 compiler: N/A Desktop: Xfce 4.14.2
           tk: Gtk 3.24.13 wm: xfwm4 dm: LightDM Distro: Linux Mint 20.1 Ulyssa
           base: Ubuntu 20.04 focal
Machine:   Type: Laptop System: Hewlett-Packard product: HP EliteBook 840 G1 
           serial: <filter> Chassis: type: 10 serial: <filter>
           Mobo: Hewlett-Packard model: 198F v: KBC Version 15.59 serial: <filter>
           BIOS: Hewlett-Packard v: L71 Ver. 01.46 date: 07/20/2018
Battery:   ID-1: BAT0 charge: 26.6 Wh condition: 28.1/28.1 Wh (100%) volts: 12.4/11.4
           model: Hewlett-Packard Primary serial: <filter> status: Unknown
CPU:       Topology: Dual Core model: Intel Core i5-4300U bits: 64 type: MT MCP arch: Haswell
           rev: 1 L2 cache: 3072 KiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19953
           Speed: 2732 MHz min/max: 800/2900 MHz Core speeds (MHz): 1: 2662 2: 2883 3: 2594
           4: 2595
Graphics:  Device-1: Intel Haswell-ULT Integrated Graphics vendor: Hewlett-Packard driver: i915
           v: kernel bus ID: 00:02.0 chip ID: 8086:0a16
           Display: x11 server: X.Org 1.20.9 driver: modesetting unloaded: fbdev,vesa
           resolution: 1920x1080~60Hz
           OpenGL: renderer: Mesa DRI Intel HD Graphics 4400 (HSW GT2) v: 4.5 Mesa 20.2.6
           compat-v: 3.0 direct render: Yes
Audio:     Device-1: Intel Haswell-ULT HD Audio vendor: Hewlett-Packard driver: snd_hda_intel
           v: kernel bus ID: 00:03.0 chip ID: 8086:0a0c
           Device-2: Intel 8 Series HD Audio vendor: Hewlett-Packard driver: snd_hda_intel
           v: kernel bus ID: 00:1b.0 chip ID: 8086:9c20
           Sound Server: ALSA v: k5.8.0-50-generic
Network:   Device-1: Intel Ethernet I218-LM vendor: Hewlett-Packard driver: e1000e v: 3.2.6-k
           port: 3080 bus ID: 00:19.0 chip ID: 8086:155a
           IF: enp0s25 state: down mac: <filter>
           Device-2: Intel Wireless 7260 driver: iwlwifi v: kernel port: ef80 bus ID: 02:00.0
           chip ID: 8086:08b1
           IF: wlo1 state: up mac: <filter>
Drives:    Local Storage: total: 447.14 GiB used: 466.66 GiB (104.4%)
           ID-1: /dev/sda vendor: SanDisk model: SSD PLUS 480GB size: 447.14 GiB speed: 6.0 Gb/s
           serial: <filter>
Partition: ID-1: / size: 438.63 GiB used: 233.33 GiB (53.2%) fs: ext4 dev: /dev/sda5
USB:       Hub: 1-0:1 info: Full speed (or root) Hub ports: 3 rev: 2.0 chip ID: 1d6b:0002
           Hub: 1-1:2 info: Intel ports: 8 rev: 2.0 chip ID: 8087:8000
           Hub: 2-0:1 info: Full speed (or root) Hub ports: 9 rev: 2.0 chip ID: 1d6b:0002
           Hub: 2-1:2 info: Microchip (formerly SMSC) Hub ports: 4 rev: 2.1 chip ID: 0424:2134
           Device-1: 2-1.2:4 info: Logitech M90/M100 Optical Mouse type: Mouse
           driver: hid-generic,usbhid rev: 2.0 chip ID: 046d:c05a
           Hub: 2-1.3:6 info: Genesys Logic 4-port hub ports: 4 rev: 2.1 chip ID: 05e3:0610
           Device-2: 2-1.4:7 info: Dell type: Keyboard driver: hid-generic,usbhid rev: 1.1
           chip ID: 413c:2107
           Hub: 2-3:3 info: Microchip (formerly SMSC) Hub ports: 4 rev: 2.1 chip ID: 0424:2134
           Device-3: 2-3.2:5 info: Intel type: Bluetooth driver: btusb rev: 2.0 chip ID: 8087:07dc
           Hub: 3-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.0 chip ID: 1d6b:0003
           Hub: 3-1:2 info: Microchip (formerly SMSC) Hub ports: 4 rev: 3.0 chip ID: 0424:5534
           Hub: 3-1.3:4 info: Genesys Logic Hub ports: 4 rev: 3.1 chip ID: 05e3:0612
           Hub: 3-3:3 info: Microchip (formerly SMSC) Hub ports: 4 rev: 3.0 chip ID: 0424:5534
Sensors:   System Temperatures: cpu: 45.0 C mobo: 0.0 C
           Fan Speeds (RPM): N/A


Re: Abbruch beim Kopieren auf externe Festplatten
« Antwort #1 am: 20.04.2021, 11:18:36 »
Nuja, die erste Maßnahme wäre ein Blick ins Logfile, weil eine Glaskugel wird hier niemand haben.
Und dann wäre es noch von Vorteil zu wissen, um welche Art externe Platte es sich handelt. Hat die eine eigene Stromversorgung oder kommt der Saft über den USB Port.
Falls letzteres, dann kann es schon sein, dass Deine Platte mehr Saft benötigt, als der Port liefert.

Re: Abbruch beim Kopieren auf externe Festplatten
« Antwort #2 am: 20.04.2021, 11:38:11 »
Vielleicht ist es eine diese superschlauen Festplatten, deren Controller in den Ruhezustand geht, währen noch kopiert wird. Hatte auch mal so solche Exemplare.
Teils hat es geholfen, wenn ich regelmäßigen Zugriff auf die Platte erzeugt habe, um sie wach zu halten. Etwa mit:
watch -n60 ls /Pfad/zu/einem/Ordner/auf/der/externen/Festplatte

Re: Abbruch beim Kopieren auf externe Festplatten
« Antwort #3 am: 20.04.2021, 12:11:27 »
Hallo,
anscheinend hast Du da noch einen/weitere passive USB-Hub zwischen Laptop und Festplatte!?
* wie sieht der Anschluss aus und wie lang sind die USB-Kabel?
* was ist das für eine Festplatte, mit oder ohne eigene Stromversorgung?
Was zeigt
lsusb
lsusb -t

Re: Abbruch beim Kopieren auf externe Festplatten
« Antwort #4 am: 20.04.2021, 18:06:09 »
Hallo,
kenne das Problem in ähnlicher Weise:
1. hatte einen HP-PC von 2008 und hatte eine PCIe-USB-Karte eingebaut: mehrere USB3 PLatten (2,5 Zoll) OHNE eigene Stromversorgung) liefen ohne Problem, darunter eine Toshiba 500GB. Angangs lief auch die 4TB Intenso Platte (3,5 Zoll MIT eigener Stromversorgung) ohne Probleme.
Wahrscheinlich nach einigen Updates von Linux hatte ich das Problem, dass die Platte dann irgendwann (variable Zeit) mit dem Speichern abbrach. Ich bin mir nicht mehr sicher, ob Linux evt. auch mal eingefroren ist. Habe dann die USB3 Karte mal gewechselt ohne Erfolg. Unter USB KEIN Problem, aber blöd. Unter damals Win 7 mit der gleichen USB3-Karte: KEIN Problem (selber Rechner mit Dualboot)

2. Jetzt habe ich einen alten Dell Optiplex 9020 mit einer USB3-fähigen Hauptplatine: die Platte funktioniert einwandfrei.
Aber: die o.g. Toshiba 500GB 2,5 Zoll bricht jetzt wie deine Platte ab oder wie meine o.g. 4TB-Platte. Alle anderen Platten laufen ohne Problem.
Dachte, die Platte wäre evt. defekt: habe sie dann an 2 anderen Linuxrechner ausproblert: ein Rechner mit einer USB3-PCI-Karte und ein weiter Rechner mit einer USB3-fühigen Hauptplatine: hier jeweils keine Probleme! (ALLE Rechner laufen mit Linux Mint 20.1)
Somit müsste die Platte ja funktionieren -defekt ist unwahrscheinlich.
Habe dann in den Dell 9020 einfach die USB3-PCIe Karte eingebaut und die Toshiba Platte über diesen "Extra-Anschluss" laufen lassen: KEIN Problem.

Habe hier und anderswo im Internet nach einer Erklärung gesucht. Im Prinzip ohne Erfolg.

Habe auch mal bei den Einstellungen (Zubehör -> Laufwerke) versucht, an den Zeiten zum Ausschalten der Platte zu drehen und habe auch über das Terminal so etwas versucht: keine Änderung.

Die Toshiba-Platte Platte läuft an diesem Rechner nur über die PCIe-Karte oder an den beiden anderen Rechnern - dafür funktioniert hier die 4TB-Platte von Intenso.
Die anderen Platten sins alle von WD.

Also wenn nun die "sleep"-Funktion schuld ist (was ich vermute), warum geht das bei gleichen Kernel problemlos mit den anderen Rechnern.
Hinweis: solche Probleme sollen auch unter windows auftreten.
Ärgerlich: hätte ich ein kleines Laptop, dann wäre der Einbau einer Erweiterung evt. gar nicht möglich.
Dieses Problem scheint gar nicht so selten. Es wurden öfter Toshiba Platten genannt.

Also: probiere mal die Platte an einem anderen Rechner. Um welche Platte handelt es sich?

Re: Abbruch beim Kopieren auf externe Festplatten
« Antwort #5 am: 21.04.2021, 18:52:04 »
Danke erstmal für die Antworten. Ich war jetzt 2 Tage ohne Laptop unterwegs.

Ich habe die externe Quell Festplatte mit ext4 formatiert, die Ziel Festplatte mit NTFS. Aber das ist am Ende egal, da es immzickt, wenn ich solche Sachen mache.

Mit etwas Abstand betrachtet ist wohl der Hinweis von NASH007 am ehesten dran. Mein HP Laptop läuft einfach nicht rund mit Mint. Ich dachte vor einiger Zeit erst, es wäre die veraltete Version, aber mit jeder Neuen haben sich die Probleme nicht verbessert. Vor allem bei Datenaustausch mit externen Datenträgern hakt es sehr. z.B. brauche ich mehrere Versuche um eine bootfähige Version von Mint auf den Stick zu bekommen und selbst dann meckert das Installationprogramm herum. Daten auslagern auf Festplatten ist (wie bechrieben) immer ein Glücksspiel.

Ich werde morgen mal meine Festplatten in die Firma nehmen, da stehen genug Rechner herum.


Re: Abbruch beim Kopieren auf externe Festplatten
« Antwort #6 am: 21.04.2021, 18:59:56 »
poste mal bitt im codeblock inxi -Fz

Re: Abbruch beim Kopieren auf externe Festplatten
« Antwort #7 am: 21.04.2021, 20:11:23 »
System:
  Kernel: 5.8.0-50-generic x86_64 bits: 64 Desktop: Xfce 4.14.2
  Distro: Linux Mint 20.1 Ulyssa
Machine:
  Type: Laptop System: Hewlett-Packard product: HP EliteBook 840 G1
  v: A3009CD10002 serial: <filter>
  Mobo: Hewlett-Packard model: 198F v: KBC Version 15.59 serial: <filter>
  BIOS: Hewlett-Packard v: L71 Ver. 01.46 date: 07/20/2018
Battery:
  ID-1: BAT0 charge: 28.0 Wh condition: 28.0/28.0 Wh (100%)
CPU:
  Topology: Dual Core model: Intel Core i5-4300U bits: 64 type: MT MCP
  L2 cache: 3072 KiB
  Speed: 898 MHz min/max: 800/2900 MHz Core speeds (MHz): 1: 888 2: 883
  3: 862 4: 886
Graphics:
  Device-1: Intel Haswell-ULT Integrated Graphics driver: i915 v: kernel
  Display: x11 server: X.Org 1.20.9 driver: modesetting unloaded: fbdev,vesa
  resolution: 1920x1080~60Hz
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4400 (HSW GT2)
  v: 4.5 Mesa 20.2.6
Audio:
  Device-1: Intel Haswell-ULT HD Audio driver: snd_hda_intel
  Device-2: Intel 8 Series HD Audio driver: snd_hda_intel
  Sound Server: ALSA v: k5.8.0-50-generic
Network:
  Device-1: Intel Ethernet I218-LM driver: e1000e
  IF: enp0s25 state: down mac: <filter>
  Device-2: Intel Wireless 7260 driver: iwlwifi
  IF: wlo1 state: up mac: <filter>
Drives:
  Local Storage: total: 447.14 GiB used: 461.21 GiB (103.1%)
  ID-1: /dev/sda vendor: SanDisk model: SSD PLUS 480GB size: 447.14 GiB
Partition:
  ID-1: / size: 438.63 GiB used: 230.61 GiB (52.6%) fs: ext4 dev: /dev/sda5
Sensors:
  System Temperatures: cpu: 47.0 C mobo: 0.0 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 186 Uptime: 19m Memory: 7.64 GiB used: 1014.1 MiB (13.0%)
  Shell: bash inxi: 3.0.38

poste mal bitt im codeblock inxi -Fz

Re: Abbruch beim Kopieren auf externe Festplatten
« Antwort #8 am: 21.04.2021, 20:55:56 »
Den gab es schon im Eröffnungspost. Es fehlen noch:
Was zeigt

lsusb
lsusb -t

Re: Abbruch beim Kopieren auf externe Festplatten
« Antwort #9 am: 22.04.2021, 07:27:27 »
lusb
Bus 001 Device 002: ID 8087:8000 Intel Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 003: ID 0424:5534 Microchip Technology, Inc. (formerly SMSC) Hub
Bus 003 Device 004: ID 05e3:0612 Genesys Logic, Inc. Hub
Bus 003 Device 002: ID 0424:5534 Microchip Technology, Inc. (formerly SMSC) Hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 005: ID 8087:07dc Intel Corp.
Bus 002 Device 003: ID 0424:2134 Microchip Technology, Inc. (formerly SMSC) Hub
Bus 002 Device 007: ID 413c:2107 Dell Computer Corp.
Bus 002 Device 006: ID 05e3:0610 Genesys Logic, Inc. 4-port hub
Bus 002 Device 004: ID 046d:c05a Logitech, Inc. M90/M100 Optical Mouse
Bus 002 Device 002: ID 0424:2134 Microchip Technology, Inc. (formerly SMSC) Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

lusb -t
/:  Bus 03.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/4p, 5000M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/4p, 5000M
        |__ Port 3: Dev 4, If 0, Class=Hub, Driver=hub/4p, 5000M
    |__ Port 3: Dev 3, If 0, Class=Hub, Driver=hub/4p, 5000M
/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/9p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/4p, 480M
        |__ Port 2: Dev 4, If 0, Class=Human Interface Device, Driver=usbhid, 1.5M
        |__ Port 3: Dev 6, If 0, Class=Hub, Driver=hub/4p, 480M
        |__ Port 4: Dev 7, If 0, Class=Human Interface Device, Driver=usbhid, 1.5M
    |__ Port 3: Dev 3, If 0, Class=Hub, Driver=hub/4p, 480M
        |__ Port 2: Dev 5, If 0, Class=Wireless, Driver=btusb, 12M
        |__ Port 2: Dev 5, If 1, Class=Wireless, Driver=btusb, 12M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/3p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/8p, 480M

Re: Abbruch beim Kopieren auf externe Festplatten
« Antwort #10 am: 22.04.2021, 07:38:53 »
usb -t ohne Docking Station

/:  Bus 03.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/4p, 5000M
    |__ Port 3: Dev 2, If 0, Class=Hub, Driver=hub/4p, 5000M
/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/9p, 480M
    |__ Port 3: Dev 2, If 0, Class=Hub, Driver=hub/4p, 480M
        |__ Port 2: Dev 3, If 0, Class=Wireless, Driver=btusb, 12M
        |__ Port 2: Dev 3, If 1, Class=Wireless, Driver=btusb, 12M
    |__ Port 4: Dev 4, If 0, Class=Human Interface Device, Driver=usbhid, 12M
    |__ Port 4: Dev 4, If 1, Class=Human Interface Device, Driver=usbhid, 12M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/3p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/8p, 480M

Re: Abbruch beim Kopieren auf externe Festplatten
« Antwort #11 am: 22.04.2021, 08:00:23 »
Hallo,
wichtige Info
Zitat
ohne Docking Station
Teste mal ohne das Dock. Hardwareerkennung sieht soweit ok aus. Frage war ja auch noch, ob die Festplatten und der Hub über eine eigene Stromversorgung verfügen, oder alles über USB vom Laptop versorgt werden muss.

Re: Abbruch beim Kopieren auf externe Festplatten
« Antwort #12 am: 22.04.2021, 10:24:54 »
Das gleiche Spiel.
als ich an den Laptop ging, war dieser bei der login MAske, aber schon im Freeze  ::)

Gibt es eine Logdatei über die man nchlesen kann, was vielleicht passiert ist?


Re: Abbruch beim Kopieren auf externe Festplatten
« Antwort #13 am: 22.04.2021, 12:16:57 »
So,

anderer Rechner, gleiche Festplatten, gleiche Files, keine Probleme.
Ergo werde ich mir wohl was Neues holen müssen. :(

Danke für eure Hilfe

Re: Abbruch beim Kopieren auf externe Festplatten
« Antwort #14 am: 23.04.2021, 11:06:00 »
Hallo,
genauso, wie ich es vermutet habe. Anderer Rechner: es funktioniert.

Vermutlich ist der andere Rechner ein Windows Rechner?
Es ist somit nicht garantiert, dass man mit einer anderen Festlatte nicht auch so ein Problem bekommt!

Nach meinen Erfahrungen und Tests liegt es also nicht an der Festplatte allein, sondern am Zusammenspiel von Festplatte - Hardware - Betriebssystem.

Damit das Problem auftritt müssen verschieden Konstellationen vorliegen (habe es einfach ausprobiert):
Erste Voraussetzung ist eine bestimmte Festplatte, die sich vorzeitig (während eines Speichervorganges) in den Ruhezustand versetzten kann.
-> scheint bei Toshiba eher möglich (siehe Foren)
Zweite Voraussetzung: die Hardware des PC muss eine Rolle spielen (habe mit identischen Linux MInt20.1 getestet): Stromsparmechanismus des USB3-Controler!
-> es macht offenbar einen riesigen Unterschied, welchen PC man nimmt oder ob man einfach nur eine PCIe-Karte einbaut (die aber in einer anderen Konstellation/Festplatte das gleiche Problem produziert hat)
Dritte Voraussetzung: das Betriebssystem
-> bei identischer Hardware (Dualbootsystem) macht das Betriebssystem einen Unterschied. Windows hat funktioniert. Aus Erfahrungsberichten im Internet geht aber klar hervor, dass das Problem auch unter Windows auftritt. Es wird sogar öfter davon unter Win berichtet - kann aber daran liegen, dass einfach mehr Win-PCs unterwegs sind. Dafür spricht auch, dass meine 3,5Zoll Platte 2-3 Jahre kein Problem hatte und dann erst das Problem aufgetaucht ist. Inzwischen hat diese Platte mit dem neueren Rechner kein Problem mehr!

Zwar habe ich das Problem durch Einbau einer PCIe-Karte gelöst, das kann aber nicht die Lösung sein.

Kann es am Kernel liegen, der das Zusammenspiel von Hardware und Peripherie steuert. Das würde erklären, warum bei meiner 3,5Zoll Platte (Intenso) das Problem erst nach evt. 2-3 Jahren der problemlosen Nutzung aufgetreten ist.
Da könnte doch ein grundsätzlicher Fehler liegen, der bislang nicht gelöst wurde, weil die User einfach die Festplatte weggeworfen haben oder eine PCIe-Karte eingebaut haben ;)

Interessant ist auch: nachdem ich früher mit der PCIe-Karte das Problem auf zwei PCs mit zwei verschiedenen 3,5Zoll Intenso Platten hatte, scheint das Problem aktuell (Mint20.1) mit den 3,5 Zoll Festplatten nicht mehr aufzutreten.
Das spricht ja auch für die Kernel-Theorie!

Wichtig: das Problem taucht nur bei Nutzung des USB3-Ports auf. Die genannten 3,5Zoll USB3 Platten konnte ich dann immer noch am USB2-Port problemlos nutzen.
Das wäre aber für eine 2,5 Zoll Platte keine gute Lösung wegen der Stromversorgung. Das wäre  auf Dauer auch zu langsam bei den heutigen Datenmengen.