Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
10.04.2021, 13:18:13

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 25476
  • Letzte: Monadjemi
Statistiken
  • Beiträge insgesamt: 727525
  • Themen insgesamt: 58741
  • Heute online: 584
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema: [erledigt] Interner Kartenleser spinnt  (Gelesen 356 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[erledigt] Interner Kartenleser spinnt
« am: 14.02.2021, 08:38:44 »
Schönen Morgen,
wie im Titel gesagt mein Interner Kartenleser
06:00.0 SD Host controller: O2 Micro, Inc. SD/MMC Card Reader Controller (rev 01)
spinnt plötzlich, er kann plötzlich Karten die er früher lesen konnte nicht mehr lesen. Es sind 2 Karten die er nicht lesen kann, die anderen Karten doch.
Hier mal die Ausgabe von dmesg

[ 8647.894195] blk_update_request: I/O error, dev sde, sector 471064 op 0x0:(READ) flags 0x80700 phys_seg 1 prio class 0
[ 8647.894247] blk_update_request: I/O error, dev sde, sector 471064 op 0x0:(READ) flags 0x0 phys_seg 1 prio class 0
[ 8647.894256] Buffer I/O error on dev sde2, logical block 3, async page read
[ 8647.902402] sd 6:0:0:0: [sde] Synchronizing SCSI cache
[ 8648.006819] usb 2-1.1: USB disconnect, device number 7
[14656.311667] mmc0: new ultra high speed SDR104 SDXC card at address 0007
[14656.317177] mmcblk0: mmc0:0007 SD64G 58.2 GiB
[14656.643674] blk_update_request: I/O error, dev mmcblk0, sector 0 op 0x0:(READ) flags 0x0 phys_seg 1 prio class 0
[14656.648767] Buffer I/O error on dev mmcblk0, logical block 0, async page read
[14656.815935] blk_update_request: I/O error, dev mmcblk0, sector 0 op 0x0:(READ) flags 0x0 phys_seg 1 prio class 0
[14656.871952] blk_update_request: I/O error, dev mmcblk0, sector 4 op 0x0:(READ) flags 0x0 phys_seg 1 prio class 0
[14656.874713] Buffer I/O error on dev mmcblk0, logical block 0, async page read
[14657.039961] blk_update_request: I/O error, dev mmcblk0, sector 0 op 0x0:(READ) flags 0x0 phys_seg 1 prio class 0
[14657.095996] blk_update_request: I/O error, dev mmcblk0, sector 1 op 0x0:(READ) flags 0x0 phys_seg 1 prio class 0
[14657.151709] blk_update_request: I/O error, dev mmcblk0, sector 2 op 0x0:(READ) flags 0x0 phys_seg 1 prio class 0
[14657.207959] blk_update_request: I/O error, dev mmcblk0, sector 3 op 0x0:(READ) flags 0x0 phys_seg 1 prio class 0
[14657.211413] Buffer I/O error on dev mmcblk0, logical block 0, async page read
[14657.211517] ldm_validate_partition_table(): Disk read failed.
[14657.379959] blk_update_request: I/O error, dev mmcblk0, sector 0 op 0x0:(READ) flags 0x0 phys_seg 1 prio class 0
[14657.435967] blk_update_request: I/O error, dev mmcblk0, sector 2 op 0x0:(READ) flags 0x0 phys_seg 1 prio class 0
[14657.491957] blk_update_request: I/O error, dev mmcblk0, sector 4 op 0x0:(READ) flags 0x0 phys_seg 1 prio class 0
[14657.494641] Buffer I/O error on dev mmcblk0, logical block 0, async page read
[14657.827645] Buffer I/O error on dev mmcblk0, logical block 0, async page read
[14658.001877] Buffer I/O error on dev mmcblk0, logical block 0, async page read
[14658.174374] Buffer I/O error on dev mmcblk0, logical block 0, async page read
[14658.174461] Dev mmcblk0: unable to read RDB block 0
[14658.456376] Buffer I/O error on dev mmcblk0, logical block 0, async page read
[14658.628677] Buffer I/O error on dev mmcblk0, logical block 0, async page read
[14659.026783] Buffer I/O error on dev mmcblk0, logical block 0, async page

und inxi -Fz

System:
  Host: kogl-ThinkPad-E580 Kernel: 5.4.0-65-generic x86_64 bits: 64
  Desktop: Cinnamon 4.4.8 Distro: Linux Mint 19.3 Tricia
Machine:
  Type: Laptop System: LENOVO product: 20KS003GGE v: ThinkPad E580
  serial: <filter>
  Mobo: LENOVO model: 20KS003GGE v: SDK0J40697 WIN serial: <filter>
  UEFI: LENOVO v: R0PET41W (1.18 ) date: 06/11/2018
Battery:
  ID-1: BAT0 charge: 41.2 Wh condition: 41.4/45.7 Wh (90%)
CPU:
  Topology: Quad Core model: Intel Core i5-8250U bits: 64 type: MT MCP
  L2 cache: 6144 KiB
  Speed: 1079 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 2878 2: 2796
  3: 2362 4: 2472 5: 2488 6: 2326 7: 2949 8: 2754
Graphics:
  Device-1: Intel UHD Graphics 620 driver: i915 v: kernel
  Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa
  resolution: 1920x1080~60Hz
  OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (KBL GT2)
  v: 4.6 Mesa 20.3.4 - kisak-mesa PPA
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel
  Sound Server: ALSA v: k5.4.0-65-generic
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  driver: r8169
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: Intel Dual Band Wireless-AC 3165 Plus Bluetooth driver: iwlwifi
  IF: wlp5s0 state: up mac: <filter>
  IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A
Drives:
  Local Storage: total: 7.51 TiB used: 2.99 TiB (39.8%)
  ID-1: /dev/nvme0n1 vendor: Toshiba model: KXG5AZNV256G size: 238.47 GiB
  ID-2: /dev/sda vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB
  ID-3: /dev/sdb type: USB vendor: Western Digital model: WD Elements 25A2
  size: 1.82 TiB
  ID-4: /dev/sdc type: USB vendor: Western Digital model: WD20EARX-32PASB0
  size: 1.82 TiB
  ID-5: /dev/sdd type: USB vendor: Western Digital model: WD Elements 25A3
  size: 2.73 TiB
Partition:
  ID-1: / size: 233.24 GiB used: 116.17 GiB (49.8%) fs: ext4
  dev: /dev/nvme0n1p2
Sensors:
  System Temperatures: cpu: 53.0 C mobo: 0.0 C
  Fan Speeds (RPM): cpu: 0
Info:
  Processes: 353 Uptime: 4h 21m Memory: 15.41 GiB used: 3.17 GiB (20.6%)
  Shell: bash inxi: 3.0.32
[14659.256116]  mmcblk0: unable to read partition table

Wäre für Tipps von euch Spezialisten recht dankbar.

PS: Hier noch die Ausgabe einer funktionierenden Karte

[16636.833378] mmc0: new ultra high speed SDR104 SDHC card at address 0001
[16636.833658] mmcblk0: mmc0:0001 00000 14.9 GiB
[16636.856449]  mmcblk0: p1 p2
[16659.420219] EXT4-fs (mmcblk0p2): recovery complete
[16659.421545] EXT4-fs (mmcblk0p2): mounted filesystem with ordered data mode. Opts: (null)
« Letzte Änderung: 15.02.2021, 10:46:50 von woolfman »

Re: Interner Kartenleser spinnt
« Antwort #1 am: 14.02.2021, 09:35:16 »
Hallo,
wohl kein Fehler des Kartenlesers, sondern die beiden SD-Karten scheinen defekt zu sein (Sektorfehler). Die Lebensdauer ist nun mal begrenzt.

Re: Interner Kartenleser spinnt
« Antwort #2 am: 14.02.2021, 10:08:43 »
Danke @Flash63 für die prompte Antwort, die sind beide so 4 - 5 Jahre alt eine eine Medion die andere eine A-Data. Wie lange hält eigentlich so eine Micro-SD Karte, meine Samsung in meinem Raspi ist ebenfalls ca. 4,5 Jahre alt und funktioniert noch, ist da mit einem baldigen Ausfall zu rechnen und sind Samsung Endurance wirklich langlebiger?

Re: Interner Kartenleser spinnt
« Antwort #3 am: 14.02.2021, 10:09:50 »
Das ist schlecht vorherzusagen, hängt u.a. von der Schreibleistung ab, weniger vom Alter an sich. Grundsätzlich sind aber billige Karten sicher nicht besonders langlebig.
Einer "Medion", wo du gar nicht weißt, was da drin steckt, würde ich jedenfalls keine wichtigen Daten für länger anvertrauen.

Re: Interner Kartenleser spinnt
« Antwort #4 am: 14.02.2021, 11:15:32 »
Hallo,
ich habe über die Jahre gegenteilige Erfahrungen gemacht. USB-Sticks und SD/microSD-Karten von Aldi haben bei mir bisher die geringste Ausfallquote. Aldi "verspricht" i.d.R. ja immerhin 3 Jahre Garantie auf die Teile. Bei Speicherkarten für die Digitalkamera tauchen dann z.B. erst nur vereinzelt Pixelfehler bei den gespeicherten Bildern auf bevor die Karte gänzlich defekt ist. Das sind dann die ersten Anzeichen für Verschleiß und man sollte die Speicherkarte entsorgen. Beim Raspi und Smartphone ist der Speicherdurchsatz eher niedrig und die Lebensdauer der Speicherkarten dadurch rel. hoch. Meist wird das Smartphone selbst bereits ersetzt bevor die Speicherkarte Fehler zeigt.
« Letzte Änderung: 14.02.2021, 11:19:09 von Flash63 »

Re: Interner Kartenleser spinnt
« Antwort #5 am: 14.02.2021, 11:18:54 »
Ja, so ist das bei Flashspeicher: frage 3 Leute und du bekommst 4 Meinungen... ;D

Re: Interner Kartenleser spinnt
« Antwort #6 am: 14.02.2021, 11:26:26 »
Ich sehe SD - Karten aber nur als Kurzzeitspeicher an.
Wie beim Einsatz in Kameras, man macht 14 Tage Foto's im Urlaub und wenn man nach Hause kommt holt man sie runter auf eine HDD/SSD Langzeitspeicherung dann auf CD/DVD/Blue Ray.
Im Handy mag es anders sein, da sie dort ja ständig unter Strom stehen.
 

Re: Interner Kartenleser spinnt
« Antwort #7 am: 14.02.2021, 11:33:14 »
Von den microSD Kärtchen ist mir bisher noch keins kaputt gegangen, auch nicht im Raspi bei 24/7 Betrieb. Wenn, dann wurden Sticks unbrauchbar.

Re: Interner Kartenleser spinnt
« Antwort #8 am: 15.02.2021, 08:32:13 »
Schönen Morgen,
herzlichen Dank für eure Antworten, werde mir sicherheitshalber ein Samsung Endurence anschaffen und von meiner Raspi SD regelmäßig ein Backup mit dd machen, so hab ich im Notfall eine SD bereitliegen, sicher ist sicher.

Re: Interner Kartenleser spinnt
« Antwort #9 am: 15.02.2021, 10:39:39 »
Dann setze bitte noch ein "gelöst" oder "erledigt": dazu den Eröffnungspost "ändern" und das Präfix setzen. Dann sehen andere gleich, dass hier keine Hilfe mehr notwendig ist. (Anleitung: https://www.linuxmintusers.de/index.php?topic=3603.0)