Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
13.12.2017, 21:26:52

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 19250
  • Letzte: Labrat
Statistiken
  • Beiträge insgesamt: 497654
  • Themen insgesamt: 39971
  • Heute online: 470
  • Am meisten online: 679
  • (03.04.2017, 15:20:01)
Benutzer Online

Autor Thema:  Error bei der Aktualisierungsverwaltung  (Gelesen 510 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Error bei der Aktualisierungsverwaltung
« am: 11.10.2017, 22:23:16 »
Hallo,

Die Liste der Aktualisierungsverwaltung kann nicht aufgefrischt werden.
E:Error, pkgProblemResolver::Resolve generated breaks, this may be cause by held packages.

Wenn ich die Aktualisirungsverwaltung auffrische kommt: Der Treiber für Methode /usr/lib/apt/methods/https// konnte nicht gefunden werden.
Zudem bekomme ich eine Benachrichtung: Die Abhängigkeiten von 16 Paketen auf ihrem System sind defekt. Wählen sie den Filter >Defekte Pakete<, um diese anzuzeigen.

Ich habe Linuxmint 17.1 rebecca

Ich kenne mich leider nicht damit aus und freue mich sehr über Lösungsvorschläge.

LG

Re: Error bei der Aktualisierungsverwaltung
« Antwort #1 am: 12.10.2017, 13:14:48 »
Hi :)
oh oh, hört sich an als wenn du was entfernt hast, ohne zu gucken was du dabei mit entfernst..
vermutlich auch apt weg..  dann hast du dir den ast abgesägt, auf dem du sitzt....

zeig mal was dabei kommt... bitte als code block (# oben)
sudo apt-get -f install

Re: Error bei der Aktualisierungsverwaltung
« Antwort #2 am: 13.10.2017, 16:42:52 »
Danke für deine schnelle Antwort. ;)

/code[]lisa@lisa-X55A ~ $ sudo apt-get -f install
[sudo] password for lisa:
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Abhängigkeiten werden korrigiert ... fehlgeschlagen.
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 cinnamon-settings-daemon : Hängt ab von: liblcms2-2 (>= 2.2+git20110628) ist aber nicht installierbar
 colord : Hängt ab von: liblcms2-2 (>= 2.2+git20110628) ist aber nicht installierbar
 cups-filters-core-drivers : Hängt ab von: liblcms2-2 (>= 2.2+git20110628) ist aber nicht installierbar
 eog : Hängt ab von: liblcms2-2 (>= 2.2+git20110628) ist aber nicht installierbar
 gimp : Hängt ab von: liblcms2-2 (>= 2.2+git20110628) ist aber nicht installierbar
 gnome-settings-daemon : Hängt ab von: liblcms2-2 (>= 2.2+git20110628) ist aber nicht installierbar
 libcdr-0.0-0 : Hängt ab von: liblcms2-2 (>= 2.2+git20110628) ist aber nicht installierbar
 libcolord1 : Hängt ab von: liblcms2-2 (>= 2.5) ist aber nicht installierbar
 libgs9 : Hängt ab von: liblcms2-2 (>= 2.5) ist aber nicht installierbar
 libgxps2 : Hängt ab von: liblcms2-2 (>= 2.2+git20110628) ist aber nicht installierbar
 libmng2 : Hängt ab von: liblcms2-2 (>= 2.2+git20110628) ist aber nicht installierbar
 libpoppler44 : Hängt ab von: liblcms2-2 (>= 2.2+git20110628) ist aber nicht installierbar
 libreoffice-core : Hängt ab von: liblcms2-2 (>= 2.2+git20110628) ist aber nicht installierbar
 openjdk-7-jre-headless : Hängt ab von: liblcms2-2 (>= 2.2+git20110628) ist aber nicht installierbar
 poppler-utils : Hängt ab von: liblcms2-2 (>= 2.2+git20110628) ist aber nicht installierbar
 python-pil : Hängt ab von: liblcms2-2 (>= 2.2+git20110628) ist aber nicht installierbar
E: Fehler: Unterbrechungen durch pkgProblemResolver::Resolve hervorgerufen; dies könnte durch zurückgehaltene Pakete verursacht worden sein.
E: Abhängigkeiten konnten nicht korrigiert werden.

Re: Error bei der Aktualisierungsverwaltung
« Antwort #3 am: 13.10.2017, 21:42:54 »
Zeige bitte noch woher die Paketverwaltung das Paket liblcms2-2 beziehen möchte
apt-cache policy liblcms2-2
inxi -r

Re: Error bei der Aktualisierungsverwaltung
« Antwort #4 am: 14.10.2017, 12:21:35 »
Danke für deine Hilfe! :)

lisa@lisa-X55A ~ $ apt-cache policy liblcms2-2
liblcms2-2:i386:
  Installiert:           (keine)
  Installationskandidat: (keine)
  Versionstabelle:
     2.5-0ubuntu4.1 0
        100 /var/lib/dpkg/status
lisa@lisa-X55A ~ $ inxi -r
Repos:     Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
           deb http://linux-mint.froonix.org rebecca main upstream import
           deb http://extra.linuxmint.com rebecca main
           deb http://ftp.tu-chemnitz.de/pub/linux/ubuntu trusty main restricted universe multiverse
           deb http://ftp.tu-chemnitz.de/pub/linux/ubuntu trusty-updates main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu/ trusty-security main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu/ trusty partner
           Active apt sources in file: /etc/apt/sources.list.d/opera-stable.list
           deb https//:deb.opera.com/opera-stable/ stable non-free #Opera Browser (final releases)

Re: Error bei der Aktualisierungsverwaltung
« Antwort #5 am: 14.10.2017, 12:23:04 »
Ich habe es falsch eingefügt!
Das gleich also nochmal.

lisa@lisa-X55A ~ $ apt-cache policy liblcms2-2
liblcms2-2:i386:
  Installiert:           (keine)
  Installationskandidat: (keine)
  Versionstabelle:
     2.5-0ubuntu4.1 0
        100 /var/lib/dpkg/status
lisa@lisa-X55A ~ $ inxi -r
Repos:     Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
           deb http://linux-mint.froonix.org rebecca main upstream import
           deb http://extra.linuxmint.com rebecca main
           deb http://ftp.tu-chemnitz.de/pub/linux/ubuntu trusty main restricted universe multiverse
           deb http://ftp.tu-chemnitz.de/pub/linux/ubuntu trusty-updates main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu/ trusty-security main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu/ trusty partner
           Active apt sources in file: /etc/apt/sources.list.d/opera-stable.list
           deb https//:deb.opera.com/opera-stable/ stable non-free #Opera Browser (final releases)


Re: Error bei der Aktualisierungsverwaltung
« Antwort #6 am: 14.10.2017, 20:55:55 »
Zitat von: lisa857
Ich habe es falsch eingefügt!
Dafür gibt es den «Ändern»-Knopf.

Zitat
Installationskandidat: (keine)
Da stimmt doch was nicht.
Zeigst du noch die Ausgabe von
apt update

Re: Error bei der Aktualisierungsverwaltung
« Antwort #7 am: 14.10.2017, 23:45:28 »
lisa@lisa-X55A ~ $ apt update
[sudo] password for lisa:
E: Der Treiber für Methode /usr/lib/apt/methods/https// konnte nicht gefunden werden.

Re: Error bei der Aktualisierungsverwaltung
« Antwort #8 am: 15.10.2017, 07:18:35 »
Denke, das es an der nachträglichen Installation von Opera liegt, der möchte https.
Was sagt denn apt-cache policy apt-transport-https?
Falls nicht vorhanden, mal ein sudo apt-get install apt-transport-https versuchen.
Sollte dies nicht den gewünschten Effekt bringen, ein sudo apt-get remove --purge apt-transport-https durchführen.

Re: Error bei der Aktualisierungsverwaltung
« Antwort #9 am: 15.10.2017, 14:21:30 »
Das ist dabei raus gekommen.
lisa@lisa-X55A ~ $ apt-cache policy apt-transport-https
apt-transport-https:
  Installiert:           1.0.1ubuntu2.17
  Installationskandidat: 1.0.1ubuntu2.17
  Versionstabelle:
 *** 1.0.1ubuntu2.17 0
        100 /var/lib/dpkg/status

Re: Error bei der Aktualisierungsverwaltung
« Antwort #10 am: 15.10.2017, 15:30:38 »
           deb https//:deb.opera.com/opera-stable/ stable non-free #Opera Browser (final releases)
Hach! Da fällt mir jetzt erst was auf: Warum ist denn der Doppelpunkt erst hinter den Schrägstrichen?

Kannst du die Datei bitte bearbeiten und das richtig stellen. Dann nochmal
apt update

Re: Error bei der Aktualisierungsverwaltung
« Antwort #11 am: 16.10.2017, 19:27:58 »
Hey ;)
Ich weiß leider nicht wie ich die Datei bearbeite. Ich habe es versucht heraus zu finden, jedoch möchte ich es nicht falsch machen und es letztendlich verschlimmern.
Könntest du mir dass erklären?

Re: Error bei der Aktualisierungsverwaltung
« Antwort #12 am: 16.10.2017, 19:37:31 »
Du kannst die Datei mit gksudo gedit /etc/apt/sources.list.d/opera-stable.list bearbeiten.

Nach dem speichern der Datei und beenden des Editors führe nochmal ein apt update aus.

Re: Error bei der Aktualisierungsverwaltung
« Antwort #13 am: 16.10.2017, 20:09:04 »
Es hat alles funktioniert!
Vielen vielen Dank für Eure Hilfe!!!! ;D
« Letzte Änderung: 16.10.2017, 20:43:38 von lisa857 »