Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
18.07.2018, 05:17:47

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 539085
  • Themen insgesamt: 43258
  • Heute online: 345
  • Am meisten online: 680
  • (27.03.2018, 20:17:41)
Benutzer Online
Mitglieder: 2
Gäste: 207
Gesamt: 209

Autor Thema:  WLAN bricht ständig ab  (Gelesen 848 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

WLAN bricht ständig ab
« am: 01.09.2017, 17:53:53 »
Hallo,

ich hab zwar schon eine Weile Linux Mint und bis jetzt immer ganz gut selbst Lösungen gefunden, diesmal geht's allerdings um die Internetverbindung und ich finde keine Lösung und deshalb bin ich jetzt neu hier im Forum ;)

Folgendes Problem:
Meine Internetverbindung über WLAN hört immer wieder auf zu funktionieren. Laut Netzwerkverbindungen besteht die Verbindung zwar noch, aber weder kann ich übern Browser Seiten laden, noch haben andere Programme eine Verbindung, noch lässt sich der Router anpingen. Einzige Lösung die bis jetzt funktioniert hat, ist Funknetzwerk aus- und wieder einschalten, aber das nervt langsam, da das manchmal im Minutentakt passiert. Streckenweise bleibt die Verbindung wiederum über Stunden bestehen, wie jetzt, was die Fehlersuche nochmals erschwert..
Das Problem besteht seit einigen Tagen, auch schon unter 18.1 (Habe gestern geupgradet, dachte das löst vllt. was). Wiederum einige Tage davor bin ich umgezogen (Dadurch neuer Router/Internet/...), aber das Problem war wie gesagt nicht von Anfang an vorhanden.

Mein System: Acer Aspire V15 (VN7-572G-56VP) mit Linux Mint 18.2 Sonya 64bit

Hier mal Ausgaben von denen ich dachte, dass sie hilfreich sein könnten:

inxi -Fxz
System:    Host: nitro Kernel: 4.8.0-53-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.4.6 (Gtk 3.18.9-1ubuntu3.3) Distro: Linux Mint 18.2 Sonya
Machine:   System: Acer (portable) product: Aspire VN7-572G v: V1.11
           Mobo: Acer model: Aspire VN7-572G v: V1.11 Bios: Insyde v: V1.11 date: 05/09/2016
CPU:       Dual core Intel Core i5-6200U (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9600
           clock speeds: max: 2800 MHz 1: 2778 MHz 2: 2700 MHz 3: 2732 MHz 4: 2699 MHz
Graphics:  Card-1: Intel Sky Lake Integrated Graphics bus-ID: 00:02.0
           Card-2: NVIDIA GM107M [GeForce GTX 950M] bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa) FAILED: nouveau
           Resolution: 1920x1080@60.02hz
           GLX Renderer: Mesa DRI Intel HD Graphics 520 (Skylake GT2)
           GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes
Audio:     Card Intel Sunrise Point-LP HD Audio driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.8.0-53-generic
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: 3000 bus-ID: 02:00.0
           IF: enp2s0 state: down mac: <filter>
           Card-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter driver: ath10k_pci bus-ID: 03:00.0
           IF: wlp3s0 state: up mac: <filter>
Drives:    HDD Total Size: 756.2GB (27.5% used) ID-1: /dev/sda model: SAMSUNG_MZNLN256 size: 256.1GB
           ID-2: /dev/sdb model: WDC_WD5000LPVX size: 500.1GB
Partition: ID-1: / size: 226G used: 187G (87%) fs: ext4 dev: /dev/dm-1
           ID-2: /boot size: 473M used: 172M (39%) fs: ext2 dev: /dev/sda2
           ID-3: swap-1 size: 8.48GB used: 0.00GB (0%) fs: swap dev: /dev/dm-3
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 64.0C mobo: 50.0C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 272 Uptime: 8:52 Memory: 3369.7/7879.1MB Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35

wconfig
wlp3s0    IEEE 802.11  ESSID:"o2-WLAN70" 
          Mode:Managed  Frequency:2.457 GHz  Access Point: E4:3E:D7:F8:EB:E1   
          Bit Rate=1 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=50/70  Signal level=-60 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:21  Invalid misc:487   Missed beacon:0

vmnet1    no wireless extensions.

vmnet8    no wireless extensions.

lo        no wireless extensions.

enp2s0    no wireless extensions.

Viele Grüße!

Re: WLAN bricht ständig ab
« Antwort #1 am: 01.09.2017, 18:00:15 »
Das Power Management könnte das Problem sein.
Versuch mal ob  sudo sed -i "s/wifi.powersave = 3/wifi.powersave = 2/g" /etc/NetworkManager/conf.d/default-wifi-powersave-on.confsystemctl restart network-managerdas Problem behebt.

Re: WLAN bricht ständig ab
« Antwort #2 am: 01.09.2017, 18:27:21 »
Habs probiert, jetzt kann ich den network-manager nicht mehr starten...

systemctl restart network-manager
Job for NetworkManager.service failed because the control process exited with error code. See "systemctl status NetworkManager.service" and "journalctl -xe" for details.

systemctl status NetworkManager.service
● NetworkManager.service - Network Manager
   Loaded: loaded (/lib/systemd/system/NetworkManager.service; enabled; vendor preset: enabled)
   Active: inactive (dead) (Result: exit-code) since Fr 2017-09-01 18:12:54 CEST; 24s ago
     Docs: man:NetworkManager(8)
  Process: 680 ExecStart=/usr/sbin/NetworkManager --no-daemon (code=exited, status=226/NAMESPACE)
 Main PID: 680 (code=exited, status=226/NAMESPACE)
   CGroup: /system.slice/NetworkManager.service
           â””─1671 /usr/sbin/dnsmasq --no-resolv --keep-in-foreground --no-hosts --bind-interfaces --pid-file=/var/run/NetworkManager/dnsmasq.pid --listen-address=127.0.1.1 --cache-size=0 --conf-file=/dev/null --proxy-dnssec --enable-dbus=

Sep 01 18:12:53 nitro systemd[1]: Failed to start Network Manager.
Sep 01 18:12:53 nitro systemd[1]: NetworkManager.service: Unit entered failed state.
Sep 01 18:12:53 nitro systemd[1]: NetworkManager.service: Failed with result 'exit-code'.
Sep 01 18:12:54 nitro systemd[1]: NetworkManager.service: Service hold-off time over, scheduling restart.
Sep 01 18:12:54 nitro systemd[1]: Stopped Network Manager.
Sep 01 18:12:54 nitro systemd[1]: NetworkManager.service: Start request repeated too quickly.
Sep 01 18:12:54 nitro systemd[1]: Failed to start Network Manager.
...skipping...
● NetworkManager.service - Network Manager
   Loaded: loaded (/lib/systemd/system/NetworkManager.service; enabled; vendor preset: enabled)
   Active: inactive (dead) (Result: exit-code) since Fr 2017-09-01 18:12:54 CEST; 24s ago
     Docs: man:NetworkManager(8)
  Process: 680 ExecStart=/usr/sbin/NetworkManager --no-daemon (code=exited, status=226/NAMESPACE)
 Main PID: 680 (code=exited, status=226/NAMESPACE)
   CGroup: /system.slice/NetworkManager.service
           â””─1671 /usr/sbin/dnsmasq --no-resolv --keep-in-foreground --no-hosts --bind-interfaces --pid-file=/var/run/NetworkManager/dnsmasq.pid --listen-address=127.0.1.1 --cache-size=0 --conf-file=/dev/null --proxy-dnssec --enable-dbus=

Sep 01 18:12:53 nitro systemd[1]: Failed to start Network Manager.
Sep 01 18:12:53 nitro systemd[1]: NetworkManager.service: Unit entered failed state.
Sep 01 18:12:53 nitro systemd[1]: NetworkManager.service: Failed with result 'exit-code'.
Sep 01 18:12:54 nitro systemd[1]: NetworkManager.service: Service hold-off time over, scheduling restart.
Sep 01 18:12:54 nitro systemd[1]: Stopped Network Manager.
Sep 01 18:12:54 nitro systemd[1]: NetworkManager.service: Start request repeated too quickly.
Sep 01 18:12:54 nitro systemd[1]: Failed to start Network Manager.

journalctl -xe
-- Subject: Unit NetworkManager.service has finished shutting down
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit NetworkManager.service has finished shutting down.
Sep 01 18:12:53 nitro systemd[1]: Starting Network Manager...
-- Subject: Unit NetworkManager.service has begun start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit NetworkManager.service has begun starting up.
Sep 01 18:12:53 nitro systemd[680]: NetworkManager.service: Failed at step NAMESPACE spawning /usr/sbin/NetworkManager: Invalid argument
-- Subject: Process /usr/sbin/NetworkManager could not be executed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- The process /usr/sbin/NetworkManager could not be executed and failed.
--
-- The error number returned by this process is 22.
Sep 01 18:12:53 nitro systemd[1]: NetworkManager.service: Main process exited, code=exited, status=226/NAMESPACE
Sep 01 18:12:53 nitro systemd[1]: Failed to start Network Manager.
-- Subject: Unit NetworkManager.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit NetworkManager.service has failed.
--
-- The result is failed.
Sep 01 18:12:53 nitro systemd[1]: NetworkManager.service: Unit entered failed state.
Sep 01 18:12:53 nitro systemd[1]: NetworkManager.service: Failed with result 'exit-code'.
Sep 01 18:12:54 nitro systemd[1]: NetworkManager.service: Service hold-off time over, scheduling restart.
Sep 01 18:12:54 nitro systemd[1]: Stopped Network Manager.
-- Subject: Unit NetworkManager.service has finished shutting down
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit NetworkManager.service has finished shutting down.
Sep 01 18:12:54 nitro systemd[1]: NetworkManager.service: Start request repeated too quickly.
Sep 01 18:12:54 nitro systemd[1]: Failed to start Network Manager.
-- Subject: Unit NetworkManager.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit NetworkManager.service has failed.
--
-- The result is failed.
Sep 01 18:12:54 nitro ntpd[1343]: Deleting interface #18 wlp3s0, 192.168.1.63#123, interface stats: received=423, sent=423, dropped=0, active_time=13719 secs
Sep 01 18:12:54 nitro ntpd[1343]: 178.63.22.87 local addr 192.168.1.63 -> <null>
Sep 01 18:12:54 nitro ntpd[1343]: 88.99.126.167 local addr 192.168.1.63 -> <null>
Sep 01 18:12:54 nitro ntpd[1343]: 148.251.6.18 local addr 192.168.1.63 -> <null>
Sep 01 18:12:54 nitro ntpd[1343]: 129.250.35.250 local addr 192.168.1.63 -> <null>
Sep 01 18:12:54 nitro ntpd[1343]: 136.243.177.133 local addr 192.168.1.63 -> <null>
Sep 01 18:12:54 nitro ntpd[1343]: 217.13.65.177 local addr 192.168.1.63 -> <null>
Sep 01 18:12:54 nitro ntpd[1343]: 213.95.200.109 local addr 192.168.1.63 -> <null>
Sep 01 18:12:54 nitro ntpd[1343]: 78.47.226.8 local addr 192.168.1.63 -> <null>
Sep 01 18:12:54 nitro ntpd[1343]: 88.198.12.78 local addr 192.168.1.63 -> <null>
Sep 01 18:12:54 nitro ntpd[1343]: 213.95.200.107 local addr 192.168.1.63 -> <null>
Sep 01 18:12:54 nitro ntpd[1343]: 176.9.1.211 local addr 192.168.1.63 -> <null>

Wie stell ich das wieder zurück?? Is ziemlich umständlich mit dem Handy ;)

Re: WLAN bricht ständig ab
« Antwort #3 am: 01.09.2017, 18:31:15 »
Probier mal sudo systemctl restart network-manager.service

Re: WLAN bricht ständig ab
« Antwort #4 am: 01.09.2017, 18:33:15 »
Zurück mit
sudo sed -i "s/wifi.powersave = 2/wifi.powersave = 3/g" /etc/NetworkManager/conf.d/default-wifi-powersave-on.confMir scheint du hast das Kommando nicht kopiert sondern abgeschrieben und dabei muss dir ein Fehler unterlaufen sein.
Das der NM danach nicht mehr startet ist jedenfalls nicht normal.

Zeig mal die Ausgabe von
cat /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

Re: WLAN bricht ständig ab
« Antwort #5 am: 01.09.2017, 18:34:41 »
Gleicher Fehler wie eben.

Job for NetworkManager.service failed because the control process exited with error code. See "systemctl status NetworkManager.service" and "journalctl -xe" for details.

Re: WLAN bricht ständig ab
« Antwort #6 am: 01.09.2017, 18:44:59 »
Zurück mit
sudo sed -i "s/wifi.powersave = 2/wifi.powersave = 3/g" /etc/NetworkManager/conf.d/default-wifi-powersave-on.confMir scheint du hast das Kommando nicht kopiert sondern abgeschrieben und dabei muss dir ein Fehler unterlaufen sein.
Das der NM danach nicht mehr startet ist jedenfalls nicht normal.

Zeig mal die Ausgabe von
cat /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

Kommando wurde kopiert und nicht abgetippt.
Ausgabe zeigt:
cat: /etc/NetworkManager/conf.d/default-wifi-powersafe-on.conf: Datei oder Verzeichnis nicht gefunden
Allerdings ist das seltsam, weil ich die Datei finde.. Da steht folgendes Drin:
[connection]
wifi.powersave = 3

Re: WLAN bricht ständig ab
« Antwort #7 am: 01.09.2017, 18:48:45 »
cat: /etc/NetworkManager/conf.d/default-wifi-powersafe-on.conf
Das kann nicht funktionieren, nach cat kommt kein :
Startet der NM nun wieder?

Re: WLAN bricht ständig ab
« Antwort #8 am: 01.09.2017, 18:51:03 »
cat: /etc/NetworkManager/conf.d/default-wifi-powersafe-on.conf
Das kann nicht funktionieren, nach cat kommt kein :
Startet der NM nun wieder?

Das ist die Ausgabe, im Kommando hatte ich das : nicht drin.
Nein, NM startet nicht.

Re: WLAN bricht ständig ab
« Antwort #9 am: 01.09.2017, 18:54:49 »
cat /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf
[connection]
wifi.powersave = 3
So ist der Standard, mein ich.

Re: WLAN bricht ständig ab
« Antwort #10 am: 01.09.2017, 18:56:06 »
Zeig mal bitte ls -l /etc/NetworkManager/conf.d

Re: WLAN bricht ständig ab
« Antwort #11 am: 01.09.2017, 18:59:56 »
Ok, jetzt bin ich wieder drin, nachm zweiten Neustart wollte der NM wieder.. Jetzt passen auch die Ausgaben:

flo@nitro ~ $ ls -l /etc/NetworkManager/conf.d
insgesamt 4
-rw-r--r-- 1 root root 31 Sep  1 18:32 default-wifi-powersave-on.conf
flo@nitro ~ $ cat /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf
[connection]
wifi.powersave = 3

Re: WLAN bricht ständig ab
« Antwort #12 am: 01.09.2017, 19:05:12 »
Dann mal anders
gksudo xed /etc/NetworkManager/conf.d/default-wifi-powersave-on.confdann änderst du die 3 auf 2 und speicherst das ganze.
Danach den NM neustarten.

Re: WLAN bricht ständig ab
« Antwort #13 am: 01.09.2017, 19:17:20 »
So, jetzt ist's geändert, musste wiederum zweimal neustarten, weil der NM nicht restarten wollte... Komisch...
Ich werde mal abwarten, ob das Problem dadurch behoben wurde und keine Abbrüche mehr auftreten, wenn nicht schreib ich hier wieder ;)

Vielen Dank auf jeden Fall! :)

Re: WLAN bricht ständig ab
« Antwort #14 am: 01.09.2017, 19:31:46 »
musste wiederum zweimal neustarten, weil der NM nicht restarten wollte...
Mit "systemctl restart network-manager"?