Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
17.04.2021, 23:54:55

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 25505
  • Letzte: Henk2021
Statistiken
  • Beiträge insgesamt: 729434
  • Themen insgesamt: 58846
  • Heute online: 610
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  Boot Probleme mit Windows 8 - Dual Boot mit Linux Mint 15  (Gelesen 6437 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Jamuna

  • Gast
Re: Boot Probleme mit Windows 8 - Dual Boot mit Linux Mint 15
« Antwort #15 am: 11.07.2013, 21:23:10 »
Uefi am besten abstellen, im Bios..

jou - oder auf "UEFI only" stellen - ich hatte von Anfang an den Verdacht, das es sich um diesen Mischmasch-Modus handelt und der ist einfach nur bullshit.

Von daher - ich schließ mich der Aussage von DocHifi an.  :)

edit:

die Anleitung von diesem RapaNui auf uu.de ist ok - kann da keinen Fehler entdecken - die anleitung zur Grubreparatur auch, sofern du sie verstehst.

Ich vermute neben diesem blöden Kompatibilitätsmodus für UEFI/msdos nen Tippfehler als Ursache deines Problemchens.

Egal, stell das dingens auf "legacy only", si wie Doc es empfohlen hat - da gibts wohl auch deutlich mehr User hier, die sich damit auskennen.

 :-*
J.
« Letzte Änderung: 11.07.2013, 21:32:12 von Jamuna »

Re: Boot Probleme mit Windows 8 - Dual Boot mit Linux Mint 15
« Antwort #16 am: 11.07.2013, 21:38:10 »
Das ist irgendwie echt doof, ich kann Windows nicht im UEFI Mode installieren (es gibt keine UEFI Option beim Boot) und Mint kann ich zwar mit und ohne starten aber wenn ich es ohne starte wird mir nur gesagt, dass kein Betriebssystem gefunden wurde und er neu startet.
Ich kann generell in meinem Bios kein legacy only einstellen sondern nur enablen und disablen und dann im Boot Menu ist dann das Geraet einmal mit UEFI und ohne UEFI aufgefuehrt, ausser halt bei Windows.
Mich verwirrt das selber zu sehr, sorry fuer die seltsame Beschreibung  ???


Edit: Windows 8 kann vom USB Stick anscheinend nicht im UEFI Modus installiert werden.. Ich brenne es jetzt auf DVD und versuche es erneut.. Dann melde ich mich nochmal :)
« Letzte Änderung: 11.07.2013, 21:54:08 von HenryHux »

Re: Boot Probleme mit Windows 8 - Dual Boot mit Linux Mint 15
« Antwort #17 am: 11.07.2013, 22:02:01 »
Möglicherweise sind Frieder's Experimente hilfreich:

https://www.linuxmintusers.de/index.php?topic=9808.msg89115#msg89115

Zitat
Hi @ all, ich möchte euch mal mein neuestes Projekt vorstellen, einen Dualboot mit Win8 und Ubuntu 12.10 im UEFI-Modus. Das Ganze funzt auch mit Mint14 Cinnamon (von mir getestet)

WARNUNG: nachmachen erfolgt auf eigene Gefahr und da ich selber noch Lehrling in der Materie bin, gibts auch nur begrenzten Support

Nachmachen führt zum Erfolg  :)

Ok, zu den Ausgangsbedingungen:

- UEFI-fähiges Läppi, Lenovo X220
- leere Festplatte mit 320 GB
- legales Win8 mit Schlüssel
- aktuelles Ubuntu 12.10 und aktuelles Mint 14 Cinnamon

Vorgehensweise:

als erstes hab ich Win 8 installiert, das geht mittlerweile auch recht flott (30-40 Minuten) - Lan und Wlan werden automatisch erkannt. Microsoft besteht auf das anlegen eines Useraccounts, hab ich gemacht, aber die Registrierung nicht bestätigt - spielt aber für das Experiment auch keine Rolle.

Dem Win 8 hab ich beim Installieren im Windowsinstaller 70 GB gegönnt was auch brav angenommen wurde - Win hat dann 4 Partitionen angelegt, 2 davon sind uninteressant - was zählt ist die /boot.efi und das System.

Nach der Installation kurz geprüft, ob das System startet - hat es gemacht und ich habs schnell wieder geschlossen - grausam

--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------


Jetzt Ubuntu 12.10 eingelegt und im Live-Modus gestartet - dann installieren. Am Eingang zum Partitionsmenü hab ich "etwas anderes machen" ausgewählt, Ubuntu dann vom freien Speicher einfach mal 50 Gb zugeteilt, noch ne Swap mit 5 GB angelegt und auf "installieren" geklickt.

WICHTIG: Grub muß nach sda ohne Zahl - den Rest macht der Installer das war falsch - es wird "grub.efi" verwendet und der installiert sich automatisch in die EFI-Partition

sodele, man könnte sagen, das wars eigentlich schon - beide Systeme sollten über das Bootmenü abrufbereit sein und gut isses.

War/ist auch bei mir so - aber als langjähriger Linuxnutzer will ich natürlich ein Grub-Auswahlmenü mit meinen installierten Systemen und nicht den "Umweg" über F12 (damit wird auf meinem Läppi das Bootmenü aufgerufen)

-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Grub einrichten

unter UEFI wird das Grub-Menü nicht per default angezeigt, um es zu bekommen muß folgendes gemacht werden:

die Datei /etc/default/grub mit nem Editor mit Rootrechten öffnen, z.B
Code: [Auswählen]

sudo nano /etc/default/grub

und folgende Zeilen auskommentieren
Code: [Auswählen]

#GRUB_HIDDEN_TIMEOUT=0
#GRUB_HIDDEN_TIMEOUT_QUIET=true


danach ein
Code: [Auswählen]

sudo update-grub


wieter geht es mit
Code: [Auswählen]

BOOT="/boot/efi";NAME="/EFI/Microsoft/Boot/bootmgfw.efi";UUID=$(sudo grub-probe -t fs_uuid "${BOOT}${NAME}");DEV=$(sudo grub-probe -t device "${BOOT}${NAME}"); { echo -e "\n# snip--->\nmenuentry \"Windows UEFI:  bootmgfw.efi $DEV\" {\n    search --fs-uuid --no-floppy --set=root $UUID\n    chainloader (\${root})$NAME\n}\n\n# <--- snip"  ;}

was bei mir dann dieses Ergebniss brachte
Code: [Auswählen]

# snip--->
menuentry "Windows UEFI:  bootmgfw.efi /dev/sda2" {
    search --fs-uuid --no-floppy --set=root 0AEA-ED99
    chainloader (${root})/EFI/Microsoft/Boot/bootmgfw.efi
}

# <--- snip


jetzt die Datei /etc/grub.d/40_custum öffnen mit
Code: [Auswählen]

sudo nano /etc/grub.d/40_custom

und den "snip-Eintrag" reinkopieren, sieht dann so aus
Code: [Auswählen]

#!/bin/sh
exec tail -n +3 $0
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
menuentry "Windows UEFI:  bootmgfw.efi /dev/sda2" {
    search --fs-uuid --no-floppy --set=root 0AEA-ED99
    chainloader (${root})/EFI/Microsoft/Boot/bootmgfw.efi
}

speichern und beenden und nochmal "update-grub" ausführen - danach dann noch "os-prober" ausschalten
Code: [Auswählen]

sudo chmod -x /etc/grub.d/30_os-prober

nochmal
Code: [Auswählen]

sudo update-grub

durchlaufen lassen und rebooten - das wars, beim Neustart erscheint ein sauberes gewohntes Grubmenü wie wir es gewohnt sind.

------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

noch offene Themen sind

- Bootreihenfolge ändern, so das z.B. Windows zuerst startet - sollte machbat sein durch bearbeiten der /boot/boot.efi, hat mich aber bisher noch nicht interessiert

- Multiboot, da ist das Problem, dass das neue Linux den Eintrag aus dem ersten Linux überschreibt und somit Linux1 nicht mehr gestartet werden kann - hab noch keine verwertbare Lösung gefunden, hab mich aber auch noch nicht intensiv darum gekümmert. Ne Idde dazu hab ich, hab es bisher aber noch nicht getestet - kommt noch  ;)

-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Sodele, soweit erst mal - weitere Experimente werden folgen - aber vielleicht kann der Eine oder Andere mit dieser Vorgehensweise schon mal was anfangen.

Grüße

Frieder

p.s. ich hab das auch mit Mint14 Cinnamon probiert => funktioniert => und dann, um in dem Thema etwas "sattelfester" zu werden, das Ganze nochmal mit 12.10 Unity

« Letzte Änderung: 11.07.2013, 22:06:31 von helli »

Jamuna

  • Gast
Re: Boot Probleme mit Windows 8 - Dual Boot mit Linux Mint 15
« Antwort #18 am: 11.07.2013, 23:03:32 »
Zitat
Edit: Windows 8 kann vom USB Stick anscheinend nicht im UEFI Modus installiert werden.. Ich brenne es jetzt auf DVD und versuche es erneut.. Dann melde ich mich nochmal :)

mach das - weil Win8 kann zumindest eines richtig gut -> UEFI

Re: Boot Probleme mit Windows 8 - Dual Boot mit Linux Mint 15
« Antwort #19 am: 12.07.2013, 09:04:37 »
Soo, also langsam geht es voran :)
Habe Windows und Mint jetzt komplett im UEFI Modus neu installiert und siehe da, es klappt.
Windows 8 startet ganz normal und Mint kann ich beim Start mit F10 über den Bios Loader laden.
Allerdings kriege ich Mint nicht in den Windows-eigenen Loader rein, wenn ich es mit EasyBCD versuche, dann kommt beim Booten ein Fehler und er gibt eine Datei mit der Endung .mbr aus. Müsste ja sowieso .efi sein, wenn ich das richtig verstanden habe?
Also, weiß jemand wie ich jetzt noch Mint in den Bootloader kriege? :)

Re: Boot Probleme mit Windows 8 - Dual Boot mit Linux Mint 15
« Antwort #20 am: 12.07.2013, 09:25:18 »
Hast du das schon probiert das helli zitiert hat? Oder bestehst du auf den Windows Bootloader?

Hier nochmal als Link:
https://www.linuxmintusers.de/index.php?action=posthistory;topic=9808.0;msg=89115;edit=16250;popup

Interessant ab diesem Absatz denke ich:
Zitat
Grub einrichten

unter UEFI wird das Grub-Menü nicht per default angezeigt, um es zu bekommen muß folgendes gemacht werden:

die Datei /etc/default/grub mit nem Editor mit Rootrechten öffnen...