Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
28.11.2021, 00:39:47

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 26097
  • Letzte: stan.e.p
Statistiken
  • Beiträge insgesamt: 764930
  • Themen insgesamt: 61375
  • Heute online: 474
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online
Mitglieder: 4
Gäste: 376
Gesamt: 380

Autor Thema:  LM20.2: Nach Update Firefox auf Englisch - trotz anderer Einstellungen.  (Gelesen 999 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Hallo MitMintler !

Wie schon oben erwähnt, ist mein Firefox nach Update nun auf Englisch - obwohl meine Einstellungen, die auch angezeigt werden, anders lauten :

Bildschirmfoto vom 2021 09 25 17 19 34
Bildschirmfoto vom 2021 09 25 17 19 34
[/img]

Was läuft hier falsch ?

Das Thema hatten wir hier erst kürzlich, SuFu mal anwerfen.... ;)

Mir bekannt.
Da ich die kürzlich gelöste Problematik ebenfalls nachvollzogen habe und dementsprechend nachgedoktort habe, stehe ich nun trotzdem wieder vor dem selben Problem.
dpkg -l | grep firefox
ii  firefox                                           92.0.1+linuxmint1+uma                 amd64        Safe and easy web browser from Mozilla
ii  firefox-locale-de                                 92.0.1+linuxmint1+uma                 amd64        German language pack for Firefox
ii  firefox-locale-en                                 92.0.1+linuxmint1+uma                 amd64        English language pack for Firefox

Was ist nun hier falsch gelaufen ?

Hast du mal im Profilordner von Firefox nachgesehen ob sich dort im Ordner extensions eine language.de.xpi oder so ähnlich befindet. Bei mir war das der Fall. Ich habe daraufhin zur Keule gegriffen und Firefox vollständig deinstalliert. Anschließend habe ich den Ordner .mozilla im Homeverzeichnis gelöscht und Firefox neu installiert. Die Einrichtung von Firefox geht bei mir schnell und die Lesezeichen sichere ich regelmäßig. Ich bin gespannt, ob das Problem damit behoben ist. Möglicherweise liegt es bei mir daran, dass ich beim letzten Mal das System im Offline-Modus aufgesetzt habe und dass dabei nicht alle Sprachpakete heruntergeladen wurden. Vorher hatte ich dieses Problem nie.

Völlig egal was ich auch schon versucht habe, ohne Profil, neues Profil, Safe-mode, mehrere Neuinstallationen, mit Synaptic die Begriffe Firefox und Mozilla gänzlich eleminiert,
deutsches Sprachpaket weg und wieder neu - scheissegal, das Drecksteil bleibt englisch.
Könnte mir egal sein, aber der Lappi ist nicht für mich und MUSS einen deutschen Firefox haben !
Das ist in letzter Zeit bei fast jedem FF- Update passiert -  produziert Mozilla nur noch Dreck ?

wie sieht es hier bei dir aus

Hallo,
um die deutsche Beschriftung zurück zubekommen kann man den Fehlerbehebungsmodus ( unter Help) starten. Danach sind wieder die "deutsche Version" präsent. Mit rechter Maustaste im entsprechenden Feld kann die Menüleiste aktiviert werden, falls sie "verschwunden" ist.

Das ist in letzter Zeit bei fast jedem FF- Update passiert -  produziert Mozilla nur noch Dreck ?
Das ist doch völliger Unfug. Wenn es tatsächlich so wäre, hätte man so etwas nicht erst von Dir gehört.
Ich überblicke etwa 10 Linux-Betriebssysteme mit Firefox, alle sind auf Deutsch und daran hat sich in letzter Zeit trotz regelmäßiger Updates nicht geändert. Ich würde mal lieber etwas systematischer vorgehen, anstatt blind und wild herumzubasteln und nach Deinem Fehler suchen, anstatt das ehrwürdige Mozilla-Team zu diffamieren.
Hinweise gab es doch schon, die man anwenden und konkrete Rückmeldungen dazu geben könnte.

thebookkeeper

  • aka AnanasDampf
  • *****
... Da ich die kürzlich gelöste Problematik ebenfalls nachvollzogen habe und dementsprechend nachgedoktort habe, stehe ich nun trotzdem wieder vor dem selben Problem.
dpkg -l | grep firefox
ii  firefox                                           92.0.1+linuxmint1+uma                 amd64        Safe and easy web browser from Mozilla
ii  firefox-locale-de                                 92.0.1+linuxmint1+uma                 amd64        German language pack for Firefox
ii  firefox-locale-en                                 92.0.1+linuxmint1+uma                 amd64        English language pack for Firefox

Was ist nun hier falsch gelaufen ?
Mal oben in Firefox-Adresszeile eingeben:
about:configund danach dort suchen oder evtl. neu-anlegen:
intl.locale.requesteddieser String-Wert muss de sein.

@aexe :
Ich würde NICHT mit Ed Mercer schimpfen, da er sehr wohl RECHT hat! Bei Ubuntu ist dieser sehr lästige "nur englisch" Fehler bereits seit ~16.04 "gang und gebe" ! Noch schlimmer, dort (Ubuntu) wird auch bei jedem Firefox Update die "Standardsuchmaschine"  auf guugel-Spionage (oder yahoo (?), blöder Schädelbasistumor verursacht Kurzzeitgedächtnisprobleme) verbogen!
Also liegt die Vermutung nahe, daß entweder Mozilla selbst, oder Canonical diesen Bockmist verursacht.

Das war MIT ein Grund, warum ich vor kurzem auf meinem neuen PC Ubuntu NICHT mehr installiert habe. Aber siehe da, da Linux Mint auf Ubuntu basiert -> selber Mist. Dann werde ich halt wohl doch mal ein rolling release testen, Manjaro liegt da bis jetzt in meiner Auswahl vorne.

Und dieses "xpi" wird im Ubuntuusers-Forum sogar öfters als Abhilfe erwähnt, wenn's mal wieder nur englisch ist. In "meinem" Profil Ordner ist z.B. auch was mit xpi, es nennt sich langpack-de@firefox.mozilla.org.xpi und hat als Datum den 09.September, aber da war es noch auf deutsch ?

Gruß Rainier
« Letzte Änderung: 26.09.2021, 10:29:43 von Rainier »

@ Rainier
Es geht aber hier doch nicht um Ubuntu, sondern lt. Betreff eindeutig um LinuxMint (das seinen eigenen Firefox liefert)..
Selbstverständlich gibt es in den Foren auch ungeeignete Lösungsvorschläge, das lässt sich nie ausschließen.

@red1900:
Bildschirmfoto vom 2021 09 26 13 10 38
Bildschirmfoto vom 2021 09 26 13 10 38
[/img]
aktuell schaut das so aus.
Aber leider ist der FF auch dann englisch, wenn nur das deutsche Paket vorhanden und "aktiv" ist.

@thebookkeeper:
Bildschirmfoto vom 2021 09 26 13 04 17
Bildschirmfoto vom 2021 09 26 13 04 17
[/img]
Auch hier gilt : egal was ich hier ändere - es bleibt englisch. Auch wenn nur ein deutsches Sprachpaket hier in der config- Ebene zu sehen ist.

Ich habe den Firefox nunmehr auch schon aus mehreren Quellen geholt und installiert(Anwendungsverwaltung, von mozilla direkt, sourceforge).
Immer das gleiche Problem.

@aexe:
geh' bitte woanders spielen oder nimm' die Tabletten wieder !

Warum geht es nicht sachlich und ohne Beleidigungen?
 
intl.locale.requested dieser String-Wert muss de sein.
Glaube ich nicht. Bei mir ist dort gar nichts eingetragen.
Aber (aus einem Debian11 Cinnamon, FF 78.14.0 esr)
installierte Pakete
firefox-esr_78.14.0esr-1~deb11u1_amd64.deb
firefox-esr-l10n-de_78.14.0esr-1~deb11u1_all.deb

Firefox Einstellungen:
« Letzte Änderung: 26.09.2021, 14:47:41 von aexe »

Bang !! Der Spuk ist vorbei, der Firefox "spricht" wieder deutsch !

Der Vorschlag von @uwe steil
Zitat
Hallo,
um die deutsche Beschriftung zurück zubekommen kann man den Fehlerbehebungsmodus ( unter Help) starten. Danach sind wieder die "deutsche Version" präsent. Mit rechter Maustaste im entsprechenden Feld kann die Menüleiste aktiviert werden, falls sie "verschwunden" ist.

So ist der FF nun wieder deutsch. Neu einrichten musste ich ihn jedoch schon, aber was soll's...  :)
Es wurmt mich jedoch schon, nicht zu erfahren, woran GENAU es nun lag...... denn eigentlich habe ich alle mir bekannten Schritte, das Problem zu beseitigen, vorgenommen.
Sprachpakete überprüft, bzw erneuert, persönliche Einstellungen entfernt, mein einziges Plugin(ublock-o.) deaktiviert, und was man so sonst noch probiert. Mehrere Neuinstallationen, sowie das vollständige entfernen der Bergriffe "Firefox" UND "mozilla" aus dem System.

Vielleicht erforschen wir das ja beim nächsten Fall etwas genauer..... hier lasse ich trotz "für mich erledigt" noch mal offen, weil :
nicht gelöst .

Danke allen konstruktiven Teilnehmern - danke uwe !

Gruß,
Ed

Sprachpakete überprüft, bzw erneuert, persönliche Einstellungen entfernt, mein einziges Plugin(ublock-o.) deaktiviert, und was man so sonst noch probiert. Mehrere Neuinstallationen, sowie das vollständige entfernen der Bergriffe "Firefox" UND "mozilla" aus dem System.
Das meinte ich mit
blind und wild herumzubasteln