Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
22.10.2021, 21:39:14

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 26004
  • Letzte: TimtS
Statistiken
  • Beiträge insgesamt: 759152
  • Themen insgesamt: 61000
  • Heute online: 673
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema: [gelöst]  Trotz WLAN Verbindung - Internet verbindung bricht dauern ab  (Gelesen 439 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] Trotz WLAN Verbindung - Internet verbindung bricht dauern ab
« am: 10.09.2021, 10:03:32 »
Moin zusammen,

ich wollte mich mal wieder intensiver mit Linux beschäftigen und habe auf meinem Notebook Mint Linux installiert

Zunächst ein Überblick über das System
inxi -Fz

System:    Kernel: 5.4.0-84-generic x86_64 bits: 64 Desktop: Cinnamon 5.0.5 Distro: Linux Mint 20.2 Uma
Machine:   Type: Laptop System: Hewlett-Packard product: HP 350 G1 v: 0998100000000010000600007 serial: <filter>
           Mobo: Hewlett-Packard model: 21B7 v: KBC Version 46.0B serial: <filter> UEFI: Insyde v: F.13 date: 10/17/2014
Battery:   ID-1: BAT0 charge: 19.6 Wh condition: 27.9/27.9 Wh (100%)
CPU:       Topology: Dual Core model: Intel Core i3-4030U bits: 64 type: MT MCP L2 cache: 3072 KiB
           Speed: 798 MHz min/max: 800/1800 MHz Core speeds (MHz): 1: 798 2: 798 3: 798 4: 798
Graphics:  Device-1: Intel Haswell-ULT Integrated Graphics driver: i915 v: kernel
           Display: x11 server: X.Org 1.20.11 driver: modesetting unloaded: fbdev,vesa resolution: 1366x768~60Hz
           OpenGL: renderer: Mesa DRI Intel HD Graphics 4400 (HSW GT2) v: 4.5 Mesa 21.0.3
Audio:     Device-1: Intel Haswell-ULT HD Audio driver: snd_hda_intel
           Device-2: Intel 8 Series HD Audio driver: snd_hda_intel
           Sound Server: ALSA v: k5.4.0-84-generic
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169
           IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
           Device-2: Ralink RT3290 Wireless 802.11n 1T/1R PCIe driver: rt2800pci
           IF: wlo1 state: up mac: <filter>
Drives:    Local Storage: total: 74.53 GiB used: 19.00 GiB (25.5%)
           ID-1: /dev/sda vendor: Western Digital model: WD800BEVS-22RST0 size: 74.53 GiB
Partition: ID-1: / size: 72.37 GiB used: 18.99 GiB (26.2%) fs: ext4 dev: /dev/sda2
Sensors:   System Temperatures: cpu: 39.0 C mobo: 0.0 C
           Fan Speeds (RPM): N/A
Info:      Processes: 197 Uptime: 50m Memory: 7.69 GiB used: 1.23 GiB (15.9%) Shell: bash inxi: 3.0.38

Mein Problem ist, dass der Rechner zwar eine aktive WLAN Verbindung hat, wobei die Signalstärke Luftlinie 3 m vom Router entfernt mit ca. 50% auch ziemlich zu wünschen übrig lässt, die Internetverbindung aber entweder schon direkt nach dem Anmeldevorgang oder kurz danach unterbrochen wird. Erst nach einem Neustart des Netzwerk Managers bzw. eines aktiven Trennen und Neuverbindens des WLAN Adapters wird für eine kurze Zeit, weniger als 1 Minute, eine Verbindung mit dem Internet möglich. Danach geht das Spiel wieder von vorne los. Ein Problem der Netzwerkeinstellungen (DNS, etc.) schließe ich erst mal aus, weil ja erst alles geht und dann plötzlich nicht mehr. Auch ein Ping direkt an eine IP geht dann nicht mehr raus. Meine erste Recherche hat ergeben, dass der WLAN Chip unter Linux wohl einige Probleme macht. Die Suchergebnisse traten dann aber immer in Verbindung mit einer nicht erkannten WLAN Karte auf und weniger mit dem Verhalten in meinem Fall.

Anbei vielleicht noch zwei relevante Informationen

iwconfig

eno1      no wireless extensions.

wlo1      IEEE 802.11  ESSID:"o2-WLAN94" 
          Mode:Managed  Frequency:2.452 GHz  Access Point: 04:BF:6D:AB:B2:F2   
          Bit Rate=72.2 Mb/s   Tx-Power=20 dBm   
          Retry short  long limit:2   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=44/70  Signal level=-66 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:5  Invalid misc:5   Missed beacon:0

lo        no wireless extensions.

rfkill list

0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no

Aktuell bin ich mit dem Rechner über Kabel verbunden und habe absolut keine Probleme. Vielleicht hat ja jemand eine Idee, wie ich das Problem lösen kann.

Schöne Grüße
« Letzte Änderung: 16.09.2021, 09:29:10 von BPHH85 »

Re: Trotz WLAN Verbindung - Internet verbindung bricht dauern ab
« Antwort #1 am: 10.09.2021, 13:55:28 »
Hi :)
um zu testen mal temporär powermanagement abschalten... mit iwconfig kontrollieren

sudo iwconfig wlo1 power off
die mehrfach vorhandenen wlan schnittstellen wundern mich..
standardmässig wäre die wlp2s0

Re: Trotz WLAN Verbindung - Internet verbindung bricht dauern ab
« Antwort #2 am: 10.09.2021, 14:22:32 »
Moin,

danke für deine Rückmeldung :-) ich hatte tatsächlich auch schon an so etwas wie das Energiemanagement gedacht, wusste aber nicht an welcher Stellschraube ich da drehen kann. Allerdings tritt das Problem auch im Netzbetrieb auf. Ich werde beobachten, ob sich das Problem dadurch lösen lässt und melde mich dann noch mal wieder.

Schöne Grüße

Re: Trotz WLAN Verbindung - Internet verbindung bricht dauern ab
« Antwort #3 am: 10.09.2021, 15:37:56 »
Ehtron meint hier das Powermanagement der WLAN-Karte, nicht das Netzkabel des Laptops.

Re: Trotz WLAN Verbindung - Internet verbindung bricht dauern ab
« Antwort #4 am: 10.09.2021, 15:47:28 »
So, seit meinem letzten Posting ist das Problem tatsächlich nicht mehr aufgetreten :-) Weder im Akku- noch im Netzbetrieb. Allerdings hatte ich zwischenzeitlich keinen Neustart des Rechners. Wo wäre jetzt die geeignete Stelle, damit die Anweisung auch direkt beim Booten ausgeführt wird?

Schöne Grüße

Re: Trotz WLAN Verbindung - Internet verbindung bricht dauern ab
« Antwort #5 am: 10.09.2021, 15:51:16 »
Ehtron meint hier das Powermanagement der WLAN-Karte, nicht das Netzkabel des Laptops.
Danke für den Hinweis. Mir war schon klar, dass er das Powermanagement des WLAN Adapters im Spziellen meinte. Ich ging nur davon aus, dass es an das globe Powermanagement des ganzen Notebooks gekoppelt ist und sich das Profil an der Stelle unterscheiden könnte im Fall von Akku- bzw. Netzbetrieb.

Re: Trotz WLAN Verbindung - Internet verbindung bricht dauern ab
« Antwort #6 am: 10.09.2021, 15:54:49 »
Hi .)
dauerhaft
sudo sed -i "s/wifi.powersave = 3/wifi.powersave = 2/g" /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf
wiederum mit iwconfig nach boot zu kontrollieren

normalerweise wird powersave im accu betrieb aktiviert und ist im netzbetrieb ausgeschaltet.

Re: Trotz WLAN Verbindung - Internet verbindung bricht dauern ab
« Antwort #7 am: 15.09.2021, 11:45:22 »
Hi .)
dauerhaft
sudo sed -i "s/wifi.powersave = 3/wifi.powersave = 2/g" /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf
wiederum mit iwconfig nach boot zu kontrollieren

normalerweise wird powersave im accu betrieb aktiviert und ist im netzbetrieb ausgeschaltet.

Wunderbar, das scheint alles reibungslos geklappt zu haben. Zumindest ist das Problem damit gelöst. Besten Dank :-)

Re: Trotz WLAN Verbindung - Internet verbindung bricht dauern ab
« Antwort #8 am: 15.09.2021, 11:47:22 »
Hi :)
bitte richtig auf gelöst setzen.. siehe hilfe oben... danke :)