Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
28.11.2021, 00:16:16

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 26097
  • Letzte: stan.e.p
Statistiken
  • Beiträge insgesamt: 764933
  • Themen insgesamt: 61375
  • Heute online: 474
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online
Mitglieder: 8
Gäste: 403
Gesamt: 411

Autor Thema: [gelöst]  Netzwerk plötzlich ohne Funktion  (Gelesen 1422 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] Re: Netzwerk plötzlich ohne Funktion
« Antwort #30 am: 17.09.2021, 09:21:29 »
Die Konfigurationsdateien sind soweit alle in Ordnung, erneut abzufragen bringt nichts.
Zus. noch schauen, ob die /etc/network/interfaces.d leer ist
cat /etc/network/interfaces.dOhne WLAN testen:
nmcli con up id "ethernet"

Re: Netzwerk plötzlich ohne Funktion
« Antwort #31 am: 17.09.2021, 09:41:04 »
Off-Topic:
/etc/network/interfaces.d: Ist ein Verzeichnis.
Deshalb besser: ls /etc/network/interfaces.d

Re: Netzwerk plötzlich ohne Funktion
« Antwort #32 am: 17.09.2021, 09:43:55 »
Danke, aber leider nichts neues:
root@darkwing-pc:~# cat /etc/network/interfaces.d
cat: /etc/network/interfaces.d: Ist ein Verzeichnis
root@darkwing-pc:~# nmcli con up id "ethernet"
Fehler: Aktivierung der Verbindung ist gescheitert: No suitable device found for this connection (device wlx00e02d6b1144 not available because device is not available).
WLAN war aus!
Mit abgezogenem Stick:
root@darkwing-pc:~# nmcli con up id "ethernet"
Fehler: Aktivierung der Verbindung ist gescheitert: No suitable device found for this connection (device lo not available because device is strictly unmanaged).
root@darkwing-pc:~#

Nachtrag:
root@darkwing-pc:~# ls -l /etc/network/interfaces.d
insgesamt 0

Re: Netzwerk plötzlich ohne Funktion
« Antwort #33 am: 17.09.2021, 10:27:46 »
Dann trage doch mal alles in das Verbindungsprofil ein.
 * Gerät: enp0s31f6
 * Verbindungsaushandlung und MTU: Automatisch
Rest ausgegraut lassen.
Unter "Allgemein" noch
 * "Automatisch mit Priorität verbinden"
 * Wert: -999
« Letzte Änderung: 17.09.2021, 10:34:44 von Flash63 »

Re: Netzwerk plötzlich ohne Funktion
« Antwort #34 am: 17.09.2021, 10:51:26 »
Alles eingetragen und gespeichert. Leider immer noch ohne Erfolg.
Im Panel sieht man nicht mal Ethernet
darkwing@darkwing-pc ~ $ nmcli con up id "ethernet"
Fehler: Aktivierung der Verbindung ist gescheitert: No suitable device found for this connection (device lo not available because device is strictly unmanaged).
darkwing@darkwing-pc ~ $ sudo nmcli con up id "ethernet"
[sudo] Passwort für darkwing:     
Fehler: Aktivierung der Verbindung ist gescheitert: No suitable device found for this connection (device lo not available because device is strictly unmanaged).
darkwing@darkwing-pc ~ $ sudo systemctl restart net
netplan-ovs-cleanup.service  networking.service           network-manager.service      network-online.target
darkwing@darkwing-pc ~ $ sudo systemctl restart networking.service
darkwing@darkwing-pc ~ $ sudo nmcli con up id "ethernet"
Fehler: Aktivierung der Verbindung ist gescheitert: No suitable device found for this connection (device lo not available because device is strictly unmanaged).

Re: Netzwerk plötzlich ohne Funktion
« Antwort #35 am: 17.09.2021, 11:10:13 »
Was zeigt denn aktuell:
nmcli connection
nmcli -f NAME,TYPE,AUTOCONNECT,ACTIVE,DEVICE con
ifconfig -a
lspci -nnk | grep -i net -A2

Re: Netzwerk plötzlich ohne Funktion
« Antwort #36 am: 17.09.2021, 11:22:54 »
darkwing@darkwing-pc ~ $ nmcli connection
NAME                  UUID                                  TYPE      DEVICE         
Automatisch MCP_WLAN  77ee32f3-7770-46b5-a445-8a995808b31e  wifi      wlx00e02d6b1144
ethernet              80f53be3-e781-40dd-8c8e-09c5040058aa  ethernet  --             

darkwing@darkwing-pc ~ $ nmcli -f NAME,TYPE,AUTOCONNECT,ACTIVE,DEVICE con
NAME                  TYPE      AUTOCONNECT  ACTIVE  DEVICE         
Automatisch MCP_WLAN  wifi      ja           ja      wlx00e02d6b1144
ethernet              ethernet  ja           nein    --             

darkwing@darkwing-pc ~ $ ifconfig -a
enp0s31f6: flags=4098<BROADCAST,MULTICAST>  mtu 1500
        ether 38:d5:47:78:62:02  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 16  memory 0xf7100000-f7120000 

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Lokale Schleife)
        RX packets 41754  bytes 2809656 (2.8 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 41754  bytes 2809656 (2.8 MB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlx00e02d6b1144: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.178.34  netmask 255.255.255.0  broadcast 192.168.178.255
        inet6 fe80::538a:c094:898e:cb10  prefixlen 64  scopeid 0x20<link>
        ether 00:e0:2d:6b:11:44  txqueuelen 1000  (Ethernet)
        RX packets 198201  bytes 186680914 (186.6 MB)
        RX errors 0  dropped 3354  overruns 0  frame 0
        TX packets 156980  bytes 23947995 (23.9 MB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

darkwing@darkwing-pc ~ $ lspci -nnk | grep -i net -A2
00:1f.6 Ethernet controller [0200]: Intel Corporation Ethernet Connection (2) I219-V [8086:15b8] (rev 31)
Subsystem: ASUSTeK Computer Inc. Ethernet Connection (2) I219-V [1043:8672]
Kernel driver in use: e1000e
Kernel modules: e1000e

Nachtrag:
Nächste Woche probier ich dann mal eine Logilink PCIe-Netzwerkkarte einzubauen. Mal sehen ob die erkannt wird.
« Letzte Änderung: 17.09.2021, 11:31:00 von MegaV0lt »

Re: Netzwerk plötzlich ohne Funktion
« Antwort #37 am: 17.09.2021, 12:25:37 »
Kontrolliere, ob Du im Verbindungsprofil wirklich das Interface enp0s31f6 eingetragen hast:
Zitat
NAME                            UUID                                                                   TYPE         DEVICE         
Automatisch MCP_WLAN  77ee32f3-7770-46b5-a445-8a995808b31e  wifi             wlx00e02d6b1144
ethernet                              80f53be3-e781-40dd-8c8e-09c5040058aa  ethernet    --             
Es fehlt bei "Device". An der Hardware liegt es nicht, mit Live-System funktioniert es ja.
« Letzte Änderung: 17.09.2021, 12:30:55 von Flash63 »

Re: Netzwerk plötzlich ohne Funktion
« Antwort #38 am: 17.09.2021, 13:22:44 »
Ist eingetragen. Hab das gesehen und gleich überprüft. Ich bin nicht mehr zu hause und schau mir das Montag noch mal an. Teste dann auch mit einer Einsteckkarte. Mal sehen, was dann passiert.

Schon komisch, dass gerade das LAN, das ja nie Probleme macht nach nem Neustart plötzlich nicht mehr geht.

Re: Netzwerk plötzlich ohne Funktion
« Antwort #39 am: 20.09.2021, 11:31:35 »
Kontrolliere, ob Du im Verbindungsprofil wirklich das Interface enp0s31f6 eingetragen hast:

Re: Netzwerk plötzlich ohne Funktion
« Antwort #40 am: 20.09.2021, 11:47:50 »
Hab jetzt die LogiLink Netzwerkkarte drin und auch die wird nicht verwendet.
darkwing@darkwing-pc ~ $ nmcli
wlx00e02d6b1144: verbunden zu Automatisch MCP_WLAN
        "Ralink MT7601U"
        wifi (mt7601u), 00:E0:2D:6B:11:44, hw, mtu 1500
        ip4-Vorgabe
        inet4 192.168.178.34/24
        route4 0.0.0.0/0
        route4 192.168.178.0/24
        route4 169.254.0.0/16
        inet6 fe80::538a:c094:898e:cb10/64
        route6 fe80::/64

enp0s31f6: nicht verwaltet
        "Intel Ethernet"
        ethernet (e1000e), 38:D5:47:78:62:02, hw, mtu 1500

enp2s0: nicht verwaltet
        "Realtek RTL8111/8168/8411"
        ethernet (r8169), 00:E0:4C:68:57:10, hw, mtu 1500

lo: nicht verwaltet
        "lo"
        loopback (unknown), 00:00:00:00:00:00, sw, mtu 65536

DNS configuration:
        servers: 192.168.178.1
        domains: fritz.box
        interface: wlx00e02d6b1144

Rufen Sie »nmcli device show« auf, um vollständige Informationen über bekannte Geräte abzurufen
und »nmcli connection show« für eine Übersicht über aktive Verbindungsprofile.


Das wäre dann die enp2s0 mir angeschlossenen Kabel...

Was ist da bloß faul?

Re: Netzwerk plötzlich ohne Funktion
« Antwort #41 am: 20.09.2021, 13:15:05 »
Zitat
Was ist da bloß faul?
Ich weiß es nicht., alle Konfigurationsdateien sind soweit ok.
Letzter Versuch:
sudo touch /etc/NetworkManager/conf.d/10-globally-managed-devices.conf
sudo systemctl restart network-manager.service
nmcli -d
Ansonsten - Datensicherung - Neuinstallation ist schneller erledigt als jetzt noch tagelang Fehler zu suchen.

Re: Netzwerk plötzlich ohne Funktion
« Antwort #42 am: 20.09.2021, 13:25:17 »
In der Tat! Ich hab das auch gerade gefunden im Ubuntu-Wiki. Und siehe da, es geht!

Warum aber ist es überhaupt ausgefallen?

darkwing@darkwing-pc ~ $ nmcli
enp2s0: verbunden zu Kabelgebundene Verbindung 1
        "Realtek RTL8111/8168/8411"
        ethernet (r8169), 00:E0:4C:68:57:10, hw, mtu 1500
        ip4-Vorgabe
        inet4 192.168.178.20/24
        route4 0.0.0.0/0
        route4 192.168.178.0/24
        inet6 fe80::83dc:443d:93ee:67a1/64
        route6 fe80::/64

enp0s31f6: nicht verfügbar
        "Intel Ethernet"
        ethernet (e1000e), 38:D5:47:78:62:02, hw, mtu 1500

lo: nicht verwaltet
        "lo"
        loopback (unknown), 00:00:00:00:00:00, sw, mtu 65536

DNS configuration:
        servers: 192.168.178.1
        domains: fritz.box
        interface: enp2s0

Rufen Sie »nmcli device show« auf, um vollständige Informationen über bekannte Geräte abzurufen
und »nmcli connection show« für eine Übersicht über aktive Verbindungsprofile.


Die Hilfeseiten nmcli(1) und nmcli-examples(7) geben vollständige Aufrufbeschreibungen.
« Letzte Änderung: 20.09.2021, 13:28:37 von MegaV0lt »

Re: Netzwerk plötzlich ohne Funktion
« Antwort #43 am: 20.09.2021, 13:28:20 »
Verm. ein sehr selten auftretender Bug, mehr weiß ich dazu nicht.