Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
21.10.2021, 07:03:32

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 26000
  • Letzte: Rhys
Statistiken
  • Beiträge insgesamt: 758822
  • Themen insgesamt: 60981
  • Heute online: 464
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online
Mitglieder: 7
Gäste: 351
Gesamt: 358

Autor Thema: [erledigt] Webcam funktioniert nicht bei Skype  (Gelesen 1003 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[erledigt] Webcam funktioniert nicht bei Skype
« am: 05.09.2021, 12:05:40 »
Hallo zusammen,

ich wende mich an euch, weil ich langsam echt nicht weiter weiß. Ich habe mich zwar schon ein bisschen mit Linux beschäftigt, aber dieses Problem bekomme ich einfach nicht gelöst.

Meine Webcam (Logitech Quickcam Communicate STX) funktioniert bei guvcview, aber nicht bei cheese und auch nicht auf Skype.

Ich habe schon einige Hilfestellungen im Internet dazu gefunden, aber gar nichts funktioniert.

Das mit dem Preload von v4l1 scheint einen Versuch Wert zu sein, aber ich weiß einfach nicht, wie ich das einrichten kann für Skype. Es klappt einfach nicht.

Ich bin für jede Hilfe sehr dankbar.

« Letzte Änderung: 08.09.2021, 17:56:45 von MintBenutzer10098 »

Re: Webcam funktioniert nicht bei Skype
« Antwort #1 am: 05.09.2021, 12:39:47 »
Hallo, und herzlich willkommen bei LinuxMintUsers :)

Grundsätzlich ist es immer hilfreich, die genaue Linux Mint Version anzugeben.
Für die Standardfunktionen einer Cam ist guvcview eigentlich nicht notwendig.

Gib bitte mal im Terminal  usb-devicesein und poste das Ergebnis im Codeblock.

Re: Webcam funktioniert nicht bei Skype
« Antwort #2 am: 05.09.2021, 13:09:28 »
Hallo,

vielen Dank für die rasche Rückmeldung. Ich nutze Linux Mint 20.2. Alle Aktualisierungen sind installiert.

T:  Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=480 MxCh= 3
D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=1d6b ProdID=0002 Rev=05.04
S:  Manufacturer=Linux 5.4.0-81-generic ehci_hcd
S:  Product=EHCI Host Controller
S:  SerialNumber=0000:00:1a.0
C:  #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
I:  If#=0x0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub

T:  Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  2 Spd=480 MxCh= 6
D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=01 MxPS=64 #Cfgs=  1
P:  Vendor=8087 ProdID=8008 Rev=00.05
C:  #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
I:  If#=0x0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub

T:  Bus=02 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=480 MxCh= 3
D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=1d6b ProdID=0002 Rev=05.04
S:  Manufacturer=Linux 5.4.0-81-generic ehci_hcd
S:  Product=EHCI Host Controller
S:  SerialNumber=0000:00:1d.0
C:  #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
I:  If#=0x0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub

T:  Bus=02 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  2 Spd=480 MxCh= 8
D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=01 MxPS=64 #Cfgs=  1
P:  Vendor=8087 ProdID=8000 Rev=00.05
C:  #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
I:  If#=0x0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub

T:  Bus=03 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=480 MxCh=15
D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=01 MxPS=64 #Cfgs=  1
P:  Vendor=1d6b ProdID=0002 Rev=05.04
S:  Manufacturer=Linux 5.4.0-81-generic xhci-hcd
S:  Product=xHCI Host Controller
S:  SerialNumber=0000:00:14.0
C:  #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
I:  If#=0x0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub

T:  Bus=03 Lev=01 Prnt=01 Port=10 Cnt=01 Dev#=  3 Spd=480 MxCh= 0
D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=04a9 ProdID=185c Rev=01.04
S:  Manufacturer=Canon
S:  Product=TS9500 series
S:  SerialNumber=110452
C:  #Ifs= 5 Cfg#= 1 Atr=c0 MxPwr=2mA
I:  If#=0x0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=00 Prot=ff Driver=(none)
I:  If#=0x1 Alt= 0 #EPs= 2 Cls=07(print) Sub=01 Prot=02 Driver=usblp
I:  If#=0x2 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
I:  If#=0x3 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
I:  If#=0x4 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)

T:  Bus=03 Lev=01 Prnt=01 Port=11 Cnt=02 Dev#=  4 Spd=1.5 MxCh= 0
D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
P:  Vendor=046d ProdID=c05a Rev=63.00
S:  Manufacturer=Logitech
S:  Product=USB Optical Mouse
C:  #Ifs= 1 Cfg#= 1 Atr=a0 MxPwr=100mA
I:  If#=0x0 Alt= 0 #EPs= 1 Cls=03(HID  ) Sub=01 Prot=02 Driver=usbhid

T:  Bus=03 Lev=01 Prnt=01 Port=04 Cnt=03 Dev#=  2 Spd=12  MxCh= 0
D:  Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
P:  Vendor=046d ProdID=08ad Rev=01.00
C:  #Ifs= 3 Cfg#= 1 Atr=a0 MxPwr=100mA
I:  If#=0x0 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=gspca_zc3xx
I:  If#=0x1 Alt= 0 #EPs= 0 Cls=01(audio) Sub=01 Prot=00 Driver=snd-usb-audio
I:  If#=0x2 Alt= 0 #EPs= 0 Cls=01(audio) Sub=02 Prot=00 Driver=snd-usb-audio

T:  Bus=04 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=5000 MxCh= 6
D:  Ver= 3.00 Cls=09(hub  ) Sub=00 Prot=03 MxPS= 9 #Cfgs=  1
P:  Vendor=1d6b ProdID=0003 Rev=05.04
S:  Manufacturer=Linux 5.4.0-81-generic xhci-hcd
S:  Product=xHCI Host Controller
S:  SerialNumber=0000:00:14.0
C:  #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
I:  If#=0x0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub

Re: Webcam funktioniert nicht bei Skype
« Antwort #3 am: 05.09.2021, 13:42:36 »
Soweit ich das überblicke, wird deine Cam hier nicht angezeigt.
Das wundert mich ein wenig, weil sie ja via guvcview funktioniert, wie du schreibst.
Die Cam war doch bei der Terminalabfrage angeschlossen, oder?

Hast du es schon Mal mit einem anderen USB-Anschluss versucht?
Am besten direkt, ohne Umweg über eine Hub oder ein USB-Kabel.

Re: Webcam funktioniert nicht bei Skype
« Antwort #4 am: 05.09.2021, 13:52:13 »
Ja, bei der Abfrage war sie bereits angeschlossen. Ich habe sie jetzt an einen anderen Port angeschlossen.

Im Anhang ist einmal gucview zu finden, dass die Webcam erkennt und ein Foto von Skype, welches die Webcam auch erkennt. Gucview funktioniert alles super und bei Skype ist ein schwarzes Bild.

T:  Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=480 MxCh= 3
D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=1d6b ProdID=0002 Rev=05.04
S:  Manufacturer=Linux 5.4.0-81-generic ehci_hcd
S:  Product=EHCI Host Controller
S:  SerialNumber=0000:00:1a.0
C:  #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
I:  If#=0x0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub

T:  Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  2 Spd=480 MxCh= 6
D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=01 MxPS=64 #Cfgs=  1
P:  Vendor=8087 ProdID=8008 Rev=00.05
C:  #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
I:  If#=0x0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub

T:  Bus=02 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=480 MxCh= 3
D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=1d6b ProdID=0002 Rev=05.04
S:  Manufacturer=Linux 5.4.0-81-generic ehci_hcd
S:  Product=EHCI Host Controller
S:  SerialNumber=0000:00:1d.0
C:  #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
I:  If#=0x0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub

T:  Bus=02 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  2 Spd=480 MxCh= 8
D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=01 MxPS=64 #Cfgs=  1
P:  Vendor=8087 ProdID=8000 Rev=00.05
C:  #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
I:  If#=0x0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub

T:  Bus=03 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=480 MxCh=15
D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=01 MxPS=64 #Cfgs=  1
P:  Vendor=1d6b ProdID=0002 Rev=05.04
S:  Manufacturer=Linux 5.4.0-81-generic xhci-hcd
S:  Product=xHCI Host Controller
S:  SerialNumber=0000:00:14.0
C:  #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
I:  If#=0x0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub

T:  Bus=03 Lev=01 Prnt=01 Port=10 Cnt=01 Dev#=  3 Spd=480 MxCh= 0
D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=04a9 ProdID=185c Rev=01.04
S:  Manufacturer=Canon
S:  Product=TS9500 series
S:  SerialNumber=110452
C:  #Ifs= 5 Cfg#= 1 Atr=c0 MxPwr=2mA
I:  If#=0x0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=00 Prot=ff Driver=(none)
I:  If#=0x1 Alt= 0 #EPs= 2 Cls=07(print) Sub=01 Prot=02 Driver=usblp
I:  If#=0x2 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
I:  If#=0x3 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
I:  If#=0x4 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)

T:  Bus=03 Lev=01 Prnt=01 Port=11 Cnt=02 Dev#=  4 Spd=1.5 MxCh= 0
D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
P:  Vendor=046d ProdID=c05a Rev=63.00
S:  Manufacturer=Logitech
S:  Product=USB Optical Mouse
C:  #Ifs= 1 Cfg#= 1 Atr=a0 MxPwr=100mA
I:  If#=0x0 Alt= 0 #EPs= 1 Cls=03(HID  ) Sub=01 Prot=02 Driver=usbhid

T:  Bus=03 Lev=01 Prnt=01 Port=05 Cnt=03 Dev#=  5 Spd=12  MxCh= 0
D:  Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
P:  Vendor=046d ProdID=08ad Rev=01.00
C:  #Ifs= 3 Cfg#= 1 Atr=a0 MxPwr=100mA
I:  If#=0x0 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=gspca_zc3xx
I:  If#=0x1 Alt= 0 #EPs= 0 Cls=01(audio) Sub=01 Prot=00 Driver=snd-usb-audio
I:  If#=0x2 Alt= 0 #EPs= 0 Cls=01(audio) Sub=02 Prot=00 Driver=snd-usb-audio

T:  Bus=04 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=5000 MxCh= 6
D:  Ver= 3.00 Cls=09(hub  ) Sub=00 Prot=03 MxPS= 9 #Cfgs=  1
P:  Vendor=1d6b ProdID=0003 Rev=05.04
S:  Manufacturer=Linux 5.4.0-81-generic xhci-hcd
S:  Product=xHCI Host Controller
S:  SerialNumber=0000:00:14.0
C:  #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
I:  If#=0x0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub

Re: Webcam funktioniert nicht bei Skype
« Antwort #5 am: 05.09.2021, 18:31:01 »
Hallo,
Ist libv4l installiert?
dpkg -l libv4l* | grep iiPfad zu Skype?
which skypeAufruf dann entsprechend probieren:
LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so <Pfad zu Skype>

Re: Webcam funktioniert nicht bei Skype
« Antwort #6 am: 05.09.2021, 18:57:38 »
Auch dir vielen Dank für die Hilfe :) Hat aber leider nicht geklappt:

sudo dpkg -l libv4l* | grep ii
[sudo] Passwort für ///---///   
ii  libv4l-0:amd64       1.18.0-2build1 amd64        Collection of video4linux support libraries
ii  libv4l2rds0:amd64    1.18.0-2build1 amd64        Video4Linux Radio Data System (RDS) decoding library
ii  libv4lconvert0:amd64 1.18.0-2build1 amd64        Video4linux frame format conversion library

sudo which skypeforlinux
/usr/bin/skypeforlinux

LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so /usr/bin/skypeforlinux
ERROR: ld.so: object '/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.

Re: Webcam funktioniert nicht bei Skype
« Antwort #7 am: 05.09.2021, 19:15:29 »
libv4l ist noch unvollständig. Nachinstallieren und erneut versuchen:
sudo apt install libv4l-0:i386 libv4lconvert0:i386
# Bibliothek/shared objekt nun vorhanden?
ls -l /usr/lib/i386-linux-gnu/libv4l
« Letzte Änderung: 05.09.2021, 19:20:05 von Flash63 »

Re: Webcam funktioniert nicht bei Skype
« Antwort #8 am: 05.09.2021, 19:54:30 »
Hat leider auch nicht funktioniert  :-X

sudo apt install libv4l-0:i386 libv4lconvert0:i386
[sudo] Passwort für ---///---:     
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Die folgenden zusätzlichen Pakete werden installiert:
  gcc-10-base:i386 libc6:i386 libcrypt1:i386 libgcc-s1:i386 libidn2-0:i386
  libjpeg-turbo8:i386 libjpeg8:i386 libunistring2:i386
Vorgeschlagene Pakete:
  glibc-doc:i386 locales:i386
Die folgenden NEUEN Pakete werden installiert:
  gcc-10-base:i386 libc6:i386 libcrypt1:i386 libgcc-s1:i386 libidn2-0:i386
  libjpeg-turbo8:i386 libjpeg8:i386 libunistring2:i386 libv4l-0:i386
  libv4lconvert0:i386
0 aktualisiert, 10 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
Es müssen 3.410 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 16,4 MB Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren? [J/n] j
Holen:1 http://archive.ubuntu.com/ubuntu focal-updates/main i386 gcc-10-base i386 10.3.0-1ubuntu1~20.04 [20,2 kB]
Holen:2 http://archive.ubuntu.com/ubuntu focal-updates/main i386 libgcc-s1 i386 10.3.0-1ubuntu1~20.04 [49,4 kB]
Holen:3 http://archive.ubuntu.com/ubuntu focal/main i386 libcrypt1 i386 1:4.4.10-10ubuntu4 [90,9 kB]
Holen:4 http://archive.ubuntu.com/ubuntu focal-updates/main i386 libc6 i386 2.31-0ubuntu9.2 [2.572 kB]
Holen:5 http://archive.ubuntu.com/ubuntu focal/main i386 libunistring2 i386 0.9.10-2 [377 kB]
Holen:6 http://archive.ubuntu.com/ubuntu focal/main i386 libidn2-0 i386 2.2.0-2 [51,4 kB]
Holen:7 http://archive.ubuntu.com/ubuntu focal-updates/main i386 libjpeg-turbo8 i386 2.0.3-0ubuntu1.20.04.1 [127 kB]
Holen:8 http://archive.ubuntu.com/ubuntu focal/main i386 libjpeg8 i386 8c-2ubuntu8 [2.188 B]
Holen:9 http://archive.ubuntu.com/ubuntu focal/main i386 libv4lconvert0 i386 1.18.0-2build1 [77,8 kB]
Holen:10 http://archive.ubuntu.com/ubuntu focal/main i386 libv4l-0 i386 1.18.0-2build1 [42,6 kB]
Es wurden 3.410 kB in 6 s geholt (612 kB/s).
Vorkonfiguration der Pakete ...
Vormals nicht ausgewähltes Paket gcc-10-base:i386 wird gewählt.
(Lese Datenbank ... 326462 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../0-gcc-10-base_10.3.0-1ubuntu1~20.04_i386.deb
...
Entpacken von gcc-10-base:i386 (10.3.0-1ubuntu1~20.04) ...
Vormals nicht ausgewähltes Paket libgcc-s1:i386 wird gewählt.
Vorbereitung zum Entpacken von .../1-libgcc-s1_10.3.0-1ubuntu1~20.04_i386.deb ..
.
Entpacken von libgcc-s1:i386 (10.3.0-1ubuntu1~20.04) ...
Vormals nicht ausgewähltes Paket libcrypt1:i386 wird gewählt.
Vorbereitung zum Entpacken von .../2-libcrypt1_1%3a4.4.10-10ubuntu4_i386.deb ...
Entpacken von libcrypt1:i386 (1:4.4.10-10ubuntu4) ...
Vormals nicht ausgewähltes Paket libc6:i386 wird gewählt.
Vorbereitung zum Entpacken von .../3-libc6_2.31-0ubuntu9.2_i386.deb ...
Entpacken von libc6:i386 (2.31-0ubuntu9.2) ...
Vormals nicht ausgewähltes Paket libunistring2:i386 wird gewählt.
Vorbereitung zum Entpacken von .../4-libunistring2_0.9.10-2_i386.deb ...
Entpacken von libunistring2:i386 (0.9.10-2) ...
Vormals nicht ausgewähltes Paket libidn2-0:i386 wird gewählt.
Vorbereitung zum Entpacken von .../5-libidn2-0_2.2.0-2_i386.deb ...
Entpacken von libidn2-0:i386 (2.2.0-2) ...
Vormals nicht ausgewähltes Paket libjpeg-turbo8:i386 wird gewählt.
Vorbereitung zum Entpacken von .../6-libjpeg-turbo8_2.0.3-0ubuntu1.20.04.1_i386.
deb ...
Entpacken von libjpeg-turbo8:i386 (2.0.3-0ubuntu1.20.04.1) ...
Vormals nicht ausgewähltes Paket libjpeg8:i386 wird gewählt.
Vorbereitung zum Entpacken von .../7-libjpeg8_8c-2ubuntu8_i386.deb ...
Entpacken von libjpeg8:i386 (8c-2ubuntu8) ...
Vormals nicht ausgewähltes Paket libv4lconvert0:i386 wird gewählt.
Vorbereitung zum Entpacken von .../8-libv4lconvert0_1.18.0-2build1_i386.deb ...
Entpacken von libv4lconvert0:i386 (1.18.0-2build1) ...
Vormals nicht ausgewähltes Paket libv4l-0:i386 wird gewählt.
Vorbereitung zum Entpacken von .../9-libv4l-0_1.18.0-2build1_i386.deb ...
Entpacken von libv4l-0:i386 (1.18.0-2build1) ...
gcc-10-base:i386 (10.3.0-1ubuntu1~20.04) wird eingerichtet ...
libcrypt1:i386 (1:4.4.10-10ubuntu4) wird eingerichtet ...
libgcc-s1:i386 (10.3.0-1ubuntu1~20.04) wird eingerichtet ...
libc6:i386 (2.31-0ubuntu9.2) wird eingerichtet ...
libunistring2:i386 (0.9.10-2) wird eingerichtet ...
libidn2-0:i386 (2.2.0-2) wird eingerichtet ...
libjpeg-turbo8:i386 (2.0.3-0ubuntu1.20.04.1) wird eingerichtet ...
libjpeg8:i386 (8c-2ubuntu8) wird eingerichtet ...
libv4lconvert0:i386 (1.18.0-2build1) wird eingerichtet ...
libv4l-0:i386 (1.18.0-2build1) wird eingerichtet ...
Trigger für libc-bin (2.31-0ubuntu9.2) werden verarbeitet ...


ls -l /usr/lib/i386-linux-gnu/libv4l
insgesamt 36
drwxr-xr-x 2 root root  4096 Sep  5 19:50 plugins
-rw-r--r-- 1 root root 13516 Mär 24  2020 v4l1compat.so
-rw-r--r-- 1 root root 13672 Mär 24  2020 v4l2convert.so

LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so /usr/bin/skypeforlinux
ERROR: ld.so: object '/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: ld.so: object '/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: ld.so: object '/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: ld.so: object '/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: ld.so: object '/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.




Re: Webcam funktioniert nicht bei Skype
« Antwort #9 am: 05.09.2021, 20:05:30 »
Nein, leider nicht, scheint eine Inkompatibilität bei dieser Kamera zu sein.

Wurde auch schon an anderer Stelle behandelt (ohne Ergebnis) - https://forum.ubuntuusers.de/topic/logitech-cam-046d-08da-laeuft-nicht-im-skype/

Frage mal erneut ab
lsusb
ls /dev/* | grep video
Steht unter Skype nur diese Kamera zur Auswahl, oder noch weitere?
« Letzte Änderung: 05.09.2021, 20:28:12 von Flash63 »

Re: Webcam funktioniert nicht bei Skype
« Antwort #10 am: 05.09.2021, 21:15:37 »
Mir wird nur diese eine Webcam angezeigt... Heißt das, dass man's aufgeben kann? Bei welchen Webcams kann ich mir denn sicher sein, dass sie auf Linux Mint funktionieren werden? Gibt es da ein Merkmal worauf ich achten kann?

lsusb
Bus 002 Device 002: ID 8087:8000 Intel Corp.
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:8008 Intel Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 002: ID 046d:08ad Logitech, Inc. QuickCam Communicate STX
Bus 003 Device 004: ID 046d:c05a Logitech, Inc. M90/M100 Optical Mouse
Bus 003 Device 003: ID 04a9:185c Canon, Inc. TS9500 series
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

ls /dev/* | grep video
/dev/video0

Re: Webcam funktioniert nicht bei Skype
« Antwort #11 am: 05.09.2021, 21:20:53 »
Zitat
Heißt das, dass man's aufgeben kann
Hier kann ich zumindest nicht mehr weiterhelfen. In dem verlinkten Beitrag wurde auf alternative Messenger und Fehlerreport an Skype hingewiesen.
Zitat
Bei welchen Webcams kann ich mir denn sicher sein, dass sie auf Linux Mint funktionieren werden?
Dabei kann ich dir leider nicht konkret weiterhelfen. Ich habe nur eine Web-Cam im Laptop fest eingebaut, welche problemlos funktioniert.

Re: Webcam funktioniert nicht bei Skype
« Antwort #12 am: 05.09.2021, 21:45:27 »
Moin,
du könntest es mal mit diesem >ppa< versuchen:
https://launchpad.net/~libv4l/+archive/ubuntu/stable
sudo add-apt-repository ppa:libv4l/stablesudo apt-get updatesudo apt-get upgradeDann dies versuchen:
LD_PRELOAD=/usr/lib/x86_64-linux-gnu/libv4l/v4l1convert.so skypeoder
LD_PRELOAD=/usr/lib/x86_64-linux-gnu/libv4l/v4l2compat.so skype
Kommt wieder der Fehler, dann dies:
sudo dpkg --add-architecture i386sudo apt-get updatesudo apt-get install libv4l-0:i386und nun dies:
LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so skypeGruß
Wolfgang
« Letzte Änderung: 06.09.2021, 17:46:32 von Wolfgang58 »

Re: Webcam funktioniert nicht bei Skype
« Antwort #13 am: 06.09.2021, 18:11:28 »
Auch dir vielen Dank für die Ratschläge. Leider war das allerdings auch nicht erfolgreich.

sudo add-apt-repository ppa:libv4l/stable
[sudo] Passwort für ---///---:     
Sie sind dabei das folgende PPA hinzuzufügen:
 Stable snapshot of v4l-utils libv4l
 Mehr Informationen: https://launchpad.net/~libv4l/+archive/ubuntu/stable
Zum Fortfahren bitte Eingabetaste drücken oder Strg+C zum Abbrechen

Executing: /tmp/apt-key-gpghome.YeFvTwVoDb/gpg.1.sh --keyserver hkps://keyserver.ubuntu.com:443 --recv-keys F096A7E0B2919317A7535B12F86C6AC1C3FFB4AA
gpg: Schlüssel F86C6AC1C3FFB4AA: Öffentlicher Schlüssel "Launchpad libv4l" importiert
gpg: Anzahl insgesamt bearbeiteter Schlüssel: 1
gpg:               importiert: 1

udo apt-get update
Holen:1 http://ppa.launchpad.net/libv4l/stable/ubuntu focal InRelease [17,5 kB]
OK:2 http://archive.ubuntu.com/ubuntu focal InRelease                         
OK:3 http://archive.canonical.com/ubuntu focal InRelease                       
Holen:4 http://archive.ubuntu.com/ubuntu focal-updates InRelease [114 kB]     
OK:5 https://repo.skype.com/deb stable InRelease                               
OK:6 http://packages.microsoft.com/repos/edge stable InRelease                 
Holen:7 http://archive.ubuntu.com/ubuntu focal-backports InRelease [101 kB]   
Ign:8 http://packages.linuxmint.com uma InRelease                             
Holen:9 http://security.ubuntu.com/ubuntu focal-security InRelease [114 kB]
Holen:10 http://ppa.launchpad.net/libv4l/stable/ubuntu focal/main amd64 Packages [2.348 B]
OK:11 http://packages.linuxmint.com uma Release                               
Holen:12 http://ppa.launchpad.net/libv4l/stable/ubuntu focal/main i386 Packages [2.336 B]
Holen:13 http://ppa.launchpad.net/libv4l/stable/ubuntu focal/main Translation-en [1.920 B]
Holen:14 http://archive.ubuntu.com/ubuntu focal-updates/main i386 Packages [527 kB]
Holen:15 http://archive.ubuntu.com/ubuntu focal-updates/main amd64 Packages [1.175 kB]
Holen:17 http://archive.ubuntu.com/ubuntu focal-updates/main amd64 DEP-11 Metadata [283 kB]
Holen:18 http://archive.ubuntu.com/ubuntu focal-updates/universe amd64 Packages [853 kB]
Holen:19 http://archive.ubuntu.com/ubuntu focal-updates/universe i386 Packages [631 kB]
Holen:20 http://archive.ubuntu.com/ubuntu focal-updates/universe amd64 DEP-11 Metadata [351 kB]
Holen:21 http://security.ubuntu.com/ubuntu focal-security/main i386 Packages [275 kB]
Holen:22 http://archive.ubuntu.com/ubuntu focal-updates/multiverse amd64 DEP-11 Metadata [944 B]
Holen:23 http://archive.ubuntu.com/ubuntu focal-backports/universe amd64 DEP-11 Metadata [10,3 kB]
Holen:24 http://security.ubuntu.com/ubuntu focal-security/main amd64 Packages [830 kB]
Holen:25 http://security.ubuntu.com/ubuntu focal-security/main amd64 DEP-11 Metadata [27,6 kB]
Holen:26 http://security.ubuntu.com/ubuntu focal-security/universe amd64 DEP-11 Metadata [61,0 kB]
Holen:27 http://security.ubuntu.com/ubuntu focal-security/multiverse amd64 DEP-11 Metadata [2.468 B]
Es wurden 5.379 kB in 2 s geholt (3.307 kB/s).                       
Paketlisten werden gelesen... Fertig

sudo apt-get upgrade
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Paketaktualisierung (Upgrade) wird berechnet... Fertig
Die folgenden Pakete werden aktualisiert (Upgrade):
  libv4l-0 libv4l-0:i386 libv4l2rds0 libv4lconvert0 libv4lconvert0:i386
  python-apt-common python3-apt qv4l2 v4l-utils
9 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
Es müssen 1.572 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 191 kB Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren? [J/n] j
Holen:1 http://archive.ubuntu.com/ubuntu focal-updates/main amd64 python-apt-common all 2.0.0ubuntu0.20.04.6 [17,1 kB]
Holen:2 http://ppa.launchpad.net/libv4l/stable/ubuntu focal/main amd64 v4l-utils amd64 1.20.0-202007101525-202012071927~ubuntu20.04.1 [633 kB]
Holen:3 http://archive.ubuntu.com/ubuntu focal-updates/main amd64 python3-apt amd64 2.0.0ubuntu0.20.04.6 [154 kB]
Holen:4 http://ppa.launchpad.net/libv4l/stable/ubuntu focal/main amd64 qv4l2 amd64 1.20.0-202007101525-202012071927~ubuntu20.04.1 [202 kB]
Holen:5 http://ppa.launchpad.net/libv4l/stable/ubuntu focal/main i386 libv4l-0 i386 1.20.0-202007101525-202012071927~ubuntu20.04.1 [105 kB]
Holen:6 http://ppa.launchpad.net/libv4l/stable/ubuntu focal/main amd64 libv4l-0 amd64 1.20.0-202007101525-202012071927~ubuntu20.04.1 [105 kB]
Holen:7 http://ppa.launchpad.net/libv4l/stable/ubuntu focal/main amd64 libv4lconvert0 amd64 1.20.0-202007101525-202012071927~ubuntu20.04.1 [139 kB]
Holen:8 http://ppa.launchpad.net/libv4l/stable/ubuntu focal/main i386 libv4lconvert0 i386 1.20.0-202007101525-202012071927~ubuntu20.04.1 [140 kB]
Holen:9 http://ppa.launchpad.net/libv4l/stable/ubuntu focal/main amd64 libv4l2rds0 amd64 1.20.0-202007101525-202012071927~ubuntu20.04.1 [77,7 kB]
Es wurden 1.572 kB in 1 s geholt (1.724 kB/s).
(Lese Datenbank ... 326787 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../python-apt-common_2.0.0ubuntu0.20.04.6_all.deb ...
Entpacken von python-apt-common (2.0.0ubuntu0.20.04.6) über (2.0.0ubuntu0.20.04.5) ...
python-apt-common (2.0.0ubuntu0.20.04.6) wird eingerichtet ...
(Lese Datenbank ... 326787 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../python3-apt_2.0.0ubuntu0.20.04.6_amd64.deb ...
Entpacken von python3-apt (2.0.0ubuntu0.20.04.6) über (2.0.0ubuntu0.20.04.5) ...
python3-apt (2.0.0ubuntu0.20.04.6) wird eingerichtet ...
(Lese Datenbank ... 326787 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../0-v4l-utils_1.20.0-202007101525-202012071927~ubuntu20.04.1_amd64.deb ...
Entpacken von v4l-utils (1.20.0-202007101525-202012071927~ubuntu20.04.1) über (1.18.0-2build1) ...
Vorbereitung zum Entpacken von .../1-libv4l2rds0_1.20.0-202007101525-202012071927~ubuntu20.04.1_amd64.deb ...
Entpacken von libv4l2rds0:amd64 (1.20.0-202007101525-202012071927~ubuntu20.04.1) über (1.18.0-2build1) ...
Vorbereitung zum Entpacken von .../2-libv4l-0_1.20.0-202007101525-202012071927~ubuntu20.04.1_i386.deb ...
libv4l-0:amd64 (1.18.0-2build1) wird de-konfiguriert ...
Entpacken von libv4l-0:i386 (1.20.0-202007101525-202012071927~ubuntu20.04.1) über (1.18.0-2build1) ...
Vorbereitung zum Entpacken von .../3-libv4l-0_1.20.0-202007101525-202012071927~ubuntu20.04.1_amd64.deb ...
Entpacken von libv4l-0:amd64 (1.20.0-202007101525-202012071927~ubuntu20.04.1) über (1.18.0-2build1) ...
Vorbereitung zum Entpacken von .../4-qv4l2_1.20.0-202007101525-202012071927~ubuntu20.04.1_amd64.deb ...
Entpacken von qv4l2 (1.20.0-202007101525-202012071927~ubuntu20.04.1) über (1.18.0-2build1) ...
Vorbereitung zum Entpacken von .../5-libv4lconvert0_1.20.0-202007101525-202012071927~ubuntu20.04.1_amd64.deb ...
libv4lconvert0:i386 (1.18.0-2build1) wird de-konfiguriert ...
Entpacken von libv4lconvert0:amd64 (1.20.0-202007101525-202012071927~ubuntu20.04.1) über (1.18.0-2build1) ...
Vorbereitung zum Entpacken von .../6-libv4lconvert0_1.20.0-202007101525-202012071927~ubuntu20.04.1_i386.deb ...
Entpacken von libv4lconvert0:i386 (1.20.0-202007101525-202012071927~ubuntu20.04.1) über (1.18.0-2build1) ...
libv4lconvert0:amd64 (1.20.0-202007101525-202012071927~ubuntu20.04.1) wird eingerichtet ...
libv4lconvert0:i386 (1.20.0-202007101525-202012071927~ubuntu20.04.1) wird eingerichtet ...
libv4l2rds0:amd64 (1.20.0-202007101525-202012071927~ubuntu20.04.1) wird eingerichtet ...
libv4l-0:amd64 (1.20.0-202007101525-202012071927~ubuntu20.04.1) wird eingerichtet ...
libv4l-0:i386 (1.20.0-202007101525-202012071927~ubuntu20.04.1) wird eingerichtet ...
qv4l2 (1.20.0-202007101525-202012071927~ubuntu20.04.1) wird eingerichtet ...
v4l-utils (1.20.0-202007101525-202012071927~ubuntu20.04.1) wird eingerichtet ...
Trigger für desktop-file-utils (0.24+linuxmint1) werden verarbeitet ...
Trigger für mime-support (3.64ubuntu1) werden verarbeitet ...
Trigger für hicolor-icon-theme (0.17-2) werden verarbeitet ...
Trigger für gnome-menus (3.36.0-1ubuntu1) werden verarbeitet ...
Trigger für libc-bin (2.31-0ubuntu9.2) werden verarbeitet ...
Trigger für man-db (2.9.1-1) werden verarbeitet ...

LD_PRELOAD=/usr/lib/x86_64-linux-gnu/libv4l/v4l1convert.so skypeforlinux
ERROR: ld.so: object '/usr/lib/x86_64-linux-gnu/libv4l/v4l1convert.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/lib/x86_64-linux-gnu/libv4l/v4l1convert.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/lib/x86_64-linux-gnu/libv4l/v4l1convert.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/lib/x86_64-linux-gnu/libv4l/v4l1convert.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/lib/x86_64-linux-gnu/libv4l/v4l1convert.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.

LD_PRELOAD=/usr/lib/x86_64-linux-gnu/libv4l/v4l2compat.so skypeforlinux
ERROR: ld.so: object '/usr/lib/x86_64-linux-gnu/libv4l/v4l2compat.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/lib/x86_64-linux-gnu/libv4l/v4l2compat.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/lib/x86_64-linux-gnu/libv4l/v4l2compat.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/lib/x86_64-linux-gnu/libv4l/v4l2compat.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/lib/x86_64-linux-gnu/libv4l/v4l2compat.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.

sudo dpkg --add-architecture i386

sudo apt-get update
OK:1 http://ppa.launchpad.net/libv4l/stable/ubuntu focal InRelease
OK:2 https://repo.skype.com/deb stable InRelease                               
OK:3 http://archive.canonical.com/ubuntu focal InRelease                       
OK:4 http://packages.microsoft.com/repos/edge stable InRelease                 
OK:5 http://archive.ubuntu.com/ubuntu focal InRelease                         
OK:6 http://archive.ubuntu.com/ubuntu focal-updates InRelease                 
OK:7 http://archive.ubuntu.com/ubuntu focal-backports InRelease               
OK:8 http://security.ubuntu.com/ubuntu focal-security InRelease               
Ign:9 http://packages.linuxmint.com uma InRelease
OK:10 http://packages.linuxmint.com uma Release
Paketlisten werden gelesen... Fertig

sudo apt-get install libv4l-0:i386
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
libv4l-0:i386 ist schon die neueste Version (1.20.0-202007101525-202012071927~ubuntu20.04.1).
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.

LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so skypeforlinux
ERROR: ld.so: object '/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: ld.so: object '/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: ld.so: object '/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: ld.so: object '/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: ld.so: object '/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.







Re: Webcam funktioniert nicht bei Skype
« Antwort #14 am: 06.09.2021, 20:41:58 »
Moin,
irgendwas stimmt mit der i386 Installation nicht, versuch mal folgendes
sudo apt-get install libv4l-devund schau mal ob der Ordner >libv4l< im Verzeichnis >/usr/lib/i386-linux-gnu/< existiert...
ls -l /usr/lib/i386-linux-gnu/Gruß
Wolfgang