Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
19.10.2021, 20:13:33

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 25999
  • Letzte: Bob99
Statistiken
  • Beiträge insgesamt: 758661
  • Themen insgesamt: 60965
  • Heute online: 600
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema: [erledigt] Externes und internes Mikrofon werden nicht erkannt  (Gelesen 530 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[erledigt] Externes und internes Mikrofon werden nicht erkannt
« am: 08.08.2021, 10:19:05 »
Hallo!
Habe inzwischen sehr viele ähnliche, daber nicht dieses Problem gefunden und frage jetzt einfach selber!
Erstmal:
Linux Mint 20 Cinnamon version 4.6.7
Als Dualboot mit Windows 10(das ich aber nicht wirklich nutze) auf einem
Panaconic CF-53

Nach einigen Problemen mit der festplatte haben wir allet neu installiert (auf einer neuen Festplatte). Ich versuche nun ein externes Mikrofon zum Laufen zu kriegen. Ich bin der Meinung das interne Mikrofon und ein Headset wurde vorher erkannt, es hat zwar nicht wirklich geklappt damit im Teamspeak zu sprechen, aber es war da. Hat rauschen, feedbacks und störsignale ausgespuckt, aber wurde erkannt.

Nun also.
Der vorinstalliere Klangregler sagt: Keine Eingabegeräte
Habe pavucontroll installiert, schönes Tool, das sagt: Keine Eingabegeräte verfügbar, bei Konfigurationen die analoge stereo-eingabe sei (ausgesteckt)(nicht verfügbar)
Verschiede Infos habe ich dem Laptob schon entlockt

Meine Soundkarte
**** Liste der Hardware-Geräte (CAPTURE) ****
Karte 1: PCH [HDA Intel PCH], Gerät 0: ALC255 Analog [ALC255 Analog]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0

~$ dmesg | grep snd
[   44.336705] snd_hda_intel 0000:00:03.0: enabling device (0000 -> 0002)
[   44.336856] snd_hda_intel 0000:00:03.0: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[   44.336952] snd_hda_intel 0000:00:1b.0: enabling device (0000 -> 0002)
[   44.677840] snd_hda_codec_realtek hdaudioC1D0: autoconfig for ALC255: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:speaker
[   44.677842] snd_hda_codec_realtek hdaudioC1D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[   44.677843] snd_hda_codec_realtek hdaudioC1D0:    hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
[   44.677843] snd_hda_codec_realtek hdaudioC1D0:    mono: mono_out=0x0
[   44.677844] snd_hda_codec_realtek hdaudioC1D0:    inputs:
[   44.677845] snd_hda_codec_realtek hdaudioC1D0:      Headset Mic=0x19

und das letzte wo ich den fehler vermute (wegen der zeile available: no) aber nicht weiß wie ich es ändern kann

~$ pacmd list-cards
2 card(s) available.
    index: 0
name: <alsa_card.pci-0000_00_03.0>
driver: <module-alsa-card.c>
owner module: 8
properties:
alsa.card = "0"
alsa.card_name = "HDA Intel HDMI"
alsa.long_card_name = "HDA Intel HDMI at 0xf7e3c000 irq 57"
alsa.driver_name = "snd_hda_intel"
device.bus_path = "pci-0000:00:03.0"
sysfs.path = "/devices/pci0000:00/0000:00:03.0/sound/card0"
device.bus = "pci"
device.vendor.id = "8086"
device.vendor.name = "Intel Corporation"
device.product.id = "0a0c"
device.product.name = "Haswell-ULT HD Audio Controller"
device.form_factor = "internal"
device.string = "0"
device.description = "Eingebautes Tongerät"
module-udev-detect.discovered = "1"
device.icon_name = "audio-card-pci"
profiles:
output:hdmi-stereo: Digital Stereo (HDMI)-Ausgabe (priority 5900, available: no)
output:hdmi-surround: Digital Surround 5.1 (HDMI)-Ausgabe (priority 800, available: no)
output:hdmi-surround71: Digital Surround 7.1 (HDMI)-Ausgabe (priority 800, available: no)
output:hdmi-stereo-extra1: Digital Stereo (HDMI 2)-Ausgabe (priority 5700, available: no)
output:hdmi-surround-extra1: Digital Surround 5.1 (HDMI 2)-Ausgabe (priority 600, available: no)
output:hdmi-surround71-extra1: Digital Surround 7.1 (HDMI 2)-Ausgabe (priority 600, available: no)
output:hdmi-stereo-extra2: Digital Stereo (HDMI 3)-Ausgabe (priority 5700, available: no)
output:hdmi-surround-extra2: Digital Surround 5.1 (HDMI 3)-Ausgabe (priority 600, available: no)
output:hdmi-surround71-extra2: Digital Surround 7.1 (HDMI 3)-Ausgabe (priority 600, available: no)
output:hdmi-stereo-extra3: Digital Stereo (HDMI 4)-Ausgabe (priority 5700, available: no)
output:hdmi-surround-extra3: Digital Surround 5.1 (HDMI 4)-Ausgabe (priority 600, available: no)
output:hdmi-surround71-extra3: Digital Surround 7.1 (HDMI 4)-Ausgabe (priority 600, available: no)
output:hdmi-stereo-extra4: Digital Stereo (HDMI 5)-Ausgabe (priority 5700, available: no)
output:hdmi-surround-extra4: Digital Surround 5.1 (HDMI 5)-Ausgabe (priority 600, available: no)
output:hdmi-surround71-extra4: Digital Surround 7.1 (HDMI 5)-Ausgabe (priority 600, available: no)
off: Aus (priority 0, available: unknown)
active profile: <off>
ports:
hdmi-output-0: HDMI / DisplayPort (priority 5900, latency offset 0 usec, available: no)
properties:
device.icon_name = "video-display"
hdmi-output-1: HDMI / DisplayPort 2 (priority 5800, latency offset 0 usec, available: no)
properties:
device.icon_name = "video-display"
hdmi-output-2: HDMI / DisplayPort 3 (priority 5700, latency offset 0 usec, available: no)
properties:
device.icon_name = "video-display"
hdmi-output-3: HDMI / DisplayPort 4 (priority 5600, latency offset 0 usec, available: no)
properties:
device.icon_name = "video-display"
hdmi-output-4: HDMI / DisplayPort 5 (priority 5500, latency offset 0 usec, available: no)
properties:
device.icon_name = "video-display"
    index: 1
name: <alsa_card.pci-0000_00_1b.0>
driver: <module-alsa-card.c>
owner module: 9
properties:
alsa.card = "1"
alsa.card_name = "HDA Intel PCH"
alsa.long_card_name = "HDA Intel PCH at 0xf7e38000 irq 58"
alsa.driver_name = "snd_hda_intel"
device.bus_path = "pci-0000:00:1b.0"
sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card1"
device.bus = "pci"
device.vendor.id = "8086"
device.vendor.name = "Intel Corporation"
device.product.id = "9c20"
device.product.name = "8 Series HD Audio Controller"
device.form_factor = "internal"
device.string = "1"
device.description = "Eingebautes Tongerät"
module-udev-detect.discovered = "1"
device.icon_name = "audio-card-pci"
profiles:
input:analog-stereo: Analog Stereo-Eingabe (priority 65, available: no)
output:analog-stereo: Analog Stereo-Ausgabe (priority 39268, available: unknown)
output:analog-stereo+input:analog-stereo: Analog Stereo Duplex (priority 6565, available: unknown)
off: Aus (priority 0, available: unknown)
active profile: <output:analog-stereo>
sinks:
alsa_output.pci-0000_00_1b.0.analog-stereo/#0: Eingebautes Tongerät Analog Stereo
sources:
alsa_output.pci-0000_00_1b.0.analog-stereo.monitor/#0: Monitor of Eingebautes Tongerät Analog Stereo
ports:
analog-input-headset-mic: Mikrofon der Freisprecheinrichtung (priority 8800, latency offset 0 usec, available: no)
properties:
device.icon_name = "audio-input-microphone"
analog-output-speaker: Lautsprecher (priority 10000, latency offset 0 usec, available: unknown)
properties:
device.icon_name = "audio-speakers"
analog-output-headphones: Kopfhörer (priority 9900, latency offset 0 usec, available: no)
properties:
device.icon_name = "audio-headphones"


Was ich schon versucht habe:
Ich habe in den letzten 2 Tagen gelernt, Dateirechte zu ändern und nano zu beutzen; ich bin eher so anfänger als pro. Grundlegendes verstehe ich auch.
Also habe ich
https://wiki.archlinux.org/title/PulseAudio/Troubleshooting#Microphone_not_detected_by_PulseAudio
das in den Pulseaudio eingefügt und
dell-headset-multi
in den alsa textfile hinzugefügt.

und nichts passiert... habe eine testaufnahme versucht, es nimmt internen sound (monitor)auf aber keinen externen.

Wenn mensch mir einen ansatz geben kann, wo ich da ansetzen sollte wär ich sehr dankbar. Gibt es eine möglichkeit denn ganz stumpf die buchse abzufragen, so wie einen USB eingang?
Bis dahin,
Aux
« Letzte Änderung: 10.08.2021, 18:46:47 von LightAux »


Re: Externes und internes Mikrofon werden nicht erkannt
« Antwort #2 am: 09.08.2021, 01:46:18 »
Hallo Mintnix,

Ja, die Seite hatte ich auch schon gefunden, hat mich auch (im Verständnis) weitergebracht, nur in der Problemlösung nicht.
Habe die Dinge genauso ausgeführt, aber immer noch keine Eingabegeräte erkannt, also auch nicht das interne.


Re: Externes und internes Mikrofon werden nicht erkannt
« Antwort #3 am: 09.08.2021, 15:19:54 »
Hi :)
versuche mal
headset microfon wird nicht erkannt..
sudo tee /etc/modprobe.d/headset-fix.conf <<<'options snd-hda-intel model=dell-headset-multi'und reboot

wenn es nicht hilft die angelegte /etc/modprobe.d/headset-fix.conf  wieder löschen

Re: Externes und internes Mikrofon werden nicht erkannt
« Antwort #4 am: 10.08.2021, 10:12:33 »
Macht keinen Unterschied.

https://www.kernel.org/doc/html/v4.14/sound/hd-audio/models.html

Könnte es etwas anderes aus dieser Liste sein?

Liegt es denn an der Soundkarteneinstellung?
 Danke..

Re: Externes und internes Mikrofon werden nicht erkannt
« Antwort #5 am: 10.08.2021, 12:01:38 »
Oha! Ich habe zum versuch mal mein handy headset (also eine 4pol miniklinke eingesteckt, da erkennt es auf einmal ein mikrofon einer freisprechanlage.. ich teste mal ob as was aufnehmen kann.. sinn macht das aber irgendwie nicht. es ist doch nur eine ausgangsbuchse..


Re: Externes und internes Mikrofon werden nicht erkannt
« Antwort #6 am: 10.08.2021, 15:50:29 »
ich lass euch weiter teilhaben...
Ich habe in die /etc/modprobe.d/alsa-base.conf
 nun eingefügt
options snd-hda-intel model=headset-mic

ich bin mir aber nicht sicher, ob das nun irgendwas ausführt. Pulseaudio erkennt nun "mikrophon der freisprecheinrichtung" (egal ob ichs in die kopfhörer oder in die mikrophon Buchse stecke. Die DB anzeige peakt auch beim aus und einstecken, nimmt aber keinen Sound auf. Auch im Alsa sind alle mutes aus, verstärkung aufgedreht. Auf der Testaufnahme ist nur Rauschen.
 Was ist den das S****problem.... ich raffs einfach nicht.





Re: Externes und internes Mikrofon werden nicht erkannt
« Antwort #7 am: 10.08.2021, 18:40:24 »
Nun gut.
Habe jetzt nochmal alle einstellungen zurückgesetzt, dann den obrigen link nochmal den anweisungen gefolgt
Ich habe jetzt das handy headset eingestelckt und das externe mikrofon eingesteckt und den Teamspeak neugestartet - und dada: ich weis nicht warum, aber es geht.

Re: Externes und internes Mikrofon werden nicht erkannt
« Antwort #8 am: 10.08.2021, 18:42:38 »
Wäre nett, wenn du noch auf gelöst setzen würdest.
Wie das geht steht oben unter "Hilfe"

Re: Externes und internes Mikrofon werden nicht erkannt
« Antwort #9 am: 10.08.2021, 18:44:46 »
Genau da bin ich gerade bei, dont worry.

Re: Externes und internes Mikrofon werden nicht erkannt
« Antwort #10 am: 10.08.2021, 19:04:56 »
Pardon, habe nicht auf die Zeit geachtet.  ;)

Re: Externes und internes Mikrofon werden nicht erkannt
« Antwort #11 am: 10.08.2021, 19:13:47 »
Off-Topic:
Don't Worry Be Happy