Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
21.10.2021, 07:44:24

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 26000
  • Letzte: Rhys
Statistiken
  • Beiträge insgesamt: 758823
  • Themen insgesamt: 60981
  • Heute online: 464
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema: [gelöst]  Neuinstallation - Problem mit interner Grafik  (Gelesen 892 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] Neuinstallation - Problem mit interner Grafik
« am: 28.07.2021, 22:02:31 »
Hallo,

ich dachte, es wäre sinnvoll, mir mal (nach 6 Jahren) neue Hardware zuzulegen, zumal das alte Mainboard schon einige Probleme hat.  Ich wollte mir gleich was mit integrierter Grafik anschaffen, weil meine Grafik-Ansprüche ohnehin eher bescheiden sind (in Richtung typische Büroanwendungen).

Also habe ich mir als Mainboard eines von Gigabyte H510M-S2H (Chipsatz ist intel 510) angeschafft, als CPU einen intel Pentium Gold G6405.  Ja, der hat integrierte Grafik.

Nun alles zusammengebaut, zunächst nur Minimalkonfiguration.  Ich habe versucht, dort per USB-Stick zunächst einmal probehalber LM 20.2 zu starten, was beim alten PC ja problemlos ging.  Hier aber eine böse Überraschung.  Ich kann mir das BIOS-Setup auf dem Monitor anschauen.  Der Anfangsbildschirm mit dem Gigabyte-Logo wird auch dargestellt.  Dann kommen allenfalls ein paar Textzeilen, das Bild wird dann dunkel, und der Monitor geht in Standby-Betrieb.  Interessanterweise hört man bei angeschlossenen Lautsprechern aber noch die Startmelodie.

Also irgendwie scheint LM schon zu laufen, aber ich habe keine Grafikausgabe mehr.  Seltsam.  Die Grafikauflösung des Monitor ist mit 1280 x 1024 Pixeln vergleichsweise bescheiden und weit unterhalb dessen, was angeblich unterstützt wird.

Ich habe im Bios-Setup auch nachgeschaut, daß dort die interne Grafik aktiviert ist.   Da scheint alles in Ordnung zu sein.

Wenn ich ein anderes Linux-Image vom USB-Stick starte, beispielsweise Knoppix, habe ich genau denselben Effekt.  Text wird dargestellt, dann ist die Anzeige weg.

Ich habe vorsichtshalter weiterhin das Bios mal auf den neuesten Stand aktualisiert.  Das klappt zwar (im Bios-Setup), löst das Problem aber auch nicht.

Jetzt weiß ich wirklich nicht mehr weiter.  So was hatte ich noch nie.  Bin ich da zu dumm, daß ich was ganz Elementares übersehe, oder ist da vielleicht was an der neuen Hardware kaputt?  Ich hatte bislang nur PCs mit Grafikkarte, ohne integrierte Grafik. 

Danke für Hinweise.
« Letzte Änderung: 30.07.2021, 09:27:52 von felix92 »

Re: Neuinstallation - Problem mit interner Grafik
« Antwort #1 am: 28.07.2021, 23:42:49 »
Diese CPU ist ja erst Januar 2021 eingeführt worden - der Chipsatz ist schon älter. Das braucht doch bestimmt einen ganz neuen Kernel?
Oder liege ich da falsch?

Welche Mint-Version wolltest Du denn installieren?

Hier gibt es z.Bsp. die Cinnamon Edge mit Kernel 5.8x
https://sourceforge.net/projects/linuxmintdeutsch/files/20.2/linuxmint-20.2-cinnamon-64bit-edge-de-20210709-0156.iso/download
« Letzte Änderung: 28.07.2021, 23:53:45 von Michelle_Br »

Re: Neuinstallation - Problem mit interner Grafik
« Antwort #2 am: 29.07.2021, 08:23:26 »
Das braucht doch bestimmt einen ganz neuen Kernel?
Oder liege ich da falsch?



Nein da liegst du nicht falsch. Neueste Hardware = Neuester Kernel. Und Kernel 5.8 wird auch nur noch bis Aug. 2021 unterstützt.
Also sollte man sich sehr schnell den 5.11 zulegen.

LG von Markus

Re: Neuinstallation - Problem mit interner Grafik
« Antwort #3 am: 29.07.2021, 12:21:29 »
sicher - ihm ging es aber bestimmt darum, eine Distribution zu finden, die erst einmal läuft - um DANN den neuesten Kernel zu installieren.
Deshalb mein Gedanke hinsichtlich Mint Cinnamon Edge.

Bei seinem Pentium Gold wird der CPU-Teil ja erkannt - nur der Grafikteil wahrscheinlich nicht.

Re: Neuinstallation - Problem mit interner Grafik
« Antwort #4 am: 29.07.2021, 13:11:25 »
Hallo,

zunächst mal danke an alle, die geantwortet haben.

Richtig, erstmal müßte ich überhaupt ein System zum Laufen bringen, ehe ich den Kernel ändern kann.  Ich habe aber auch Knoppix 9.1 vom USB-Stick aus versucht, und dort ist sogar Kernel 5.10 eingebaut.  Geht genauso wenig.  Die Anfangsmeldungen erscheinen, aber nach der in Knoppix eingebauten akustischen Ansage "initiating startup sequence" wird der Monitor schwarz.  Die graphische Oberfläche baut sich wie gehabt nicht auf.

Ich habe verschiedene Grafik-Einstellungen im Bios-Setup probiert (so viele gibt es dafür gar nicht).  "Initial Display Output" ist für die Anfangsmeldungen auf "IGFX" (also interne Grafik) gesetzt, "internal Graphics" auf "enabled".  Mehr kann man da bezüglich Grafik anscheinend nicht einstellen.

Als nächsten Schritt habe ich einfach mal eine alte Grafikkarte in den PCIe-Slot eingesetzt und den Monitor dort angeschlossen, die obigen Grafik-Parameter im Bios-Setup natürlich verändert.  Die Anfangsausgabe soll jetzt also über die Grafikkarte erfolgen, die interne Grafik ist automatisch ausgeschaltet, sofern eine Grafikkarte eingesetzt ist.  Und siehe da, die graphische Oberfläche startet.  Das ist für mich aber letztlich keine praktikable Lösung, da ich ja einen PC ohne extra Grafikkarte haben wollte.

Ergänzung: wenn ich alternativ eine alte Windows 10-Installation von einer eingebauten Festplatte zu starten versuche, ist das Verhalten das gleiche wie bei den Linux-Systemen.  Bei der internen Grafik baut sich die grafische Oberfläche nicht auf, bei Verwendung einer Grafikkarte ist alles in Ordnung.

Den Arbeitsspeicher (neu gekauft) habe ich mit memtest86 durchgeprüft, alles ohne Beanstandungen.

Beim Versuch des Starts von LM 20.2 (und auch Manjaro) sind mir dann im anfänglichen Textmodus einige Fehlermeldungen aufgefallen:
[   0.085146] mce: [Hardware Error]: CPU 0: Machine Check: 0 Bank 6: ee0000000040110a
[   0.085148] mce: [Hardware Error]: TSC 0 ADDR fef1e680 MISC 438800004086
[   0.085150] mce: [Hardware Error]: PROCESSOR 0:a0653 TIME 1627519314 SOCKET 0 APIC 0 microcode ea

Ich habe dazu im Internet gesucht und auch teilweise genau dasselbe in mehreren Forumsbeiträgen gefunden.  Eine eindeutige Erklärung oder gar Lösung gibt es dazu freilich dort nicht.

Mein Fazit: irgendwas stimmt mit der internen Grafik (CPU oder deren Verbindung mit dem Mainboard) nicht, eventuell Hardware-Fehler oder was weiß ich.  Das Betriebssystem scheint ja "ohne Bildausgabe" irgendwie im Hintergrund zu laufen.  Ich glaube, ich werde hier keine weitere Zeit mit Herumprobieren verschwenden, sondern beides beim Händler reklamieren.  Soll der sich doch drum kümmern.   >:(
« Letzte Änderung: 29.07.2021, 14:12:52 von felix92 »

Re: Neuinstallation - Problem mit interner Grafik
« Antwort #5 am: 29.07.2021, 14:43:59 »
Hi :)
nur mal ein suchpfad... 
nomodeset
eruiert?

Re: Neuinstallation - Problem mit interner Grafik
« Antwort #6 am: 29.07.2021, 20:39:58 »
Aha!  Das scheint weiterzuhelfen, jedenfalls für's erste.  Vielen Dank!

(Falls es jemand später liest: Bei der Textausgabe des Grub-Bootloaders für den Start von LM den ersten Standardeintrag wählen, durch Eingabe von "e" in den Editier-Modus wechseln, in der Zeile mit "linux ..." den Parameter "nomodeset" zu den anderen hinzufügen, mit <F10> oder <Strg-X> neu booten; später diese Änderung in /boot/grub/grub.cfg permanent eintragen.)

Jetzt muß ich nur noch passende Grafik-Treiber für die Intel GPU finden.  Momentan scheint es in einer Art von Standard-Auflösung zu laufen, die nicht optimal ist -- angeblich habe ich einen Laptop mit 1024 x 768 pxl.  Die Treiberverwaltung sagt mir nur "das System benötigt zusätzliche Treiber", aber nicht, wo diese zu finden sind.


Re: Neuinstallation - Problem mit interner Grafik
« Antwort #7 am: 29.07.2021, 21:30:52 »
später diese Änderung in /boot/grub/grub.cfg permanent eintragen
Nein, wenn es permanent sein soll, dann in /etc/default/grub
(GRUB_CMDLINE_LINUX_DEFAULT="nomodeset")
Danach ein sudo update-grub
« Letzte Änderung: 29.07.2021, 21:36:05 von aexe »

Re: Neuinstallation - Problem mit interner Grafik
« Antwort #8 am: 29.07.2021, 22:49:03 »
naja - wenn Du entweder mit "nomodeset" oder temporär einer anderen Grafikeinheit das System booten kannst, kannst Du doch sofort den neuesten Kernel installieren (...neu booten) und ggfs. auch noch nach eventuellen Treibern suchen in der Treiberverwaltung.
Ich sagte ja - der Pentium Gold ist erst 01/2021 (!) released....

@aexe
Er will das doch gar nicht permanent?! Er will doch, dass die Grafikeinheit RICHTIG angesteuert wird ... mit dem richtigen Treiber?

Re: Neuinstallation - Problem mit interner Grafik
« Antwort #9 am: 30.07.2021, 00:33:06 »
@ Michelle_Br
später diese Änderung in /boot/grub/grub.cfg permanent eintragen.)
??
darauf bezog sich meine Antwort:
wenn es permanent sein soll, dann …
Ob er das wirklich will, weiß ich nicht. Aber wenn, dann RICHTIG.
Falls es jemand später liest.
« Letzte Änderung: 30.07.2021, 00:50:24 von aexe »

thebookkeeper

  • aka AnanasDampf
  • *****
Re: Neuinstallation - Problem mit interner Grafik
« Antwort #10 am: 30.07.2021, 01:03:13 »
... Bei seinem Pentium Gold wird der CPU-Teil ja erkannt - nur der Grafikteil wahrscheinlich nicht.
... den neuesten Kernel installieren ... Er will doch, dass die Grafikeinheit RICHTIG angesteuert wird ... mit dem richtigen Treiber?
Kann sein, dass er für die neue Intel-Grafik den neusten i915-Patch aus Linux-Firmware braucht.
... per linux-firmware_1.198 nutze ich das Intel-Treiber-Update:
Download der neusten Linux-Firmware (1.199) gibt's hier => https://packages.ubuntu.com/de/impish/linux-firmware
Danach im Terminal:
cd Downloadsund
sudo apt install ./linux-firmware_1.199_all.deb
Off-Topic:
thebookkeeper@Dell-DV051:~$ cd Downloads
thebookkeeper@Dell-DV051:~/Downloads$ sudo apt install ./linux-firmware_1.199_all.deb
[sudo] Passwort für thebookkeeper:
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Hinweis: »linux-firmware« wird an Stelle von »./linux-firmware_1.199_all.deb« gewählt.
Die folgenden Pakete werden aktualisiert (Upgrade):
  linux-firmware
1 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
Es müssen noch 0 B von 191 MB an Archiven heruntergeladen werden.
Nach dieser Operation werden 11,3 MB Plattenplatz zusätzlich benutzt.
Holen:1 /home/thebookkeeper/Downloads/linux-firmware_1.199_all.deb linux-firmware all 1.199 [191 MB]
(Lese Datenbank ... 194114 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../linux-firmware_1.199_all.deb ...
Entpacken von linux-firmware (1.199) über (1.198) ...
linux-firmware (1.199) wird eingerichtet ...
update-initramfs: Generating /boot/initrd.img-5.4.0-80-generic
thebookkeeper@Dell-DV051:~/Downloads$
« Letzte Änderung: 30.07.2021, 01:50:31 von thebookkeeper »

Re: Neuinstallation - Problem mit interner Grafik
« Antwort #11 am: 30.07.2021, 07:43:20 »
@felix92:
"nomodset" lädt dir quasi nen Standarttreiber für die Grafik. Diesen Eintrag will man nicht dauerhaft behalten. Wie Michelle und thebookkeeper schon schrieben, das System mit nomodset booten, den neuesten Kernel installieren und den Patch laden und ausführen. Dann neu starten und das System OHNE nomodset starten. aexe hat zwar recht mit seiner Aussage, wie man etwas permanent macht, aber nomodset willl man idR nicht permanent. Falls du es also so gemacht hast, diesen eintrag wieder raus nehmen und grub updaten.

Re: Neuinstallation - Problem mit interner Grafik
« Antwort #12 am: 30.07.2021, 09:27:27 »
Hallo,

erneut vielen Dank an alle.  Jetzt funktioniert es endlich so, wie es sollte.  Ich war schon ziemlich am Verzweifeln, weil mich LM ständig dazu aufgefordert hat, einen passenden Treiber zu installieren, mir aber nie direkt gesagt hat, wo ich einen Grafiktreiber finden kann (war auch nicht im neuesten Kernel oder den standardmäßigen Aktualisierungskanälen).  Man braucht also offenbar das aktuelle Firmware-Update (1.199) aus diesem "impish" Kanal.

Ich habe dann auch wieder wie empfohlen das "nomodeset" aus dem grub.cfg herausgenommen (ausgenommen die Einträge für die Recovery-Starteinträge) und so neu gestartet.

Nun erscheint der Desktop in der korrekten Auflösung (1280 x 1024 pxl), der Monitor wird mit der korrekten Modellbezeichnung erkannt, und die Bildwiederholfrequenz ist richtig auf 60 Hz eingestellt.

Ich setze dann den Anfangsbeitrag auf [gelöst].

@ Michelle_Br
Die Intel-CPU Pentium Gold G6405 ist zwar aus Q1/2021 und damit ziemlich neu.  Die integrierte Grafik Intel UHD 610 scheint aber schon seit Q2/2018 in diversen CPUs verwendet zu werden.
https://ark.intel.com/content/www/de/de/ark/products/graphics/129486/intel-uhd-graphics-610.html

Re: Neuinstallation - Problem mit interner Grafik
« Antwort #13 am: 30.07.2021, 16:25:20 »
tja - wer weiß ......
Aber augenscheinlich war es halt DOCH einfach ein Treiberproblem, was durch die neueste firmware gelöst wurde. Vielleicht ist es die Art der Verkoppelung, die die Geräte nicht richtig "sichtbar" für den Systemunterbau machte?! Keine Ahnung ...... aber irgend so etwas kann es eigentlich nur sein.