LMU - Das Hilfe Forum für Linux Mint

Hardware => Hardware stellt sich quer? => Thema gestartet von: j-o am 31.08.2021, 17:54:46

Titel: VM mit Cinnamon läuft derzeit ohne Video-Hardwarebeschleunigung
Beitrag von: j-o am 31.08.2021, 17:54:46
Hallo,

ich weiß, dass das Thema schon umfangreich behandelt wurde, aber irgendwie komme ich nicht so recht weiter.

Ich habe LM 20.2 mit Cinnamon in einer VM (ProxMox 7.0-8) installiert. Nach dem Login bekomme ich die Fehlermeldung, dass kein Grafiktreiber installiert ist und Cinnamon ohne Video-Hardwarebeschleunigung läuft. Klickt man auf den Link in dem Hinweis zum Prüfen der Treiber, wird angezeigt, dass es einige Treiber braucht plus OK-Haken und keine Chance für eine weitere Aktion. (Dass der Text einen Übersetzungsfehler hat und eigentlich meint, dass alles ok ist, habe ich inzwischen schon rausgefunden ;) )

Folgende Infos zum System

inxi -Fz
System:
  Kernel: 5.4.0-81-generic x86_64 bits: 64 Desktop: Cinnamon 5.0.5
  Distro: Linux Mint 20.2 Uma
Machine:
  Type: Kvm System: QEMU product: Standard PC (i440FX + PIIX, 1996)
  v: pc-i440fx-6.0 serial: <filter>
  Mobo: N/A model: N/A serial: N/A BIOS: SeaBIOS
  v: rel-1.14.0-0-g155821a1990b-prebuilt.qemu.org date: 04/01/2014
CPU:
  Topology: Dual Core model: Common KVM bits: 64 type: MCP
  L2 cache: 16.0 MiB
  Speed: 1995 MHz min/max: N/A Core speeds (MHz): 1: 1995 2: 1995
Graphics:
  Device-1: Red Hat QXL paravirtual graphic card driver: qxl v: kernel
  Display: x11 server: X.Org 1.20.11 driver: none
  unloaded: fbdev,modesetting,vesa tty: N/A
  OpenGL: renderer: llvmpipe (LLVM 12.0.0 128 bits) v: 4.5 Mesa 21.0.3
Audio:
  Message: No Device data found.
Network:
  Device-1: Intel 82371AB/EB/MB PIIX4 ACPI type: network bridge
  driver: piix4_smbus
  Device-2: Red Hat Virtio network driver: virtio-pci
  IF: ens18 state: up speed: -1 duplex: unknown mac: <filter>
Drives:
  Local Storage: total: 80.00 GiB used: 7.16 GiB (9.0%)
  ID-1: /dev/sda vendor: QEMU model: HARDDISK size: 80.00 GiB
Partition:
  ID-1: / size: 70.73 GiB used: 7.16 GiB (10.1%) fs: ext4 dev: /dev/sda1
  ID-2: swap-1 size: 7.63 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda2
Sensors:
  Message: No sensors data was found. Is sensors configured?
Info:
  Processes: 165 Uptime: 5m Memory: 7.78 GiB used: 711.2 MiB (8.9%)
  Shell: bash inxi: 3.0.38

inxi -x -G
Graphics:  Device-1: Red Hat QXL paravirtual graphic card driver: qxl v: kernel bus ID: 00:02.0
           Display: x11 server: X.Org 1.20.11 driver: none unloaded: fbdev,modesetting,vesa tty: N/A
           OpenGL: renderer: llvmpipe (LLVM 12.0.0 128 bits) v: 4.5 Mesa 21.0.3 direct render: Yes

Könnt ihr damit schon was anfangen/erkennen oder braucht ihr noch weitere Infos?

Grüße
Jo
Titel: Re: VM mit Cinnamon läuft derzeit ohne Video-Hardwarebeschleunigung
Beitrag von: red1900 am 31.08.2021, 19:15:35
hast du in der VM die 3D Beschleunigung an?
Titel: Re: VM mit Cinnamon läuft derzeit ohne Video-Hardwarebeschleunigung
Beitrag von: toffifee am 31.08.2021, 19:23:40
Der Haken muss jedenfalls im VBox Manager manuell gesetzt werden. Wird wohl der Grund sein.
Titel: Re: VM mit Cinnamon läuft derzeit ohne Video-Hardwarebeschleunigung
Beitrag von: j-o am 31.08.2021, 20:13:37
hast du in der VM die 3D Beschleunigung an?
Hmmm ... 3D Beschleunigung habe ich beim ProxMox bisher noch nicht gesehen. Und per SuMa habe ich dazu jetzt auch nichts gefunden ...
Titel: Re: VM mit Cinnamon läuft derzeit ohne Video-Hardwarebeschleunigung
Beitrag von: j-o am 31.08.2021, 20:14:51
Der Haken muss jedenfalls im VBox Manager manuell gesetzt werden. Wird wohl der Grund sein.
Ähm ... nicht VirtualBox, sondern ProxMox  ;)
Da habe ich so einen Haken leider nicht.
Titel: Re: VM mit Cinnamon läuft derzeit ohne Video-Hardwarebeschleunigung
Beitrag von: red1900 am 31.08.2021, 20:29:34
nun wo das und ob überhaupt es bei ProxMox geht, bin ich überfragt
Titel: Re: VM mit Cinnamon läuft derzeit ohne Video-Hardwarebeschleunigung
Beitrag von: j-o am 31.08.2021, 20:45:24
Ich habe mal die top-Anzeige ein paar Minuten angestarrt: da ist so gut wie keine Last auf dem System. Gerade Cinnamon dümpelt so bei 3-5% CPU-Leistung vor sich hin. Es ist natürlich auch noch nichts los auf dem Rechner. Kann es sein, dass der Hinweis guten Gewissens ignoriert werden kann? Wenn es Probleme geben würde, würde dann Cinnamon auch im Ruhezustand mehr CPU-Last verursachen?
Titel: Re: VM mit Cinnamon läuft derzeit ohne Video-Hardwarebeschleunigung
Beitrag von: red1900 am 31.08.2021, 20:47:28
behalte es einfach im Auge  ;D