Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
16.05.2021, 02:57:14

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 735583
  • Themen insgesamt: 59248
  • Heute online: 489
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online
Mitglieder: 7
Gäste: 386
Gesamt: 393

Autor Thema:  Grub nach Neuinstallation nicht installiert...  (Gelesen 488 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Grub nach Neuinstallation nicht installiert...
« am: 06.02.2019, 23:20:55 »
Hallo Mate 19.1 64 Bit Rechner.

Nach einer Neuinstallation von LM19.1 Mate kam am Schluß die Fehlermeldung, dass der Bootloader nicht installiert werden konnte.

Auf der andern Platte lief fehlerfrei Debian 8.x.

Nun ließ sich auch das System nicht starten und folgende Fehlermeldung wird beim Start angezeigt.

error: file' /boot/grub/i386-pc/normal.mod' not found
Entering rescue mode...
grub rescue>


In der Zwischenzeit habe ich Superfrub heruntergeladen und als DVD eingelegt.
Damit kann ich nun zwar die installierte Version LM 19.1 starten, aber wenn ich die DVD heraus nehme ist die vorgenannte Fehlermeldung wieder da.

Auch ist bisher das andere Betriebssystem mit dem Debian auf der anderen Festplatte nicht eingebunden. KeinUEFI- System...

Wie komme ich weiter, dass da LB alleine ohne Hilfe von der Supergrub DVD startet und auch das Debiansystem der anderen Festplatte eingebunden wird?

Re: Grub nach Neuinstallation nicht installiert...
« Antwort #1 am: 07.02.2019, 04:14:57 »
Normal sollte, wenn du LM 19.1 mit der Supergrub2 Disk gestartet hast, die Installation von Grub2 möglich sein.
Daher versuche es einfach mit:
sudo grub-install /dev/sdaund
sudo update-grub