Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
14.04.2021, 08:42:13

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 25494
  • Letzte: Beda
Statistiken
  • Beiträge insgesamt: 728503
  • Themen insgesamt: 58797
  • Heute online: 427
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  LM20 erkennt sda (mit Win10) nicht  (Gelesen 1768 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Re: LM20 erkennt sda (mit Win10) nicht
« Antwort #15 am: 17.09.2020, 18:00:13 »
Ja, so einen habe ich auch noch: HP 625

Re: LM20 erkennt sda (mit Win10) nicht
« Antwort #16 am: 17.09.2020, 18:05:43 »
Zitat
Jetzt unter Linux habe ich es 2x nur mit UEFI-Modus geschafft. Per MBR/Bios booten kam da nur ein Curser-Blinken.
Schon sehr merkwürdig - zumal der Rechner ja nicht im UEFI-Mode läuft ?!
Zitat
Da ich viel Wert auf eine persistente Installation lege
Um eventuelle Fehlerquellen auszuschließen wäre es m. E. ein Versuch wert einmal das Einfache zu tun -
beschreibe einmal einen Stick mit der USB-Abbilderstellung und der ISO von dieser Seite und teste den Stick an "Brüderles-Rechner".

Re: LM20 erkennt sda (mit Win10) nicht
« Antwort #17 am: 17.09.2020, 21:02:00 »
Das war halt nur die falsche Herangehensweise. Jetzt, dieser Stick mit LM 20 Mate funktioniert ja (der bootet immer, egal in welcher Bootoption).
Aber ich habe mal heute abend bei meinem Bruder das lba-Flag gesetzt - das brachte auch keine Besserung. Dann habe ich mittels LM 19.1 Live-Stick (der wurde anders hergestellt) mal alle Linux-Partitionen gelöscht, neu hergestellt, lba für die Erweiterte gelöscht - neu gesetzt, aber auch hier wieder: Nada.

Jetzt werde ich Deinen Rat mal befolgen und den 3.ten Stick herstellen. Mal sehen was dann ist.

-volker-

Re: LM20 erkennt sda (mit Win10) nicht
« Antwort #18 am: 17.09.2020, 21:08:31 »
Kannst du mir mal sagen, was du da mit lba willst?
Wichtig ist, das der Bootloder grub richtig installiert wird.

Re: LM20 erkennt sda (mit Win10) nicht
« Antwort #19 am: 17.09.2020, 21:17:59 »
Der Vergleich mit meiner Festplatte ergab, dass die Erweiterte auf meiner Platte das lba-Flag hatte - im Gegensatz zur Platte meines Bruders.
...und ohne sda (also die ganze Platte) zu sehen kann ich auch kein grub installieren.

Sie einfach ein paar Beiträge vorher.

-volker-
« Letzte Änderung: 17.09.2020, 21:23:30 von Volker S »

Re: LM20 erkennt sda (mit Win10) nicht
« Antwort #20 am: 17.09.2020, 21:23:37 »
Mag sein, ist aber antiquiert und für Linux völlig irrelevant.

Re: LM20 erkennt sda (mit Win10) nicht
« Antwort #21 am: 17.09.2020, 21:23:45 »
Zeige bitte mal:
sudo bash -c "for d in \$(parted -l|grep -o \"/dev/[^ :]*\");do case \$(hexdump -v -s 0x80 -n 2 -e '2/1 \"%x\" \"\n\"' \$d) in 'aa75'|'5272') echo \$d: Grub Legacy;;'48b4'|'7c3c'|'020') echo \$d: Grub 2;;*) echo \$d;;esac;done"

Re: LM20 erkennt sda (mit Win10) nicht
« Antwort #22 am: 17.09.2020, 21:28:44 »
Ich spiele das mal hier in einer VM durch.
Die 5 GB Windows hab ich ja in 30 min. auf dem Rechner.
Ich habe es ja schon hir, aber im UEFI.

Re: LM20 erkennt sda (mit Win10) nicht
« Antwort #23 am: 17.09.2020, 21:43:34 »
@tommix,

kann ich erst morgen beantworten.

-volker-

Re: LM20 erkennt sda (mit Win10) nicht
« Antwort #24 am: 17.09.2020, 22:34:27 »
So muss deine Platte aussehen:test@test:~$ sudo parted -l
[sudo] Passwort für test:       
Modell: ATA VBOX HARDDISK (scsi)
Festplatte  /dev/sda:  34,4GB
Sektorgröße (logisch/physisch): 512B/512B
Partitionstabelle: msdos
Disk-Flags:

Nummer  Anfang  Ende    Größe   Typ       Dateisystem  Flags
 1      1049kB  53,5MB  52,4MB  primary   ntfs         boot
 2      53,5MB  18,5GB  18,5GB  primary   ntfs
 3      18,5GB  19,1GB  546MB   primary   ntfs         msftres
 4      19,1GB  34,4GB  15,3GB  extended
 5      19,1GB  19,6GB  537MB   logical   fat32
 6      19,6GB  34,4GB  14,7GB  logical   ext4


test@test:~$

Off-Topic:
Wobei da ein Fehler bei ist und das ist die sda5!
Das war eine Automatik Installation im BIOS Mode.
Warum da eine /efi/boot/ erstellt wird ist die Frage.
Das ist hier aber Cinnamon
« Letzte Änderung: 17.09.2020, 23:55:43 von tommix »

Re: LM20 erkennt sda (mit Win10) nicht
« Antwort #25 am: 18.09.2020, 14:31:51 »
Hi :)
um mal zu eigentlichen thema zurück zu kommen...

in win$ als admin
shutdown.exe /s /hybrid /t 0

Re: LM20 erkennt sda (mit Win10) nicht
« Antwort #26 am: 18.09.2020, 18:40:53 »
...so, bin wieder da.

Also auch der 3.te hergestellte Live-Stick mit Echter führte zum selben Ergebnis (daran liegt ea also nicht).

@tommix,
deine Terminalanweisung brachte folgendes Ergebnis:
mint@mint:~$ sudo bash -c "for d in \$(parted -l|grep -o \"/dev/[^ :]*\");do case \$(hexdump -v -s 0x80 -n 2 -e '2/1 \"%x\" \"\n\"' \$d) in 'aa75'|'5272') echo \$d: Grub Legacy;;'48b4'|'7c3c'|'020') echo \$d: Grub 2;;*) echo \$d;;esac;done"
/dev/sda
/dev/sdb
/dev/sdc
mint@mint:~$

...wobei die Installationsroutine von LM (Mate) sda nicht sieht (siehe Anhang: nach ausgeführten Install für grub auf sda kommt das kleine Fenster - das kann ohne zugehörige root-Partition ja auch nicht funktionieren):

@ehtron,
nachdem ich mit Deiner Anweisung Win10 runter gefahren habe und danach mit dem Live-Stick LM installieren wollte, kam wieder das gleiche Fenster, wie im Anhang -> keine sda-Partitionen.

@tommix,
ob ich Cinnamon oder Mate installiere, dass dürfte der Installroutine eigentlich ziemlich egal sein. Was meinst Du mit: Meine Platte muß so aussehen?
Das Einzige was ich in Deinen Vorgaben da hinein interpretiere ist, dass evt die Bootpartition (irgendwas mit 500 MB) bei meinem Bruder zu groß ist - meinst Du das?

-volker-
« Letzte Änderung: 18.09.2020, 18:44:00 von Volker S »

Re: LM20 erkennt sda (mit Win10) nicht
« Antwort #27 am: 18.09.2020, 18:50:11 »
Was willst du den mit sdb5 machen?
Da soll doch nicht etwa Linux Mint drauf?
Auf eine NTFS - Partition!?

Linux kommt auf eine ext4!

Re: LM20 erkennt sda (mit Win10) nicht
« Antwort #28 am: 18.09.2020, 18:54:13 »
Siehe mein Eingangsmail mit den dort gezeigten Partitionaufteilungen (sudo parted -l). sdb ist eine Datenplatte.

-volker-

Re: LM20 erkennt sda (mit Win10) nicht
« Antwort #29 am: 18.09.2020, 18:58:51 »
Was machst du dann auf sdb?

Was wird dann sda5?
was wird dann sda6?