Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
17.04.2021, 03:46:48

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 25502
  • Letzte: j.red
Statistiken
  • Beiträge insgesamt: 729240
  • Themen insgesamt: 58836
  • Heute online: 414
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online
Mitglieder: 2
Gäste: 242
Gesamt: 244

Autor Thema: [gelöst]  LM20: Gimp nach Bereinigung nur noch per Flatpack?  (Gelesen 718 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] LM20: Gimp nach Bereinigung nur noch per Flatpack?
« am: 15.07.2020, 16:14:07 »
LM 20 Mate

Hi,
nachdem ich hier nach einer Paketinstallation das hier
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 1 nicht aktualisiert.stehen hatte, wollte ich dem etwas auf den Grund gehen.

In einem Nachbarthread gab es schon ein ähnliches Problem und ich klinkte mich da ein.

Nach dem Absetzen von:
apt list --upgradable
...bekam ich folgendes Ergebnis:
Auflistung... Fertig
libavcodec-extra/focal 7:4.2.2-1ubuntu1 all [aktualisierbar von: 7:3.4.6-0ubuntu0.18.04.1]
libgegl-0.4-0/focal 1:0.4.18+om-0ubu20.04.18~ppa amd64 [aktualisierbar von: 0.4.22-3]
libgegl-dev/focal 1:0.4.18+om-0ubu20.04.18~ppa amd64 [aktualisierbar von: 0.4.22-3]

Nun, in der Synaptic-Paketverwaltung bekam ich unter "Aktualisierbare Pakete" ebenfalls diese 3 Pakete angezeigt - allerdings auch unter "fehlerhafte Pakete".
Da man die Abhängigkeiten im Synaptic gut erkennen kann, konnte man den Fehlern entgegenwirken. Der libavcodec-extra wurde durch den libavcodec-extra58 ersetzt (konnte nicht gelöscht werden, wegen irgendwelcher Paketunstimmigkeiten).
Die anderen Beiden habe ich löschen lassen (vor der ganzen Aktion natürlich ein Backup gefahren).

Nun, der libgegl-0.4-0 schmeißt dabei auch gimp und die (ebenfalls mit gimp installierte) Scannersoft 'XSane' raus. Danach hab ich das System aufgefrischt und neu gebootet.

Synaptic zeigte mir dann auch keine Fehler mehr an. Ergo wollte ich gimp neu installieren:

~$ sudo apt install gimp
[sudo] Passwort für volker:         
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 gimp : Hängt ab von: libgimp2.0 (>= 2.10.18) soll aber nicht installiert werden
        Hängt ab von: libgimp2.0 (<= 2.10.18-z) soll aber nicht installiert werden
        Hängt ab von: libgegl-0.4-0 (>= 0.4.22) soll aber nicht installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.

Prima :( In anderen Foren haben sie dann Gimp per Flatpack (ungefähr 2 GB) installiert (ok, ist ja nicht nur Gimp - beim Erstinstall wird ja nochmal das halbe System mit installiert - nachfolgende Installationen sind ja dann wieder kleiner - ich mag den Mist aber nicht).
Auch die andere Standardpaketverwaltung zeigte mit Gimp nur als Flatpackvariante als installierbar an :(

Ein Forenuser empfahl dann Gimp mittels 'aptitude' zu installieren. Da auch hier der erste Versuch in die Hose ging und ich beim 2.ten Versuch eine Abfrage verneinte verlinke ich das komplette Script für Interessierte mal (Achtung, ist echt lang):
volker@linux:~$ sudo aptitude install gimp
Die folgenden NEUEN Pakete werden zusätzlich installiert:
  gimp gimp-data{a} libgegl-0.4-0{ab} libgimp2.0{a} libheif1{a}
  libmypaint-1.5-1{a} libmypaint-common{a}
0 Pakete aktualisiert, 7 zusätzlich installiert, 0 werden entfernt und 0 nicht aktualisiert.
13,3 MB an Archiven müssen heruntergeladen werden. Nach dem Entpacken werden 81,4 MB zusätzlich belegt sein.
Die folgenden Pakete haben verletzte Abhängigkeiten:
 libgegl-0.4-0 : Hängt ab von: libopenexr23 welches ein virtuelles Paket ist und nicht durch ein verfügbares Paket bereitgestellt wird

Die folgenden Aktionen werden diese Abhängigkeiten auflösen:

     Beibehalten der folgenden Pakete in ihrer aktuellen Version:
1)     gimp [Nicht installiert]                                 
2)     libgegl-0.4-0 [Nicht installiert]                         
3)     libgimp2.0 [Nicht installiert]                           



Diese Lösung akzeptieren? [Y/n/q/?] Y
Es werden keine Pakete installiert, aktualisiert oder entfernt.
0 Pakete aktualisiert, 0 zusätzlich installiert, 0 werden entfernt und 0 nicht aktualisiert.
0 B an Archiven müssen heruntergeladen werden. Nach dem Entpacken werden 0 B zusätzlich belegt sein.


Jetzt kommt der 2.te Versuch
******************************************

volker@linux:~$ sudo aptitude install gimp
Die folgenden NEUEN Pakete werden zusätzlich installiert:
  gimp gimp-data{a} libgegl-0.4-0{ab} libgimp2.0{a} libheif1{a}
  libmypaint-1.5-1{a} libmypaint-common{a}
0 Pakete aktualisiert, 7 zusätzlich installiert, 0 werden entfernt und 0 nicht aktualisiert.
13,3 MB an Archiven müssen heruntergeladen werden. Nach dem Entpacken werden 81,4 MB zusätzlich belegt sein.
Die folgenden Pakete haben verletzte Abhängigkeiten:
 libgegl-0.4-0 : Hängt ab von: libopenexr23 welches ein virtuelles Paket ist und nicht durch ein verfügbares Paket bereitgestellt wird

Die folgenden Aktionen werden diese Abhängigkeiten auflösen:

     Beibehalten der folgenden Pakete in ihrer aktuellen Version:
1)     gimp [Nicht installiert]                                 
2)     libgegl-0.4-0 [Nicht installiert]                         
3)     libgimp2.0 [Nicht installiert]                           



Diese Lösung akzeptieren? [Y/n/q/?] n
Die folgenden Aktionen werden diese Abhängigkeiten auflösen:

     Installieren der folgenden Pakete:
1)     libgegl-0.4-0 [0.4.22-3 (focal)]



Diese Lösung akzeptieren? [Y/n/q/?] y
Die folgenden NEUEN Pakete werden zusätzlich installiert:
  gimp gimp-data{a} libgegl-0.4-0{a} libgimp2.0{a} libheif1{a}
  libmypaint-1.5-1{a} libmypaint-common{a}
0 Pakete aktualisiert, 7 zusätzlich installiert, 0 werden entfernt und 0 nicht aktualisiert.
12,4 MB/13,3 MB an Archiven müssen heruntergeladen werden. Nach dem Entpacken werden 81,1 MB zusätzlich belegt sein.
Möchten Sie fortsetzen? [Y/n/?] y
Holen: 1 http://ftp.hosteurope.de/mirror/archive.ubuntu.com focal/universe amd64 libgimp2.0 amd64 2.10.18-1 [428 kB]
Holen: 2 http://ftp.hosteurope.de/mirror/archive.ubuntu.com focal/universe amd64 gimp-data all 2.10.18-1 [7.322 kB]
Holen: 3 http://ftp.hosteurope.de/mirror/archive.ubuntu.com focal/universe amd64 libheif1 amd64 1.6.1-1build1 [164 kB]
Holen: 4 http://ftp.hosteurope.de/mirror/archive.ubuntu.com focal/universe amd64 libmypaint-common all 1.5.1-1 [139 kB]
Holen: 5 http://ftp.hosteurope.de/mirror/archive.ubuntu.com focal/universe amd64 libmypaint-1.5-1 amd64 1.5.1-1 [48,2 kB]
Holen: 6 http://ftp.hosteurope.de/mirror/archive.ubuntu.com focal/universe amd64 gimp amd64 2.10.18-1 [4.286 kB]
12,4 MB wurden in 3 s heruntergeladen (4.340 kB/s)
Vormals nicht ausgewähltes Paket libgegl-0.4-0:amd64 wird gewählt.
(Lese Datenbank ... 386217 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../0-libgegl-0.4-0_0.4.22-3_amd64.deb ...
Entpacken von libgegl-0.4-0:amd64 (0.4.22-3) ...
Vormals nicht ausgewähltes Paket libgimp2.0 wird gewählt.
Vorbereitung zum Entpacken von .../1-libgimp2.0_2.10.18-1_amd64.deb ...
Entpacken von libgimp2.0 (2.10.18-1) ...
Vormals nicht ausgewähltes Paket gimp-data wird gewählt.
Vorbereitung zum Entpacken von .../2-gimp-data_2.10.18-1_all.deb ...
Entpacken von gimp-data (2.10.18-1) ...
Vormals nicht ausgewähltes Paket libheif1:amd64 wird gewählt.
Vorbereitung zum Entpacken von .../3-libheif1_1.6.1-1build1_amd64.deb ...
Entpacken von libheif1:amd64 (1.6.1-1build1) ...
Vormals nicht ausgewähltes Paket libmypaint-common wird gewählt.
Vorbereitung zum Entpacken von .../4-libmypaint-common_1.5.1-1_all.deb ...
Entpacken von libmypaint-common (1.5.1-1) ...
Vormals nicht ausgewähltes Paket libmypaint-1.5-1:amd64 wird gewählt.
Vorbereitung zum Entpacken von .../5-libmypaint-1.5-1_1.5.1-1_amd64.deb ...
Entpacken von libmypaint-1.5-1:amd64 (1.5.1-1) ...
Vormals nicht ausgewähltes Paket gimp wird gewählt.
Vorbereitung zum Entpacken von .../6-gimp_2.10.18-1_amd64.deb ...
Entpacken von gimp (2.10.18-1) ...
libmypaint-common (1.5.1-1) wird eingerichtet ...
libheif1:amd64 (1.6.1-1build1) wird eingerichtet ...
libmypaint-1.5-1:amd64 (1.5.1-1) wird eingerichtet ...
gimp-data (2.10.18-1) wird eingerichtet ...
libgegl-0.4-0:amd64 (0.4.22-3) wird eingerichtet ...
libgimp2.0 (2.10.18-1) wird eingerichtet ...
gimp (2.10.18-1) wird eingerichtet ...
Trigger für mime-support (3.64ubuntu1) werden verarbeitet ...
Trigger für hicolor-icon-theme (0.17-2) werden verarbeitet ...
Trigger für libc-bin (2.31-0ubuntu9) werden verarbeitet ...
Trigger für man-db (2.9.1-1) werden verarbeitet ...
Trigger für desktop-file-utils (0.24+linuxmint1) werden verarbeitet ...
                                                   
Aktueller Status: 1 (+1) aktualisierbar.

Nun sagt mir zwar ein "sudo apt-get dist-upgrade -s" wieder
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
Aber Synaptic zeigt mir natürlich wieder Folgendes an:


Die Terminalausgabe:
volker@linux:~$ apt list --upgradable -a
Auflistung... Fertig
libgegl-0.4-0/focal 1:0.4.18+om-0ubu20.04.18~ppa amd64 [aktualisierbar von: 0.4.22-3]
libgegl-0.4-0/focal,now 0.4.22-3 amd64  [Installiert,aktualisierbar auf: 1:0.4.18+om-0ubu20.04.18~ppa]


Tja, was macht man jetzt? Echt die Flatpackvariante installieren?

-Volker-
« Letzte Änderung: 15.07.2020, 21:32:06 von Volker S »

Re: LM20: Gimp nach Bereinigung nur noch per Flatpack?
« Antwort #1 am: 15.07.2020, 17:09:34 »
Ich würde das nicht tun, aus grundsätzlichen Erwägungen.
Flatpack ist eine unselige Entwicklung, die ich nicht gut finde.
Es gibt doch Alternativen:

https://www.gimp.org/downloads/

Re: LM20: Gimp nach Bereinigung nur noch per Flatpack?
« Antwort #2 am: 15.07.2020, 17:32:18 »
...das ist zu 99% auch nicht besser, als Gimp aus der Paketverwaltung zu installieren.

gimp : Hängt ab von: libgimp2.0 (>= 2.10.18) soll aber nicht installiert werden
        Hängt ab von: libgimp2.0 (<= 2.10.18-z) soll aber nicht installiert werden
        Hängt ab von: libgegl-0.4-0 (>= 0.4.22) soll aber nicht installiert werden


-volker-

Re: LM20: Gimp nach Bereinigung nur noch per Flatpack?
« Antwort #3 am: 15.07.2020, 17:44:20 »
Kann ich den jetzigen libgegl denn dabei installiert lassen? Denn wenn ich den deinstalliere ist auch wieder gimp weg.
Wenn ich danach dann das ppa "deb http://ppa.launchpad.net/otto-kesselgulasch/gimp/ubuntu focal main" deaktiviere, kann ich dann gimp immer noch installieren?

Also in Kurzform:
a) Deine Variante - ohne eine vorige Deinstallation des jetzigen libgegl
b) jetziges libgegl deinstallieren (und damit auch Gimp), ppa rausschmeißen und ein "sudo apt install gimp" absetzen (weiß nicht ob es dann noch geht).

-volker-

Re: LM20: Gimp nach Bereinigung nur noch per Flatpack?
« Antwort #4 am: 15.07.2020, 17:48:06 »
@Volker S, du stellst das ja dar, als wenn gimp sich nur als flatpak installieren ließe. Dem ist nicht so.
Wenn du Probleme mit deiner Paketverwaltung hast, ist das eine Sache.
Aber keine Sache die grundsätzlich für Linux Mint 20 und einer gimp Installation steht.

sudo apt-get install -s gimp
[sudo] Passwort für mintcin:       
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Die folgenden zusätzlichen Pakete werden installiert:
  gimp-data libamd2 libbabl-0.1-0 libblas3 libcamd2 libccolamd2 libcholmod3 libgegl-0.4-0 libgegl-common libgexiv2-2 libgfortran5 libgimp2.0 libheif1 liblapack3 libmetis5
  libmng2 libmypaint-1.5-1 libmypaint-common libraw19 libumfpack5
Vorgeschlagene Pakete:
  gimp-help-en | gimp-help gimp-data-extras
Die folgenden NEUEN Pakete werden installiert:
  gimp gimp-data libamd2 libbabl-0.1-0 libblas3 libcamd2 libccolamd2 libcholmod3 libgegl-0.4-0 libgegl-common libgexiv2-2 libgfortran5 libgimp2.0 libheif1 liblapack3
  libmetis5 libmng2 libmypaint-1.5-1 libmypaint-common libraw19 libumfpack5
0 aktualisiert, 21 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
Hinweis, bei mir funzt die Paketverwaltung. Habe bisher keine ppas aktiviert und ich hatte Mint neu installiert!

Re: LM20: Gimp nach Bereinigung nur noch per Flatpack?
« Antwort #5 am: 15.07.2020, 17:52:41 »
@BR01,
man soll die Problematik ja kurz und knapp in der Überschrifft erfassen können. Da ich natürlich nicht wissen kann, dass diese Problematik sich auf alle Installationen auswirkt - deshalb steht da ja ein Fragezeichen hinter meinem eröffneten Thema.

-volker-

Re: LM20: Gimp nach Bereinigung nur noch per Flatpack?
« Antwort #6 am: 15.07.2020, 17:54:12 »
Das könntest du kürzer in einer überschrift halt:
"Probleme bei gimp Installation"

Und keine Vermutungen in der Überschrift...

Re: LM20: Gimp nach Bereinigung nur noch per Flatpack?
« Antwort #7 am: 15.07.2020, 21:22:20 »
@lmumischabln

wollt mich hier nochmal extra bedanken - allein das Deaktivieren des PPA's und das darauf folgende Aufrischen des Paketcaches und des Systems hat den Fehler verschwinden lassen. Alles ist gut :)

-volker-