Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
13.04.2021, 13:25:22

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 728320
  • Themen insgesamt: 58788
  • Heute online: 562
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  apt meldet Konflikt nach Upgrade von 19.3 auf 20  (Gelesen 566 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

apt meldet Konflikt nach Upgrade von 19.3 auf 20
« am: 15.07.2020, 19:58:27 »
Das Upgrade von Linux Mint 19.3 auf 20 hat gut geklappt, aber irgendwas klemmt noch bei den installierten Komponenten:
(base) rico@hex:~$ sudo apt upgrade
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Probieren Sie »apt --fix-broken install«, um dies zu korrigieren.
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 libc-dev-bin : Hängt ab von: libc6 (< 2.28) aber 2.31-0ubuntu9 ist installiert
 libc6-dbg : Hängt ab von: libc6 (= 2.27-3ubuntu1.2) aber 2.31-0ubuntu9 ist installiert
 libc6-dev : Hängt ab von: libc6 (= 2.27-3ubuntu1.2) aber 2.31-0ubuntu9 ist installiert
 libc6-i386 : Hängt ab von: libc6 (= 2.27-3ubuntu1.2) aber 2.31-0ubuntu9 ist installiert
E: Unerfüllte Abhängigkeiten. Versuchen Sie »apt --fix-broken install« ohne Angabe eines Pakets (oder geben Sie eine Lösung an).

Der vorgeschlagene Befehl "apt --fix-broken install" funktioniert garnicht - das zeigt immer nur die apt-Hilfe.
"sudo apt-get --fix-broken install" tut dann auch etwas, leider ohne Erfolg :-(

(base) rico@hex:~$ sudo apt-get --fix-broken install
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Abhängigkeiten werden korrigiert ... Fertig
Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
  gnome-session-common gtk2-engines-xfce nextcloud-client nextcloud-client-l10n xwayland-hwe-18.04
Verwenden Sie »sudo apt autoremove«, um sie zu entfernen.
Die folgenden zusätzlichen Pakete werden installiert:
  libc-dev-bin libc6-dbg libc6-dev libc6-i386 libcrypt-dev
Vorgeschlagene Pakete:
  glibc-doc
Die folgenden NEUEN Pakete werden installiert:
  libcrypt-dev
Die folgenden Pakete werden aktualisiert (Upgrade):
  libc-dev-bin libc6-dbg libc6-dev libc6-i386
4 aktualisiert, 1 neu installiert, 0 zu entfernen und 1240 nicht aktualisiert.
2 nicht vollständig installiert oder entfernt.
Es müssen noch 0 B von 11,1 MB an Archiven heruntergeladen werden.
Nach dieser Operation werden 7.613 kB Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren? [J/n]
libc-bin (2.31-0ubuntu9) wird eingerichtet ...
Bus error (core dumped)
/sbin/ldconfig.real: Can't stat /usr/local/lib/i386-linux-gnu: No such file or directory
/sbin/ldconfig.real: Can't stat /usr/local/lib/i686-linux-gnu: No such file or directory
/sbin/ldconfig.real: Can't stat /lib/i686-linux-gnu: No such file or directory
/sbin/ldconfig.real: Can't stat /usr/lib/i686-linux-gnu: No such file or directory
/sbin/ldconfig.real: Can't stat /usr/local/lib/x86_64-linux-gnu: No such file or directory
/sbin/ldconfig.real: Path `/lib/x86_64-linux-gnu' given more than once
/sbin/ldconfig.real: Path `/usr/lib/x86_64-linux-gnu' given more than once
/usr/lib/x86_64-linux-gnu/libfakeroot:
libfakeroot-0.so -> libfakeroot-tcp.so
/lib/i386-linux-gnu:
libcrypt.so.1 -> libcrypt.so.1.1.0
libutil.so.1 -> libutil-2.31.so
libthread_db.so.1 -> libthread_db-1.0.so
librt.so.1 -> librt-2.31.so
libresolv.so.2 -> libresolv-2.31.so
libpthread.so.0 -> libpthread-2.31.so
libpcprofile.so -> libpcprofile.so
libnss_nisplus.so.2 -> libnss_nisplus-2.31.so
libnss_nis.so.2 -> libnss_nis-2.31.so
libnss_hesiod.so.2 -> libnss_hesiod-2.31.so
libnss_files.so.2 -> libnss_files-2.31.so
libnss_dns.so.2 -> libnss_dns-2.31.so
libnss_compat.so.2 -> libnss_compat-2.31.so
libnsl.so.1 -> libnsl-2.31.so
libmemusage.so -> libmemusage.so
libm.so.6 -> libm-2.31.so
libdl.so.2 -> libdl-2.31.so
libc.so.6 -> libc-2.31.so
libanl.so.1 -> libanl-2.31.so
libSegFault.so -> libSegFault.so
libBrokenLocale.so.1 -> libBrokenLocale-2.31.so
/sbin/ldconfig.real: /lib/i386-linux-gnu/ld-2.31.so is the dynamic linker, ignoring

ld-linux.so.2 -> ld-2.31.so
libgcc_s.so.1 -> libgcc_s.so.1
libncurses.so.5 -> libncurses.so.5.9
libtinfo.so.5 -> libtinfo.so.5.9
libkeyutils.so.1 -> libkeyutils.so.1.8
libexpat.so.1 -> libexpat.so.1.6.11
libcap.so.2 -> libcap.so.2.32
libpcre.so.3 -> libpcre.so.3.13.3
liblzma.so.5 -> liblzma.so.5.2.4
libz.so.1 -> libz.so.1.2.11
libdbus-1.so.3 -> libdbus-1.so.3.19.4
libsystemd.so.0 -> libsystemd.so.0.21.0
libudev.so.1 -> libudev.so.1.6.9
libcom_err.so.2 -> libcom_err.so.2.1
libusb-1.0.so.0 -> libusb-1.0.so.0.1.0
libmount.so.1 -> libmount.so.1.1.0
libselinux.so.1 -> libselinux.so.1
libblkid.so.1 -> libblkid.so.1.1.0
libuuid.so.1 -> libuuid.so.1.3.0
libgcrypt.so.20 -> libgcrypt.so.20.2.1
libgpg-error.so.0 -> libgpg-error.so.0.22.0
/usr/lib/i386-linux-gnu:
libXxf86vm.so.1 -> libXxf86vm.so.1.0.0
libXss.so.1 -> libXss.so.1.0.0
libxcb-xfixes.so.0 -> libxcb-xfixes.so.0.0.0
libxcb-sync.so.1 -> libxcb-sync.so.1.0.0
libxcb-present.so.0 -> libxcb-present.so.0.0.0
libxcb-glx.so.0 -> libxcb-glx.so.0.0.0
libxcb-dri2.so.0 -> libxcb-dri2.so.0.0.0
libwrap.so.0 -> libwrap.so.0.7.6
libv4lconvert.so.0 -> libv4lconvert.so.0.0.0
libv4l2.so.0 -> libv4l2.so.0.0.0
libv4l1.so.0 -> libv4l1.so.0.0.0
libtheoraenc.so.1 -> libtheoraenc.so.1.1.2
libtheoradec.so.1 -> libtheoradec.so.1.1.4
libtheora.so.0 -> libtheora.so.0.3.10
libsamplerate.so.0 -> libsamplerate.so.0.1.8
liborc-test-0.4.so.0 -> liborc-test-0.4.so.0.31.0
liborc-0.4.so.0 -> liborc-0.4.so.0.31.0
libodbccr.so.2 -> libodbccr.so.2.0.0
libodbc.so.2 -> libodbc.so.2.0.0
libgsm.so.1 -> libgsm.so.1.0.18
libdrm_radeon.so.1 -> libdrm_radeon.so.1.0.1
libdrm_nouveau.so.2 -> libdrm_nouveau.so.2.0.0
libdrm_intel.so.1 -> libdrm_intel.so.1.0.0
libvorbis.so.0 -> libvorbis.so.0.4.8
libvorbisenc.so.2 -> libvorbisenc.so.2.0.11
libogg.so.0 -> libogg.so.0.8.4
libltdl.so.7 -> libltdl.so.7.3.1
libX11-xcb.so.1 -> libX11-xcb.so.1.0.0
libXrandr.so.2 -> libXrandr.so.2.2.0
libxkbcommon.so.0 -> libxkbcommon.so.0.0.0
libXdamage.so.1 -> libXdamage.so.1.1.0
libXcursor.so.1 -> libXcursor.so.1.0.2
libXfixes.so.3 -> libXfixes.so.3.1.0
libXcomposite.so.1 -> libXcomposite.so.1.0.0
libxcb-shm.so.0 -> libxcb-shm.so.0.0.0
libxcb-render.so.0 -> libxcb-render.so.0.0.0
libwayland-egl.so.1 -> libwayland-egl.so.1.0.0
libpanel.so.5 -> libpanel.so.5.9
libmenu.so.5 -> libmenu.so.5.9
libform.so.5 -> libform.so.5.9
libtic.so.5 -> libtic.so.5.9
libjpeg.so.8 -> libjpeg.so.8.2.2
libhx509.so.5 -> libhx509.so.5.0.0
libgssapi.so.3 -> libgssapi.so.3.0.0
libheimntlm.so.0 -> libheimntlm.so.0.1.0
libwind.so.0 -> libwind.so.0.0.0
libhcrypto.so.4 -> libhcrypto.so.4.1.0
libheimbase.so.1 -> libheimbase.so.1.0.0
libavahi-client.so.3 -> libavahi-client.so.3.2.9
libasn1.so.8 -> libasn1.so.8.0.0
libXau.so.6 -> libXau.so.6.0.0
libtasn1.so.6 -> libtasn1.so.6.6.0
libidn2.so.0 -> libidn2.so.0.3.6
libunistring.so.2 -> libunistring.so.2.1.0
libgmp.so.10 -> libgmp.so.10.4.0
libexpatw.so.1 -> libexpatw.so.1.6.11
libpcreposix.so.3 -> libpcreposix.so.3.13.3
liblz4.so.1 -> liblz4.so.1.9.2
libXinerama.so.1 -> libXinerama.so.1.0.0
libxcb-dri3.so.0 -> libxcb-dri3.so.0.0.0
libGLdispatch.so.0 -> libGLdispatch.so.0.0.0
libGLX.so.0 -> libGLX.so.0.0.0
libGL.so.1 -> libGL.so.1.7.0
libEGL.so.1 -> libEGL.so.1.1.0
libpciaccess.so.0 -> libpciaccess.so.0.11.1
libXdmcp.so.6 -> libXdmcp.so.6.0.0
libbsd.so.0 -> libbsd.so.0.10.0
libXi.so.6 -> libXi.so.6.1.0
libXext.so.6 -> libXext.so.6.4.0
libpulse.so.0 -> libpulse.so.0.20.2
libpulse-simple.so.0 -> libpulse-simple.so.0.1.1
libgnutls.so.30 -> libgnutls.so.30.14.10
libexif.so.12 -> libexif.so.12.3.3
libdrm_amdgpu.so.1 -> libdrm_amdgpu.so.1.0.0
libdrm.so.2 -> libdrm.so.2.4.0
libsqlite3.so.0 -> libsqlite3.so.0.8.6
libssl.so.1.1 -> libssl.so.1.1
libcrypto.so.1.1 -> libcrypto.so.1.1
libldap_r-2.4.so.2 -> libldap_r-2.4.so.2.10.8
liblber-2.4.so.2 -> liblber-2.4.so.2.10.8
libcups.so.2 -> libcups.so.2
libGLU.so.1 -> libGLU.so.1.3.1
libOSMesa.so.8 -> libOSMesa.so.8.0.0
libcapi20.so.3 -> libcapi20.so.3.0.6
libxslt.so.1 -> libxslt.so.1.1.29
libexslt.so.0 -> libexslt.so.0.8.17
libSDL2-2.0.so.0 -> libSDL2-2.0.so.0.8.0
libwayland-cursor.so.0 -> libwayland-cursor.so.0.0.0
libsane.so.1 -> libsane.so.1.0.27
libieee1284.so.3 -> libieee1284.so.3.2.2
libgpm.so.2 -> libgpm.so.2
libEGL_mesa.so.0 -> libEGL_mesa.so.0.0.0
libwayland-client.so.0 -> libwayland-client.so.0.3.0
libgbm.so.1 -> libgbm.so.1.0.0
libwayland-server.so.0 -> libwayland-server.so.0.1.0
libavahi-common.so.3 -> libavahi-common.so.3.5.3
libvisual-0.4.so.0 -> libvisual-0.4.so.0.0.0
libcairo.so.2 -> libcairo.so.2.11510.0
libXrender.so.1 -> libXrender.so.1.3.0
libpixman-1.so.0 -> libpixman-1.so.0.34.0
libopus.so.0 -> libopus.so.0.5.2
libcdda_paranoia.so.0 -> libcdda_paranoia.so.0.10.2
libcdda_interface.so.0 -> libcdda_interface.so.0.10.2
libgssapi_krb5.so.2 -> libgssapi_krb5.so.2.2
libkrb5.so.3 -> libkrb5.so.3.3
libk5crypto.so.3 -> libk5crypto.so.3.1
libkrb5support.so.0 -> libkrb5support.so.0.1
libspeexdsp.so.1 -> libspeexdsp.so.1.5.0
libjackserver.so.0 -> libjackserver.so.0.1.0
libjacknet.so.0 -> libjacknet.so.0.1.0
libjack.so.0 -> libjack.so.0.1.0
libOpenCL.so.1 -> libOpenCL.so.1.0.0
libsndfile.so.1 -> libsndfile.so.1.0.28
libFLAC.so.8 -> libFLAC.so.8.3.0
libasyncns.so.0 -> libasyncns.so.0.3.1
libpcap.so.0.8 -> libpcap.so.1.8.1
libopenal.so.1 -> libopenal.so.1.18.2
libsndio.so.6.1 -> libsndio.so.6.1
libmpg123.so.0 -> libmpg123.so.0.44.8
libsasl2.so.2 -> libsasl2.so.2.0.25
libdb-5.3.so -> libdb-5.3.so
libkrb5.so.26 -> libkrb5.so.26.0.0
libroken.so.18 -> libroken.so.18.1.0
libp11-kit.so.0 -> libp11-kit.so.0.3.0
libhogweed.so.4 -> libhogweed.so.4.4
libnettle.so.6 -> libnettle.so.6.4
liblcms2.so.2 -> liblcms2.so.2.0.8
libgstvideo-1.0.so.0 -> libgstvideo-1.0.so.0.1405.0
libgsttag-1.0.so.0 -> libgsttag-1.0.so.0.1405.0
libgstsdp-1.0.so.0 -> libgstsdp-1.0.so.0.1405.0
libgstrtsp-1.0.so.0 -> libgstrtsp-1.0.so.0.1405.0
libgstrtp-1.0.so.0 -> libgstrtp-1.0.so.0.1405.0
libgstriff-1.0.so.0 -> libgstriff-1.0.so.0.1405.0
libgstpbutils-1.0.so.0 -> libgstpbutils-1.0.so.0.1405.0
libgstfft-1.0.so.0 -> libgstfft-1.0.so.0.1405.0
libgstaudio-1.0.so.0 -> libgstaudio-1.0.so.0.1405.0
libgstapp-1.0.so.0 -> libgstapp-1.0.so.0.1405.0
libgstallocators-1.0.so.0 -> libgstallocators-1.0.so.0.1405.0
libgstreamer-1.0.so.0 -> libgstreamer-1.0.so.0.1405.0
libgstnet-1.0.so.0 -> libgstnet-1.0.so.0.1405.0
libgstcontroller-1.0.so.0 -> libgstcontroller-1.0.so.0.1405.0
libgstcheck-1.0.so.0 -> libgstcheck-1.0.so.0.1405.0
libgstbase-1.0.so.0 -> libgstbase-1.0.so.0.1405.0
libgphoto2.so.6 -> libgphoto2.so.6.0.0
libxml2.so.2 -> libxml2.so.2.9.4
libicuuc.so.60 -> libicuuc.so.60.2
libicutu.so.60 -> libicutu.so.60.2
libicutest.so.60 -> libicutest.so.60.2
libicuio.so.60 -> libicuio.so.60.2
libicui18n.so.60 -> libicui18n.so.60.2
libicudata.so.60 -> libicudata.so.60.2
libgphoto2_port.so.12 -> libgphoto2_port.so.12.0.0
libgd.so.3 -> libgd.so.3.0.5
libXpm.so.4 -> libXpm.so.4.11.0
libwebp.so.6 -> libwebp.so.6.0.2
libtiff.so.5 -> libtiff.so.5.3.0
libjbig.so.0 -> libjbig.so.0
libfontconfig.so.1 -> libfontconfig.so.1.10.1
libfreetype.so.6 -> libfreetype.so.6.15.0
libpng16.so.16 -> libpng16.so.16.34.0
libgthread-2.0.so.0 -> libgthread-2.0.so.0.5600.4
libgobject-2.0.so.0 -> libgobject-2.0.so.0.5600.4
libgmodule-2.0.so.0 -> libgmodule-2.0.so.0.5600.4
libglib-2.0.so.0 -> libglib-2.0.so.0.5600.4
libgio-2.0.so.0 -> libgio-2.0.so.0.5600.4
libasound.so.2 -> libasound.so.2.0.0
libGLX_mesa.so.0 -> libGLX_mesa.so.0.0.0
libxshmfence.so.1 -> libxshmfence.so.1.0.0
libsensors.so.4 -> libsensors.so.4.4.0
libLLVM-9.so.1 -> libLLVM-9.so.1
libffi.so.6 -> libffi.so.6.0.4
libedit.so.2 -> libedit.so.2.0.56
libatomic.so.1 -> libatomic.so.1.2.0
libglapi.so.0 -> libglapi.so.0.0.0
libelf.so.1 -> libelf-0.170.so
libX11.so.6 -> libX11.so.6.3.0
libxcb.so.1 -> libxcb.so.1.1.0
libstdc++.so.6 -> libstdc++.so.6.0.25
/usr/local/lib:
/lib/x86_64-linux-gnu:
libcrypt.so.1 -> libcrypt.so.1.1.0
libutil.so.1 -> libutil-2.31.so
libthread_db.so.1 -> libthread_db-1.0.so
librt.so.1 -> librt-2.31.so
libresolv.so.2 -> libresolv-2.31.so
libpthread.so.0 -> libpthread-2.31.so
libpcprofile.so -> libpcprofile.so
libnss_nisplus.so.2 -> libnss_nisplus-2.31.so
libnss_nis.so.2 -> libnss_nis-2.31.so
libnss_hesiod.so.2 -> libnss_hesiod-2.31.so
libnss_files.so.2 -> libnss_files-2.31.so
libnss_dns.so.2 -> libnss_dns-2.31.so
libnss_compat.so.2 -> libnss_compat-2.31.so
libnsl.so.1 -> libnsl-2.31.so
libmvec.so.1 -> libmvec-2.31.so
libmemusage.so -> libmemusage.so
libm.so.6 -> libm-2.31.so
libdl.so.2 -> libdl-2.31.so
libc.so.6 -> libc-2.31.so
libanl.so.1 -> libanl-2.31.so
libSegFault.so -> libSegFault.so
libBrokenLocale.so.1 -> libBrokenLocale-2.31.so
/sbin/ldconfig.real: /lib/x86_64-linux-gnu/ld-2.31.so is the dynamic linker, ignoring

ld-linux-x86-64.so.2 -> ld-2.31.so
libgcc_s.so.1 -> libgcc_s.so.1
libiw.so.30 -> libiw.so.30
libnss_mdns_minimal.so.2 -> libnss_mdns_minimal.so.2
libnss_mdns6_minimal.so.2 -> libnss_mdns6_minimal.so.2
libnss_mdns6.so.2 -> libnss_mdns6.so.2
libnss_mdns4_minimal.so.2 -> libnss_mdns4_minimal.so.2
libnss_mdns4.so.2 -> libnss_mdns4.so.2
libnss_mdns.so.2 -> libnss_mdns.so.2
libusb-0.1.so.4 -> libusb-0.1.so.4.4.4
libdevmapper-event.so.1.02.1 -> libdevmapper-event.so.1.02.1
libnl-3.so.200 -> libnl-3.so.200.26.0
libnl-genl-3.so.200 -> libnl-genl-3.so.200.26.0
liblzo2.so.2 -> liblzo2.so.2.0.0
libncurses.so.5 -> libncurses.so.5.9
libncursesw.so.5 -> libncursesw.so.5.9
libtinfo.so.5 -> libtinfo.so.5.9
libidn.so.11 -> libidn.so.11.6.16
libkeyutils.so.1 -> libkeyutils.so.1.8
libexpat.so.1 -> libexpat.so.1.6.11
libcap.so.2 -> libcap.so.2.32
libss.so.2 -> libss.so.2.0
libsepol.so.1 -> libsepol.so.1
libpcre.so.3 -> libpcre.so.3.13.3
libfdisk.so.1 -> libfdisk.so.1.1.0
libbz2.so.1.0 -> libbz2.so.1.0.4
liblzma.so.5 -> liblzma.so.5.2.4
libsmartcols.so.1 -> libsmartcols.so.1.1.0
libz.so.1 -> libz.so.1.2.11
libpamc.so.0 -> libpamc.so.0.82.1
libpam_misc.so.0 -> libpam_misc.so.0.82.1
libpam.so.0 -> libpam.so.0.84.2
libaudit.so.1 -> libaudit.so.1.0.0
libcap-ng.so.0 -> libcap-ng.so.0.0.0
libdbus-1.so.3 -> libdbus-1.so.3.19.4
liblvm2app.so.2.2 -> liblvm2app.so.2.2
libdevmapper-event-lvm2.so.2.02 -> libdevmapper-event-lvm2.so.2.02
liblvm2cmd.so.2.02 -> liblvm2cmd.so.2.02
libjson-c.so.3 -> libjson-c.so.3.0.1
libdevmapper.so.1.02.1 -> libdevmapper.so.1.02.1
libsystemd.so.0 -> libsystemd.so.0.21.0
libnss_myhostname.so.2 -> libnss_myhostname.so.2
libudev.so.1 -> libudev.so.1.6.9
libnss_systemd.so.2 -> libnss_systemd.so.2
libdns-export.so.1100 -> libdns-export.so.1100.1.1
libisc-export.so.169 -> libisc-export.so.169.0.1
libcom_err.so.2 -> libcom_err.so.2.1
libgcrypt.so.20 -> libgcrypt.so.20.2.1
libmount.so.1 -> libmount.so.1.1.0
libblkid.so.1 -> libblkid.so.1.1.0
libuuid.so.1 -> libuuid.so.1.3.0
libext2fs.so.2 -> libext2fs.so.2.4
libe2p.so.2 -> libe2p.so.2.3
libusb-1.0.so.0 -> libusb-1.0.so.0.1.0
libulockmgr.so.1 -> libulockmgr.so.1.0.1
libslang.so.2 -> libslang.so.2.3.1
libselinux.so.1 -> libselinux.so.1
libreadline.so.7 -> libreadline.so.7.0
libreadline.so.5 -> libreadline.so.5.2
libprocps.so.6 -> libprocps.so.6.0.0
libply.so.4 -> libply.so.4.0.0
libply-splash-graphics.so.4 -> libply-splash-graphics.so.4.0.0
libply-splash-core.so.4 -> libply-splash-core.so.4.0.0
libply-boot-client.so.4 -> libply-boot-client.so.4.0.0
libpci.so.3 -> libpci.so.3.5.2
libparted.so.2 -> libparted.so.2.0.1
libparted-fs-resize.so.0 -> libparted-fs-resize.so.0.0.1
libntfs-3g.so.88 -> libntfs-3g.so.88.0.0
libnih.so.1 -> libnih.so.1.0.0
libmnl.so.0 -> libmnl.so.0.2.0
libhistory.so.7 -> libhistory.so.7.0
libhistory.so.5 -> libhistory.so.5.2
libgpg-error.so.0 -> libgpg-error.so.0.22.0
libfuse.so.2 -> libfuse.so.2.9.7
libcryptsetup.so.12 -> libcryptsetup.so.12.2.0
libbrlapi.so.0.6 -> libbrlapi.so.0.6.6
/usr/lib/x86_64-linux-gnu:
Bus error (core dumped)
dpkg: Fehler beim Bearbeiten des Paketes libc-bin (--configure):
 »installiertes libc-bin-Skript des Paketes post-installation«-Unterprozess gab den Fehlerwert 135 zurück
Fehler traten auf beim Bearbeiten von:
 libc-bin
E: Sub-process /usr/bin/dpkg returned an error code (1)

Was ich meine zu verstehen: Ich habe anscheinend libc6 in Version 2.31-0ubuntu9 installiert, brauche aber zwingend Version 2.27-3ubuntu1.2 davon.
Das müsste doch eigentlich mit einem der folgenden Befehle gehen, oder?
(base) rico@hex:~$ sudo apt install libc6=2.27-3ubuntu1.2
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
E: Version »2.27-3ubuntu1.2« für »libc6« konnte nicht gefunden werden.
(base) rico@hex:~$ sudo apt install libc6=2.27-3
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
E: Version »2.27-3« für »libc6« konnte nicht gefunden werden.
(base) rico@hex:~$ sudo apt install libc6=2.27
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
E: Version »2.27« für »libc6« konnte nicht gefunden werden.

Kann mir jemand helfen zu verstehen, was hier los ist und wie ich das löse?

Schonmal vielen Dank im Voraus für eure hilfreichen Antworten!


Re: apt meldet Konflikt nach Upgrade von 19.3 auf 20
« Antwort #1 am: 16.07.2020, 14:11:55 »
Hi :)
Zitat
4 aktualisiert, 1 neu installiert, 0 zu entfernen und 1240 nicht aktualisiert.

den genutzten desktop nachtagen.

in anwendungspaketquellen die ersten beiden wartungs punkte ausführen.

in synaptic unter status die zurückgebliebenen pakete entfernen
dann

sudo apt-get dist-upgrade

Sati

  • Gast
Re: apt meldet Konflikt nach Upgrade von 19.3 auf 20
« Antwort #2 am: 16.07.2020, 17:21:39 »
Erneut jemand der die Anweisungen zum Update nicht beherzigt hat

Purge PPAs and 3rd party repositories

PPAs or 3rd party repositories can introduce issues during the upgrade if the versions of the packages they provide are higher than in Linux Mint 20. This can result in unmet dependencies, held packages or resolver issues.

To purge 3rd party packages follow these steps:

        Launch the Software Sources tool from Menu ‣ Administration ‣ Software Sources.
        Open the Additional repositories tab and disable all additional repositories.
        Open the PPA tab and disable all PPAs.
        Click on the button to refresh your APT cache.
        Open the Maintenance tab and click on Downgrade Foreign Packages.
        Select all foreign packages and click Downgrade.
        Click on Remove Foreign Packages.
        Select all foreign packages and click Remove.
        Reboot the computer.
        Create another Timeshift snapshot.


Re: apt meldet Konflikt nach Upgrade von 19.3 auf 20
« Antwort #3 am: 16.07.2020, 17:23:30 »
Hi :)
das macht mintupgrade automatisch..

inxi -r

Sati

  • Gast
Re: apt meldet Konflikt nach Upgrade von 19.3 auf 20
« Antwort #4 am: 16.07.2020, 17:33:24 »
@ehtron;
Dann viel Erfolg mit den weiteren Fragen.
Meine Antworten wären gewesen:
Ist eine Timeshift Sicherung vorhanden?
Ja -- > Zurück zu der letzten 19.3 Sicherung
"How to upgrade to Linux Mint 20" dringend beherzigen.


Re: apt meldet Konflikt nach Upgrade von 19.3 auf 20
« Antwort #5 am: 17.07.2020, 16:25:31 »
Erneut jemand der die Anweisungen zum Update nicht beherzigt hat

Was du alles aus der Ferne erkennen kannst...

M.E. hatte ich diese Anleitung abgearbeitet - aber da man nie wissen kann, habe ich es einfach nochmal probiert.
  • Den BTRFS-Snapshot vor dem Update wiederhergestellt
  • alle anstehenden Updates eingespielt
  • alle PPAs deaktiviert
  • alle zusätzlichen Paketquellen deaktiviert
  • alle fremden Pakete herabgestuft
  • alle fremden Pakete entfernt
  • Reboot
  • Timeshift-Snapshot erstellt
  • apt install mintupgrade
  • mintupgrade check (Ausgabe sieht gut aus)
  • mintupgrade download
  • nochmal einen Timeshift-Snapshot erstellt
  • mintupgrade upgrade
Ergebnis:
/usr/lib/x86_64-linux-gnu:
Bus error (core dumped)
dpkg: Fehler beim Bearbeiten des Paketes libc-bin (--configure):
 »installiertes libc-bin-Skript des Paketes post-installation«-Unterprozess gab den Fehlerwert 135 zurück
Fehler traten auf beim Bearbeiten von:
 libc-bin
E: Sub-process /usr/bin/dpkg returned an error code (1)

  + An issue was detected during the upgrade, running dist-upgrade in manual mode....
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Probieren Sie »apt --fix-broken install«, um dies zu korrigieren.
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 libc-dev-bin : Hängt ab von: libc6 (< 2.28) aber 2.31-0ubuntu9 ist installiert
 libc6-dbg : Hängt ab von: libc6 (= 2.27-3ubuntu1.2) aber 2.31-0ubuntu9 ist installiert
 libc6-dev : Hängt ab von: libc6 (= 2.27-3ubuntu1.2) aber 2.31-0ubuntu9 ist installiert
 libc6-i386 : Hängt ab von: libc6 (= 2.27-3ubuntu1.2) aber 2.31-0ubuntu9 ist installiert
E: Unerfüllte Abhängigkeiten. Versuchen Sie »apt --fix-broken install« ohne Angabe eines Pakets (oder geben Sie eine Lösung an).

------------------------------------------------
!!  ERROR: Failed to dist-upgrade some of the packages. Please review the error message, use APT to fix the situation and try again.
!!  Exiting.
------------------------------------------------
Es ist also exakt die gleiche Problemlage wie beim letzten Mal.
Meine Hoffnung liegt nun darin, dass mir jemand sagen kann, wie ich die Ursache dieser unpassenden Versionen beheben kann.
Irgendwelche konstruktiven Ideen?

Ach ja: Die Installation ist übrigens immer noch der Meinung, auf Version 19.3 zu stehen:
(base) rico@hex:~$ cat /etc/issue
Linux Mint 19.3 Tricia \n \l