Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
15.04.2021, 05:14:21

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 25497
  • Letzte: shmoo
Statistiken
  • Beiträge insgesamt: 728773
  • Themen insgesamt: 58812
  • Heute online: 404
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online
Mitglieder: 3
Gäste: 273
Gesamt: 276

Autor Thema: [gelöst]  Interne-SSD bootet nicht  (Gelesen 496 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] Interne-SSD bootet nicht
« am: 08.01.2021, 17:16:27 »
Mint 19.1 Cinnamon
Hallo Forum, ich setze hier aus Gründen der Transparenz ein beendetes Thema neu auf.
Situation: Meine Mutter-SSD bootet nicht und das System reagiert dreizeilig mit dem Rescue-Modus.
Dort habe ich mir inzwischen mit "ls" die Partitionen anzeigen lassen.
Ausgabe: (hd0) (hd0,msdos1)
Nach Eingabe: "ls (hd0,msdos1)"
Ausgabe: ./ ../ lost+found/ swapfile etc/ ... boot/ ... root/ ...

Ich möchte gern einer Anleitung folgen, die ich nicht im Detail, aber ihrem Wesen nach, noch zu verstehen glaube.
Demnach würden jetzt folgen:
set prefix=(hd0,1)/grub
set root=(hd0,2)
insmod linux
insmod normal
normal
Weil ich mir nicht noch mehr zerschießen möchte, wäre ich dankbar wenn mir jemand auf Basis der o.a. Ausgaben
die richtigen Eingaben für die set-Befehlszeilen nennen könnte.
Dankbar wäre ich auch für zweckdienliche Hinweise, wenn ich hier formale Fehler gemacht haben sollte;
besonders, wie es richtig geht.
Mit freundlichem Gruß   Hans-Dieter
« Letzte Änderung: 12.01.2021, 19:58:30 von hadirost »

Re: Interne-SSD bootet nicht
« Antwort #1 am: 08.01.2021, 18:46:31 »
Hallo Forum, gelesen 38 mal und keine Antwort, das macht nachdenklich.
"Keine Antwort ist auch eine Antwort" - sagt man.
Nur, solche Art zu antworten macht nur Sinn, wenn der Fragende ahnen kann, was gemeint ist.
Zu meinen hätte ich nur, wenn ich unterstellen würde. Und das, meine ich, gehört sich nicht in einem Forum.
Also: Frisch auf, mit der Kritik, falls ich etwas falsch gemacht haben sollte.
Und, sollte es zur Kritik keinen Grund geben, vergesst was ich geschrieben habe, - nur nicht meine Fragen.
Bis dahin, mit freundlichen Grüßen   Hans-Dieter

Re: Interne-SSD bootet nicht
« Antwort #2 am: 08.01.2021, 18:58:36 »
Vielleicht mal mit einem aktuellen Live System starten und Boot Repair schauen lassen.

Re: Interne-SSD bootet nicht
« Antwort #3 am: 08.01.2021, 20:29:20 »
Hallo Forum, Guten Abend,

Aktuell stecken im Rechner;
Die interne, nicht bootende SSD Mint 19.1.
Gebootet, läuft daneben eine SSD Mint 19.3, mit der ich hier arbeite.
Kann ich von hier ebenfalls mit Boot Repair arbeiten?
Wenn ja, wäre es hilfreich,
wenn Ihr mir die zweckdienlichen Schritte ansagen könntest.
Mit freundlichem Gruß   Hans-Dieter
« Letzte Änderung: 08.01.2021, 21:12:00 von hadirost »

Re: Interne-SSD bootet nicht
« Antwort #4 am: 08.01.2021, 21:01:44 »
Hallo Forum, könnte Isolator gemeint haben:

Auf der "gebooteten SSD" Terminal öffnen und ...

sudo add-apt-repository ppa:yannubuntu/boot-repair
sudo apt-get update
sudo apt-get install -y boot-repair
boot-repair
im geöffneten Programm "Recommend Repair" wählen.

Das frage ich zur Sicherheit, weil ich nichts zerschießen möchte.
Mit freundlichem Gruß   Hans-Dieter
« Letzte Änderung: 08.01.2021, 21:13:08 von hadirost »

Re: Interne-SSD bootet nicht
« Antwort #5 am: 08.01.2021, 21:21:17 »
Hallo hadirost,

ich empfehle das aus einem Livesystem zu machen. Hintergrund: Je nach Konfiguration an deinem Rechner funktionieren manche Aktionen aus einem laufenden System heraus nicht. Daher ein Livesystem.
Die Gefahr dass BootRepair etwas kaputt macht ist vermutlich gering, aber nicht ausgeschlossen. Seine Daten solte man als Backup irgendwo außerhalb des Rechners haben.

Viele Erfolg

Re: Interne-SSD bootet nicht
« Antwort #6 am: 08.01.2021, 21:46:58 »
Danke, Isolator.

Da werde ich mich morgen drüber hermachen.
Guts Nächtle,   Hans-Dieter

Re: Interne-SSD bootet nicht
« Antwort #7 am: 09.01.2021, 08:20:44 »
Guten Morgen, ich habe auf einem life-Stick boot-repair installiert und laufen lassen.
Dabei habe ich bisher nur ein Prptokoll erhalten.
Soweit ich es verstehe, gab es noch keine Aktivit't in Richtung Reparatur.
Das Protokoll f[ge ich hier ein.
This live-session is not in EFI-mode.



============================= Drive/Partition Info =============================

Disks info: ____________________________________________________________________


Partitions info (1/3): _________________________________________________________


Partitions info (2/3): _________________________________________________________


Partitions info (3/3): _________________________________________________________


fdisk -l (filtered): ___________________________________________________________

Disk sdd: 3.8 GiB, 4026531840 bytes, 7864320 sectors
Disk identifier: 0x09bebfcf
      Boot   Start     End Sectors  Size Id Type
sdd1  *          0 3855295 3855296  1.9G  0 Empty
sdd2       3843044 3847715    4672  2.3M ef EFI (FAT-12/16/32)

parted -lm (filtered): _________________________________________________________

sdd:4027MB:scsi:512:512:unknown:Intenso Rainbow Line:;

blkid (filtered): ______________________________________________________________

NAME   FSTYPE   UUID                                 PARTUUID                             LABEL                           PARTLABEL
sdd    iso9660  2018-12-17-14-00-47-00                                                    Linux Mint 19.1 Cinnamon 64-bit
├─sdd1 iso9660  2018-12-17-14-00-47-00               09bebfcf-01                          Linux Mint 19.1 Cinnamon 64-bit
└─sdd2 vfat     044E-AC17                            09bebfcf-02                          Linux Mint 19.1 Cinnamon 64-bit

df (filtered): _________________________________________________________________

        Avail Use% Mounted on
sdd         0 100% /cdrom

Mount options: __________________________________________________________________

sdd    ro,noatime,nojoliet,check=s,map=n,blocksize=2048

====================== sdd/boot/grub/grub.cfg (filtered) =======================

Start Linux Mint 19.1 Cinnamon 64-bit
Start Linux Mint 19.1 Cinnamon 64-bit (compatibility mode)
OEM install (for manufacturers)
Check the integrity of the medium

==================== sdd: Location of files loaded by Grub =====================

           GiB - GB             File                                 Fragment(s)
            ?? = ??             boot/grub/grub.cfg                             1


======================== Unknown MBRs/Boot Sectors/etc =========================

Unknown BootLoader on sdd

00000000  45 52 08 00 00 00 90 90  00 00 00 00 00 00 00 00  |ER..............|
00000010  00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00  |................|
00000020  33 ed fa 8e d5 bc 00 7c  fb fc 66 31 db 66 31 c9  |3......|..f1.f1.|
00000030  66 53 66 51 06 57 8e dd  8e c5 52 be 00 7c bf 00  |fSfQ.W....R..|..|
00000040  06 b9 00 01 f3 a5 ea 4b  06 00 00 52 b4 41 bb aa  |.......K...R.A..|
00000050  55 31 c9 30 f6 f9 cd 13  72 16 81 fb 55 aa 75 10  |U1.0....r...U.u.|
00000060  83 e1 01 74 0b 66 c7 06  f1 06 b4 42 eb 15 eb 00  |...t.f.....B....|
00000070  5a 51 b4 08 cd 13 83 e1  3f 5b 51 0f b6 c6 40 50  |ZQ......?[Q...@P|
00000080  f7 e1 53 52 50 bb 00 7c  b9 04 00 66 a1 b0 07 e8  |..SRP..|...f....|
00000090  44 00 0f 82 80 00 66 40  80 c7 02 e2 f2 66 81 3e  |D.....f@.....f.>|
000000a0  40 7c fb c0 78 70 75 09  fa bc ec 7b ea 44 7c 00  |@|..xpu....{.D|.|
000000b0  00 e8 83 00 69 73 6f 6c  69 6e 75 78 2e 62 69 6e  |....isolinux.bin|
000000c0  20 6d 69 73 73 69 6e 67  20 6f 72 20 63 6f 72 72  | missing or corr|
000000d0  75 70 74 2e 0d 0a 66 60  66 31 d2 66 03 06 f8 7b  |upt...f`f1.f...{|
000000e0  66 13 16 fc 7b 66 52 66  50 06 53 6a 01 6a 10 89  |f...{fRfP.Sj.j..|
000000f0  e6 66 f7 36 e8 7b c0 e4  06 88 e1 88 c5 92 f6 36  |.f.6.{.........6|
00000100  ee 7b 88 c6 08 e1 41 b8  01 02 8a 16 f2 7b cd 13  |.{....A......{..|
00000110  8d 64 10 66 61 c3 e8 1e  00 4f 70 65 72 61 74 69  |.d.fa....Operati|
00000120  6e 67 20 73 79 73 74 65  6d 20 6c 6f 61 64 20 65  |ng system load e|
00000130  72 72 6f 72 2e 0d 0a 5e  ac b4 0e 8a 3e 62 04 b3  |rror...^....>b..|
00000140  07 cd 10 3c 0a 75 f1 cd  18 f4 eb fd 00 00 00 00  |...<.u..........|
00000150  00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00  |................|
*
000001b0  d0 6e 39 00 00 00 00 00  cf bf be 09 00 00 80 00  |.n9.............|
000001c0  01 00 00 75 e0 fc 00 00  00 00 c0 d3 3a 00 00 fe  |...u........:...|
000001d0  ff ff ef fe ff ff e4 a3  3a 00 40 12 00 00 00 00  |........:.@.....|
000001e0  00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00  |................|
000001f0  00 00 00 00 00 00 00 00  00 00 00 00 00 00 55 aa  |..............U.|
00000200


========= Devices which don't seem to have a corresponding hard drive ==========

sda sdb sdc sde sdf

=============================== StdErr Messages ================================

File descriptor 63 (pipe:[98570]) leaked on lvs invocation. Parent PID 25094: /bin/bash

Suggested repair: ______________________________________________________________

The default repair of the Boot-Repair utility would not act on the boot.

Nun bin ich sehr gespannt welche Schritte ich jetzt tun sollte.
Mit freundlichem Gruss   Hans/Dieter

Re: Interne-SSD bootet nicht
« Antwort #8 am: 09.01.2021, 08:31:22 »
UPDATE
Als boot-repair lief, blinkte das betroffene LW kurzzeitig auf.
Die Live-Stick-LED leuchtet dauerhaft weiter.
Das betroffene LW blinkt dauerhaft.
Keine Ahnung was es dabei tut.
Ich arbeite aktuell auf dem Live-System.

Re: Interne-SSD bootet nicht
« Antwort #9 am: 09.01.2021, 09:02:52 »
UPDATE
Habe Live-System beendet und versucht von der betroffenen SSD zu booten.
Wie vermutet, hat boot-repair noch nicht eingegriffen.
Das betroffene System meldet sich wieder mit dem Rescue-Mode.

Re: Interne-SSD bootet nicht
« Antwort #10 am: 09.01.2021, 15:05:35 »
UPDATE, hallo Forum,
ich melde mich von der betroffenen SSD; sie bootet wieder.

Die zielführende und leicht nachvollziehbare Antwort auf "Antwort#4" wäre gewesen:
Du bist auf dem Weg. Öffne ein terminal, verwende die vorliegenden Befehlszeilen.
boot-repair öffnet sich, wähle: Advanced options, > Main options > Reinstall GRUB und: "Apply".

Ich bedanke mich für Eure Hilfe
Mitfreundlichem Gruß   Hans-Dieter

Siehe auch: https://itrig.de/index.php?/archives/1777-Boot-Repair-Linux-Bootloader-per-Hand,-USB-Stick-oder-Boot-CD-reparieren.html

Re: Interne-SSD bootet nicht
« Antwort #11 am: 09.01.2021, 18:18:26 »
Hallo Foum, ich habe dieses Thema noch nicht auf "erledigt" gestellt,
weil meine Ausgangsfrage nicht beantwortet ist.
Auch wenn der Weg über boot-repair erfolgreich war, bleibt die Frage offen:
Bietet der Resque-Mode (hier ohne Live-System) die Möglichkeit einer direkteren Lösung?
Darum wiederhole ich aus meiner Eingangsfrage:
Zitat
Situation: Meine Mutter-SSD bootet nicht und das System reagiert dreizeilig mit dem Rescue-Modus.
Dort habe ich mir inzwischen mit "ls" die Partitionen anzeigen lassen.
Ausgabe: (hd0) (hd0,msdos1)
Nach Eingabe: "ls (hd0,msdos1)"
Ausgabe: ./ ../ lost+found/ swapfile etc/ ... boot/ ... root/ ...

Ich möchte gern einer Anleitung folgen, die ich nicht im Detail, aber ihrem Wesen nach, noch zu verstehen glaube.
Demnach würden jetzt folgen:
set prefix=(hd0,1)/grub
set root=(hd0,2)
insmod linux
insmod normal
normal
Weil ich mir nicht noch mehr zerschießen möchte, wäre ich dankbar wenn mir jemand auf Basis der o.a. Ausgaben
die richtigen Eingaben für die set-Befehlszeilen nennen könnte.

Für mich wäre eine Antwort zwar nicht mehr von akutem Interesse,
von technischem Interesse aber schon.

Mit freundlichem Gruß   Hans-Dieter
« Letzte Änderung: 09.01.2021, 18:31:10 von hadirost »