Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
06.05.2021, 06:49:22

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 25562
  • Letzte: Furacin
Statistiken
  • Beiträge insgesamt: 733539
  • Themen insgesamt: 59113
  • Heute online: 378
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online
Mitglieder: 6
Gäste: 316
Gesamt: 322

Autor Thema:  Wieder MG5350  (Gelesen 438 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Wieder MG5350
« am: 15.01.2021, 15:26:24 »
Hallo,
Cinnamon 20.1,
nachdem ich mit eurer Hilfe meinen Canon MG5350 unter Cinnamon 20 zum Drucken und Scannen gebracht habe, ist nun nach der Installation von Cinnamon 20.1 ein weiteres Problem aufgetaucht.
Installiert wurde als erstes multiarch-support_2.27-3ubuntu1.3_amd64.deb, danach libtiff4_3.9.7-2ubuntu1_amd64.deb
Mein Problem: es lässt sich nicht libpng12-0_1.2.54-1ubuntu1.1_amd64.deb installieren. Es kommt immer wieder eine Fehlermeldung

Reading database ...
(Reading database ... 5%%
(Reading database ... 10%%
(Reading database ... 15%%
(Reading database ... 20%%
(Reading database ... 25%%
(Reading database ... 30%%
(Reading database ... 35%%
(Reading database ... 40%%
(Reading database ... 45%%
(Reading database ... 50%%
(Reading database ... 55%%
(Reading database ... 60%%
(Reading database ... 65%%
(Reading database ... 70%%
(Reading database ... 75%%
(Reading database ... 80%%
(Reading database ... 85%%
(Reading database ... 90%%
(Reading database ... 95%%
(Reading database ... 100%%
(Reading database ... 370354 files and directories currently installed.)
Preparing to unpack .../libpng12-0_1.2.54-1ubuntu1.1_amd64.deb ...
Unpacking libpng12-0:amd64 (1.2.54-1ubuntu1.1) ...
dpkg: error processing archive /home/mint/Dokumente/PC/Einrichtung Canon MG 5350/libpng12-0_1.2.54-1ubuntu1.1_amd64.deb (--install):
 unable to install new version of '/lib/x86_64-linux-gnu/libpng12.so.0': No such file or directory
Processing triggers for libc-bin (2.31-0ubuntu9.1) ...
Errors were encountered while processing:
 /home/mint/Dokumente/PC/Einrichtung Canon MG 5350/libpng12-0_1.2.54-1ubuntu1.1_amd64.deb
« Letzte Änderung: 20.01.2021, 11:51:25 von mint13 »

Re: Wieder MG5350
« Antwort #1 am: 16.01.2021, 08:52:41 »
Hallo,
das Problem wurde, auch ohne die Datei zu installieren, gelöst.
Drucker über Kabel anschließen, einrichten, Testseite gedruckt und anschließend die Verbindung auf W-Lan umgestellt, Testseite, ein Dokument aus LO sowie ein Bild gedruckt,  fertig.
Bis jetzt habe ich noch keine Probleme feststellen können, es funktioniert alles mit den LM Treibern wie gewünscht.

Re: Wieder MG5350
« Antwort #2 am: 20.01.2021, 11:56:31 »
Hallo,
Problem doch nicht zur Zufriedenheit gelöst. Bein drucken stellen sich verschiedene Probleme ein.
Kann mir jemand einen Tipp geben wie ich die fehlende Datei,   libpng12-0_1.2.54-1ubuntu1.1_amd64.deb   installieren kann?

Re: Wieder MG5350
« Antwort #3 am: 20.01.2021, 12:05:22 »
In Synaptic gibt es das Paket nicht - aber "libpng16 ..." ?!
Hast du das Paket schon ?
Wenn JA - "deb-Pakete" lassen sich im Normalfall durch Doppelklick zur Installation bewegen.

Re: Wieder MG5350
« Antwort #4 am: 20.01.2021, 17:21:35 »
Hallo, danke für die Antwort.
ja, das Paket " libpng16 "habe ich schon. Vielleicht sollte ich dies wieder deinstallieren? Kannst Du mir den Terminalbefehl mitteilen?
Ich weis das mit dem Doppelklick, funktioniert aber nicht. Ich bekomme nur die oben stehende Fehlermeldung. Ohne die gewünschte Installation kann ich die Canon Treiber nicht installieren. Bei Cinnamon 20 hat die Installation funktioniert, erst seit 20.1 geht das nicht.

Re: Wieder MG5350
« Antwort #5 am: 20.01.2021, 21:29:40 »
das Paket " libpng16 "habe ich schon. Vielleicht sollte ich dies wieder deinstallieren?
Das ist keine gute Idee, es gibt sicherlich Programme die von der höheren Version abhängig sind. Libs sind aber abwärtskompatibel. Du kannst dir einen Symlink auf libpng12.so.0 erstellen. Dazu öffnest du dir ein Terminal und wechselst in das Verzeichnis wo libpng16 liegt (der vollständige Name lautet libpng16.so.16.36.0). Evtl. ist bei dir auch schon eine höhere Versionsnummer installiert. Das wirst du dann sehen. Bei mir liegt diese lib in /usr/lib/x86_64-linux-gnu/. Du gehst folgendermaßen vor.
1. Terminal öffnen.
2. Ins Verzeichnis der lib-Datei wechseln. Kleiner Tip, im Terminal kann man mit der Tab-Taste die Namen vervollständigen. Das schützt vorm Vertippen.
3. mit ls gucken, ob die entsprechende lib auch vorhanden ist.
4 Symlink erstellen.
5. Überprüfen ob der Symlink richtig erstellt wurde
Die Befehle sehen dann so aus:

cd /usr/lib/x86_64-linux-gnu
ls -la |grep libpng16
Es kann sein, dass ls mehrere Dateien anzeigt. Das ist dann der Fall, wenn es schon einen Symlink gibt. Das ist daran zu erkennen, dass die Ausgabe so aussieht (lrwxrwxrwx   1 root root        19 Apr  8  2019 libpng16.so.16 -> libpng16.so.16.36.0). Der Pfeil verweist auf die Originaldatei. Du wählst die ohne Pfeil aus. Wahrscheinlich ist das libpng16.so.16.36.0. Weiter:
sudo ln -s libpng16.so.16.36.0 libpng12.so.0Den Namen libpng16.so16.36.0 musst du natürlich gegebenenfalls anpassen.  Jetzt noch einmal prüfen, ob der Symlink richtig geschrieben wurde.
ls -la libpng12.so.0Nun sollte sich das Druckerprogrmm installieren lassen. Falls nicht, einfach den Symlink wieder löschen.

Re: Wieder MG5350
« Antwort #6 am: 21.01.2021, 14:34:28 »
Hallo tam,
habe ich es richtig verstanden? Die aufgeführten Schritte nach einander im Terminal ausführen?
1. Schritt:
Zitat
cd /usr/lib/x86_64-linux-gnu
ls -la |grep libpng16
2.Schritt:
Zitat
sudo ln -s libpng16.so.16.37.0 libpng12.so.0
(Version angepasst auf 16.37.0)
3. Schritt:
Zitat
ls -la libpng12.so.0

Das Ergebnis siehe Anhang, Datei lässt sich immer noch nicht installieren. Kannst Du mir mitteilen wo der Fehler liegt?

Re: Wieder MG5350
« Antwort #7 am: 21.01.2021, 15:42:00 »
Kein Fehler. Der Symlink existierte bereits. Aber ich hätte etwas genauer lesen sollen.Das Installationsprogramm versucht die libpng12xx im Verzeichnis /lib/x86_64-linux-gnu/ zu installieren. Aber das Verzeichnis x86_64-linux-gnu existiert nicht unter /lib, sondern unter /usr.

Edit: Wichtig! Nicht den Symlink löschen, wie ich es in meinem vorigen Post geschrieben hatte, weil er ja schon existierte und gebraucht wird.
Richte dich mal nach dem Vorschlag von @ehtron.
« Letzte Änderung: 21.01.2021, 16:11:07 von tam »

Re: Wieder MG5350
« Antwort #8 am: 21.01.2021, 15:59:36 »
Hi :)
am besten mal
sudo apt-get install usrmerge -y && sudo apt-get purge usrmerge -y
durchlaufen lassen, dann gibt es diese verzeichnis probleme nicht mehr.

btw..
nach > 400 posts, solltest du ausgaben aus dem terminal per codeblock doch eigentlich kennen ;)

Re: Wieder MG5350
« Antwort #9 am: 21.01.2021, 16:56:59 »
Hallo,
ehtron, du hast Recht. Statt ein Bildschirmfoto hätte ich es besser wissen müssen, Entschuldigung. Ich war nur etwas genervt und habe nicht nachgedacht.
Mein Problem ist aber mit dem durchlaufen lassen noch nicht gelöst und  libpng12-0_1.2.54-1ubuntu1.1_amd64.deb lässt sich immer noch nicht installieren. Diese wird zur Installation des Canon Druckertreibers benötigt.
Hat noch Jemand eine Idee?
« Letzte Änderung: 21.01.2021, 17:04:26 von mint13 »