Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
25.04.2014, 08:28:01

Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 8643
  • Letzte: forilux
Statistiken
  • Beiträge insgesamt: 200667
  • Themen insgesamt: 16699
  • Heute online: 272
  • Am meisten online: 514
  • (18.04.2014, 17:38:30)
Benutzer Online

Autor Thema: [gelöst]  Firefox macht Probleme  (Gelesen 3690 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] Firefox macht Probleme
« am: 07.05.2011, 20:38:45 »
Hallo,

ich hab beim versuch FF 4 zum Systembrowser zu machen irgendwie Scheiße gebaut und hab jetzt folgende Probleme

Beim Aktualisieren in der Aktualisierungsverwaltung erscheint folgende Fehlermeldung:

Zitat
E: mint-search-addon: »/opt/firefox/extensions/mint-search-enhancer@linuxmint.com« kann nicht auf sichere Weise entfernt werden: Ist kein Verzeichnis

Beim Versuch den ursprünglichen Firefox neu zu intallieren/deinstallieren kommt die selbe Fehlermeldung. FF kann nicht gestartet werden.

Was kann ich tun?

Gruß Fidel

« Letzte Änderung: 19.07.2011, 01:15:26 von DeVIL-I386 »

Korfox

  • Global Moderator
  • *****
  • Beiträge: 4494
  • '·,·'·,·'·,·'·,·'·,·'·,·'·,·'·,·'·,·'·,·'·,·'·,·'·
Re: Firefox macht Probleme
« Antwort #1 am: 07.05.2011, 20:57:50 »
Kannst du Firefox noch im Safe-Mode starten?
firefox -safe-modein der Konsole... Dann ist es ein Add-On, das Probleme macht...
« Letzte Änderung: Heute um 04:64:28 von Korfox »
Jo, richtig geraten - mein "z" ist kaputt... ok, das "l" jetzt auch...

Re: Firefox macht Probleme
« Antwort #2 am: 07.05.2011, 21:10:18 »
Nein FF startet auch im Safemode nicht:

Zitat
The program 'firefox' is currently not installed.  To run 'firefox' please ask your administrator to install the package 'iceweasel'
firefox: command not found

FF wird aber in der Synaptic als installiert abgezeigt und taucht auch im Hauptmenü noch auf allerdings ohne Icon. Wenn ich versuche Iceweasel zu installieren kommt die selbe Fehlermeldung.

Re: Firefox macht Probleme
« Antwort #3 am: 07.05.2011, 21:15:32 »
Kommt diese Meldung auch, wenn Du
sudo aptitude purge firefox
eingibst?

Ist da bei Dir etwas in /opt/firefox/extensions/ ?
Also was kommt bei
ls -la /opt/firefox/extensions/und/oder
ls -la /opt/firefox/?

Re: Firefox macht Probleme
« Antwort #4 am: 07.05.2011, 21:26:55 »
sudo aptitude purge firefox

E: Konnte Sperre /var/lib/dpkg/lock nicht bekommen - open (11: Die Ressource ist zur Zeit nicht verfügbar)
E: Sperren des Administrationsverzeichnisses (/var/lib/dpkg/) nicht möglich, wird es von einem anderen Prozess verwendet?
W: Konnte die Cache-Datei nicht sperren. Das bedeutet in der Regel, dass dpkg oder ein anderes APT-Werkzeug bereits Pakete installiert. Öffne sie im Nur-Lesen-Modus. Alle Änderungen, die Sie am Status von Paketen durchführen, werden VERLOREN gehen!
E: Konnte Sperre /var/lib/dpkg/lock nicht bekommen - open (11: Die Ressource ist zur Zeit nicht verfügbar)
E: Sperren des Administrationsverzeichnisses (/var/lib/dpkg/) nicht möglich, wird es von einem anderen Prozess verwendet?

ls -la /opt/firefox/extensions/

ls: Zugriff auf /opt/firefox/extensions/ nicht möglich: Ist kein Verzeichnis
ls -la /opt/firefox/

ls: Zugriff auf /opt/firefox/ nicht möglich: Ist kein Verzeichnis

Re: Firefox macht Probleme
« Antwort #5 am: 07.05.2011, 21:29:18 »
Huch sorry hatte synaptic noch auf, moment

Re: Firefox macht Probleme
« Antwort #6 am: 07.05.2011, 21:46:31 »
Also sudo aptitude purge firefox gibt folgendes aus:

Die folgenden Pakete werden ENTFERNT:         
  firefox{p} mint-meta-codecs{u}
Die folgenden teilweise installierten Pakete werden konfiguriert:
  xulrunner-1.9.1
0 Pakete aktualisiert, 0 zusätzlich installiert, 2 werden entfernt und 0 nicht aktualisiert.
Muss 9.092 B an Archiven herunterladen. Nach dem Entpacken werden 29,2 MB frei werden.
Die folgenden Pakete haben verletzte Abhängigkeiten:
  mint-search-addon: Hängt ab von: firefox but it is not going to be installed. oder
                                    firefox-3.0, welches ein virtuelles Paket ist. oder
                                    firefox-2, welches ein virtuelles Paket ist. oder
                                    abrowser, welches ein virtuelles Paket ist. oder
                                    flock, welches ein virtuelles Paket ist. oder
                                    songbird, welches ein virtuelles Paket ist. oder
                                    iceweasel but it is not going to be installed.
Die folgenden Aktionen werden diese Abhängigkeiten auflösen:

     Entferne die folgenden Pakete:
1)     mint-search-addon           



Diese Lösung akzeptieren? [Y/n/q/?] y
Die folgenden Pakete werden ENTFERNT:
  firefox{p} mint-meta-codecs{u} mint-search-addon{a}
Die folgenden teilweise installierten Pakete werden konfiguriert:
  xulrunner-1.9.1
0 Pakete aktualisiert, 0 zusätzlich installiert, 3 werden entfernt und 0 nicht aktualisiert.
Muss 0 B an Archiven herunterladen. Nach dem Entpacken werden 29,3 MB frei werden.
Wollen Sie fortsetzen? [Y/n/?] y
(Lese Datenbank ... 147176 Dateien und Verzeichnisse sind derzeit installiert.)
Entfernen von mint-search-addon ...
dpkg: Fehler beim Bearbeiten von mint-search-addon (--remove):
 »/opt/firefox/extensions/mint-search-enhancer@linuxmint.com« kann nicht auf sichere Weise entfernt werden: Ist kein Verzeichnis
configured to not write apport reports
                                      Fehler traten auf beim Bearbeiten von:
 mint-search-addon
E: Sub-process /usr/bin/dpkg returned an error code (1)
Ein Paket konnte nicht installiert werden. Versuche zu lösen:
xulrunner-1.9.1 (1.9.1.18-1) wird eingerichtet ...
update-alternatives: Fehler: »/opt/firefox/firefox« kann nicht mit stat abgefragt werden: Ist kein Verzeichnis
dpkg: Fehler beim Bearbeiten von xulrunner-1.9.1 (--configure):
 Unterprozess installiertes post-installation-Skript gab den Fehlerwert 2 zurück
Fehler traten auf beim Bearbeiten von:
 xulrunner-1.9.1

Ich habe beide Male mit Y geantwortet, weil es mir sinnvoll erschien.

Re: Firefox macht Probleme
« Antwort #7 am: 07.05.2011, 21:52:48 »
Probier mal
sudo dpkg --configure -a

Re: Firefox macht Probleme
« Antwort #8 am: 07.05.2011, 21:55:51 »
xulrunner-1.9.1 (1.9.1.18-1) wird eingerichtet ...
update-alternatives: Fehler: »/opt/firefox/firefox« kann nicht mit stat abgefragt werden: Ist kein Verzeichnis
dpkg: Fehler beim Bearbeiten von xulrunner-1.9.1 (--configure):
 Unterprozess installiertes post-installation-Skript gab den Fehlerwert 2 zurück
Fehler traten auf beim Bearbeiten von:
 xulrunner-1.9.1

Re: Firefox macht Probleme
« Antwort #9 am: 07.05.2011, 22:00:29 »
Das ist - glaub ich - diese blöde Sache bei LMDE, dass man Firefox oder Iceweasel installiert haben MUSS, also nicht beide entfernen kann.
Was kommt bei
sudo aptitude purge mint-search-addon
und dann bei
sudo aptitude install iceweasel

Re: Firefox macht Probleme
« Antwort #10 am: 07.05.2011, 22:13:48 »
Das war ja wieder klar das ich den größten Fehler gleich mal mach  :-[


sudo aptitude purge mint-search-addon

Die folgenden Pakete werden ENTFERNT:       
  mint-search-addon{p}
Die folgenden teilweise installierten Pakete werden konfiguriert:
  firefox xulrunner-1.9.1
0 Pakete aktualisiert, 0 zusätzlich installiert, 1 werden entfernt und 0 nicht aktualisiert.
Muss 0 B an Archiven herunterladen. Nach dem Entpacken werden 139 kB frei werden.
Wollen Sie fortsetzen? [Y/n/?] y
(Lese Datenbank ... 147176 Dateien und Verzeichnisse sind derzeit installiert.)
Entfernen von mint-search-addon ...
dpkg: Fehler beim Bearbeiten von mint-search-addon (--purge):
 »/opt/firefox/extensions/mint-search-enhancer@linuxmint.com« kann nicht auf sichere Weise entfernt werden: Ist kein Verzeichnis
configured to not write apport reports
                                      Fehler traten auf beim Bearbeiten von:
 mint-search-addon
E: Sub-process /usr/bin/dpkg returned an error code (1)
Ein Paket konnte nicht installiert werden. Versuche zu lösen:
xulrunner-1.9.1 (1.9.1.18-1) wird eingerichtet ...
update-alternatives: Fehler: »/opt/firefox/firefox« kann nicht mit stat abgefragt werden: Ist kein Verzeichnis
dpkg: Fehler beim Bearbeiten von xulrunner-1.9.1 (--configure):
 Unterprozess installiertes post-installation-Skript gab den Fehlerwert 2 zurück
Fehler traten auf beim Bearbeiten von:
 xulrunner-1.9.1
                                             
sudo aptitude install iceweasel

Die folgenden NEUEN Pakete werden zusätzlich installiert:
  iceweasel
Die folgenden teilweise installierten Pakete werden konfiguriert:
  firefox xulrunner-1.9.1
0 Pakete aktualisiert, 1 zusätzlich installiert, 0 werden entfernt und 0 nicht aktualisiert.
Muss 9.092 B/1.109 kB an Archiven herunterladen. Nach dem Entpacken werden 4.080 kB zusätzlich belegt sein.
Hole:1 http://linux-mint.froonix.org/ debian/main mint-search-addon all 2.1 [9.092 B]
9.092 B wurden in 0 s heruntergeladen (34,0 kB/s)
Vormals abgewähltes Paket iceweasel wird gewählt.
(Lese Datenbank ... 147176 Dateien und Verzeichnisse sind derzeit installiert.)
Entpacken von iceweasel (aus .../iceweasel_3.5.18-1_i386.deb) ...
»Umleitung von /usr/bin/firefox zu /usr/bin/firefox.real durch iceweasel« wird hinzugefügt
Vormals abgewähltes Paket mint-search-addon wird gewählt.
Vorbereitung zum Ersetzen von mint-search-addon 2.1 (durch .../mint-search-addon_2.1_all.deb) ...
Ersatz für mint-search-addon wird entpackt ...
dpkg: Fehler beim Bearbeiten von /var/cache/apt/archives/mint-search-addon_2.1_all.deb (--unpack):
 Versuch, »/opt/firefox« zu überschreiben, welches auch in Paket firefox 3.6.13-1linuxmint1 ist
configured to not write apport reports
                                      Trigger für mintsystem werden verarbeitet ...
Trigger für man-db werden verarbeitet ...
Trigger für menu werden verarbeitet ...
Trigger für gnome-menus werden verarbeitet ...
Trigger für desktop-file-utils werden verarbeitet ...
Trigger für hicolor-icon-theme werden verarbeitet ...
Fehler traten auf beim Bearbeiten von:
 /var/cache/apt/archives/mint-search-addon_2.1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Ein Paket konnte nicht installiert werden. Versuche zu lösen:
xulrunner-1.9.1 (1.9.1.18-1) wird eingerichtet ...
update-alternatives: Fehler: »/opt/firefox/firefox« kann nicht mit stat abgefragt werden: Ist kein Verzeichnis
dpkg: Fehler beim Bearbeiten von xulrunner-1.9.1 (--configure):
 Unterprozess installiertes post-installation-Skript gab den Fehlerwert 2 zurück
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von iceweasel:
 iceweasel hängt ab von xulrunner-1.9.1 (>= 1.9.1.18); aber:
  Paket xulrunner-1.9.1 ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von iceweasel (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
Fehler traten auf beim Bearbeiten von:
 xulrunner-1.9.1
 iceweasel


Re: Firefox macht Probleme
« Antwort #11 am: 07.05.2011, 22:20:58 »
sudo aptitude install --reinstall xulrunner-1.9.1?

Re: Firefox macht Probleme
« Antwort #12 am: 07.05.2011, 22:31:18 »
Weil der Befehl nicht funktioniert hat hab ich einfach mal sudo aptitude reinstall xulrunner-1.9.1 probiert:

Die folgenden teilweise installierten Pakete werden konfiguriert:
  firefox iceweasel xulrunner-1.9.1
Es werden keine Pakete installiert, aktualisiert oder entfernt.
0 Pakete aktualisiert, 0 zusätzlich installiert, 0 werden entfernt und 0 nicht aktualisiert.
Muss 0 B/9.092 B an Archiven herunterladen. Nach dem Entpacken werden 0 B zusätzlich belegt sein.
(Lese Datenbank ... 147288 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Ersetzen von mint-search-addon 2.1 (durch .../mint-search-addon_2.1_all.deb) ...
Ersatz für mint-search-addon wird entpackt ...
dpkg: Fehler beim Bearbeiten von /var/cache/apt/archives/mint-search-addon_2.1_all.deb (--unpack):
 Versuch, »/opt/firefox« zu überschreiben, welches auch in Paket firefox 3.6.13-1linuxmint1 ist
configured to not write apport reports
                                      Fehler traten auf beim Bearbeiten von:
 /var/cache/apt/archives/mint-search-addon_2.1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Ein Paket konnte nicht installiert werden. Versuche zu lösen:
xulrunner-1.9.1 (1.9.1.18-1) wird eingerichtet ...
update-alternatives: Fehler: »/opt/firefox/firefox« kann nicht mit stat abgefragt werden: Ist kein Verzeichnis
dpkg: Fehler beim Bearbeiten von xulrunner-1.9.1 (--configure):
 Unterprozess installiertes post-installation-Skript gab den Fehlerwert 2 zurück
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von iceweasel:
 iceweasel hängt ab von xulrunner-1.9.1 (>= 1.9.1.18); aber:
  Paket xulrunner-1.9.1 ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von iceweasel (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
Fehler traten auf beim Bearbeiten von:
 xulrunner-1.9.1
 iceweasel

Hab auch noch ein paar andere Kombinationen aus install und reinstall pribiert mit etwa dem gleichen Ergebnis

Re: Firefox macht Probleme
« Antwort #13 am: 07.05.2011, 22:58:00 »
Hm, blöd, weiß auch nicht genau grade.
Was kommt denn eigentlich bei
sudo update-alternatives --config x-www-browser

Re: Firefox macht Probleme
« Antwort #14 am: 07.05.2011, 23:05:34 »
Oh Mist jetzt hab ich grad gemerkt daß ich garnix mehr installieren kann!

sudo update-alternatives --config x-www-browser

update-alternatives: Fehler: »/opt/firefox/firefox« kann nicht mit stat abgefragt werden: Ist kein Verzeichnis

 :'(