Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
26.10.2014, 06:08:41

Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 10496
  • Letzte: itsurk
Statistiken
  • Beiträge insgesamt: 247541
  • Themen insgesamt: 20103
  • Heute online: 180
  • Am meisten online: 514
  • (18.04.2014, 17:38:30)
Benutzer Online
Mitglieder: 8
Gäste: 94
Gesamt: 102

Autor Thema:  Telekom Speedstick LTE II (Alcatel One Touch L100V LTE)  (Gelesen 4728 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Hallo zusammen,

über die Linux-Unterstützung von LTE-Hardware, insbesondere von dem weit verbreiteten Telekom Speedstick LTE II, findet man nicht viel im Netz. Ich konnte diesen Surfstick günstig erwerben. Um ihn unter Linux Mint 13 (Mate, 32 Bit) zum Laufen zu bringen, ist allerdings ein wenig Handarbeit nötig. Was gemacht werden muss, ist die Anpassung von zwei Konfigurationsdateien, damit der Stick erkannt, von USB-Modeswitch in den Modemmodus geschaltet und der Treiber geladen wird. Ich habe es zugegebenermaßen nicht alleine herausgefunden, sondern nach längerer Suche von hier:
http://www.draisberghof.de/usb_modeswitch/bb/viewtopic.php?f=3&t=1200&sid=0d846a7b4d81d57bf26b3b406e541bae

Zunächst gehen wir nach /lib/udev/rules.d und laden als Administrator die Datei 40-usb_modeswitch.rules in einen Editor. An das Ende der Liste (natürlich vor der letzten Zeile) hängen wir den folgenden Eintrag an:
# Alcatel One Touch L100V LTE
ATTRS{idVendor}=="1bbb", ATTRS{idProduct}=="f017", RUN+="usb_modeswitch '%b/%k'"

Jetzt erstellen wir mit einem Editor eine Textdatei mit dem Inhalt
# Alcatel One Touch L100V LTE

TargetVendor= 0x1bbb
TargetProduct= 0x011e

MessageContent="55534243123456788000000080000606f50402527000000000000000000000"
und speichern sie mit dem Dateinamen 1bbb:f017

Wir gehen nach /usr/share/usb_modeswitch und öffnen als Administrator das dort befindliche Archiv configPack.tar.gz. In dieses Archiv kopieren wir die zuvor erstellte Datei 1bbb:f017 und speichern die Änderung.

Nach einem Neustart (Abmelden reicht vielleicht auch, habe ich nicht probiert) kann der Stick angesteckt und ausprobiert werden. Achtung, die Initialisierung dauert etwa eine Minute! Sobald die LED nicht mehr schnell orange blinkt, sondern zu langsamem Blinken (rot=LTE, grün=UMTS, blau=GPRS), übergeht, wurde ein Netz gefunden und der Stick ist betriebsbereit.

Wenn alles richtig eingerichtet wurde, meldet lsusb:
Bus 001 Device 044: ID 1bbb:011e T & A Mobile Phones
Wichtig ist, dass es 1bbb:011e lautet und nicht 1bbb:f017, sonst hat die Umschaltung von USB_modeswitch nicht funktioniert.

Als nächstes prüfen wir die Ausgabe von usb-devices. Hier ist unser Stick:
T:  Bus=01 Lev=01 Prnt=01 Port=02 Cnt=01 Dev#= 44 Spd=480 MxCh= 0
D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=1bbb ProdID=011e Rev=00.00
S:  Manufacturer=USBModem
S:  Product=Mobile Broad Band
C:  #Ifs= 5 Cfg#= 1 Atr=e0 MxPwr=500mA
I:  If#= 0 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
I:  If#= 1 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
I:  If#= 2 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
I:  If#= 3 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
I:  If#= 4 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
Wenn nur zwei Zeilen mit "Driver"=usb-storage" zu sehen sind, hat die Umschaltung in den Modemmodus nicht funktioniert. Bei "Driver=none" wurde der Treiber nicht geladen, hier hilft manchmal nur warten.

Im Netzwerkmanager lässt sich, wenn alles läuft, das mobile Breitband aktivieren und eine Verbindung einrichten. Hier gibt es aber ein paar Besonderheiten zu beachten, damit die Einwahl auch funktioniert:
Unter "Mobiles Breitband - Typ" muss zwingend "beliebig" ausgewählt sein! Ist dort UMTS, GPRS oder eine Bevorzugung eingestellt, ist keine Einwahl möglich!

Für LTE mit der Telekom muss der APN auf "internet.telekom" geändert werden. Ob LTE überhaupt funktioniert, konnte ich mangels Versorgung an meinem Ort noch nicht testen. HSPA+ scheint aber zu gehen, denn die erreichte Download-Geschwindigkeit liegt bedeutend höher als mit meinen HSPA-Sticks. Das Ding rennt!

Ein Problem ergibt sich leider bei Verwendung einer Vodafone-Prepaidkarte (Bildmobil): Sehr gute Downloadwerte, aber nur EDGE-Geschwindigkeit im Upload. Weiterhin vermisse ich grundsätzlich eine Möglichkeit, die Betriebsart manuell festzulegen, denn bei der Telekom schaltet der Stick gerne nach GPRS/EDGE, weil mein UMTS-Empfang etwas schwach ist. Leider funktioniert ja die Betriebsartwahl im Netzwerkmanager nicht.

Ideen? Tipps? Gerne! Ich freue mich auf einen regen Erfahrungsaustausch!
Mint 17 Mate 64bit
Lenovo Thinkpad X200 mit SSD und Boe Hydis Display

crizzly

  • Gast
Re: Telekom Speedstick LTE II (Alcatel One Touch L100V LTE)
« Antwort #1 am: 08.03.2013, 02:39:32 »
ATTRS{idProduct} 011e ist in  /lib/udev/rules.d/40-usb_modeswitch.rules nicht vorhanden. Ich würde den Maintainer darüber informieren, damit dies mit aufgenommen werden kann. apt-cache show usb-modeswitch|grep -i maintainer
Was man bezüglich der Verbindungseinstellungen machen weiß ich im Moment nicht.

Re: Telekom Speedstick LTE II (Alcatel One Touch L100V LTE)
« Antwort #2 am: 08.03.2013, 06:39:46 »
Hab das mal gemacht. Wobei der Stick in der Vorabversion von Ubuntu 13.04 unterstützt wird, ich habe es gestern am Livesystem getestet. Mint 14 geht vielleicht auch, müsste mal jemand ausprobieren. Da Mint 13 eine LTS ist, könnte die Anleitung dennoch hilfreich sein. Der Maintainer wird für Mint 13 wohl kaum die Stickunterstützung noch einpflegen, oder?

So richtig zuverlässig funktioniert es übrigens noch nicht. Nach einem Neustart des Rechners schaltet der Stick zwar in den Modemmodus, lädt den Treiber aber anscheinend nicht, jedenfalls blinkt er dauerhaft orange und usb-devices meldet "Driver: none". Erst nachdem ich mit einem anderen Stick (K3765) einmalig eine Verbindung aufgebaut habe, funktioniert der Speedstick wieder.
Mint 17 Mate 64bit
Lenovo Thinkpad X200 mit SSD und Boe Hydis Display

crizzly

  • Gast
Re: Telekom Speedstick LTE II (Alcatel One Touch L100V LTE)
« Antwort #3 am: 08.03.2013, 07:24:14 »
Du könntest die raring-Quelle einbinden, den Kernel 3.8 aus raring installieren (unter diesem funktionierte es doch ?) und das pinning der restlichen Pakete aus dieser Quelle auf 100 setzen.

Als erstes die sourceslist für raring anlegen. Editiere die sources.list in
/etc/apt/sources.listeinfügen
Zitat
deb http://archive.ubuntu.com/ubuntu/ raring main
Datei speichern.

Dann dem Paketsystem mitteilen das alle Pakete aus raring eine untergeordnete Rolle einnehmen
Editieren: /etc/apt/preferences
und dort hineinfügen
Package: *
Pin: release l=Ubuntu, a=raring
Pin-Priority: 100
Diese Datei auch speichern.

Dann den Kernel aus raring holen mit:
apt-get update && apt-get install -t raring linux-image linux-headers-generic Nach einem Neustart im Grubmenü den Kernel 3.8 auswählen. Wenn Probleme auftauchen bitte den vollständigen Output posten.

Hinweis:
Du kannst statt die sources.list zu editieren auch in /etc/apt/sources.list.d eine eigene Datei anlegen.
Ebenso brauchst Du nicht die preferences zu editieren. Wie vor kannst Du im dafür vorgesehenen Verzeichnis /etc/apt/preferences.d eine eigene Datei anlegen.
Setze meinen Vorschlag nicht um, wenn Du den proprietären Grafikkartentreiber installiert hast (dazu ist mehr handarbeit oder gar friggelei nötig)
« Letzte Änderung: 08.03.2013, 07:53:33 von crizzly »

Re: Telekom Speedstick LTE II (Alcatel One Touch L100V LTE)
« Antwort #4 am: 16.03.2013, 14:45:29 »
Zur Installation möchte ich zur Vorsicht raten - das Zurückhalten der Pakete hat bei mir nicht funktioniert. Egal, es stand ohnehin ein Update auf Mint 14 an. Und unter Mint 14 läuft der Stick ootb, nur die Umschaltung 2G/3G/4G klappt nicht manuell, sondern ausschließlich automatisch.

Speed ist klasse, wenn LTE verfügbar ist (Messung in Dortmund-Oespel):

Mint 17 Mate 64bit
Lenovo Thinkpad X200 mit SSD und Boe Hydis Display

crizzly

  • Gast
Re: Telekom Speedstick LTE II (Alcatel One Touch L100V LTE)
« Antwort #5 am: 16.03.2013, 15:30:16 »
Zitat
Zur Installation möchte ich zur Vorsicht raten - das Zurückhalten der Pakete hat bei mir nicht funktioniert.
Dann hast Du was falsch gemacht. Bei mir funktioniert die oben beschriebene Vorgehensweise!

Re: Telekom Speedstick LTE II (Alcatel One Touch L100V LTE)
« Antwort #6 am: 19.03.2013, 22:59:57 »
Kann gut sein, ich kann es aber nicht mehr nachvollziehen. Trotzdem vielen Dank für deine Mühe, auch wenn es bei mir nicht funktioniert hat!

Der Speedstick läuft jetzt unter Mint 14 so weit prima, aber die manuelle Umschaltung der Betriebsart (2G/3G/4G) funktioniert nicht (das gilt auch unter Raring).

Ein Verbindungsaufbau ist nur dann möglich, wenn der Verbindungstyp im Netzwerkmanager auf "beliebig" steht. Wird irgendeine Betriebsart ausgewählt oder auch nur eine Präferenz (wie "3G bevorzugen"), scheitert jeder Verbindungsaubau.

Und jetzt kommts: Wird der Stick unter Windows mit dem Telekom-Einwahltool auf eine Verbindungsart festgelegt, "merkt" er sich das und baut auch unter Mint nur noch diesen unter Windows vorher festgelegten Verbindungstyp auf! Immerhin "merkt" sich der Stick auch, wenn ich unter Windows "automatisch" wähle, danach funktioniert auch unter Mint wieder jede verfügbare Verbindungsart.

Leider ist das für mich unbefriedigend. Zu Hause habe ich zu schwaches 4G, schwach aber ausreichend 3G und mit richtig fetter Signalstärke 2G anstehen. Folglich schaltet der Stick meistens auf 2G, und mir macht EDGE nun mal keinen Spaß. Gut, ich kann den Stick an den Windows-PC hängen, auf 3G festnageln und damit dann unter Mint munter per HSPA surfen. Nur geht dann unterwegs weder 4G noch 2G, es sei denn, ich gehe wieder an den Windows-PC und stelle ihn dort auf Automatik zurück.

Weiß jemand, wie das Windows-Tool die Umschaltung bewerkstelligt? Da wird doch bestimmt nur ein Terminal-Befehl abgesetzt! Per Konsole müsste man folglich den Stick doch umgeschaltet bekommen, wenn man die Befehle kennt. Hat jemand eine Idee?
Mint 17 Mate 64bit
Lenovo Thinkpad X200 mit SSD und Boe Hydis Display

Re: Telekom Speedstick LTE II (Alcatel One Touch L100V LTE)
« Antwort #7 am: 24.03.2013, 09:43:50 »
Bei mir trat leider genau das Problem auf, dass kein Treiber zur Verfügung war (driver=(none).
(Ich habe Linux Mint 14)
Da ich nicht warten wollte, habe ich rumprobiert.
1. den alten LTE Treiber von der T-Mobile-Seite.
Die Installation lief nur mit sehr vielen Fehlern ab und danach ging's noch nicht.
2. aus den Paketquellen das Paket "linux-image-generic" installiert.
Danach ging es. Komischerweise ging es auch noch, nachdem ich das Paket wieder deinstalliert hatte. Bleiben vielleicht Treiber auch bei einer Deinstallation erhalten?
usb-devices ergab am Schluss Folgendes:
T:  Bus=02 Lev=01 Prnt=01 Port=01 Cnt=01 Dev#=  3 Spd=480 MxCh= 0
D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=1bbb ProdID=011e Rev=00.00
S:  Manufacturer=USBModem
S:  Product=Mobile Broad Band
C:  #Ifs= 5 Cfg#= 1 Atr=e0 MxPwr=500mA
I:  If#= 0 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
I:  If#= 1 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
I:  If#= 2 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
I:  If#= 3 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
I:  If#= 4 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
Das "none" in der letzten Zeile ist anscheinend kein Problem.
Danke für die Infos!

Re: Telekom Speedstick LTE II (Alcatel One Touch L100V LTE)
« Antwort #8 am: 24.03.2013, 11:56:59 »
Bei mir lief der LTE Speedstick II unter Mint 14 ootb. Allerdings hatte ich Mint 14.1 heruntergeladen und installiert, da ist möglicherweise ein neuerer Kernel drin.

Was bleibt, ist das Problem der Betriebsartwahl. Ich habe intensiv im Netz gesucht, aber keine Seite gefunden, wo AT-Befehle für den Stick (oder den baugleichen Alcatel L100) veröffentlicht sind. Es muss ja abweichen von den üblichen Umschaltbefehlen, ansonsten gäbe es das Problem ja nicht.
Mint 17 Mate 64bit
Lenovo Thinkpad X200 mit SSD und Boe Hydis Display

Re: Telekom Speedstick LTE II (Alcatel One Touch L100V LTE)
« Antwort #9 am: 10.04.2014, 13:26:41 »
Ich hole das Thema noch mal nach oben. Den Stick verwende ich aufgrund der guten Performance weiterhin gerne, aber mich nervt es, dass die Betriebsart (2G/3G/4G) unter Linux nicht umgeschaltet werden kann. Auch unter Xubuntu 13.10 besteht das Problem weiterhin: Wird im Netzwerkmanager eine andere Betriebsart als "beliebig" ausgewählt, komme ich gar nicht ins Netz. Gibt es mittlerweile eine Lösung?
Mint 17 Mate 64bit
Lenovo Thinkpad X200 mit SSD und Boe Hydis Display

toffifee

Re: Telekom Speedstick LTE II (Alcatel One Touch L100V LTE)
« Antwort #10 am: 10.04.2014, 13:39:08 »
Da du anscheinend 2 PC hast, wäre folgender Hardware-Workaround denkbar: den Stick an einen passenden WLAN Router hängen, dort die Betriebsart vorgeben und mit beiden PC parallel surfen...

Zitat
Leider fehlt dem Alcatel L100V die Kompatibilität zu diversen gängigen Router Modellen wie etwa der AVM FritzBox oder dem Dovado Tiny. Das liegt aber nicht an Alcatel, sondern an der Firmware der Router, denn diese erkennt den Alcatel Stick nicht als USB Modem. Wer aber sowieso keinen Router nutzen will, dem kann dieser Umstand herzlich egal sein.

Scheint wohl keine Lösung zu sein :(
** Die Signatur ersetzt keine Angabe des verwendeten Systems/Desktops im Beitrag! ** Lesbare Posts erhöhen die Bereitschaft zum Antworten. ** Kein Support per PM. **

Re: Telekom Speedstick LTE II (Alcatel One Touch L100V LTE)
« Antwort #11 am: 10.04.2014, 13:57:13 »
Den 2. PC (Dualboot Linux/Windows XP) nutze ich so gut wie gar nicht mehr, deshalb will ich nur dafür auch keinen Router anschaffen. Außerdem wohne ich in einem Ballungsraum, WLAN ist hier total überlastet, da müsste schon ein Router mit 5 GHz WLAN her. Ich möchte auch ungern weitere Hardware anschaffen, sondern lieber den Stick umschalten können, denn von der Leistung her ist er super.

Allenfalls käme ein anderer LTE-fähiger Stick infrage, gibt es da mittlerweile was bezahlbares, das unter Linux Mint ootb und einwandfrei läuft?
Mint 17 Mate 64bit
Lenovo Thinkpad X200 mit SSD und Boe Hydis Display