Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
17.04.2014, 14:29:15

Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 198049
  • Themen insgesamt: 16533
  • Heute online: 306
  • Am meisten online: 488
  • (16.01.2011, 08:57:12)
Benutzer Online

Autor Thema:  Linux Mint 14.1 cinnamon - wlan lässt sich nicht aktivieren  (Gelesen 3210 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Hallöchen zusammen,

ich habe meiner Freundin gestern Linux Mint 14.1 cinnamon auf ihr Laptop gespielt (als alleiniges Betriebssystem, ohne Dual und so ein Quatsch)  ;D

Ihr Notebook ist ein Fujitsu Siemens Amilo L1310G.

Wlan lässt sich normalerweise anhand eines Wlan-Knöpfchens ein oder ausschalten. Aber unter Linux Mint - keine Chance.

Per Lan-Kabel klappt die Verbindung hervorragend...aber Wlan sich sich einfach nicht einschalten...


Vielleicht kann mir einer von euch ein bisschen unter die Arme greifen, damit ich das Wlan doch noch zum laufen bekomme, und ich meiner Freundin nicht wieder Win-XP draufbrezeln muss...

Vielen Dank schon mal im Voraus...


Re: Linux Mint 14.1 cinnamon - wlan lässt sich nicht aktivieren
« Antwort #1 am: 16.01.2013, 21:23:11 »
Herzlich Willkommen hier im Forum melramo!

Die Hardwareschalter werden nicht immer unterstützt. Geht es per Software? Also unten in der Leiste mit dem Netzwerkmanager, wird da "Funknetzwerke" angeboten?
linux-firmeware-nonfree solltest du auf jeden Fall noch installieren.
Ansonsten erste mal das System auf den neusten Stand bringen sudo apt-get update && sudo apt-get dist-upgrade und jetzt neu starten.

Grüße
LMUCS
Nimm das Leben nicht zu ernst, du kommst nie lebend raus ;-)

Re: Linux Mint 14.1 cinnamon - wlan lässt sich nicht aktivieren
« Antwort #2 am: 16.01.2013, 21:28:12 »
Jo, fangen wir mal an.
Terminal auf,  folgende Abfragen machen und Ergebnisse hier posten, aber bitte in Codeblocks.
lspci - k | grep -i -A2  netZeigt die Karte und den Treiber.
Dann
iwconfigZeigt ob die Karte auch erkannt wird.
Nun noch
rfkill listZeigt ob die Krte geblockt ist und wie.
Wenn Unrecht zu Recht wird, wird Widerstand zur Pflicht.

Acer Aspire 8730g Debian Jessie Mate & Mint 13 Mate, CubieBoard Debian Wheezy LXDE

Re: Linux Mint 14.1 cinnamon - wlan lässt sich nicht aktivieren
« Antwort #3 am: 16.01.2013, 21:34:07 »
Sehr schön Doc, ich hätte mir die ganzen Befehle erst mal zusammen suchen müssen  :D
Nimm das Leben nicht zu ernst, du kommst nie lebend raus ;-)

Re: Linux Mint 14.1 cinnamon - wlan lässt sich nicht aktivieren
« Antwort #4 am: 16.01.2013, 21:44:16 »
Sehr schön Doc, ich hätte mir die ganzen Befehle erst mal zusammen suchen müssen  :D

Irgendwann, gehen die einem in Fleisch und Blut über, warte nur ab. ;D
Wenn Unrecht zu Recht wird, wird Widerstand zur Pflicht.

Acer Aspire 8730g Debian Jessie Mate & Mint 13 Mate, CubieBoard Debian Wheezy LXDE

Re: Linux Mint 14.1 cinnamon - wlan lässt sich nicht aktivieren
« Antwort #5 am: 16.01.2013, 22:00:34 »
so...

hab jetzt erstmal das gemacht was LMUCS geschrieben hat. Leider ohne Erfolg.

Bei Drahtlos steht "nicht verfübar" und das Schalterchen lässt sich auch nicht nach rechts ziehen...also schon irgendwie, aber es geht immer wieder zurück nach links  :(

so, dann mal an die arbeit und das machen was DocHifi geschrieben hat  ;)

ochsenklops@buddy ~ $ lspci - k | grep -i -A2  net
Usage: lspci [<switches>]

Basic display modes:
-mm Produce machine-readable output (single -m for an obsolete format)
-t Show bus tree

Display options:
-v Be verbose (-vv for very verbose)
-k Show kernel drivers handling each device
-x Show hex-dump of the standard part of the config space
-xxx Show hex-dump of the whole config space (dangerous; root only)
-xxxx Show hex-dump of the 4096-byte extended config space (root only)
-b Bus-centric view (addresses and IRQ's as seen by the bus)
-D Always show domain numbers

Resolving of device ID's to names:
-n Show numeric ID's
-nn Show both textual and numeric ID's (names & numbers)
-q Query the PCI ID database for unknown ID's via DNS
-qq As above, but re-query locally cached entries
-Q Query the PCI ID database for all ID's via DNS

Selection of devices:
-s [[[[<domain>]:]<bus>]:][<slot>][.[<func>]] Show only devices in selected slots
-d [<vendor>]:[<device>] Show only devices with specified ID's

Other options:
-i <file> Use specified ID database instead of /usr/share/misc/pci.ids.gz
-p <file> Look up kernel modules in a given file instead of default modules.pcimap
-M Enable `bus mapping' mode (dangerous; root only)

PCI access options:
-A <method> Use the specified PCI access method (see `-A help' for a list)
-O <par>=<val> Set PCI access parameter (see `-O help' for a list)
-G Enable PCI access debugging
-H <mode> Use direct hardware access (<mode> = 1 or 2)
-F <file> Read PCI configuration dump from a given file


ochsenklops@buddy ~ $ iwconfig
wlan0     IEEE 802.11bg  ESSID:off/any 
          Mode:Managed  Access Point: Not-Associated   Tx-Power=off   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
         
lo        no wireless extensions.

eth0      no wireless extensions.


ochsenklops@buddy ~ $ rfkill list
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: yes

ich hoffe das mit den codeblocks stimmt so wie ich das gemacht habe ?!  ???
« Letzte Änderung: 16.01.2013, 22:11:31 von melramo »

Re: Linux Mint 14.1 cinnamon - wlan lässt sich nicht aktivieren
« Antwort #6 am: 16.01.2013, 22:23:07 »
Den ersten Befehl hast du falsch eingegeben, ist aber egal.
Deine Karte ist prinzipiell da, aber Hardware geblockt.
Versuche mal ob das hilft..
rfkill unblock all
Wenn Unrecht zu Recht wird, wird Widerstand zur Pflicht.

Acer Aspire 8730g Debian Jessie Mate & Mint 13 Mate, CubieBoard Debian Wheezy LXDE

Re: Linux Mint 14.1 cinnamon - wlan lässt sich nicht aktivieren
« Antwort #7 am: 16.01.2013, 22:27:59 »
Den ersten Befehl hast du falsch eingegeben, ist aber egal.

hab den nicht eingegeben sondern hier kopiert und eingefügt...dann hast du dich verschrieben  :D  :D

also "rfkill unblock all" bringt keine Veränderung  ???

Re: Linux Mint 14.1 cinnamon - wlan lässt sich nicht aktivieren
« Antwort #8 am: 16.01.2013, 22:28:43 »
[Klugscheiss Modus an:]

Den ersten Befehl hast du falsch eingegeben, ist aber egal.

stimmt nicht ganz...

müsste heissen

lspci -k | grep -A2 -i net
und nicht:
lspci - k | grep -i -A2  net
;D

kann passieren.. ;D

[/Klugscheiss Modus aus]
« Letzte Änderung: 16.01.2013, 22:37:14 von Marco77 »

Frieder108

  • Gast
Re: Linux Mint 14.1 cinnamon - wlan lässt sich nicht aktivieren
« Antwort #9 am: 16.01.2013, 22:29:19 »
@ Doc, das wird nicht funktionieren - rfkill kann nur "soft blocked" schalten

@ melramo, irgendwo an deiner Maschine muß es einen Schalter für dein Wlan geben.

Re: Linux Mint 14.1 cinnamon - wlan lässt sich nicht aktivieren
« Antwort #10 am: 16.01.2013, 22:30:48 »
@Marco
wir suchen eine Netzwerkarte, kein Grafikkarte.
Wenn Unrecht zu Recht wird, wird Widerstand zur Pflicht.

Acer Aspire 8730g Debian Jessie Mate & Mint 13 Mate, CubieBoard Debian Wheezy LXDE

Re: Linux Mint 14.1 cinnamon - wlan lässt sich nicht aktivieren
« Antwort #11 am: 16.01.2013, 22:34:23 »
 ??? ??? copy/paste Fehler... :-\ :-\
ändere ich gleich

Frieder108

  • Gast
Re: Linux Mint 14.1 cinnamon - wlan lässt sich nicht aktivieren
« Antwort #12 am: 16.01.2013, 22:35:38 »
japp, und diese Wlan-Karte ist Hardware-mäßig abgeschaltet - wenn es über den Schalter nicht geht, dann ist da was defekt. Kabel lose, Platine gebrochen, es gibt viele Möglichkeiten.

Den Schalter könnte man mal überprüfen indem man sich wechselmäßig jedesmal "rfkill" anzeigen lässt

Re: Linux Mint 14.1 cinnamon - wlan lässt sich nicht aktivieren
« Antwort #13 am: 16.01.2013, 22:40:01 »
also der "schalter" bzw. das wlan knöpfchen ist nicht kaputt...hat ja bis heute mittag unter win-xp auch noch funktioniert...

also wenn nicht während der linux install. der kleine pinguin rausgekrabbelt ist und mit seinem schnabel die wlan taste kaputtgehackt, sollte sie noch funktionieren  ;D

normalerweise (also unter windows) drückt man das wlan-knöpfchen, und die wlan LED geht an...drücke ich jetzt unter linux das knöpfchen passiert mal so gar nichts  :(

ich denke das war ein kurzer ausflug ins land der pinguine...hahahaha.  :D

Re: Linux Mint 14.1 cinnamon - wlan lässt sich nicht aktivieren
« Antwort #14 am: 16.01.2013, 22:41:36 »
Da gibt es noch ganz andere Möglichkeiten.
1. Im Bios nachsehen, ob da evtl. "always on" zu schalten ist.
2. Windows war vorher drauf und hat sie abgeschaltet, wenn im Bios "last state " gesetzt ist, kommt sie nicht.
Dann 1.
Wenn Unrecht zu Recht wird, wird Widerstand zur Pflicht.

Acer Aspire 8730g Debian Jessie Mate & Mint 13 Mate, CubieBoard Debian Wheezy LXDE