Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
23.08.2014, 21:48:14

Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 9905
  • Letzte: Bernie66
Statistiken
  • Beiträge insgesamt: 231250
  • Themen insgesamt: 19054
  • Heute online: 298
  • Am meisten online: 514
  • (18.04.2014, 17:38:30)
Benutzer Online

Autor Thema:  WLan-Stick Sitecom N300 wird nicht erkannt (Linux Mint 14 / 64)  (Gelesen 3853 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Hallo,
erneut bin ich auf der Suche nach Hilfe bei einem Problem:
Da mein Rechner keine W-Lan-Karte hat, habe ich mir einen W-Lan-Stick besorgt, der unter Windows7 auch 1A lief. Seit meinem Umstieg auf Linux Mint 14 (64) tut er dies jedoch nicht mehr. unter
Zitat
lsusb
wird der Stick prinzipiell erkannt:
Zitat
Bus 002 Device 003: ID 0df6:006c Sitecom Europe B.V.

Zitat
iwconfig
sagt jedoch:

Zitat
eth0      no wireless extensions.

lo        no wireless extensions.

Ich tippe mal, dass ich einen Treiber installieren muss ...? Aber wie komme ich an den Chipsatz ran? Welchen Befehl muss ich dafür eingeben?
Gruß und Danke für eure Antworten

Hast du mal unter Softwarequellen, im letzen Reiter nachgesehen, ob dort was angeboten wird ?
Wenn Unrecht zu Recht wird, wird Widerstand zur Pflicht.

Hi Doc, schön wieder von dir zu hören. Ich muss gestehen, ich weiß nicht welchen Reiter du wo meinst ...?

EDIT: Grad gefunden. da ist aber nur der Grafikkartentreiber aufgelistet
« Letzte Änderung: 14.01.2013, 16:08:38 von Tom.mr »

Schade, wäre eine Möglichkeit gewesen.
Mal hier lesen :
http://forum.ubuntuusers.de/topic/problem-mit-sitecom-wl-352-v3/?flavour=full
Und hier:
http://forum.ubuntuusers.de/topic/usb-wlan-adapter-wird-nicht-erkannt/?highlight=wlan+probleme
Gefunden via Google mit ID 0df6:006c Sitecom Europe B.V.
« Letzte Änderung: 14.01.2013, 16:16:31 von DocHifi »
Wenn Unrecht zu Recht wird, wird Widerstand zur Pflicht.

So, mittlerweile hab ich auch den Befehl gefunden, der mir den Chipsatz anzeigt: dmesg!!!!

der Chipsatz ist: RTL8191S. Hab dazu folgendes auf deren Homepage gefunden:
Zitat
Linux Kernel 2.6.18~2.6.38 and Kernel 3.0.2
hab das runtergeladen und entpackt ... aber keine Ahnung, wie ich den installieren soll.

EDIT:
Im Paket ist eine install.sh enthalten die habe ich mit sudo sh install.sh ausgeführt und dann ist auch einiges passiert. Am Ende steht aber:
Zitat
make[1]: Verlasse Verzeichnis '/usr/src/linux-headers-3.5.0-17-generic'
make: *** [modules] Fehler 2
##################################################
Compile make driver error: 2
Please check error Mesg

Der Stick wird unter iwconfig immer noch nicht erkannt. Hat einer eine Ahnung, was der Fehler bedeutet und wie ich den Stick jetzt richtig installieren soll? HILFE

EDIT II:
hab jetzt weiter rumgewühlt, im Ordner "Driver" den Befehl "make" ausgeführt und dann "make install". Antwort:
Zitat
tom@tom-ixtreme-M5740 ~/Downloads/rtl8712_8188_8191_8192SU_usb_linux_v2.6.6.0.20120405/driver/rtl8712_8188_8191_8192SU_usb_linux_v2.6.6.0.20120405 $ make instal
l
install -p -m 644 8712u.ko  /lib/modules/3.5.0-17-generic/kernel/drivers/net/wireless/
install: Aufruf von stat für »8712u.ko“ nicht möglich: Datei oder Verzeichnis nicht gefunden
make: *** [install] Fehler 1

Das ist jetzt das Letzte, was ich heute noch versuche. Immer noch kein Erfolg, aber ich bin doch hoffentlich auf dem richtigen WEg ...? Vielleicht kann mir ja einer von euch den entscheidenden Tipp geben, wie mein Rechner den Stick erkennt.
« Letzte Änderung: 14.01.2013, 19:44:41 von Tom.mr »

Dir fehlen möglicherweise die Kernelheaders und build-essential.
Wenn Unrecht zu Recht wird, wird Widerstand zur Pflicht.

Hab ich installiert, kein Erfolg. Mittlerweile ist das WLan komplett weg ...? Keine Ahnung, was das jetzt soll. Kann ja doch eigentlich kein Zusammenhang bestehen (mega genervt).

Kauf dir doch einen ordentliche Stick, die TP-Link sollen wohl gut unter Linux laufen.
Stand hier gestern irgendwo im Forum.
Wenn Unrecht zu Recht wird, wird Widerstand zur Pflicht.

werd ich wohl machen. Ist aber super ätzend. Danke trotzdem für deine Hilfe. Gn8

Es gibt manchmal Hardware, die ist einfach schwer zum funktionieren zu bringen.
Das liegt daran, das die Hersteller, einfach keine Linux Unterstützung bieten.
Wenn Unrecht zu Recht wird, wird Widerstand zur Pflicht.

Re: WLan-Stick Sitecom N300 wird nicht erkannt (Linux Mint 14 / 64)
« Antwort #10 am: 17.01.2013, 10:35:37 »
Hallo,
es dürfte sich um einen Stick mit Realtek rtl8712u-Chipsatz handeln. So wie Belkin verwendet Sitecom eigene Geräte-ID's, welche dem System unbekannt sind.

Weise dem Treiber mal die entsprechende ID zu und teste die Funktion:
echo 'install r8712u /sbin/modprobe --ignore-install r8712u; /bin/echo "0df6 006c" > /sys/bus/usb/drivers/r8712u/new_id' | sudo tee /etc/modprobe.d/r8712u.conf
Modul laden und testen:
sudo modprobe -v r8712u
iwconfig
ifconfig
iwlist chan
sudo iwlist scan
dmesg | grep r87

Re: WLan-Stick Sitecom N300 wird nicht erkannt (Linux Mint 14 / 64)
« Antwort #11 am: 26.03.2013, 20:23:21 »
Hallo Liebes LinuxMintUsers Forum,
Hallo Flash63,

ich habe einen Sitecom n300 W-Lan Stick mit dem selben rtl8712u-Chipsatz. Wenn ich deine Anweisung befolge funktioniert der W-Lan-Stick, ich habe verbindung zur fritzbox und kann über W-Lan zugreifen. Wenn ich aber meinen Raspberry Pi Reboote funktioniert er nicht mehr. Mit dem Befehl iwconfig erhalte ich auch keinen Eintrag wlan0 mehr sonder nur noch lo und eth0. Als Hinweis ich habe Raspian auf meinem RPI (Raspberry Pi) installiert. Vielleicht kann mir jemand erklären was ich tun muss damit ich nicht nach jedem Reboot die Anweisungen von Flash63 ausführen muss. Vielen Lieben Dank

Re: WLan-Stick Sitecom N300 wird nicht erkannt (Linux Mint 14 / 64)
« Antwort #12 am: 27.03.2013, 20:17:11 »
Hallo,
das System kann den Stick auf Grund der unbekannten Geräte-ID nicht automatisch erkennen, das sollte doch nun eigentlich klar sein.

Elegante Lösung über udev-Regel:
sudo touch /etc/udev/rules.d/10-wlan_stick.rules Inhalt einfügen:
# UDEV-Rule for Sitecom n300 WLAN-Stick
# load r8712u
SUBSYSTEM=="usb", ATTR{idVendor}=="0df6", ATTR{idProduct}=="006c", RUN+="/sbin/modprobe r8712u"
Stick anschließen.

Trage das Modul ansonsten einfach in die /etc/modules ein (nicht so elegante Lösung)  ;)